source: projects/specs/trunk/l/lyx/lyx-vl.spec @ 1528

Revision 1528, 8.1 KB checked in by munepi, 14 years ago (diff)

updated lyx: new upstream release and ready for TeX Live

Line 
1%define texmf           %{_datadir}/texmf
2%define build_texmf     %{buildroot}%{texmf}
3
4%define exec_texhash  [ -x %{_bindir}/texhash     ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
5%define exec_updmap   [ -x %{_bindir}/updmap-sys  ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop 2>/dev/null
6%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
7%define vartexfonts %{_var}/lib/texmf
8
9Summary: A WYSIWYM (What You See Is What You Mean) frontend to LaTeX
10Summary(ja): LaTeX形式でも保存できる簡易ワープロ
11Name: lyx
12Version: 1.6.7
13Release: 1%{?_dist_release}
14License: GPLv2+
15Group: Applications/Editors
16URL: http://www.lyx.org/
17Source: ftp://ftp.lyx.org/pub/lyx/stable/%{name}-%{version}.tar.bz2
18#Source1: http://www.ring.gr.jp/pub/text/CTAN/macros/latex/contrib/koma-script/koma-script.tds.zip
19
20Source10: lyx.desktop
21Source11: lyxrc.dist
22Patch0: lyx-1.6.5-xdg_open.patch
23
24# vine
25Patch10: lyx-1.6.3-customize-vine.patch
26
27# BuildRequires: aiksaurus-devel
28BuildRequires:   aspell-devel
29BuildRequires:   libboost-devel
30BuildRequires:   libboost-filesystem
31BuildRequires:   libboost-signals
32BuildRequires:   desktop-file-utils
33BuildRequires:   gettext
34BuildRequires:   python
35BuildRequires:   xorg-x11-devel
36BuildRequires:   qt4-devel
37BuildRequires:   libpng-devel
38BuildRequires:   glib2-devel
39BuildRequires:   zlib-devel
40
41Requires:        texlive
42Requires(post):  texlive
43Requires:        ghostscript
44# Requires:        dvipdfmx
45# Requires:        xdvik
46Requires:        python
47Requires:        qt4
48Requires:        latex-xft-fonts
49
50Requires(hint):  xdg-utils
51Requires(hint):  rcs
52
53BuildRoot: %{_tmppath}/%{name}-%{version}-root
54
55Vendor:       Project Vine
56Distribution: Vine Linux
57
58
59%description
60LyX is a modern approach to writing documents which breaks with the
61obsolete "typewriter paradigm" of most other document preparation
62systems.
63
64It is designed for people who want professional quality output
65with a minimum of time and effort, without becoming specialists in
66typesetting.
67
68The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
69That is, the author focuses on content, not on the details of formatting.
70This allows for greater productivity, and leaves the final typesetting
71to the backends (like LaTeX) that are specifically designed for the task.
72
73With LyX, the author can concentrate on the contents of his writing,
74and let the computer take care of the rest.
75
76This is LyX built with the Qt frontend.
77
78%description -l ja
79LaTeX形式で出力もできる簡易ワープロです。数式の入力も簡単にできます。
80特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
81してあります。
82
83
84%prep
85%setup -q
86%patch0 -p1 -b .xdg_open
87
88%patch10 -p1 -b .vine
89
90
91%build
92unset QTDIR || : ; . /etc/profile.d/qt4.sh
93export QT4DIR=$(echo $QTDIR | %__sed -e "s,/lib$,,")
94
95%configure \
96    --enable-build-type=release \
97    --disable-dependency-tracking \
98    --disable-rpath \
99    --disable-debug \
100    --enable-optimization="%{optflags}" \
101    --enable-shared \
102    --disable-static \
103    \
104    --with-qt4-dir=${QT4DIR} \
105    --with-frontend=qt4 \
106    --without-aiksaurus \
107    --with-aspell \
108    ;
109#    --without-included-boost \
110%__make %{?_smp_mflags}
111
112# # make sure all .gmo files are regenerated from .po files
113# (cd po; make update-gmo)
114
115
116%install
117%__rm -rf ${RPM_BUILD_ROOT}
118%__make DESTDIR=${RPM_BUILD_ROOT} install
119
120# for pdf: ps2pdf, pdf3: dvipdfmx
121(cd ${RPM_BUILD_ROOT}%{_datadir}/lyx/images
122    ln -sf buffer-update_pdf2.png buffer-update_pdf.png
123    ln -sf buffer-update_pdf2.png buffer-update_pdf3.png
124    ln -sf buffer-view_pdf2.png buffer-view_pdf.png
125    ln -sf buffer-view_pdf2.png buffer-view_pdf3.png
126)
127
128# misc/extras
129%__install -p -m644 -D %{SOURCE11} %{buildroot}%{_datadir}/lyx/lyxrc.dist
130
131# latex
132%__mkdir_p %{build_texmf}/tex/latex
133%__mv -f ${RPM_BUILD_ROOT}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
134
135## it semms the newest Japanese translations already included in the upstream...
136#%__install -m 644 layouts/* ${RPM_BUILD_ROOT}%{_datadir}/lyx/layouts/
137#%__install -m 644 1.3.3/* ${RPM_BUILD_ROOT}%{_datadir}/lyx/doc/
138
139# # it semms the newest Japanese translations already included in the upstream...
140# install -m 644 %{SOURCE3} ${RPM_BUILD_ROOT}%{_datadir}/locale/ja/LC_MESSAGES/lyx.mo
141
142# desktop & icon
143desktop-file-install --vendor="Vine" \
144  --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
145%__install -p -D -m644 lib/images/lyx.png \
146  %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
147
148# ghost'd files
149touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
150touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
151touch %{buildroot}%{_datadir}/lyx/doc/LaTeXConfig.lyx
152
153# unpackaged files
154rm -rf %{buildroot}%{_datadir}/lyx/fonts
155
156%find_lang %{name}
157
158
159%clean
160%__rm -rf ${RPM_BUILD_ROOT}
161
162
163%post
164%{exec_texhash} >& /dev/null
165if [ -d %{_datadir}/lyx ]; then
166    cd %{_datadir}/lyx
167    echo -n "  "
168    echo "Configuring LyX for your system..."
169    %__python ./configure.py >& /dev/null || :
170fi
171
172update-desktop-database -q &> /dev/null
173touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
174gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
175
176
177%postun
178if [ $1 -eq 0 ] ; then
179    %{exec_texhash} >& /dev/null
180    update-desktop-database -q &> /dev/null
181    touch --no-create %{_datadir}/icons/hicolor &> /dev/null
182    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
183fi
184
185
186%files -f %{name}.lang
187%defattr(-,root,root,-)
188%doc ABOUT-NLS ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
189%{_bindir}/*
190%{_datadir}/lyx/
191%{texmf}/tex/latex/lyx/
192%{_datadir}/applications/*.desktop
193%{_datadir}/icons/hicolor/*/*/*
194%{_mandir}/man*/*
195%config(noreplace) %{_datadir}/lyx/lyxrc.dist
196%ghost %{_datadir}/lyx/lyxrc.defaults
197%ghost %{_datadir}/lyx/*.lst
198%ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
199
200
201%changelog
202* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
203- new upstream release
204- TeX Live 2009
205  - dropped Requires: xdvik, dvipdfmx
206
207* Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
208- new upstream release
209- updated Patch0: lyx-1.6.5-xdg_open.patch
210
211* Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
212- new upstream release
213  - dropped old source files
214- change License: GPLv2+
215- added lyx.desktop
216- added BuildRequires:
217  - aspell-devel
218  - desktop-file-utils
219  - gettext
220  - python
221  - qt4-devel
222  - zlib-devel
223  - libboost-devel
224  - libboost-filesystem
225  - libboost-signals
226  - libpng-devel
227  - glib2-devel
228- added Requires:
229  - ghostscript
230  - dvipdfmx
231  - xdvik
232  - qt4
233  - xdg-utils
234- optimized some configure options
235
236* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
237- applied new versioning policy, spec in utf-8
238
239* Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
240- updated to 1.4.4 with the most recent CJK patch
241- updated Patch1
242
243* Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
244- base spec file : Vine Linux BTS #219
245  * Mon Nov  6 2006 M.H
246  - new upstream release
247  - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
248
249* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
250- changed Group to Applications/Editors
251
252* Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
253- rebuild with qt-3.3.5
254
255* Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
256- new upstream version
257- change frontend, xforms -> qt
258- require tetex, qt, latex-xft-fonts
259- change applnk file
260- change Group
261
262* Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
263- new upstream version
264- add mime-info
265- minor change in spec file
266
267* Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
268- 1.0.3_jp-4
269- added BuildPrereq:
270
271* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
272- 1.0.3_jp-3
273- minor change in spec file
274- build for Vine Linux 2.1
275
276* Wed Jan  5 2000 Jun Nishii <jun@vinelinux.org>
277- change group
278
279* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
280- updated to lyx-1.0.3
281- rebuild for Vine Linux 2.0
282
283* Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
284- merged Japanese Documents
285
286* Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
287- first build
288
Note: See TracBrowser for help on using the repository browser.