source: projects/specs/trunk/l/lvm2/lvm2-vl.spec @ 8898

Revision 8898, 24.1 KB checked in by daisuke, 10 years ago (diff)

lvm2: update to 2.02.109

Line 
1%define lvm_version 2.02.109
2%define device_mapper_version 1.02.88
3%define with_cluster 0
4
5# Do not reset Release to 1 unless both lvm2 and device-mapper
6# versions are increased together.
7
8Summary: Userland logical volume management tools
9Summary(ja): 論理ボリューム管理ツール
10Name: lvm2
11Version: %{lvm_version}
12Release: 1%{?_dist_release}
13License: GPL
14Group: System Environment/Base
15URL: http://sources.redhat.com/lvm2
16
17Source0: LVM2.%{lvm_version}.tgz
18Patch0: lvm2-set-default-preferred_names.patch
19Patch2: lvm2-remove-mpath-device-handling-from-udev-rules.patch
20Patch10: libdevmapper-static.patch
21
22#Patch20: lvm2-2.02.107-fix-dupliate-const.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{lvm_version}-%{release}-buildroot
25BuildRequires: libtermcap-devel
26BuildRequires: ncurses-devel
27BuildRequires: readline-devel
28BuildRequires: eudev-libudev-devel
29Requires: device-mapper >= %{device_mapper_version}-%{release}
30Requires: device-mapper-event >= %{device_mapper_version}-%{release}
31Requires: %{name}-libs = %{version}-%{release}
32Conflicts: lvm
33Obsoletes: lvm
34
35Distribution: Vine Linux
36Vendor: Project Vine
37Packager: daisuke
38
39%define _exec_prefix /usr
40
41%description
42LVM2 includes all of the support for handling read/write operations on
43physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
44multiple devices (MD), see mdadd(8) or even loop devices, see
45losetup(8)), creating volume groups (kind of virtual disks) from one
46or more physical volumes and creating one or more logical volumes
47(kind of logical partitions) in volume groups.
48
49%package devel
50Summary: Development libraries and headers
51Group: Development/Libraries
52License: LGPLv2
53Requires: %{name} = %{version}-%{release}
54Requires: %{name}-libs = %{version}-%{release}
55Requires: device-mapper-devel >= %{device_mapper_version}-%{release}
56Requires: device-mapper-event-devel >= %{device_mapper_version}-%{release}
57Requires: pkgconfig
58
59%description devel
60This package contains files needed to develop applications that use
61the lvm2 libraries.
62
63%package libs
64Summary: lvm2 shared libraries
65License: LGPLv2
66Group: System Environment/Libraries
67
68%description libs
69This package contains shared lvm2 libraries for applications.
70
71%if %{with_cluster}
72# lvm2-cluster
73%package cluster
74Summary: Cluster extensions for userland logical volume management tools
75License: GPLv2
76Group: System Environment/Base
77Requires: lvm2 >= %{version}-%{lvm_release}
78Requires(post): chkconfig
79Requires(preun): chkconfig
80Requires(preun): device-mapper >= %{device_mapper_version}
81Requires(preun): lvm2 >= 2.02
82
83%description cluster
84Extensions to LVM2 to support clusters.
85%endif
86
87# device-mapper
88%package -n device-mapper
89Summary: Device mapper utility
90Version: %{device_mapper_version}
91Release: %{release}
92License: GPLv2
93Group: System Environment/Base
94URL: http://sources.redhat.com/dm
95Requires: device-mapper-libs = %{device_mapper_version}-%{release}
96Requires: eudev-libudev
97Requires: util-linux-ng >= 2.15
98
99%description -n device-mapper
100This package contains the supporting userspace utility, dmsetup,
101for the kernel device-mapper.
102
103# device-mapper-devel
104%package -n device-mapper-devel
105Summary: Development libraries and headers for device-mapper
106Version: %{device_mapper_version}
107Release: %{release}
108License: LGPLv2
109Group: Development/Libraries
110Requires: device-mapper = %{device_mapper_version}-%{release}
111Requires: device-mapper-libs = %{device_mapper_version}-%{release}
112
113%description -n device-mapper-devel
114This package contains files needed to develop applications that use
115the device-mapper libraries.
116
117# device-mapper-static
118%package -n device-mapper-static
119Summary: Static libraries for device-mapper
120Version: %{device_mapper_version}
121Release: %{release}
122License: LGPLv2
123Group: Development/Libraries
124Requires: device-mapper-devel = %{device_mapper_version}-%{release}
125
126%description -n device-mapper-static
127This package contains the device-mapper static libraries.
128
129%package -n device-mapper-libs
130Summary: Device-mapper shared library
131Version: %{device_mapper_version}
132Release: %{release}
133License: LGPLv2
134Group: System Environment/Libraries
135Obsoletes: device-mapper < 1.02.30-1
136
137%description -n device-mapper-libs
138This package contains the device-mapper shared library, libdevmapper.
139
140%package -n device-mapper-event
141Summary: Device-mapper event daemon
142Group: System Environment/Base
143Version: %{device_mapper_version}
144Release: %{release}
145Requires: device-mapper = %{device_mapper_version}-%{release}
146Requires: device-mapper-event-libs = %{device_mapper_version}-%{release}
147
148%description -n device-mapper-event
149This package contains the dmeventd daemon for monitoring the state
150of device-mapper devices.
151
152%package -n device-mapper-event-libs
153Summary: Device-mapper event daemon shared library
154Version: %{device_mapper_version}
155Release: %{release}
156License: LGPLv2
157Group: System Environment/Libraries
158
159%description -n device-mapper-event-libs
160This package contains the device-mapper event daemon shared library,
161libdevmapper-event.
162
163%package -n device-mapper-event-devel
164Summary: Development libraries and headers for the device-mapper event daemon
165Version: %{device_mapper_version}
166Release: %{release}
167License: LGPLv2
168Group: Development/Libraries
169Requires: device-mapper-event = %{device_mapper_version}-%{release}
170Requires: pkgconfig
171
172%description -n device-mapper-event-devel
173This package contains files needed to develop applications that use
174the device-mapper event library.
175
176%prep
177%setup -q -n LVM2.%{lvm_version}
178%patch0 -p1
179%patch2 -p1
180%patch10 -p1
181
182#%patch20 -p1
183
184%build
185%define _exec_prefix /
186%define _bindir /bin
187%define _sbindir /sbin
188%define _libdir /%{_lib}
189%define _udevbasedir /lib/udev
190%define _udevdir %{_udevbasedir}/rules.d
191
192%configure \
193  --enable-readline \
194  --enable-lvm1_fallback \
195  --enable-fsadm \
196  --with-pool=internal \
197  --with-staticdir=/sbin \
198  --with-user= --with-group= \
199  --with-usrlibdir=/usr/%{_lib} \
200  --with-usrsbindir=/usr/sbin \
201  --with-dmdir=device-mapper.%{device_mapper_version} \
202  --with-udevdir=%{_udevdir} \
203  --with-device-uid=0 --with-device-gid=6 \
204  --with-device-mode=0660 \
205  --enable-pkgconfig \
206  --enable-applib \
207  --enable-cmdlib \
208  --enable-dmeventd \
209  --enable-udev_sync
210
211make %{?_smp_mflags}
212
213%install
214rm -rf $RPM_BUILD_ROOT
215make install DESTDIR=$RPM_BUILD_ROOT
216install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/archive
217install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/backup
218install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/cache
219install -m 0700 -d $RPM_BUILD_ROOT/var/lock/lvm
220install -m 0600 /dev/null $RPM_BUILD_ROOT/etc/lvm/cache/.cache
221mkdir -p -m755 $RPM_BUILD_ROOT/etc/rc.d/init.d
222%if %{with_cluster}
223install scripts/clvmd_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/clvmd
224install scripts/cmirrord_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/cmirrord
225%endif
226install -m 0755 scripts/lvm2_monitoring_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/lvm2-monitor
227install -m 0755 scripts/lvmconf.sh $RPM_BUILD_ROOT/sbin/lvmconf
228
229install -m 644 libdm/ioctl/libdevmapper.a $RPM_BUILD_ROOT/usr%{_libdir}
230
231%clean
232rm -rf $RPM_BUILD_ROOT
233
234%post
235/sbin/ldconfig
236/sbin/chkconfig --add lvm2-monitor
237
238%preun
239if [ "$1" = 0 ]; then
240        /sbin/chkconfig --del lvm2-monitor
241fi
242
243%post libs -p /sbin/ldconfig
244
245%postun libs -p /sbin/ldconfig
246
247%if %{with_cluster}
248%post cluster
249/sbin/chkconfig --add clvmd
250
251/sbin/lvmconf --lockinglibdir %{_libdir}
252
253%preun cluster
254if [ "$1" = 0 ]; then
255        /sbin/chkconfig --del clvmd
256        /sbin/lvmconf --disable-cluster
257fi
258%endif
259
260%post -n device-mapper-libs -p /sbin/ldconfig
261
262%postun -n device-mapper-libs -p /sbin/ldconfig
263
264%post -n device-mapper-event-libs -p /sbin/ldconfig
265
266%postun -n device-mapper-event-libs -p /sbin/ldconfig
267
268%files
269%defattr(-,root,root,-)
270%doc COPYING COPYING.LIB INSTALL README VERSION WHATS_NEW
271%attr(555,root,root) %{_sbindir}/fsadm
272%{_sbindir}/blkdeactivate
273%{_sbindir}/lvchange
274%{_sbindir}/lvconvert
275%{_sbindir}/lvcreate
276%{_sbindir}/lvdisplay
277%{_sbindir}/lvextend
278%{_sbindir}/lvm
279%{_sbindir}/lvmchange
280%{_sbindir}/lvmdiskscan
281%{_sbindir}/lvmdump
282%{_sbindir}/lvmsadc
283%{_sbindir}/lvmsar
284%{_sbindir}/lvreduce
285%{_sbindir}/lvremove
286%{_sbindir}/lvrename
287%{_sbindir}/lvresize
288%{_sbindir}/lvs
289%{_sbindir}/lvscan
290%{_sbindir}/pvchange
291%{_sbindir}/pvck
292%{_sbindir}/pvcreate
293%{_sbindir}/pvdisplay
294%{_sbindir}/pvmove
295%{_sbindir}/pvremove
296%{_sbindir}/pvresize
297%{_sbindir}/pvs
298%{_sbindir}/pvscan
299%{_sbindir}/vgcfgbackup
300%{_sbindir}/vgcfgrestore
301%{_sbindir}/vgchange
302%{_sbindir}/vgck
303%{_sbindir}/vgconvert
304%{_sbindir}/vgcreate
305%{_sbindir}/vgdisplay
306%{_sbindir}/vgexport
307%{_sbindir}/vgextend
308%{_sbindir}/vgimport
309%{_sbindir}/vgimportclone
310%{_sbindir}/vgmerge
311%{_sbindir}/vgmknodes
312%{_sbindir}/vgreduce
313%{_sbindir}/vgremove
314%{_sbindir}/vgrename
315%{_sbindir}/vgs
316%{_sbindir}/vgscan
317%{_sbindir}/vgsplit
318%{_sbindir}/lvmconf
319%{_mandir}/man5/lvm.conf.5.gz
320%{_mandir}/man7/lvmthin.7.gz
321%{_mandir}/man8/blkdeactivate.8.gz
322%{_mandir}/man8/fsadm.8.gz
323%{_mandir}/man8/lvchange.8.gz
324%{_mandir}/man8/lvconvert.8.gz
325%{_mandir}/man8/lvcreate.8.gz
326%{_mandir}/man8/lvdisplay.8.gz
327%{_mandir}/man8/lvextend.8.gz
328%{_mandir}/man8/lvm.8.gz
329%{_mandir}/man8/lvm-dumpconfig.8.gz
330%{_mandir}/man8/lvmchange.8.gz
331%{_mandir}/man8/lvmconf.8.gz
332%{_mandir}/man8/lvmdiskscan.8.gz
333%{_mandir}/man8/lvmdump.8.gz
334%{_mandir}/man8/lvmsadc.8.gz
335%{_mandir}/man8/lvmsar.8.gz
336%{_mandir}/man8/lvreduce.8.gz
337%{_mandir}/man8/lvremove.8.gz
338%{_mandir}/man8/lvrename.8.gz
339%{_mandir}/man8/lvresize.8.gz
340%{_mandir}/man8/lvs.8.gz
341%{_mandir}/man8/lvscan.8.gz
342%{_mandir}/man8/pvchange.8.gz
343%{_mandir}/man8/pvck.8.gz
344%{_mandir}/man8/pvcreate.8.gz
345%{_mandir}/man8/pvdisplay.8.gz
346%{_mandir}/man8/pvmove.8.gz
347%{_mandir}/man8/pvremove.8.gz
348%{_mandir}/man8/pvresize.8.gz
349%{_mandir}/man8/pvs.8.gz
350%{_mandir}/man8/pvscan.8.gz
351%{_mandir}/man8/vgcfgbackup.8.gz
352%{_mandir}/man8/vgcfgrestore.8.gz
353%{_mandir}/man8/vgchange.8.gz
354%{_mandir}/man8/vgck.8.gz
355%{_mandir}/man8/vgconvert.8.gz
356%{_mandir}/man8/vgcreate.8.gz
357%{_mandir}/man8/vgdisplay.8.gz
358%{_mandir}/man8/vgexport.8.gz
359%{_mandir}/man8/vgextend.8.gz
360%{_mandir}/man8/vgimport.8.gz
361%{_mandir}/man8/vgimportclone.8.gz
362%{_mandir}/man8/vgmerge.8.gz
363%{_mandir}/man8/vgmknodes.8.gz
364%{_mandir}/man8/vgreduce.8.gz
365%{_mandir}/man8/vgremove.8.gz
366%{_mandir}/man8/vgrename.8.gz
367%{_mandir}/man8/vgs.8.gz
368%{_mandir}/man8/vgscan.8.gz
369%{_mandir}/man8/vgsplit.8.gz
370%{_udevdir}/11-dm-lvm.rules
371%dir /etc/lvm
372%ghost /etc/lvm/cache/.cache
373%config(noreplace) /etc/lvm/lvm.conf
374%dir /etc/lvm/backup
375%dir /etc/lvm/cache
376%dir /etc/lvm/archive
377%dir /var/lock/lvm
378%dir /etc/lvm/profile
379/etc/lvm/profile/*.profile
380/etc/rc.d/init.d/lvm2-monitor
381
382%files devel
383%defattr(-,root,root,-)
384/usr%{_libdir}/liblvm2app.so
385/usr%{_libdir}/liblvm2cmd.so
386%{_includedir}/lvm2app.h
387%{_includedir}/lvm2cmd.h
388/usr%{_libdir}/pkgconfig/lvm2app.pc
389/usr%{_libdir}/libdevmapper-event-lvm2.so
390
391%files libs
392%attr(755,root,root) %{_libdir}/liblvm2app.so.*
393%attr(755,root,root) %{_libdir}/liblvm2cmd.so.*
394%attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so.*
395%dir %{_libdir}/device-mapper
396%{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
397%{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
398%{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
399%{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
400%{_libdir}/libdevmapper-event-lvm2mirror.so
401%{_libdir}/libdevmapper-event-lvm2snapshot.so
402%{_libdir}/libdevmapper-event-lvm2raid.so
403%{_libdir}/libdevmapper-event-lvm2thin.so
404
405%if %{with_cluster}
406%files cluster
407%defattr(-,root,root,-)
408%attr(755,root,root) /usr/sbin/clvmd
409%{_mandir}/man8/clvmd.8.gz
410/etc/rc.d/init.d/clvmd
411%endif
412
413%files -n device-mapper
414%defattr(-,root,root,-)
415%doc COPYING COPYING.LIB WHATS_NEW_DM VERSION_DM README INSTALL udev/12-dm-permissions.rules
416%attr(755,root,root) /sbin/dmsetup
417%{_mandir}/man8/dmsetup.8.gz
418%dir %{_udevbasedir}
419%dir %{_udevdir}
420%{_udevdir}/10-dm.rules
421%{_udevdir}/13-dm-disk.rules
422%{_udevdir}/95-dm-notify.rules
423
424%files -n device-mapper-devel
425%defattr(-,root,root,-)
426%attr(755,root,root) /usr%{_libdir}/libdevmapper.so
427%{_includedir}/libdevmapper.h
428/usr%{_libdir}/pkgconfig/devmapper.pc
429
430%files -n device-mapper-static
431%defattr(-,root,root,-)
432/usr%{_libdir}/libdevmapper.a
433
434%files -n device-mapper-libs
435%attr(755,root,root) %{_libdir}/libdevmapper.so.*
436
437%files -n device-mapper-event
438%defattr(-,root,root,-)
439%{_sbindir}/dmeventd
440%{_mandir}/man8/dmeventd.8.gz
441
442%files -n device-mapper-event-libs
443%{_libdir}/libdevmapper-event.so.*
444
445%files -n device-mapper-event-devel
446%defattr(-,root,root,-)
447%attr(755,root,root) /usr%{_libdir}/libdevmapper-event.so
448%{_includedir}/libdevmapper-event.h
449/usr%{_libdir}/pkgconfig/devmapper-event.pc
450
451%changelog
452* Mon Jul 14 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.02.107-1
453- add patch20 to fix duplicate 'const' in libdevmapper.h
454
455* Mon Jul 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.02.107-1
456- update to 2.02.107
457
458* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.98-3
459- change BuildRequires: eudev-libudev-devel instead of libudev-devel
460
461* Tue Dec 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.98-2
462- add missing files to %%files
463
464* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.98-1
465- new upstream release
466
467* Mon Mar 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.84-1
468- new upstream release
469- enable static libs, add device-mapper-static subpackage
470
471* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.83-1
472- new upstream release
473
474* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.79-1
475- new upstream release
476
477* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.78-1
478- new upstream release
479- fix %%files
480
481* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.02.62-3
482- rebuilt with rpm-4.8.1 for pkg-config
483
484* Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-2
485- add missing file
486  - %{_udevdir}/11-dm-lvm.rules
487
488* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-1
489- new upstream release
490- add libs,devel subpackage
491  - liblvm2{app,cmd},libdevmapper-event-lvm2
492- enable dmeventd
493  - add device-mapper-event{,-libs,-devel}
494- enable udev sync code
495  - add BR: libudev-devel, R: libudev
496- disable static libs and binaries
497
498* Sun Feb 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.02.60-1
499- new upstream release
500
501* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.48-1
502- new upstream release
503
504* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.47-1
505- new upstream release
506
507* Wed Feb 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-2
508- add libdevmapper.a
509
510* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-1
511- new upstream release
512- upstream merge of device-mapper and lvm2 source.
513- move all binaries to /sbin
514- move libraries to /%%{_lib}
515
516* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.42-1
517- new upstream release
518
519* Sun Oct 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.41-1
520- new upstream release
521
522* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.40-1
523- new upstream release
524
525* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.39-1
526- new upstream release
527
528* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.38-1
529- new upstream release
530
531* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.35-1
532- new upstream release
533
534* Sat Dec 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.28-0vl1
535- new upstream release
536
537* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.13-0vl1
538- new upstream release
539
540* Sat Aug 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.06-0vl1
541- initial build for Vine Linux
542
543* Tue Aug  1 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-3
544- require new libselinux to avoid segfaults on xen (#200783)
545
546* Thu Jul 27 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-2
547- free trip through the buildsystem
548
549* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.02.06-1.2.1
550- rebuild
551
552* Tue Jun  6 2006 Stephen C. Tweedie <sct@redhat.com> - 2.02.06-1.2
553- Rebuild to pick up new nosegneg libc.a for lvm.static
554
555* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.1
556- Reinstate archs now build system is back.
557- BuildRequires libsepol-devel.
558
559* Fri May 12 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.0
560- New upstream release.
561
562* Sat Apr 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.1
563- Exclude archs that aren't building.
564
565* Fri Apr 21 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.0
566- Fix VG uuid comparisons.
567
568* Wed Apr 19 2006 Alasdair Kergon <agk@redhat.com> - 2.02.04-1.0
569- New release upstream, including better handling of duplicated VG names.
570
571* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2.1
572- bump again for double-long bug on ppc(64)
573
574* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2
575- rebuilt for new gcc4.1 snapshot and glibc changes
576
577* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
578- rebuilt
579
580* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> - 2.02.01-1
581- update to 2.02.01
582
583* Tue Nov  8 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-4
584- add patch for xen block devices
585
586* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
587- add -lselinux -lsepol to the static linking -ldevice-mapper requires it
588
589* Wed Sep 14 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-2
590- the distro doesn't really work without a 2.6 kernel, so no need to require it
591
592* Thu Aug 4 2005 Alasdair Kergon <agk@redhat.com> - 2.01.14-1.0
593- And a few more bugs fixes.
594
595* Wed Jul 13 2005 Alasdair Kergon <agk@redhat.com> - 2.01.13-1.0
596- Fix several bugs discovered in the last release.
597
598* Tue Jun 14 2005 Alasdair Kergon <agk@redhat.com> - 2.01.12-1.0
599- New version upstream with a lot of fixes and enhancements.
600
601* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.1
602- Add /etc/lvm
603
604* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.0
605- No longer abort read operations if archive/backup directories aren't there.
606- Add runtime directories and file to the package.
607
608* Tue Mar 22 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-1.0
609- Improve detection of external changes affecting internal cache.
610- Add clustered VG attribute.
611- Suppress rmdir opendir error message.
612
613* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.3
614* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.2
615* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.1
616- Suppress some new compiler messages.
617
618* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.0
619- Remove build directory from built-in path.
620- Extra /dev scanning required for clustered operation.
621
622* Thu Mar 03 2005 Alasdair Kergon <agk@redhat.com> - 2.01.06-1.0
623- Allow anaconda to suppress warning messages.
624
625* Fri Feb 18 2005 Alasdair Kergon <agk@redhat.com> - 2.01.05-1.0
626- Upstream changes not affecting Fedora.
627
628* Wed Feb 09 2005 Alasdair Kergon <agk@redhat.com> - 2.01.04-1.0
629- Offset pool minors; lvm2cmd.so skips open fd check; pvmove -f gone.
630
631* Tue Feb 01 2005 Alasdair Kergon <agk@redhat.com> - 2.01.03-1.0
632- Fix snapshot device size & 64-bit display output.
633
634* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> - 2.01.02-1.0
635- Minor fixes.
636
637* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.01-1.0
638- Update vgcreate man page.  Preparation for snapshot origin extension fix.
639
640* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.00-1.0
641- Fix metadata auto-correction. Only request open_count when needed.
642
643* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 2.00.33-2.0
644- Rebuilt for new readline.
645
646* Fri Jan 7 2005 Alasdair Kergon <agk@redhat.com> - 2.00.33-1.0
647- pvcreate wipes ext label
648- several clvm fixes
649
650* Thu Jan 6 2005 Alasdair Kergon <agk@redhat.com> - 2.00.32-2.0
651- Remove temporary /sbin symlinks no longer needed.
652- Include read-only pool support in the build.
653
654* Wed Dec 22 2004 Alasdair Kergon <agk@redhat.com> - 2.00.32-1.0
655- More fixes (143501).
656
657* Sun Dec 12 2004 Alasdair Kergon <agk@redhat.com> - 2.00.31-1.0
658- Fix pvcreate install issues.
659
660* Fri Dec 10 2004 Alasdair Kergon <agk@redhat.com> - 2.00.30-1.0
661- Additional debugging code.
662- Some trivial man page corrections.
663
664* Tue Nov 30 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.3
665- Reinstate all archs.
666
667* Sun Nov 28 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.2
668- Try excluding more archs.
669
670* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.1
671- Exclude s390x which fails.
672
673* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1
674- Fix last fix.
675
676* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.28-1
677- Endian fix to partition/md signature detection.
678
679* Wed Nov 24 2004 Alasdair Kergon <agk@redhat.com> - 2.00.27-1
680- Fix partition table detection & an out of memory segfault.
681
682* Tue Nov 23 2004 Alasdair Kergon <agk@redhat.com> - 2.00.26-1
683- Several installation-related fixes & man page updates.
684
685* Mon Oct 25 2004 Elliot Lee <sopwith@redhat.com> - 2.00.25-1.01
686- Fix 2.6 kernel requirement
687
688* Wed Sep 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.25-1
689- Fix vgmknodes return code & vgremove locking.
690
691* Fri Sep 17 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-2
692- Obsolete old lvm1 packages; refuse install if running kernel 2.4. [bz 128185]
693
694* Thu Sep 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-1
695- More upstream fixes.  (Always check WHATS_NEW file for details.)
696- Add requested BuildRequires. [bz 124916, 132408]
697
698* Wed Sep 15 2004 Alasdair Kergon <agk@redhat.com> - 2.00.23-1
699- Various minor upstream fixes.
700
701* Fri Sep  3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.22-1
702- Permission fix included upstream; use different endian conversion macros.
703
704* Thu Sep  2 2004 Jeremy Katz <katzj@redhat.com> - 2.00.21-2
705- fix permissions on vg dirs
706
707* Thu Aug 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.21-1
708- New upstream release incorporating fixes plus minor enhancements.
709
710* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 2.00.20-2
711- add patch for iSeries viodasd support
712- add patch to check file type using stat(2) if d_type == DT_UNKNOWN (#129674)
713
714* Sat Jul 3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.20-1
715- New upstream release fixes 2.6 kernel device numbers.
716
717* Tue Jun 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.19-1
718- Latest upstream release.  Lots of changes (see WHATS_NEW).
719
720* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> - 2.00.15-5
721- rebuilt
722
723* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-4
724- clone %description from LVM rpm
725
726* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-3
727- vgscan shouldn't return error status when no VGs present
728
729* Thu May 06 2004 Warren Togami <wtogami@redhat.com> - 2.00.15-2
730- i2o patch from Markus Lidel
731
732* Tue Apr 20 2004 Bill Nottingham <notting@redhat.com> - 2.00.15-1.1
733- handle disabled SELinux correctly, so that LVMs can be detected in a
734  non-SELinux context
735 
736* Mon Apr 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-1
737- Fix non-root build with current version of 'install'.
738
739* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.14-1
740- Use 64-bit file offsets.
741
742* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.13-1
743- Avoid scanning devices containing md superblocks.
744- Integrate ENOTSUP patch.
745
746* Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 2.00.12-4
747- don't die if we get ENOTSUP setting selinux contexts
748
749* Thu Apr 15 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-3
750- Add temporary pvscan symlink for LVM1 until mkinitrd gets updated.
751
752* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-2
753- Mark config file noreplace.
754
755* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-1
756- Install default /etc/lvm/lvm.conf.
757- Move non-static binaries to /usr/sbin.
758- Add temporary links in /sbin to lvm.static until rc.sysinit gets updated.
759
760* Thu Apr 08 2004 Alasdair Kergon <agk@redhat.com> 2.00.11-1
761- Fallback to using LVM1 tools when using a 2.4 kernel without device-mapper.
762
763* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-2
764- Install the full toolset, not just 'lvm'.
765
766* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-1
767- Update to version 2.00.10, which incorporates the RH-specific patches
768  and includes various fixes and enhancements detailed in WHATS_NEW.
769
770* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.00.08-5
771- Fix sysfs patch to find sysfs
772- Take patch from dwalsh and tweak a little for setting SELinux contexts on
773  device node creation and also do it on the symlink creation. 
774  Part of this should probably be pushed down to device-mapper instead
775
776* Thu Feb 19 2004 Stephen C. Tweedie <sct@redhat.com> 2.00.08-4
777- Add sysfs filter patch
778- Allow non-root users to build RPM
779
780* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
781- rebuilt
782
783* Fri Dec  5 2003 Jeremy Katz <katzj@redhat.com> 2.00.08-2
784- add static lvm binary
785
786* Tue Dec  2 2003 Jeremy Katz <katzj@redhat.com>
787- Initial build.
788
789
Note: See TracBrowser for help on using the repository browser.