source: projects/specs/trunk/l/lvm2/lvm2-vl.spec @ 12411

Revision 12411, 28.0 KB checked in by tomop, 4 years ago (diff)

lvm2-2.03.09-2

Line 
1%bcond_with systemd
2
3%define device_mapper_version 1.02.171
4%define _unpackaged_files_terminate_build 1
5
6# Do not reset Release to 1 unless both lvm2 and device-mapper
7# versions are increased together.
8
9Summary: Userland logical volume management tools
10Summary(ja): 論理ボリューム管理ツール
11Name: lvm2
12Version: 2.03.09
13%global lvm_version %{version}
14Release: 2%{?_dist_release}%{?with_systemd:.systemd}
15Group: System Environment/Base
16Distribution: Vine Linux
17Vendor: Project Vine
18Packager: daisuke
19
20License: GPLv2
21URL: http://sourceware.org/lvm2/
22Source0: LVM2.%{version}.tgz
23Patch0: lvm2-set-default-preferred_names.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
26BuildRequires: libaio-devel
27BuildRequires: libtermcap-devel
28BuildRequires: ncurses-devel
29BuildRequires: readline-devel
30Requires: device-mapper >= %{device_mapper_version}-%{release}
31Requires: device-mapper-event >= %{device_mapper_version}-%{release}
32Requires: %{name}-libs = %{version}-%{release}
33%if %{with systemd}
34BuildRequires: python3
35BuildRequires: python3-rpm-macros
36BuildRequires: python3-pyudev
37BuildRequires: dbus-python3
38BuildRequires: systemd-devel
39BuildRequires: systemd-units
40%{?systemd_requires}
41%else
42BuildRequires: libudev-devel
43%endif
44Conflicts: lvm
45Obsoletes: lvm
46
47%define _exec_prefix /usr
48
49%description
50LVM2 includes all of the support for handling read/write operations on
51physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
52multiple devices (MD), see mdadd(8) or even loop devices, see
53losetup(8)), creating volume groups (kind of virtual disks) from one
54or more physical volumes and creating one or more logical volumes
55(kind of logical partitions) in volume groups.
56
57
58%package devel
59Summary: Development libraries and headers for lvm2
60Summary(ja): LVM2 の開発用ライブラリ及びヘッダファイル
61Group: Development/Libraries
62License: LGPLv2
63Requires: %{name} = %{version}-%{release}
64Requires: %{name}-libs = %{version}-%{release}
65Requires: device-mapper-devel >= %{device_mapper_version}-%{release}
66Requires: device-mapper-event-devel >= %{device_mapper_version}-%{release}
67Requires: pkgconfig
68
69%description devel
70This package contains files needed to develop applications that use
71the lvm2 libraries.
72
73
74%package libs
75Summary: lvm2 shared libraries
76Summary(ja): LVM2 の共有ライブラリ
77License: LGPLv2
78Group: System Environment/Libraries
79
80%description libs
81This package contains shared lvm2 libraries for applications.
82
83%if %{with systemd}
84%package dbusd
85Summary: LVM2 D-Bus daemon
86Summary(ja): LVM2 D-Bus デーモン
87License: GPLv2
88BuildArch: noarch
89Requires: lvm2 >= %{version}-%{release}
90Requires: dbus
91Requires: dbus-python3
92Requires: python3-pyudev
93Requires: python3-pygobject
94Requires(post): systemd-units >= %{systemd_version}
95Requires(preun): systemd-units >= %{systemd_version}
96Requires(postun): systemd-units >= %{systemd_version}
97
98%description dbusd
99Daemon for access to LVM2 functionality through a D-Bus interface.
100%endif
101
102# device-mapper
103%package -n device-mapper
104Summary: Device mapper utility
105Summary(ja): Device-mapper ユーティリティ集
106Version: %{device_mapper_version}
107Release: %{release}
108License: GPLv2
109Group: System Environment/Base
110URL: http://sources.redhat.com/dm
111Requires: device-mapper-libs = %{device_mapper_version}-%{release}
112Requires: eudev-libudev
113Requires: util-linux-ng >= 2.15
114
115%description -n device-mapper
116This package contains the supporting userspace utility, dmsetup,
117for the kernel device-mapper.
118
119
120# device-mapper-devel
121%package -n device-mapper-devel
122Summary: Development libraries and headers for device-mapper
123Summary(ja): Device-mapper の開発用ライブラリ及びヘッダファイル
124Version: %{device_mapper_version}
125Release: %{release}
126License: LGPLv2
127Group: Development/Libraries
128Requires: device-mapper = %{device_mapper_version}-%{release}
129Requires: device-mapper-libs = %{device_mapper_version}-%{release}
130
131%description -n device-mapper-devel
132This package contains files needed to develop applications that use
133the device-mapper libraries.
134
135
136%package -n device-mapper-libs
137Summary: Device-mapper shared library
138Summary(ja): Device-mapper の共有ライブラリ
139Version: %{device_mapper_version}
140Release: %{release}
141License: LGPLv2
142Group: System Environment/Libraries
143Obsoletes: device-mapper < 1.02.30-1
144
145%description -n device-mapper-libs
146This package contains the device-mapper shared library, libdevmapper.
147
148
149%package -n device-mapper-event
150Summary: Device-mapper event daemon
151Summary(ja): Device-mapper イベントデーモン
152Group: System Environment/Base
153Version: %{device_mapper_version}
154Release: %{release}
155Requires: device-mapper = %{device_mapper_version}-%{release}
156Requires: device-mapper-event-libs = %{device_mapper_version}-%{release}
157
158%description -n device-mapper-event
159This package contains the dmeventd daemon for monitoring the state
160of device-mapper devices.
161
162
163%package -n device-mapper-event-libs
164Summary: Device-mapper event daemon shared library
165Summary(ja): Device-mapper イベントデーモン共有ライブラリ
166Version: %{device_mapper_version}
167Release: %{release}
168License: LGPLv2
169Group: System Environment/Libraries
170
171%description -n device-mapper-event-libs
172This package contains the device-mapper event daemon shared library,
173libdevmapper-event.
174
175
176%package -n device-mapper-event-devel
177Summary: Development libraries and headers for the device-mapper event daemon
178Summary(ja): Device-mapper イベントデーモンの開発用ライブラリ及びヘッダファイル
179Version: %{device_mapper_version}
180Release: %{release}
181License: LGPLv2
182Group: Development/Libraries
183Requires: device-mapper-event = %{device_mapper_version}-%{release}
184Requires: pkgconfig
185
186%description -n device-mapper-event-devel
187This package contains files needed to develop applications that use
188the device-mapper event library.
189
190
191%prep
192%setup -q -n LVM2.%{lvm_version}
193%patch0 -p1 -b .preferred_names
194
195
196%build
197%define _exec_prefix /
198%define _bindir /bin
199%define _sbindir /sbin
200%define _libdir /%{_lib}
201%define _udevbasedir /lib/udev
202%define _udevdir %{_udevbasedir}/rules.d
203%if %{with systemd}
204%global _default_pid_dir /run
205%global _default_dm_run_dir /run
206%global _default_run_dir /run/lvm
207%global _default_locking_dir /run/lock/lvm
208%endif
209
210%configure \
211  --enable-readline \
212  --enable-lvm1_fallback \
213  --enable-fsadm \
214  --with-pool=internal \
215  --with-staticdir=/sbin \
216  --with-user= --with-group= \
217  --with-usrlibdir=/usr/%{_lib} \
218  --with-usrsbindir=/usr/sbin \
219  --with-dmdir=device-mapper.%{device_mapper_version} \
220  --with-udevdir=%{_udevdir} \
221  --with-device-uid=0 --with-device-gid=6 \
222  --with-device-mode=0660 \
223  --enable-pkgconfig \
224  --enable-applib \
225  --enable-cmdlib \
226  --enable-dmeventd \
227  --enable-udev_sync \
228%if %{with systemd}
229  --with-default-dm-run-dir=%{_default_dm_run_dir} \
230  --with-default-run-dir=%{_default_run_dir} \
231  --with-default-pid-dir=%{_default_pid_dir} \
232  --with-default-locking-dir=%{_default_locking_dir} \
233  --enable-dmfilemapd \
234  --enable-lvmpolld \
235  --enable-dbus-service --enable-notify-dbus \
236  --with-cache=internal \
237  --with-writecache=internal \
238  --with-vdo=internal --with-vdo-format=%{_bindir}/vdoformat \
239%endif
240  --disable-silent-rules
241
242make %{?_smp_mflags}
243
244
245%install
246rm -rf $RPM_BUILD_ROOT
247make install DESTDIR=$RPM_BUILD_ROOT
248%if %{with systemd}
249make install_system_dirs DESTDIR=$RPM_BUILD_ROOT
250make install_systemd_units DESTDIR=$RPM_BUILD_ROOT
251make install_systemd_generators DESTDIR=$RPM_BUILD_ROOT
252make install_tmpfiles_configuration DESTDIR=$RPM_BUILD_ROOT
253%else
254mkdir -p -m755 $RPM_BUILD_ROOT/etc/rc.d/init.d
255install -m 0755 scripts/lvm2_monitoring_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/lvm2-monitor
256%endif
257
258install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/archive
259install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/backup
260install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/cache
261install -m 0700 -d $RPM_BUILD_ROOT/var/lock/lvm
262install -m 0600 /dev/null $RPM_BUILD_ROOT/etc/lvm/cache/.cache
263
264
265%clean
266rm -rf $RPM_BUILD_ROOT
267
268
269%post
270/sbin/ldconfig
271%if %{with systemd}
272%systemd_post blk-availability.service lvm2-monitor.service
273if [ "$1" = "1" ] ; then
274    # FIXME: what to do with this? We do not want to start it in a container/chroot
275    # enable and start lvm2-monitor.service on completely new installation only, not on upgrades
276    systemctl enable lvm2-monitor.service
277    systemctl start lvm2-monitor.service >/dev/null 2>&1 || :
278fi
279%systemd_post lvm2-lvmpolld.socket
280# lvm2-lvmpolld socket is always enabled and started and ready to serve if lvmpolld is used
281# replace direct systemctl calls with systemd rpm macro once this is provided in the macro:
282# http://cgit.freedesktop.org/systemd/systemd/commit/?id=57ab2eabb8f92fad5239c7d4492e9c6e23ee0678
283systemctl enable lvm2-lvmpolld.socket
284systemctl start lvm2-lvmpolld.socket >/dev/null 2>&1 || :
285%else
286/sbin/chkconfig --add lvm2-monitor
287%endif
288
289%preun
290%if %{with systemd}
291%systemd_preun blk-availability.service lvm2-monitor.service
292%systemd_preun lvm2-lvmpolld.service lvm2-lvmpolld.socket
293%else
294if [ "$1" = 0 -o -x /bin/systemctl ]; then
295        /sbin/chkconfig --del lvm2-monitor
296fi
297%endif
298
299%if %{with systemd}
300%postun
301%systemd_postun lvm2-monitor.service
302%systemd_postun_with_restart lvm2-lvmpolld.service
303%endif
304
305%post libs -p /sbin/ldconfig
306
307%postun libs -p /sbin/ldconfig
308
309%if %{with systemd}
310%post dbusd
311%systemd_post lvm2-lvmdbusd.service
312
313%preun dbusd
314%systemd_preun lvm2-lvmdbusd.service
315
316%postun dbusd
317%systemd_postun lvm2-lvmdbusd.service
318
319%post -n device-mapper-event
320%systemd_post dm-event.socket
321# dm-event.socket is always enabled and started and ready to serve if dmeventd is used
322# replace direct systemctl calls with systemd rpm macro once this is provided in the macro:
323# http://cgit.freedesktop.org/systemd/systemd/commit/?id=57ab2eabb8f92fad5239c7d4492e9c6e23ee0678
324systemctl enable dm-event.socket
325systemctl start dm-event.socket >/dev/null 2>&1 || :
326if [ -e %{_default_pid_dir}/dmeventd.pid ]; then
327        %{_sbindir}/dmeventd -R || echo "Failed to restart dmeventd daemon. Please, try manual restart."
328fi
329
330%preun -n device-mapper-event
331%systemd_preun dm-event.service dm-event.socket
332%endif
333
334%post -n device-mapper-libs -p /sbin/ldconfig
335
336%postun -n device-mapper-libs -p /sbin/ldconfig
337
338%post -n device-mapper-event-libs -p /sbin/ldconfig
339
340%postun -n device-mapper-event-libs -p /sbin/ldconfig
341
342%files
343%defattr(-,root,root,-)
344%license COPYING COPYING.LIB
345%doc INSTALL README VERSION WHATS_NEW
346%attr(555,root,root) %{_sbindir}/fsadm
347%{_sbindir}/lvchange
348%{_sbindir}/lvconvert
349%{_sbindir}/lvcreate
350%{_sbindir}/lvdisplay
351%{_sbindir}/lvextend
352%{_sbindir}/lvm
353%{_sbindir}/lvmconfig
354%{_sbindir}/lvmdiskscan
355%{_sbindir}/lvmdump
356%{_sbindir}/lvmsadc
357%{_sbindir}/lvmsar
358%{_sbindir}/lvreduce
359%{_sbindir}/lvremove
360%{_sbindir}/lvrename
361%{_sbindir}/lvresize
362%{_sbindir}/lvs
363%{_sbindir}/lvscan
364%{_sbindir}/pvchange
365%{_sbindir}/pvck
366%{_sbindir}/pvcreate
367%{_sbindir}/pvdisplay
368%{_sbindir}/pvmove
369%{_sbindir}/pvremove
370%{_sbindir}/pvresize
371%{_sbindir}/pvs
372%{_sbindir}/pvscan
373%{_sbindir}/vgcfgbackup
374%{_sbindir}/vgcfgrestore
375%{_sbindir}/vgchange
376%{_sbindir}/vgck
377%{_sbindir}/vgconvert
378%{_sbindir}/vgcreate
379%{_sbindir}/vgdisplay
380%{_sbindir}/vgexport
381%{_sbindir}/vgextend
382%{_sbindir}/vgimport
383%{_sbindir}/vgimportclone
384%{_sbindir}/vgmerge
385%{_sbindir}/vgmknodes
386%{_sbindir}/vgreduce
387%{_sbindir}/vgremove
388%{_sbindir}/vgrename
389%{_sbindir}/vgs
390%{_sbindir}/vgscan
391%{_sbindir}/vgsplit
392%{_mandir}/man5/lvm.conf.5.gz
393%{_mandir}/man7/lvmcache.7.gz
394%{_mandir}/man7/lvmraid.7.gz
395%{_mandir}/man7/lvmreport.7.gz
396%{_mandir}/man7/lvmsystemid.7.gz
397%{_mandir}/man7/lvmthin.7.gz
398%{_mandir}/man7/lvmvdo.7.gz
399%{_mandir}/man8/fsadm.8.gz
400%{_mandir}/man8/lvchange.8.gz
401%{_mandir}/man8/lvconvert.8.gz
402%{_mandir}/man8/lvcreate.8.gz
403%{_mandir}/man8/lvdisplay.8.gz
404%{_mandir}/man8/lvextend.8.gz
405%{_mandir}/man8/lvm.8.gz
406%{_mandir}/man8/lvm-config.8.gz
407%{_mandir}/man8/lvm-dumpconfig.8.gz
408%{_mandir}/man8/lvm-fullreport.8.gz
409%{_mandir}/man8/lvm-lvpoll.8.gz
410%{_mandir}/man8/lvmconfig.8.gz
411%{_mandir}/man8/lvmdiskscan.8.gz
412%{_mandir}/man8/lvmdump.8.gz
413%{_mandir}/man8/lvmsadc.8.gz
414%{_mandir}/man8/lvmsar.8.gz
415%{_mandir}/man8/lvreduce.8.gz
416%{_mandir}/man8/lvremove.8.gz
417%{_mandir}/man8/lvrename.8.gz
418%{_mandir}/man8/lvresize.8.gz
419%{_mandir}/man8/lvs.8.gz
420%{_mandir}/man8/lvscan.8.gz
421%{_mandir}/man8/pvchange.8.gz
422%{_mandir}/man8/pvck.8.gz
423%{_mandir}/man8/pvcreate.8.gz
424%{_mandir}/man8/pvdisplay.8.gz
425%{_mandir}/man8/pvmove.8.gz
426%{_mandir}/man8/pvremove.8.gz
427%{_mandir}/man8/pvresize.8.gz
428%{_mandir}/man8/pvs.8.gz
429%{_mandir}/man8/pvscan.8.gz
430%{_mandir}/man8/vgcfgbackup.8.gz
431%{_mandir}/man8/vgcfgrestore.8.gz
432%{_mandir}/man8/vgchange.8.gz
433%{_mandir}/man8/vgck.8.gz
434%{_mandir}/man8/vgconvert.8.gz
435%{_mandir}/man8/vgcreate.8.gz
436%{_mandir}/man8/vgdisplay.8.gz
437%{_mandir}/man8/vgexport.8.gz
438%{_mandir}/man8/vgextend.8.gz
439%{_mandir}/man8/vgimport.8.gz
440%{_mandir}/man8/vgimportclone.8.gz
441%{_mandir}/man8/vgmerge.8.gz
442%{_mandir}/man8/vgmknodes.8.gz
443%{_mandir}/man8/vgreduce.8.gz
444%{_mandir}/man8/vgremove.8.gz
445%{_mandir}/man8/vgrename.8.gz
446%{_mandir}/man8/vgs.8.gz
447%{_mandir}/man8/vgscan.8.gz
448%{_mandir}/man8/vgsplit.8.gz
449%{_udevdir}/11-dm-lvm.rules
450%{_udevdir}/69-dm-lvm-metad.rules
451%dir /etc/lvm
452%ghost /etc/lvm/cache/.cache
453%config(noreplace) /etc/lvm/lvm.conf
454%config(noreplace) /etc/lvm/lvmlocal.conf
455%dir /etc/lvm/backup
456%dir /etc/lvm/cache
457%dir /etc/lvm/archive
458%dir /var/lock/lvm
459%dir /etc/lvm/profile
460/etc/lvm/profile/*.profile
461%if %{with systemd}
462%{_sbindir}/lvmpolld
463%{_mandir}/man8/lvmpolld.8*
464%{_mandir}/man8/lvm2-activation-generator.8*
465%{_tmpfilesdir}/lvm2.conf
466%{_unitdir}/blk-availability.service
467%{_unitdir}/lvm2-lvmpolld.service
468%{_unitdir}/lvm2-lvmpolld.socket
469%{_unitdir}/lvm2-monitor.service
470%{_unitdir}/lvm2-pvscan@.service
471%attr(555, -, -) /lib/systemd/system-generators/lvm2-activation-generator
472%else
473/etc/rc.d/init.d/lvm2-monitor
474%endif
475
476%files devel
477%defattr(-,root,root,-)
478/usr%{_libdir}/liblvm2cmd.so
479%{_includedir}/lvm2cmd.h
480/usr%{_libdir}/libdevmapper-event-lvm2.so
481
482%files libs
483%attr(755,root,root) %{_libdir}/liblvm2cmd.so.*
484%attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so.*
485%dir %{_libdir}/device-mapper
486%{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
487%{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
488%{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
489%{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
490%{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
491%{_libdir}/libdevmapper-event-lvm2mirror.so
492%{_libdir}/libdevmapper-event-lvm2snapshot.so
493%{_libdir}/libdevmapper-event-lvm2raid.so
494%{_libdir}/libdevmapper-event-lvm2thin.so
495%{_libdir}/libdevmapper-event-lvm2vdo.so
496
497%if %{with systemd}
498%files dbusd
499%defattr(555,root,root,-)
500%{_sbindir}/lvmdbusd
501%defattr(444,root,root,-)
502%{_sysconfdir}/dbus-1/system.d/com.redhat.lvmdbus1.conf
503%{_datadir}/dbus-1/system-services/com.redhat.lvmdbus1.service
504%{_mandir}/man8/lvmdbusd.8*
505%{_unitdir}/lvm2-lvmdbusd.service
506%dir %{python3_sitelib}/lvmdbusd
507%{python3_sitelib}/lvmdbusd/*
508%endif
509
510%files -n device-mapper
511%defattr(-,root,root,-)
512%license COPYING COPYING.LIB
513%doc WHATS_NEW_DM VERSION_DM README INSTALL udev/12-dm-permissions.rules
514%attr(755,root,root) /sbin/blkdeactivate
515%attr(755,root,root) /sbin/dmsetup
516/sbin/dmstats
517%{_mandir}/man8/blkdeactivate.8.gz
518%{_mandir}/man8/dmsetup.8.gz
519%{_mandir}/man8/dmstats.8.gz
520%dir %{_udevbasedir}
521%dir %{_udevdir}
522%{_udevdir}/10-dm.rules
523%{_udevdir}/13-dm-disk.rules
524%{_udevdir}/95-dm-notify.rules
525%if %{with systemd}
526/sbin/dmfilemapd
527%{_mandir}/man8/dmfilemapd.8*
528%endif
529
530%files -n device-mapper-devel
531%defattr(-,root,root,-)
532/usr%{_libdir}/libdevmapper.so
533%{_includedir}/libdevmapper.h
534/usr%{_libdir}/pkgconfig/devmapper.pc
535
536%files -n device-mapper-libs
537%attr(755,root,root) %{_libdir}/libdevmapper.so.*
538
539%files -n device-mapper-event
540%defattr(-,root,root,-)
541%{_sbindir}/dmeventd
542%{_mandir}/man8/dmeventd.8.gz
543%if %{with systemd}
544%{_unitdir}/dm-event.service
545%{_unitdir}/dm-event.socket
546%endif
547
548%files -n device-mapper-event-libs
549%{_libdir}/libdevmapper-event.so.*
550
551%files -n device-mapper-event-devel
552%defattr(-,root,root,-)
553/usr%{_libdir}/libdevmapper-event.so
554%{_includedir}/libdevmapper-event.h
555/usr%{_libdir}/pkgconfig/devmapper-event.pc
556
557%changelog
558* Wed May 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.03.09-2
559- added systemd support (disabled as default).
560
561* Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.03.09-1
562- new upstream release.
563- dropped Patch1, 2 and 10.
564
565* Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.02.177-1
566- updated to 2.02.177
567- dropped Patch2: fixed in upstream.
568- imported Patch1 and 2 from rawhide.
569
570* Mon Jul 14 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.02.107-1
571- add patch20 to fix duplicate 'const' in libdevmapper.h
572
573* Mon Jul 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.02.107-1
574- update to 2.02.107
575
576* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.98-3
577- change BuildRequires: eudev-libudev-devel instead of libudev-devel
578
579* Tue Dec 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.98-2
580- add missing files to %%files
581
582* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.98-1
583- new upstream release
584
585* Mon Mar 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.84-1
586- new upstream release
587- enable static libs, add device-mapper-static subpackage
588
589* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.83-1
590- new upstream release
591
592* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.79-1
593- new upstream release
594
595* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.78-1
596- new upstream release
597- fix %%files
598
599* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.02.62-3
600- rebuilt with rpm-4.8.1 for pkg-config
601
602* Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-2
603- add missing file
604  - %{_udevdir}/11-dm-lvm.rules
605
606* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-1
607- new upstream release
608- add libs,devel subpackage
609  - liblvm2{app,cmd},libdevmapper-event-lvm2
610- enable dmeventd
611  - add device-mapper-event{,-libs,-devel}
612- enable udev sync code
613  - add BR: libudev-devel, R: libudev
614- disable static libs and binaries
615
616* Sun Feb 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.02.60-1
617- new upstream release
618
619* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.48-1
620- new upstream release
621
622* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.47-1
623- new upstream release
624
625* Wed Feb 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-2
626- add libdevmapper.a
627
628* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-1
629- new upstream release
630- upstream merge of device-mapper and lvm2 source.
631- move all binaries to /sbin
632- move libraries to /%%{_lib}
633
634* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.42-1
635- new upstream release
636
637* Sun Oct 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.41-1
638- new upstream release
639
640* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.40-1
641- new upstream release
642
643* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.39-1
644- new upstream release
645
646* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.38-1
647- new upstream release
648
649* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.35-1
650- new upstream release
651
652* Sat Dec 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.28-0vl1
653- new upstream release
654
655* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.13-0vl1
656- new upstream release
657
658* Sat Aug 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.06-0vl1
659- initial build for Vine Linux
660
661* Tue Aug  1 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-3
662- require new libselinux to avoid segfaults on xen (#200783)
663
664* Thu Jul 27 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-2
665- free trip through the buildsystem
666
667* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.02.06-1.2.1
668- rebuild
669
670* Tue Jun  6 2006 Stephen C. Tweedie <sct@redhat.com> - 2.02.06-1.2
671- Rebuild to pick up new nosegneg libc.a for lvm.static
672
673* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.1
674- Reinstate archs now build system is back.
675- BuildRequires libsepol-devel.
676
677* Fri May 12 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.0
678- New upstream release.
679
680* Sat Apr 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.1
681- Exclude archs that aren't building.
682
683* Fri Apr 21 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.0
684- Fix VG uuid comparisons.
685
686* Wed Apr 19 2006 Alasdair Kergon <agk@redhat.com> - 2.02.04-1.0
687- New release upstream, including better handling of duplicated VG names.
688
689* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2.1
690- bump again for double-long bug on ppc(64)
691
692* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2
693- rebuilt for new gcc4.1 snapshot and glibc changes
694
695* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
696- rebuilt
697
698* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> - 2.02.01-1
699- update to 2.02.01
700
701* Tue Nov  8 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-4
702- add patch for xen block devices
703
704* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
705- add -lselinux -lsepol to the static linking -ldevice-mapper requires it
706
707* Wed Sep 14 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-2
708- the distro doesn't really work without a 2.6 kernel, so no need to require it
709
710* Thu Aug 4 2005 Alasdair Kergon <agk@redhat.com> - 2.01.14-1.0
711- And a few more bugs fixes.
712
713* Wed Jul 13 2005 Alasdair Kergon <agk@redhat.com> - 2.01.13-1.0
714- Fix several bugs discovered in the last release.
715
716* Tue Jun 14 2005 Alasdair Kergon <agk@redhat.com> - 2.01.12-1.0
717- New version upstream with a lot of fixes and enhancements.
718
719* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.1
720- Add /etc/lvm
721
722* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.0
723- No longer abort read operations if archive/backup directories aren't there.
724- Add runtime directories and file to the package.
725
726* Tue Mar 22 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-1.0
727- Improve detection of external changes affecting internal cache.
728- Add clustered VG attribute.
729- Suppress rmdir opendir error message.
730
731* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.3
732* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.2
733* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.1
734- Suppress some new compiler messages.
735
736* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.0
737- Remove build directory from built-in path.
738- Extra /dev scanning required for clustered operation.
739
740* Thu Mar 03 2005 Alasdair Kergon <agk@redhat.com> - 2.01.06-1.0
741- Allow anaconda to suppress warning messages.
742
743* Fri Feb 18 2005 Alasdair Kergon <agk@redhat.com> - 2.01.05-1.0
744- Upstream changes not affecting Fedora.
745
746* Wed Feb 09 2005 Alasdair Kergon <agk@redhat.com> - 2.01.04-1.0
747- Offset pool minors; lvm2cmd.so skips open fd check; pvmove -f gone.
748
749* Tue Feb 01 2005 Alasdair Kergon <agk@redhat.com> - 2.01.03-1.0
750- Fix snapshot device size & 64-bit display output.
751
752* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> - 2.01.02-1.0
753- Minor fixes.
754
755* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.01-1.0
756- Update vgcreate man page.  Preparation for snapshot origin extension fix.
757
758* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.00-1.0
759- Fix metadata auto-correction. Only request open_count when needed.
760
761* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 2.00.33-2.0
762- Rebuilt for new readline.
763
764* Fri Jan 7 2005 Alasdair Kergon <agk@redhat.com> - 2.00.33-1.0
765- pvcreate wipes ext label
766- several clvm fixes
767
768* Thu Jan 6 2005 Alasdair Kergon <agk@redhat.com> - 2.00.32-2.0
769- Remove temporary /sbin symlinks no longer needed.
770- Include read-only pool support in the build.
771
772* Wed Dec 22 2004 Alasdair Kergon <agk@redhat.com> - 2.00.32-1.0
773- More fixes (143501).
774
775* Sun Dec 12 2004 Alasdair Kergon <agk@redhat.com> - 2.00.31-1.0
776- Fix pvcreate install issues.
777
778* Fri Dec 10 2004 Alasdair Kergon <agk@redhat.com> - 2.00.30-1.0
779- Additional debugging code.
780- Some trivial man page corrections.
781
782* Tue Nov 30 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.3
783- Reinstate all archs.
784
785* Sun Nov 28 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.2
786- Try excluding more archs.
787
788* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.1
789- Exclude s390x which fails.
790
791* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1
792- Fix last fix.
793
794* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.28-1
795- Endian fix to partition/md signature detection.
796
797* Wed Nov 24 2004 Alasdair Kergon <agk@redhat.com> - 2.00.27-1
798- Fix partition table detection & an out of memory segfault.
799
800* Tue Nov 23 2004 Alasdair Kergon <agk@redhat.com> - 2.00.26-1
801- Several installation-related fixes & man page updates.
802
803* Mon Oct 25 2004 Elliot Lee <sopwith@redhat.com> - 2.00.25-1.01
804- Fix 2.6 kernel requirement
805
806* Wed Sep 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.25-1
807- Fix vgmknodes return code & vgremove locking.
808
809* Fri Sep 17 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-2
810- Obsolete old lvm1 packages; refuse install if running kernel 2.4. [bz 128185]
811
812* Thu Sep 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-1
813- More upstream fixes.  (Always check WHATS_NEW file for details.)
814- Add requested BuildRequires. [bz 124916, 132408]
815
816* Wed Sep 15 2004 Alasdair Kergon <agk@redhat.com> - 2.00.23-1
817- Various minor upstream fixes.
818
819* Fri Sep  3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.22-1
820- Permission fix included upstream; use different endian conversion macros.
821
822* Thu Sep  2 2004 Jeremy Katz <katzj@redhat.com> - 2.00.21-2
823- fix permissions on vg dirs
824
825* Thu Aug 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.21-1
826- New upstream release incorporating fixes plus minor enhancements.
827
828* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 2.00.20-2
829- add patch for iSeries viodasd support
830- add patch to check file type using stat(2) if d_type == DT_UNKNOWN (#129674)
831
832* Sat Jul 3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.20-1
833- New upstream release fixes 2.6 kernel device numbers.
834
835* Tue Jun 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.19-1
836- Latest upstream release.  Lots of changes (see WHATS_NEW).
837
838* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> - 2.00.15-5
839- rebuilt
840
841* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-4
842- clone %description from LVM rpm
843
844* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-3
845- vgscan shouldn't return error status when no VGs present
846
847* Thu May 06 2004 Warren Togami <wtogami@redhat.com> - 2.00.15-2
848- i2o patch from Markus Lidel
849
850* Tue Apr 20 2004 Bill Nottingham <notting@redhat.com> - 2.00.15-1.1
851- handle disabled SELinux correctly, so that LVMs can be detected in a
852  non-SELinux context
853 
854* Mon Apr 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-1
855- Fix non-root build with current version of 'install'.
856
857* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.14-1
858- Use 64-bit file offsets.
859
860* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.13-1
861- Avoid scanning devices containing md superblocks.
862- Integrate ENOTSUP patch.
863
864* Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 2.00.12-4
865- don't die if we get ENOTSUP setting selinux contexts
866
867* Thu Apr 15 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-3
868- Add temporary pvscan symlink for LVM1 until mkinitrd gets updated.
869
870* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-2
871- Mark config file noreplace.
872
873* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-1
874- Install default /etc/lvm/lvm.conf.
875- Move non-static binaries to /usr/sbin.
876- Add temporary links in /sbin to lvm.static until rc.sysinit gets updated.
877
878* Thu Apr 08 2004 Alasdair Kergon <agk@redhat.com> 2.00.11-1
879- Fallback to using LVM1 tools when using a 2.4 kernel without device-mapper.
880
881* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-2
882- Install the full toolset, not just 'lvm'.
883
884* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-1
885- Update to version 2.00.10, which incorporates the RH-specific patches
886  and includes various fixes and enhancements detailed in WHATS_NEW.
887
888* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.00.08-5
889- Fix sysfs patch to find sysfs
890- Take patch from dwalsh and tweak a little for setting SELinux contexts on
891  device node creation and also do it on the symlink creation. 
892  Part of this should probably be pushed down to device-mapper instead
893
894* Thu Feb 19 2004 Stephen C. Tweedie <sct@redhat.com> 2.00.08-4
895- Add sysfs filter patch
896- Allow non-root users to build RPM
897
898* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
899- rebuilt
900
901* Fri Dec  5 2003 Jeremy Katz <katzj@redhat.com> 2.00.08-2
902- add static lvm binary
903
904* Tue Dec  2 2003 Jeremy Katz <katzj@redhat.com>
905- Initial build.
906
907
Note: See TracBrowser for help on using the repository browser.