source: projects/specs/trunk/l/lvm2/lvm2-vl.spec @ 8753

Revision 8753, 23.9 KB checked in by daisuke, 10 years ago (diff)

lvm2: update to 2.02.107

Line 
1%define lvm_version 2.02.107
2%define device_mapper_version 1.02.86
3%define with_cluster 0
4
5# Do not reset Release to 1 unless both lvm2 and device-mapper
6# versions are increased together.
7
8Summary: Userland logical volume management tools
9Summary(ja): 論理ボリューム管理ツール
10Name: lvm2
11Version: %{lvm_version}
12Release: 1%{?_dist_release}
13License: GPL
14Group: System Environment/Base
15URL: http://sources.redhat.com/lvm2
16
17Source0: LVM2.%{lvm_version}.tgz
18Patch0: lvm2-set-default-preferred_names.patch
19Patch2: lvm2-remove-mpath-device-handling-from-udev-rules.patch
20Patch10: libdevmapper-static.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{lvm_version}-%{release}-buildroot
23BuildRequires: libtermcap-devel
24BuildRequires: ncurses-devel
25BuildRequires: readline-devel
26BuildRequires: eudev-libudev-devel
27Requires: device-mapper >= %{device_mapper_version}-%{release}
28Requires: device-mapper-event >= %{device_mapper_version}-%{release}
29Requires: %{name}-libs = %{version}-%{release}
30Conflicts: lvm
31Obsoletes: lvm
32
33Distribution: Vine Linux
34Vendor: Project Vine
35Packager: daisuke
36
37%define _exec_prefix /usr
38
39%description
40LVM2 includes all of the support for handling read/write operations on
41physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
42multiple devices (MD), see mdadd(8) or even loop devices, see
43losetup(8)), creating volume groups (kind of virtual disks) from one
44or more physical volumes and creating one or more logical volumes
45(kind of logical partitions) in volume groups.
46
47%package devel
48Summary: Development libraries and headers
49Group: Development/Libraries
50License: LGPLv2
51Requires: %{name} = %{version}-%{release}
52Requires: %{name}-libs = %{version}-%{release}
53Requires: device-mapper-devel >= %{device_mapper_version}-%{release}
54Requires: device-mapper-event-devel >= %{device_mapper_version}-%{release}
55Requires: pkgconfig
56
57%description devel
58This package contains files needed to develop applications that use
59the lvm2 libraries.
60
61%package libs
62Summary: lvm2 shared libraries
63License: LGPLv2
64Group: System Environment/Libraries
65
66%description libs
67This package contains shared lvm2 libraries for applications.
68
69%if %{with_cluster}
70# lvm2-cluster
71%package cluster
72Summary: Cluster extensions for userland logical volume management tools
73License: GPLv2
74Group: System Environment/Base
75Requires: lvm2 >= %{version}-%{lvm_release}
76Requires(post): chkconfig
77Requires(preun): chkconfig
78Requires(preun): device-mapper >= %{device_mapper_version}
79Requires(preun): lvm2 >= 2.02
80
81%description cluster
82Extensions to LVM2 to support clusters.
83%endif
84
85# device-mapper
86%package -n device-mapper
87Summary: Device mapper utility
88Version: %{device_mapper_version}
89Release: %{release}
90License: GPLv2
91Group: System Environment/Base
92URL: http://sources.redhat.com/dm
93Requires: device-mapper-libs = %{device_mapper_version}-%{release}
94Requires: eudev-libudev
95Requires: util-linux-ng >= 2.15
96
97%description -n device-mapper
98This package contains the supporting userspace utility, dmsetup,
99for the kernel device-mapper.
100
101# device-mapper-devel
102%package -n device-mapper-devel
103Summary: Development libraries and headers for device-mapper
104Version: %{device_mapper_version}
105Release: %{release}
106License: LGPLv2
107Group: Development/Libraries
108Requires: device-mapper = %{device_mapper_version}-%{release}
109Requires: device-mapper-libs = %{device_mapper_version}-%{release}
110
111%description -n device-mapper-devel
112This package contains files needed to develop applications that use
113the device-mapper libraries.
114
115# device-mapper-static
116%package -n device-mapper-static
117Summary: Static libraries for device-mapper
118Version: %{device_mapper_version}
119Release: %{release}
120License: LGPLv2
121Group: Development/Libraries
122Requires: device-mapper-devel = %{device_mapper_version}-%{release}
123
124%description -n device-mapper-static
125This package contains the device-mapper static libraries.
126
127%package -n device-mapper-libs
128Summary: Device-mapper shared library
129Version: %{device_mapper_version}
130Release: %{release}
131License: LGPLv2
132Group: System Environment/Libraries
133Obsoletes: device-mapper < 1.02.30-1
134
135%description -n device-mapper-libs
136This package contains the device-mapper shared library, libdevmapper.
137
138%package -n device-mapper-event
139Summary: Device-mapper event daemon
140Group: System Environment/Base
141Version: %{device_mapper_version}
142Release: %{release}
143Requires: device-mapper = %{device_mapper_version}-%{release}
144Requires: device-mapper-event-libs = %{device_mapper_version}-%{release}
145
146%description -n device-mapper-event
147This package contains the dmeventd daemon for monitoring the state
148of device-mapper devices.
149
150%package -n device-mapper-event-libs
151Summary: Device-mapper event daemon shared library
152Version: %{device_mapper_version}
153Release: %{release}
154License: LGPLv2
155Group: System Environment/Libraries
156
157%description -n device-mapper-event-libs
158This package contains the device-mapper event daemon shared library,
159libdevmapper-event.
160
161%package -n device-mapper-event-devel
162Summary: Development libraries and headers for the device-mapper event daemon
163Version: %{device_mapper_version}
164Release: %{release}
165License: LGPLv2
166Group: Development/Libraries
167Requires: device-mapper-event = %{device_mapper_version}-%{release}
168Requires: pkgconfig
169
170%description -n device-mapper-event-devel
171This package contains files needed to develop applications that use
172the device-mapper event library.
173
174%prep
175%setup -q -n LVM2.%{lvm_version}
176%patch0 -p1
177%patch2 -p1
178%patch10 -p1
179
180%build
181%define _exec_prefix /
182%define _bindir /bin
183%define _sbindir /sbin
184%define _libdir /%{_lib}
185%define _udevbasedir /lib/udev
186%define _udevdir %{_udevbasedir}/rules.d
187
188%configure \
189  --enable-readline \
190  --enable-lvm1_fallback \
191  --enable-fsadm \
192  --with-pool=internal \
193  --with-staticdir=/sbin \
194  --with-user= --with-group= \
195  --with-usrlibdir=/usr/%{_lib} \
196  --with-usrsbindir=/usr/sbin \
197  --with-dmdir=device-mapper.%{device_mapper_version} \
198  --with-udevdir=%{_udevdir} \
199  --with-device-uid=0 --with-device-gid=6 \
200  --with-device-mode=0660 \
201  --enable-pkgconfig \
202  --enable-applib \
203  --enable-cmdlib \
204  --enable-dmeventd \
205  --enable-udev_sync
206
207make %{?_smp_mflags}
208
209%install
210rm -rf $RPM_BUILD_ROOT
211make install DESTDIR=$RPM_BUILD_ROOT
212install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/archive
213install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/backup
214install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/cache
215install -m 0700 -d $RPM_BUILD_ROOT/var/lock/lvm
216install -m 0600 /dev/null $RPM_BUILD_ROOT/etc/lvm/cache/.cache
217mkdir -p -m755 $RPM_BUILD_ROOT/etc/rc.d/init.d
218%if %{with_cluster}
219install scripts/clvmd_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/clvmd
220install scripts/cmirrord_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/cmirrord
221%endif
222install -m 0755 scripts/lvm2_monitoring_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/lvm2-monitor
223install -m 0755 scripts/lvmconf.sh $RPM_BUILD_ROOT/sbin/lvmconf
224
225install -m 644 libdm/ioctl/libdevmapper.a $RPM_BUILD_ROOT/usr%{_libdir}
226
227%clean
228rm -rf $RPM_BUILD_ROOT
229
230%post
231/sbin/ldconfig
232/sbin/chkconfig --add lvm2-monitor
233
234%preun
235if [ "$1" = 0 ]; then
236        /sbin/chkconfig --del lvm2-monitor
237fi
238
239%post libs -p /sbin/ldconfig
240
241%postun libs -p /sbin/ldconfig
242
243%if %{with_cluster}
244%post cluster
245/sbin/chkconfig --add clvmd
246
247/sbin/lvmconf --lockinglibdir %{_libdir}
248
249%preun cluster
250if [ "$1" = 0 ]; then
251        /sbin/chkconfig --del clvmd
252        /sbin/lvmconf --disable-cluster
253fi
254%endif
255
256%post -n device-mapper-libs -p /sbin/ldconfig
257
258%postun -n device-mapper-libs -p /sbin/ldconfig
259
260%post -n device-mapper-event-libs -p /sbin/ldconfig
261
262%postun -n device-mapper-event-libs -p /sbin/ldconfig
263
264%files
265%defattr(-,root,root,-)
266%doc COPYING COPYING.LIB INSTALL README VERSION WHATS_NEW
267%attr(555,root,root) %{_sbindir}/fsadm
268%{_sbindir}/blkdeactivate
269%{_sbindir}/lvchange
270%{_sbindir}/lvconvert
271%{_sbindir}/lvcreate
272%{_sbindir}/lvdisplay
273%{_sbindir}/lvextend
274%{_sbindir}/lvm
275%{_sbindir}/lvmchange
276%{_sbindir}/lvmdiskscan
277%{_sbindir}/lvmdump
278%{_sbindir}/lvmsadc
279%{_sbindir}/lvmsar
280%{_sbindir}/lvreduce
281%{_sbindir}/lvremove
282%{_sbindir}/lvrename
283%{_sbindir}/lvresize
284%{_sbindir}/lvs
285%{_sbindir}/lvscan
286%{_sbindir}/pvchange
287%{_sbindir}/pvck
288%{_sbindir}/pvcreate
289%{_sbindir}/pvdisplay
290%{_sbindir}/pvmove
291%{_sbindir}/pvremove
292%{_sbindir}/pvresize
293%{_sbindir}/pvs
294%{_sbindir}/pvscan
295%{_sbindir}/vgcfgbackup
296%{_sbindir}/vgcfgrestore
297%{_sbindir}/vgchange
298%{_sbindir}/vgck
299%{_sbindir}/vgconvert
300%{_sbindir}/vgcreate
301%{_sbindir}/vgdisplay
302%{_sbindir}/vgexport
303%{_sbindir}/vgextend
304%{_sbindir}/vgimport
305%{_sbindir}/vgimportclone
306%{_sbindir}/vgmerge
307%{_sbindir}/vgmknodes
308%{_sbindir}/vgreduce
309%{_sbindir}/vgremove
310%{_sbindir}/vgrename
311%{_sbindir}/vgs
312%{_sbindir}/vgscan
313%{_sbindir}/vgsplit
314%{_sbindir}/lvmconf
315%{_mandir}/man5/lvm.conf.5.gz
316%{_mandir}/man7/lvmthin.7.gz
317%{_mandir}/man8/blkdeactivate.8.gz
318%{_mandir}/man8/fsadm.8.gz
319%{_mandir}/man8/lvchange.8.gz
320%{_mandir}/man8/lvconvert.8.gz
321%{_mandir}/man8/lvcreate.8.gz
322%{_mandir}/man8/lvdisplay.8.gz
323%{_mandir}/man8/lvextend.8.gz
324%{_mandir}/man8/lvm.8.gz
325%{_mandir}/man8/lvm-dumpconfig.8.gz
326%{_mandir}/man8/lvmchange.8.gz
327%{_mandir}/man8/lvmconf.8.gz
328%{_mandir}/man8/lvmdiskscan.8.gz
329%{_mandir}/man8/lvmdump.8.gz
330%{_mandir}/man8/lvmsadc.8.gz
331%{_mandir}/man8/lvmsar.8.gz
332%{_mandir}/man8/lvreduce.8.gz
333%{_mandir}/man8/lvremove.8.gz
334%{_mandir}/man8/lvrename.8.gz
335%{_mandir}/man8/lvresize.8.gz
336%{_mandir}/man8/lvs.8.gz
337%{_mandir}/man8/lvscan.8.gz
338%{_mandir}/man8/pvchange.8.gz
339%{_mandir}/man8/pvck.8.gz
340%{_mandir}/man8/pvcreate.8.gz
341%{_mandir}/man8/pvdisplay.8.gz
342%{_mandir}/man8/pvmove.8.gz
343%{_mandir}/man8/pvremove.8.gz
344%{_mandir}/man8/pvresize.8.gz
345%{_mandir}/man8/pvs.8.gz
346%{_mandir}/man8/pvscan.8.gz
347%{_mandir}/man8/vgcfgbackup.8.gz
348%{_mandir}/man8/vgcfgrestore.8.gz
349%{_mandir}/man8/vgchange.8.gz
350%{_mandir}/man8/vgck.8.gz
351%{_mandir}/man8/vgconvert.8.gz
352%{_mandir}/man8/vgcreate.8.gz
353%{_mandir}/man8/vgdisplay.8.gz
354%{_mandir}/man8/vgexport.8.gz
355%{_mandir}/man8/vgextend.8.gz
356%{_mandir}/man8/vgimport.8.gz
357%{_mandir}/man8/vgimportclone.8.gz
358%{_mandir}/man8/vgmerge.8.gz
359%{_mandir}/man8/vgmknodes.8.gz
360%{_mandir}/man8/vgreduce.8.gz
361%{_mandir}/man8/vgremove.8.gz
362%{_mandir}/man8/vgrename.8.gz
363%{_mandir}/man8/vgs.8.gz
364%{_mandir}/man8/vgscan.8.gz
365%{_mandir}/man8/vgsplit.8.gz
366%{_udevdir}/11-dm-lvm.rules
367%dir /etc/lvm
368%ghost /etc/lvm/cache/.cache
369%config(noreplace) /etc/lvm/lvm.conf
370%dir /etc/lvm/backup
371%dir /etc/lvm/cache
372%dir /etc/lvm/archive
373%dir /var/lock/lvm
374%dir /etc/lvm/profile
375/etc/lvm/profile/*.profile
376/etc/rc.d/init.d/lvm2-monitor
377
378%files devel
379%defattr(-,root,root,-)
380/usr%{_libdir}/liblvm2app.so
381/usr%{_libdir}/liblvm2cmd.so
382%{_includedir}/lvm2app.h
383%{_includedir}/lvm2cmd.h
384/usr%{_libdir}/pkgconfig/lvm2app.pc
385/usr%{_libdir}/libdevmapper-event-lvm2.so
386
387%files libs
388%attr(755,root,root) %{_libdir}/liblvm2app.so.*
389%attr(755,root,root) %{_libdir}/liblvm2cmd.so.*
390%attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so.*
391%dir %{_libdir}/device-mapper
392%{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
393%{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
394%{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
395%{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
396%{_libdir}/libdevmapper-event-lvm2mirror.so
397%{_libdir}/libdevmapper-event-lvm2snapshot.so
398%{_libdir}/libdevmapper-event-lvm2raid.so
399%{_libdir}/libdevmapper-event-lvm2thin.so
400
401%if %{with_cluster}
402%files cluster
403%defattr(-,root,root,-)
404%attr(755,root,root) /usr/sbin/clvmd
405%{_mandir}/man8/clvmd.8.gz
406/etc/rc.d/init.d/clvmd
407%endif
408
409%files -n device-mapper
410%defattr(-,root,root,-)
411%doc COPYING COPYING.LIB WHATS_NEW_DM VERSION_DM README INSTALL udev/12-dm-permissions.rules
412%attr(755,root,root) /sbin/dmsetup
413%{_mandir}/man8/dmsetup.8.gz
414%dir %{_udevbasedir}
415%dir %{_udevdir}
416%{_udevdir}/10-dm.rules
417%{_udevdir}/13-dm-disk.rules
418%{_udevdir}/95-dm-notify.rules
419
420%files -n device-mapper-devel
421%defattr(-,root,root,-)
422%attr(755,root,root) /usr%{_libdir}/libdevmapper.so
423%{_includedir}/libdevmapper.h
424/usr%{_libdir}/pkgconfig/devmapper.pc
425
426%files -n device-mapper-static
427%defattr(-,root,root,-)
428/usr%{_libdir}/libdevmapper.a
429
430%files -n device-mapper-libs
431%attr(755,root,root) %{_libdir}/libdevmapper.so.*
432
433%files -n device-mapper-event
434%defattr(-,root,root,-)
435%{_sbindir}/dmeventd
436%{_mandir}/man8/dmeventd.8.gz
437
438%files -n device-mapper-event-libs
439%{_libdir}/libdevmapper-event.so.*
440
441%files -n device-mapper-event-devel
442%defattr(-,root,root,-)
443%attr(755,root,root) /usr%{_libdir}/libdevmapper-event.so
444%{_includedir}/libdevmapper-event.h
445/usr%{_libdir}/pkgconfig/devmapper-event.pc
446
447%changelog
448* Mon Jul 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.02.107-1
449- update to 2.02.107
450
451* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.98-3
452- change BuildRequires: eudev-libudev-devel instead of libudev-devel
453
454* Tue Dec 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.98-2
455- add missing files to %%files
456
457* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.98-1
458- new upstream release
459
460* Mon Mar 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.84-1
461- new upstream release
462- enable static libs, add device-mapper-static subpackage
463
464* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.83-1
465- new upstream release
466
467* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.79-1
468- new upstream release
469
470* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.78-1
471- new upstream release
472- fix %%files
473
474* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.02.62-3
475- rebuilt with rpm-4.8.1 for pkg-config
476
477* Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-2
478- add missing file
479  - %{_udevdir}/11-dm-lvm.rules
480
481* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-1
482- new upstream release
483- add libs,devel subpackage
484  - liblvm2{app,cmd},libdevmapper-event-lvm2
485- enable dmeventd
486  - add device-mapper-event{,-libs,-devel}
487- enable udev sync code
488  - add BR: libudev-devel, R: libudev
489- disable static libs and binaries
490
491* Sun Feb 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.02.60-1
492- new upstream release
493
494* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.48-1
495- new upstream release
496
497* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.47-1
498- new upstream release
499
500* Wed Feb 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-2
501- add libdevmapper.a
502
503* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-1
504- new upstream release
505- upstream merge of device-mapper and lvm2 source.
506- move all binaries to /sbin
507- move libraries to /%%{_lib}
508
509* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.42-1
510- new upstream release
511
512* Sun Oct 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.41-1
513- new upstream release
514
515* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.40-1
516- new upstream release
517
518* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.39-1
519- new upstream release
520
521* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.38-1
522- new upstream release
523
524* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.35-1
525- new upstream release
526
527* Sat Dec 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.28-0vl1
528- new upstream release
529
530* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.13-0vl1
531- new upstream release
532
533* Sat Aug 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.06-0vl1
534- initial build for Vine Linux
535
536* Tue Aug  1 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-3
537- require new libselinux to avoid segfaults on xen (#200783)
538
539* Thu Jul 27 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-2
540- free trip through the buildsystem
541
542* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.02.06-1.2.1
543- rebuild
544
545* Tue Jun  6 2006 Stephen C. Tweedie <sct@redhat.com> - 2.02.06-1.2
546- Rebuild to pick up new nosegneg libc.a for lvm.static
547
548* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.1
549- Reinstate archs now build system is back.
550- BuildRequires libsepol-devel.
551
552* Fri May 12 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.0
553- New upstream release.
554
555* Sat Apr 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.1
556- Exclude archs that aren't building.
557
558* Fri Apr 21 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.0
559- Fix VG uuid comparisons.
560
561* Wed Apr 19 2006 Alasdair Kergon <agk@redhat.com> - 2.02.04-1.0
562- New release upstream, including better handling of duplicated VG names.
563
564* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2.1
565- bump again for double-long bug on ppc(64)
566
567* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2
568- rebuilt for new gcc4.1 snapshot and glibc changes
569
570* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
571- rebuilt
572
573* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> - 2.02.01-1
574- update to 2.02.01
575
576* Tue Nov  8 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-4
577- add patch for xen block devices
578
579* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
580- add -lselinux -lsepol to the static linking -ldevice-mapper requires it
581
582* Wed Sep 14 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-2
583- the distro doesn't really work without a 2.6 kernel, so no need to require it
584
585* Thu Aug 4 2005 Alasdair Kergon <agk@redhat.com> - 2.01.14-1.0
586- And a few more bugs fixes.
587
588* Wed Jul 13 2005 Alasdair Kergon <agk@redhat.com> - 2.01.13-1.0
589- Fix several bugs discovered in the last release.
590
591* Tue Jun 14 2005 Alasdair Kergon <agk@redhat.com> - 2.01.12-1.0
592- New version upstream with a lot of fixes and enhancements.
593
594* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.1
595- Add /etc/lvm
596
597* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.0
598- No longer abort read operations if archive/backup directories aren't there.
599- Add runtime directories and file to the package.
600
601* Tue Mar 22 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-1.0
602- Improve detection of external changes affecting internal cache.
603- Add clustered VG attribute.
604- Suppress rmdir opendir error message.
605
606* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.3
607* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.2
608* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.1
609- Suppress some new compiler messages.
610
611* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.0
612- Remove build directory from built-in path.
613- Extra /dev scanning required for clustered operation.
614
615* Thu Mar 03 2005 Alasdair Kergon <agk@redhat.com> - 2.01.06-1.0
616- Allow anaconda to suppress warning messages.
617
618* Fri Feb 18 2005 Alasdair Kergon <agk@redhat.com> - 2.01.05-1.0
619- Upstream changes not affecting Fedora.
620
621* Wed Feb 09 2005 Alasdair Kergon <agk@redhat.com> - 2.01.04-1.0
622- Offset pool minors; lvm2cmd.so skips open fd check; pvmove -f gone.
623
624* Tue Feb 01 2005 Alasdair Kergon <agk@redhat.com> - 2.01.03-1.0
625- Fix snapshot device size & 64-bit display output.
626
627* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> - 2.01.02-1.0
628- Minor fixes.
629
630* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.01-1.0
631- Update vgcreate man page.  Preparation for snapshot origin extension fix.
632
633* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.00-1.0
634- Fix metadata auto-correction. Only request open_count when needed.
635
636* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 2.00.33-2.0
637- Rebuilt for new readline.
638
639* Fri Jan 7 2005 Alasdair Kergon <agk@redhat.com> - 2.00.33-1.0
640- pvcreate wipes ext label
641- several clvm fixes
642
643* Thu Jan 6 2005 Alasdair Kergon <agk@redhat.com> - 2.00.32-2.0
644- Remove temporary /sbin symlinks no longer needed.
645- Include read-only pool support in the build.
646
647* Wed Dec 22 2004 Alasdair Kergon <agk@redhat.com> - 2.00.32-1.0
648- More fixes (143501).
649
650* Sun Dec 12 2004 Alasdair Kergon <agk@redhat.com> - 2.00.31-1.0
651- Fix pvcreate install issues.
652
653* Fri Dec 10 2004 Alasdair Kergon <agk@redhat.com> - 2.00.30-1.0
654- Additional debugging code.
655- Some trivial man page corrections.
656
657* Tue Nov 30 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.3
658- Reinstate all archs.
659
660* Sun Nov 28 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.2
661- Try excluding more archs.
662
663* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.1
664- Exclude s390x which fails.
665
666* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1
667- Fix last fix.
668
669* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.28-1
670- Endian fix to partition/md signature detection.
671
672* Wed Nov 24 2004 Alasdair Kergon <agk@redhat.com> - 2.00.27-1
673- Fix partition table detection & an out of memory segfault.
674
675* Tue Nov 23 2004 Alasdair Kergon <agk@redhat.com> - 2.00.26-1
676- Several installation-related fixes & man page updates.
677
678* Mon Oct 25 2004 Elliot Lee <sopwith@redhat.com> - 2.00.25-1.01
679- Fix 2.6 kernel requirement
680
681* Wed Sep 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.25-1
682- Fix vgmknodes return code & vgremove locking.
683
684* Fri Sep 17 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-2
685- Obsolete old lvm1 packages; refuse install if running kernel 2.4. [bz 128185]
686
687* Thu Sep 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-1
688- More upstream fixes.  (Always check WHATS_NEW file for details.)
689- Add requested BuildRequires. [bz 124916, 132408]
690
691* Wed Sep 15 2004 Alasdair Kergon <agk@redhat.com> - 2.00.23-1
692- Various minor upstream fixes.
693
694* Fri Sep  3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.22-1
695- Permission fix included upstream; use different endian conversion macros.
696
697* Thu Sep  2 2004 Jeremy Katz <katzj@redhat.com> - 2.00.21-2
698- fix permissions on vg dirs
699
700* Thu Aug 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.21-1
701- New upstream release incorporating fixes plus minor enhancements.
702
703* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 2.00.20-2
704- add patch for iSeries viodasd support
705- add patch to check file type using stat(2) if d_type == DT_UNKNOWN (#129674)
706
707* Sat Jul 3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.20-1
708- New upstream release fixes 2.6 kernel device numbers.
709
710* Tue Jun 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.19-1
711- Latest upstream release.  Lots of changes (see WHATS_NEW).
712
713* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> - 2.00.15-5
714- rebuilt
715
716* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-4
717- clone %description from LVM rpm
718
719* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-3
720- vgscan shouldn't return error status when no VGs present
721
722* Thu May 06 2004 Warren Togami <wtogami@redhat.com> - 2.00.15-2
723- i2o patch from Markus Lidel
724
725* Tue Apr 20 2004 Bill Nottingham <notting@redhat.com> - 2.00.15-1.1
726- handle disabled SELinux correctly, so that LVMs can be detected in a
727  non-SELinux context
728 
729* Mon Apr 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-1
730- Fix non-root build with current version of 'install'.
731
732* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.14-1
733- Use 64-bit file offsets.
734
735* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.13-1
736- Avoid scanning devices containing md superblocks.
737- Integrate ENOTSUP patch.
738
739* Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 2.00.12-4
740- don't die if we get ENOTSUP setting selinux contexts
741
742* Thu Apr 15 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-3
743- Add temporary pvscan symlink for LVM1 until mkinitrd gets updated.
744
745* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-2
746- Mark config file noreplace.
747
748* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-1
749- Install default /etc/lvm/lvm.conf.
750- Move non-static binaries to /usr/sbin.
751- Add temporary links in /sbin to lvm.static until rc.sysinit gets updated.
752
753* Thu Apr 08 2004 Alasdair Kergon <agk@redhat.com> 2.00.11-1
754- Fallback to using LVM1 tools when using a 2.4 kernel without device-mapper.
755
756* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-2
757- Install the full toolset, not just 'lvm'.
758
759* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-1
760- Update to version 2.00.10, which incorporates the RH-specific patches
761  and includes various fixes and enhancements detailed in WHATS_NEW.
762
763* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.00.08-5
764- Fix sysfs patch to find sysfs
765- Take patch from dwalsh and tweak a little for setting SELinux contexts on
766  device node creation and also do it on the symlink creation. 
767  Part of this should probably be pushed down to device-mapper instead
768
769* Thu Feb 19 2004 Stephen C. Tweedie <sct@redhat.com> 2.00.08-4
770- Add sysfs filter patch
771- Allow non-root users to build RPM
772
773* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
774- rebuilt
775
776* Fri Dec  5 2003 Jeremy Katz <katzj@redhat.com> 2.00.08-2
777- add static lvm binary
778
779* Tue Dec  2 2003 Jeremy Katz <katzj@redhat.com>
780- Initial build.
781
782
Note: See TracBrowser for help on using the repository browser.