source: projects/specs/trunk/l/lvm2/lvm2-vl.spec @ 7235

Revision 7235, 23.2 KB checked in by daisuke, 11 years ago (diff)

lvm2: add missing files to %%files

Line 
1%define lvm_version 2.02.98
2%define device_mapper_version 1.02.77
3%define with_cluster 0
4
5# Do not reset Release to 1 unless both lvm2 and device-mapper
6# versions are increased together.
7
8Summary: Userland logical volume management tools
9Summary(ja): 論理ボリューム管理ツール
10Name: lvm2
11Version: %{lvm_version}
12Release: 2%{?_dist_release}
13License: GPL
14Group: System Environment/Base
15URL: http://sources.redhat.com/lvm2
16
17Source0: LVM2.%{lvm_version}.tgz
18Patch10: libdevmapper-static.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{lvm_version}-%{release}-buildroot
21BuildRequires: libtermcap-devel
22BuildRequires: ncurses-devel
23BuildRequires: readline-devel
24BuildRequires: libudev-devel
25Requires: device-mapper >= %{device_mapper_version}-%{release}
26Requires: device-mapper-event >= %{device_mapper_version}-%{release}
27Requires: %{name}-libs = %{version}-%{release}
28Conflicts: lvm
29Obsoletes: lvm
30
31%define _exec_prefix /usr
32
33%description
34LVM2 includes all of the support for handling read/write operations on
35physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
36multiple devices (MD), see mdadd(8) or even loop devices, see
37losetup(8)), creating volume groups (kind of virtual disks) from one
38or more physical volumes and creating one or more logical volumes
39(kind of logical partitions) in volume groups.
40
41%package devel
42Summary: Development libraries and headers
43Group: Development/Libraries
44License: LGPLv2
45Requires: %{name} = %{version}-%{release}
46Requires: %{name}-libs = %{version}-%{release}
47Requires: device-mapper-devel >= %{device_mapper_version}-%{release}
48Requires: device-mapper-event-devel >= %{device_mapper_version}-%{release}
49Requires: pkgconfig
50
51%description devel
52This package contains files needed to develop applications that use
53the lvm2 libraries.
54
55%package libs
56Summary: lvm2 shared libraries
57License: LGPLv2
58Group: System Environment/Libraries
59
60%description libs
61This package contains shared lvm2 libraries for applications.
62
63%if %{with_cluster}
64# lvm2-cluster
65%package cluster
66Summary: Cluster extensions for userland logical volume management tools
67License: GPLv2
68Group: System Environment/Base
69Requires: lvm2 >= %{version}-%{lvm_release}
70Requires(post): chkconfig
71Requires(preun): chkconfig
72Requires(preun): device-mapper >= %{device_mapper_version}
73Requires(preun): lvm2 >= 2.02
74
75%description cluster
76Extensions to LVM2 to support clusters.
77%endif
78
79# device-mapper
80%package -n device-mapper
81Summary: Device mapper utility
82Version: %{device_mapper_version}
83Release: %{release}
84License: GPLv2
85Group: System Environment/Base
86URL: http://sources.redhat.com/dm
87Requires: device-mapper-libs = %{device_mapper_version}-%{release}
88Requires: libudev
89Requires: util-linux-ng >= 2.15
90
91%description -n device-mapper
92This package contains the supporting userspace utility, dmsetup,
93for the kernel device-mapper.
94
95# device-mapper-devel
96%package -n device-mapper-devel
97Summary: Development libraries and headers for device-mapper
98Version: %{device_mapper_version}
99Release: %{release}
100License: LGPLv2
101Group: Development/Libraries
102Requires: device-mapper = %{device_mapper_version}-%{release}
103Requires: device-mapper-libs = %{device_mapper_version}-%{release}
104
105%description -n device-mapper-devel
106This package contains files needed to develop applications that use
107the device-mapper libraries.
108
109# device-mapper-static
110%package -n device-mapper-static
111Summary: Static libraries for device-mapper
112Version: %{device_mapper_version}
113Release: %{release}
114License: LGPLv2
115Group: Development/Libraries
116Requires: device-mapper-devel = %{device_mapper_version}-%{release}
117
118%description -n device-mapper-static
119This package contains the device-mapper static libraries.
120
121%package -n device-mapper-libs
122Summary: Device-mapper shared library
123Version: %{device_mapper_version}
124Release: %{release}
125License: LGPLv2
126Group: System Environment/Libraries
127Obsoletes: device-mapper < 1.02.30-1
128
129%description -n device-mapper-libs
130This package contains the device-mapper shared library, libdevmapper.
131
132%package -n device-mapper-event
133Summary: Device-mapper event daemon
134Group: System Environment/Base
135Version: %{device_mapper_version}
136Release: %{release}
137Requires: device-mapper = %{device_mapper_version}-%{release}
138Requires: device-mapper-event-libs = %{device_mapper_version}-%{release}
139
140%description -n device-mapper-event
141This package contains the dmeventd daemon for monitoring the state
142of device-mapper devices.
143
144%package -n device-mapper-event-libs
145Summary: Device-mapper event daemon shared library
146Version: %{device_mapper_version}
147Release: %{release}
148License: LGPLv2
149Group: System Environment/Libraries
150
151%description -n device-mapper-event-libs
152This package contains the device-mapper event daemon shared library,
153libdevmapper-event.
154
155%package -n device-mapper-event-devel
156Summary: Development libraries and headers for the device-mapper event daemon
157Version: %{device_mapper_version}
158Release: %{release}
159License: LGPLv2
160Group: Development/Libraries
161Requires: device-mapper-event = %{device_mapper_version}-%{release}
162Requires: pkgconfig
163
164%description -n device-mapper-event-devel
165This package contains files needed to develop applications that use
166the device-mapper event library.
167
168%prep
169%setup -q -n LVM2.%{lvm_version}
170%patch10 -p1
171
172%build
173%define _exec_prefix /
174%define _bindir /bin
175%define _sbindir /sbin
176%define _libdir /%{_lib}
177%define _udevbasedir /lib/udev
178%define _udevdir %{_udevbasedir}/rules.d
179
180%configure \
181  --enable-readline \
182  --enable-lvm1_fallback \
183  --enable-fsadm \
184  --with-pool=internal \
185  --with-staticdir=/sbin \
186  --with-user= --with-group= \
187  --with-usrlibdir=/usr/%{_lib} \
188  --with-usrsbindir=/usr/sbin \
189  --with-dmdir=device-mapper.%{device_mapper_version} \
190  --with-udevdir=%{_udevdir} \
191  --with-device-uid=0 --with-device-gid=6 \
192  --with-device-mode=0660 \
193  --enable-pkgconfig \
194  --enable-applib \
195  --enable-cmdlib \
196  --enable-dmeventd \
197  --enable-udev_sync
198
199make %{?_smp_mflags}
200
201%install
202rm -rf $RPM_BUILD_ROOT
203make install DESTDIR=$RPM_BUILD_ROOT
204install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/archive
205install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/backup
206install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/cache
207install -m 0700 -d $RPM_BUILD_ROOT/var/lock/lvm
208install -m 0600 /dev/null $RPM_BUILD_ROOT/etc/lvm/cache/.cache
209mkdir -p -m755 $RPM_BUILD_ROOT/etc/rc.d/init.d
210%if %{with_cluster}
211install scripts/clvmd_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/clvmd
212install scripts/cmirrord_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/cmirrord
213%endif
214install -m 0755 scripts/lvm2_monitoring_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/lvm2-monitor
215install -m 0755 scripts/lvmconf.sh $RPM_BUILD_ROOT/sbin/lvmconf
216
217install -m 644 libdm/ioctl/libdevmapper.a $RPM_BUILD_ROOT/usr%{_libdir}
218
219%clean
220rm -rf $RPM_BUILD_ROOT
221
222%post
223/sbin/ldconfig
224/sbin/chkconfig --add lvm2-monitor
225
226%preun
227if [ "$1" = 0 ]; then
228        /sbin/chkconfig --del lvm2-monitor
229fi
230
231%post libs -p /sbin/ldconfig
232
233%postun libs -p /sbin/ldconfig
234
235%if %{with_cluster}
236%post cluster
237/sbin/chkconfig --add clvmd
238
239/sbin/lvmconf --lockinglibdir %{_libdir}
240
241%preun cluster
242if [ "$1" = 0 ]; then
243        /sbin/chkconfig --del clvmd
244        /sbin/lvmconf --disable-cluster
245fi
246%endif
247
248%post -n device-mapper-libs -p /sbin/ldconfig
249
250%postun -n device-mapper-libs -p /sbin/ldconfig
251
252%post -n device-mapper-event-libs -p /sbin/ldconfig
253
254%postun -n device-mapper-event-libs -p /sbin/ldconfig
255
256%files
257%defattr(-,root,root,-)
258%doc COPYING COPYING.LIB INSTALL README VERSION WHATS_NEW
259%attr(555,root,root) %{_sbindir}/fsadm
260%{_sbindir}/blkdeactivate
261%{_sbindir}/lvchange
262%{_sbindir}/lvconvert
263%{_sbindir}/lvcreate
264%{_sbindir}/lvdisplay
265%{_sbindir}/lvextend
266%{_sbindir}/lvm
267%{_sbindir}/lvmchange
268%{_sbindir}/lvmdiskscan
269%{_sbindir}/lvmdump
270%{_sbindir}/lvmsadc
271%{_sbindir}/lvmsar
272%{_sbindir}/lvreduce
273%{_sbindir}/lvremove
274%{_sbindir}/lvrename
275%{_sbindir}/lvresize
276%{_sbindir}/lvs
277%{_sbindir}/lvscan
278%{_sbindir}/pvchange
279%{_sbindir}/pvck
280%{_sbindir}/pvcreate
281%{_sbindir}/pvdisplay
282%{_sbindir}/pvmove
283%{_sbindir}/pvremove
284%{_sbindir}/pvresize
285%{_sbindir}/pvs
286%{_sbindir}/pvscan
287%{_sbindir}/vgcfgbackup
288%{_sbindir}/vgcfgrestore
289%{_sbindir}/vgchange
290%{_sbindir}/vgck
291%{_sbindir}/vgconvert
292%{_sbindir}/vgcreate
293%{_sbindir}/vgdisplay
294%{_sbindir}/vgexport
295%{_sbindir}/vgextend
296%{_sbindir}/vgimport
297%{_sbindir}/vgimportclone
298%{_sbindir}/vgmerge
299%{_sbindir}/vgmknodes
300%{_sbindir}/vgreduce
301%{_sbindir}/vgremove
302%{_sbindir}/vgrename
303%{_sbindir}/vgs
304%{_sbindir}/vgscan
305%{_sbindir}/vgsplit
306%{_sbindir}/lvmconf
307%{_mandir}/man5/lvm.conf.5.gz
308%{_mandir}/man8/blkdeactivate.8.gz
309%{_mandir}/man8/fsadm.8.gz
310%{_mandir}/man8/lvchange.8.gz
311%{_mandir}/man8/lvconvert.8.gz
312%{_mandir}/man8/lvcreate.8.gz
313%{_mandir}/man8/lvdisplay.8.gz
314%{_mandir}/man8/lvextend.8.gz
315%{_mandir}/man8/lvm.8.gz
316%{_mandir}/man8/lvmchange.8.gz
317%{_mandir}/man8/lvmconf.8.gz
318%{_mandir}/man8/lvmdiskscan.8.gz
319%{_mandir}/man8/lvmdump.8.gz
320%{_mandir}/man8/lvmsadc.8.gz
321%{_mandir}/man8/lvmsar.8.gz
322%{_mandir}/man8/lvreduce.8.gz
323%{_mandir}/man8/lvremove.8.gz
324%{_mandir}/man8/lvrename.8.gz
325%{_mandir}/man8/lvresize.8.gz
326%{_mandir}/man8/lvs.8.gz
327%{_mandir}/man8/lvscan.8.gz
328%{_mandir}/man8/pvchange.8.gz
329%{_mandir}/man8/pvck.8.gz
330%{_mandir}/man8/pvcreate.8.gz
331%{_mandir}/man8/pvdisplay.8.gz
332%{_mandir}/man8/pvmove.8.gz
333%{_mandir}/man8/pvremove.8.gz
334%{_mandir}/man8/pvresize.8.gz
335%{_mandir}/man8/pvs.8.gz
336%{_mandir}/man8/pvscan.8.gz
337%{_mandir}/man8/vgcfgbackup.8.gz
338%{_mandir}/man8/vgcfgrestore.8.gz
339%{_mandir}/man8/vgchange.8.gz
340%{_mandir}/man8/vgck.8.gz
341%{_mandir}/man8/vgconvert.8.gz
342%{_mandir}/man8/vgcreate.8.gz
343%{_mandir}/man8/vgdisplay.8.gz
344%{_mandir}/man8/vgexport.8.gz
345%{_mandir}/man8/vgextend.8.gz
346%{_mandir}/man8/vgimport.8.gz
347%{_mandir}/man8/vgimportclone.8.gz
348%{_mandir}/man8/vgmerge.8.gz
349%{_mandir}/man8/vgmknodes.8.gz
350%{_mandir}/man8/vgreduce.8.gz
351%{_mandir}/man8/vgremove.8.gz
352%{_mandir}/man8/vgrename.8.gz
353%{_mandir}/man8/vgs.8.gz
354%{_mandir}/man8/vgscan.8.gz
355%{_mandir}/man8/vgsplit.8.gz
356%{_udevdir}/11-dm-lvm.rules
357%dir /etc/lvm
358%ghost /etc/lvm/cache/.cache
359%config(noreplace) /etc/lvm/lvm.conf
360%dir /etc/lvm/backup
361%dir /etc/lvm/cache
362%dir /etc/lvm/archive
363%dir /var/lock/lvm
364/etc/rc.d/init.d/lvm2-monitor
365
366%files devel
367%defattr(-,root,root,-)
368/usr%{_libdir}/liblvm2app.so
369/usr%{_libdir}/liblvm2cmd.so
370%{_includedir}/lvm2app.h
371%{_includedir}/lvm2cmd.h
372/usr%{_libdir}/pkgconfig/lvm2app.pc
373/usr%{_libdir}/libdevmapper-event-lvm2.so
374
375%files libs
376%attr(755,root,root) %{_libdir}/liblvm2app.so.*
377%attr(755,root,root) %{_libdir}/liblvm2cmd.so.*
378%attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so.*
379%dir %{_libdir}/device-mapper
380%{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
381%{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
382%{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
383%{_libdir}/libdevmapper-event-lvm2mirror.so
384%{_libdir}/libdevmapper-event-lvm2snapshot.so
385%{_libdir}/libdevmapper-event-lvm2raid.so
386
387%if %{with_cluster}
388%files cluster
389%defattr(-,root,root,-)
390%attr(755,root,root) /usr/sbin/clvmd
391%{_mandir}/man8/clvmd.8.gz
392/etc/rc.d/init.d/clvmd
393%endif
394
395%files -n device-mapper
396%defattr(-,root,root,-)
397%doc COPYING COPYING.LIB WHATS_NEW_DM VERSION_DM README INSTALL udev/12-dm-permissions.rules
398%attr(755,root,root) /sbin/dmsetup
399%{_mandir}/man8/dmsetup.8.gz
400%dir %{_udevbasedir}
401%dir %{_udevdir}
402%{_udevdir}/10-dm.rules
403%{_udevdir}/13-dm-disk.rules
404%{_udevdir}/95-dm-notify.rules
405
406%files -n device-mapper-devel
407%defattr(-,root,root,-)
408%attr(755,root,root) /usr%{_libdir}/libdevmapper.so
409%{_includedir}/libdevmapper.h
410/usr%{_libdir}/pkgconfig/devmapper.pc
411
412%files -n device-mapper-static
413%defattr(-,root,root,-)
414/usr%{_libdir}/libdevmapper.a
415
416%files -n device-mapper-libs
417%attr(755,root,root) %{_libdir}/libdevmapper.so.*
418
419%files -n device-mapper-event
420%defattr(-,root,root,-)
421%{_sbindir}/dmeventd
422%{_mandir}/man8/dmeventd.8.gz
423
424%files -n device-mapper-event-libs
425%{_libdir}/libdevmapper-event.so.*
426
427%files -n device-mapper-event-devel
428%defattr(-,root,root,-)
429%attr(755,root,root) /usr%{_libdir}/libdevmapper-event.so
430%{_includedir}/libdevmapper-event.h
431/usr%{_libdir}/pkgconfig/devmapper-event.pc
432
433%changelog
434* Tue Dec 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.98-2
435- add missing files to %%files
436
437* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.98-1
438- new upstream release
439
440* Mon Mar 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.84-1
441- new upstream release
442- enable static libs, add device-mapper-static subpackage
443
444* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.83-1
445- new upstream release
446
447* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.79-1
448- new upstream release
449
450* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.78-1
451- new upstream release
452- fix %%files
453
454* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.02.62-3
455- rebuilt with rpm-4.8.1 for pkg-config
456
457* Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-2
458- add missing file
459  - %{_udevdir}/11-dm-lvm.rules
460
461* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-1
462- new upstream release
463- add libs,devel subpackage
464  - liblvm2{app,cmd},libdevmapper-event-lvm2
465- enable dmeventd
466  - add device-mapper-event{,-libs,-devel}
467- enable udev sync code
468  - add BR: libudev-devel, R: libudev
469- disable static libs and binaries
470
471* Sun Feb 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.02.60-1
472- new upstream release
473
474* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.48-1
475- new upstream release
476
477* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.47-1
478- new upstream release
479
480* Wed Feb 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-2
481- add libdevmapper.a
482
483* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-1
484- new upstream release
485- upstream merge of device-mapper and lvm2 source.
486- move all binaries to /sbin
487- move libraries to /%%{_lib}
488
489* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.42-1
490- new upstream release
491
492* Sun Oct 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.41-1
493- new upstream release
494
495* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.40-1
496- new upstream release
497
498* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.39-1
499- new upstream release
500
501* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.38-1
502- new upstream release
503
504* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.35-1
505- new upstream release
506
507* Sat Dec 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.28-0vl1
508- new upstream release
509
510* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.13-0vl1
511- new upstream release
512
513* Sat Aug 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.06-0vl1
514- initial build for Vine Linux
515
516* Tue Aug  1 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-3
517- require new libselinux to avoid segfaults on xen (#200783)
518
519* Thu Jul 27 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-2
520- free trip through the buildsystem
521
522* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.02.06-1.2.1
523- rebuild
524
525* Tue Jun  6 2006 Stephen C. Tweedie <sct@redhat.com> - 2.02.06-1.2
526- Rebuild to pick up new nosegneg libc.a for lvm.static
527
528* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.1
529- Reinstate archs now build system is back.
530- BuildRequires libsepol-devel.
531
532* Fri May 12 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.0
533- New upstream release.
534
535* Sat Apr 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.1
536- Exclude archs that aren't building.
537
538* Fri Apr 21 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.0
539- Fix VG uuid comparisons.
540
541* Wed Apr 19 2006 Alasdair Kergon <agk@redhat.com> - 2.02.04-1.0
542- New release upstream, including better handling of duplicated VG names.
543
544* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2.1
545- bump again for double-long bug on ppc(64)
546
547* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2
548- rebuilt for new gcc4.1 snapshot and glibc changes
549
550* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
551- rebuilt
552
553* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> - 2.02.01-1
554- update to 2.02.01
555
556* Tue Nov  8 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-4
557- add patch for xen block devices
558
559* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
560- add -lselinux -lsepol to the static linking -ldevice-mapper requires it
561
562* Wed Sep 14 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-2
563- the distro doesn't really work without a 2.6 kernel, so no need to require it
564
565* Thu Aug 4 2005 Alasdair Kergon <agk@redhat.com> - 2.01.14-1.0
566- And a few more bugs fixes.
567
568* Wed Jul 13 2005 Alasdair Kergon <agk@redhat.com> - 2.01.13-1.0
569- Fix several bugs discovered in the last release.
570
571* Tue Jun 14 2005 Alasdair Kergon <agk@redhat.com> - 2.01.12-1.0
572- New version upstream with a lot of fixes and enhancements.
573
574* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.1
575- Add /etc/lvm
576
577* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.0
578- No longer abort read operations if archive/backup directories aren't there.
579- Add runtime directories and file to the package.
580
581* Tue Mar 22 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-1.0
582- Improve detection of external changes affecting internal cache.
583- Add clustered VG attribute.
584- Suppress rmdir opendir error message.
585
586* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.3
587* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.2
588* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.1
589- Suppress some new compiler messages.
590
591* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.0
592- Remove build directory from built-in path.
593- Extra /dev scanning required for clustered operation.
594
595* Thu Mar 03 2005 Alasdair Kergon <agk@redhat.com> - 2.01.06-1.0
596- Allow anaconda to suppress warning messages.
597
598* Fri Feb 18 2005 Alasdair Kergon <agk@redhat.com> - 2.01.05-1.0
599- Upstream changes not affecting Fedora.
600
601* Wed Feb 09 2005 Alasdair Kergon <agk@redhat.com> - 2.01.04-1.0
602- Offset pool minors; lvm2cmd.so skips open fd check; pvmove -f gone.
603
604* Tue Feb 01 2005 Alasdair Kergon <agk@redhat.com> - 2.01.03-1.0
605- Fix snapshot device size & 64-bit display output.
606
607* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> - 2.01.02-1.0
608- Minor fixes.
609
610* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.01-1.0
611- Update vgcreate man page.  Preparation for snapshot origin extension fix.
612
613* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.00-1.0
614- Fix metadata auto-correction. Only request open_count when needed.
615
616* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 2.00.33-2.0
617- Rebuilt for new readline.
618
619* Fri Jan 7 2005 Alasdair Kergon <agk@redhat.com> - 2.00.33-1.0
620- pvcreate wipes ext label
621- several clvm fixes
622
623* Thu Jan 6 2005 Alasdair Kergon <agk@redhat.com> - 2.00.32-2.0
624- Remove temporary /sbin symlinks no longer needed.
625- Include read-only pool support in the build.
626
627* Wed Dec 22 2004 Alasdair Kergon <agk@redhat.com> - 2.00.32-1.0
628- More fixes (143501).
629
630* Sun Dec 12 2004 Alasdair Kergon <agk@redhat.com> - 2.00.31-1.0
631- Fix pvcreate install issues.
632
633* Fri Dec 10 2004 Alasdair Kergon <agk@redhat.com> - 2.00.30-1.0
634- Additional debugging code.
635- Some trivial man page corrections.
636
637* Tue Nov 30 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.3
638- Reinstate all archs.
639
640* Sun Nov 28 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.2
641- Try excluding more archs.
642
643* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.1
644- Exclude s390x which fails.
645
646* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1
647- Fix last fix.
648
649* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.28-1
650- Endian fix to partition/md signature detection.
651
652* Wed Nov 24 2004 Alasdair Kergon <agk@redhat.com> - 2.00.27-1
653- Fix partition table detection & an out of memory segfault.
654
655* Tue Nov 23 2004 Alasdair Kergon <agk@redhat.com> - 2.00.26-1
656- Several installation-related fixes & man page updates.
657
658* Mon Oct 25 2004 Elliot Lee <sopwith@redhat.com> - 2.00.25-1.01
659- Fix 2.6 kernel requirement
660
661* Wed Sep 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.25-1
662- Fix vgmknodes return code & vgremove locking.
663
664* Fri Sep 17 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-2
665- Obsolete old lvm1 packages; refuse install if running kernel 2.4. [bz 128185]
666
667* Thu Sep 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-1
668- More upstream fixes.  (Always check WHATS_NEW file for details.)
669- Add requested BuildRequires. [bz 124916, 132408]
670
671* Wed Sep 15 2004 Alasdair Kergon <agk@redhat.com> - 2.00.23-1
672- Various minor upstream fixes.
673
674* Thu Sep  3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.22-1
675- Permission fix included upstream; use different endian conversion macros.
676
677* Thu Sep  2 2004 Jeremy Katz <katzj@redhat.com> - 2.00.21-2
678- fix permissions on vg dirs
679
680* Thu Aug 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.21-1
681- New upstream release incorporating fixes plus minor enhancements.
682
683* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 2.00.20-2
684- add patch for iSeries viodasd support
685- add patch to check file type using stat(2) if d_type == DT_UNKNOWN (#129674)
686
687* Sat Jul 3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.20-1
688- New upstream release fixes 2.6 kernel device numbers.
689
690* Tue Jun 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.19-1
691- Latest upstream release.  Lots of changes (see WHATS_NEW).
692
693* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> - 2.00.15-5
694- rebuilt
695
696* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-4
697- clone %description from LVM rpm
698
699* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-3
700- vgscan shouldn't return error status when no VGs present
701
702* Thu May 06 2004 Warren Togami <wtogami@redhat.com> - 2.00.15-2
703- i2o patch from Markus Lidel
704
705* Tue Apr 20 2004 Bill Nottingham <notting@redhat.com> - 2.00.15-1.1
706- handle disabled SELinux correctly, so that LVMs can be detected in a
707  non-SELinux context
708 
709* Mon Apr 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-1
710- Fix non-root build with current version of 'install'.
711
712* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.14-1
713- Use 64-bit file offsets.
714
715* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.13-1
716- Avoid scanning devices containing md superblocks.
717- Integrate ENOTSUP patch.
718
719* Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 2.00.12-4
720- don't die if we get ENOTSUP setting selinux contexts
721
722* Thu Apr 15 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-3
723- Add temporary pvscan symlink for LVM1 until mkinitrd gets updated.
724
725* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-2
726- Mark config file noreplace.
727
728* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-1
729- Install default /etc/lvm/lvm.conf.
730- Move non-static binaries to /usr/sbin.
731- Add temporary links in /sbin to lvm.static until rc.sysinit gets updated.
732
733* Thu Apr 08 2004 Alasdair Kergon <agk@redhat.com> 2.00.11-1
734- Fallback to using LVM1 tools when using a 2.4 kernel without device-mapper.
735
736* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-2
737- Install the full toolset, not just 'lvm'.
738
739* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-1
740- Update to version 2.00.10, which incorporates the RH-specific patches
741  and includes various fixes and enhancements detailed in WHATS_NEW.
742
743* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.00.08-5
744- Fix sysfs patch to find sysfs
745- Take patch from dwalsh and tweak a little for setting SELinux contexts on
746  device node creation and also do it on the symlink creation. 
747  Part of this should probably be pushed down to device-mapper instead
748
749* Thu Feb 19 2004 Stephen C. Tweedie <sct@redhat.com> 2.00.08-4
750- Add sysfs filter patch
751- Allow non-root users to build RPM
752
753* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
754- rebuilt
755
756* Fri Dec  5 2003 Jeremy Katz <katzj@redhat.com> 2.00.08-2
757- add static lvm binary
758
759* Tue Dec  2 2003 Jeremy Katz <katzj@redhat.com>
760- Initial build.
761
762
Note: See TracBrowser for help on using the repository browser.