source: projects/specs/trunk/l/lvm2/lvm2-vl.spec @ 521

Revision 521, 17.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define brp-strip-shared /bin/true
2%define lvm_version 2.02.60
3%define device_mapper_version 1.02.43
4%define with_cluster 0
5
6Summary: Userland logical volume management tools
7Summary(ja): 論理ボリューム管理ツール
8Name: lvm2
9Version: %{lvm_version}
10Release: 1%{?_dist_release}
11License: GPL
12Group: System Environment/Base
13URL: http://sources.redhat.com/lvm2
14Source0: LVM2.%{lvm_version}.tgz
15BuildRoot: %{_tmppath}/%{name}-%{lvm_version}-%{release}-buildroot
16BuildRequires: libtermcap-devel
17BuildRequires: ncurses-devel
18BuildRequires: readline-devel
19Requires: device-mapper >= %{device_mapper_version}-%{release}
20Conflicts: lvm
21Obsoletes: lvm
22
23%define _exec_prefix /usr
24
25%description
26LVM2 includes all of the support for handling read/write operations on
27physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
28multiple devices (MD), see mdadd(8) or even loop devices, see
29losetup(8)), creating volume groups (kind of virtual disks) from one
30or more physical volumes and creating one or more logical volumes
31(kind of logical partitions) in volume groups.
32
33%if %{with_cluster}
34# lvm2-cluster
35%package cluster
36Summary: Cluster extensions for userland logical volume management tools
37License: GPLv2
38Group: System Environment/Base
39Requires: lvm2 >= %{version}-%{lvm_release}
40Requires(post): chkconfig
41Requires(preun): chkconfig
42Requires(preun): device-mapper >= %{device_mapper_version}
43Requires(preun): lvm2 >= 2.02
44
45%description cluster
46Extensions to LVM2 to support clusters.
47%endif
48
49# device-mapper
50%package -n device-mapper
51Summary: Device mapper utility
52Version: %{device_mapper_version}
53Release: %{release}
54License: GPLv2
55Group: System Environment/Base
56URL: http://sources.redhat.com/dm
57Requires: device-mapper-libs = %{device_mapper_version}-%{release}
58
59%description -n device-mapper
60This package contains the supporting userspace utility, dmsetup,
61for the kernel device-mapper.
62
63# device-mapper-devel
64%package -n device-mapper-devel
65Summary: Development libraries and headers for device-mapper
66Version: %{device_mapper_version}
67Release: %{release}
68License: LGPLv2
69Group: Development/Libraries
70Requires: device-mapper = %{device_mapper_version}-%{release}
71Requires: device-mapper-libs = %{device_mapper_version}-%{release}
72
73%description -n device-mapper-devel
74This package contains files needed to develop applications that use
75the device-mapper libraries.
76
77%package -n device-mapper-libs
78Summary: Device-mapper shared library
79Version: %{device_mapper_version}
80Release: %{release}
81License: LGPLv2
82Group: System Environment/Libraries
83Obsoletes: device-mapper < 1.02.30-1
84
85%description -n device-mapper-libs
86This package contains the device-mapper shared library, libdevmapper.
87
88
89%prep
90%setup -q -n LVM2.%{lvm_version}
91
92%build
93%define _exec_prefix /
94%define _bindir /bin
95%define _sbindir /sbin
96%define _libdir /%{_lib}
97
98%configure --enable-static_link --enable-readline --enable-lvm1_fallback \
99           --with-pool=internal --with-staticdir=/sbin \
100           --with-user= --with-group= \
101           --with-dmdir=device-mapper.%{device_mapper_version} \
102           --with-usrlibdir=/usr/%{_lib} --with-usrsbindir=/usr/sbin \
103           --with-device-uid=0 --with-device-gid=6 \
104           --with-device-mode=0660 --enable-pkgconfig
105
106make DESTDIR=$RPM_BUILD_ROOT
107
108%install
109rm -rf $RPM_BUILD_ROOT
110make install DESTDIR=$RPM_BUILD_ROOT
111install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/archive
112install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/backup
113install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/cache
114install -m 0700 -d $RPM_BUILD_ROOT/var/lock/lvm
115install -m 0600 /dev/null $RPM_BUILD_ROOT/etc/lvm/cache/.cache
116mkdir -p -m755 $RPM_BUILD_ROOT/etc/rc.d/init.d
117%if %{with_cluster}
118install scripts/clvmd_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/clvmd
119install -m 0755 scripts/lvmconf.sh $RPM_BUILD_ROOT/sbin/lvmconf
120%endif
121
122mkdir -p $RPM_BUILD_ROOT/%{_libdir}
123mv $RPM_BUILD_ROOT/%{_lib}/libdevmapper.a* $RPM_BUILD_ROOT/%{_prefix}/%{_lib}/
124
125# temporarily changes file permissions so that brp-strip* succeeds
126find $RPM_BUILD_ROOT/sbin -type f -exec chmod 0755 {} \;
127chmod 0755 $RPM_BUILD_ROOT/%{_lib}/*.so.*
128chmod 0755 $RPM_BUILD_ROOT/%{_prefix}/%{_lib}/*.a.*
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%if %{with_cluster}
134%post cluster
135/sbin/chkconfig --add clvmd
136
137/sbin/lvmconf --lockinglibdir %{_libdir}
138
139%preun cluster
140if [ "$1" = 0 ]; then
141        /sbin/chkconfig --del clvmd
142        /sbin/lvmconf --disable-cluster
143fi
144%endif
145
146%post -n device-mapper-libs -p /sbin/ldconfig
147
148%postun -n device-mapper-libs -p /sbin/ldconfig
149
150%files
151%defattr(-,root,root,-)
152%doc COPYING COPYING.LIB INSTALL README VERSION WHATS_NEW
153%attr(555,root,root) %{_sbindir}/fsadm
154%{_sbindir}/lvchange
155%{_sbindir}/lvconvert
156%{_sbindir}/lvcreate
157%{_sbindir}/lvdisplay
158%{_sbindir}/lvextend
159%attr(555,root,root) %{_sbindir}/lvm
160%attr(555,root,root) %{_sbindir}/lvm.static
161%{_sbindir}/lvmchange
162%{_sbindir}/lvmdiskscan
163%attr(555,root,root) %{_sbindir}/lvmdump
164%{_sbindir}/lvmsadc
165%{_sbindir}/lvmsar
166%{_sbindir}/lvreduce
167%{_sbindir}/lvremove
168%{_sbindir}/lvrename
169%{_sbindir}/lvresize
170%{_sbindir}/lvs
171%{_sbindir}/lvscan
172%{_sbindir}/pvchange
173%{_sbindir}/pvck
174%{_sbindir}/pvcreate
175%{_sbindir}/pvdisplay
176%{_sbindir}/pvmove
177%{_sbindir}/pvremove
178%{_sbindir}/pvresize
179%{_sbindir}/pvs
180%{_sbindir}/pvscan
181%{_sbindir}/vgcfgbackup
182%{_sbindir}/vgcfgrestore
183%{_sbindir}/vgchange
184%{_sbindir}/vgck
185%{_sbindir}/vgconvert
186%{_sbindir}/vgcreate
187%{_sbindir}/vgdisplay
188%{_sbindir}/vgexport
189%{_sbindir}/vgextend
190%{_sbindir}/vgimport
191%attr(555,root,root) %{_sbindir}/vgimportclone
192%{_sbindir}/vgmerge
193%{_sbindir}/vgmknodes
194%{_sbindir}/vgreduce
195%{_sbindir}/vgremove
196%{_sbindir}/vgrename
197%{_sbindir}/vgs
198%{_sbindir}/vgscan
199%{_sbindir}/vgsplit
200%{_mandir}/man5/lvm.conf.5.gz
201%{_mandir}/man8/fsadm.8.gz
202%{_mandir}/man8/lvchange.8.gz
203%{_mandir}/man8/lvconvert.8.gz
204%{_mandir}/man8/lvcreate.8.gz
205%{_mandir}/man8/lvdisplay.8.gz
206%{_mandir}/man8/lvextend.8.gz
207%{_mandir}/man8/lvm.8.gz
208%{_mandir}/man8/lvmchange.8.gz
209%{_mandir}/man8/lvmdiskscan.8.gz
210%{_mandir}/man8/lvmdump.8.gz
211%{_mandir}/man8/lvreduce.8.gz
212%{_mandir}/man8/lvremove.8.gz
213%{_mandir}/man8/lvrename.8.gz
214%{_mandir}/man8/lvresize.8.gz
215%{_mandir}/man8/lvs.8.gz
216%{_mandir}/man8/lvscan.8.gz
217%{_mandir}/man8/pvchange.8.gz
218%{_mandir}/man8/pvck.8.gz
219%{_mandir}/man8/pvcreate.8.gz
220%{_mandir}/man8/pvdisplay.8.gz
221%{_mandir}/man8/pvmove.8.gz
222%{_mandir}/man8/pvremove.8.gz
223%{_mandir}/man8/pvresize.8.gz
224%{_mandir}/man8/pvs.8.gz
225%{_mandir}/man8/pvscan.8.gz
226%{_mandir}/man8/vgcfgbackup.8.gz
227%{_mandir}/man8/vgcfgrestore.8.gz
228%{_mandir}/man8/vgchange.8.gz
229%{_mandir}/man8/vgck.8.gz
230%{_mandir}/man8/vgconvert.8.gz
231%{_mandir}/man8/vgcreate.8.gz
232%{_mandir}/man8/vgdisplay.8.gz
233%{_mandir}/man8/vgexport.8.gz
234%{_mandir}/man8/vgextend.8.gz
235%{_mandir}/man8/vgimport.8.gz
236%{_mandir}/man8/vgimportclone.8.gz
237%{_mandir}/man8/vgmerge.8.gz
238%{_mandir}/man8/vgmknodes.8.gz
239%{_mandir}/man8/vgreduce.8.gz
240%{_mandir}/man8/vgremove.8.gz
241%{_mandir}/man8/vgrename.8.gz
242%{_mandir}/man8/vgs.8.gz
243%{_mandir}/man8/vgscan.8.gz
244%{_mandir}/man8/vgsplit.8.gz
245%dir /etc/lvm
246%ghost /etc/lvm/cache/.cache
247%config(noreplace) /etc/lvm/lvm.conf
248%dir /etc/lvm/backup
249%dir /etc/lvm/cache
250%dir /etc/lvm/archive
251%dir /var/lock/lvm
252
253%if %{with_cluster}
254%files cluster
255%defattr(-,root,root,-)
256%attr(755,root,root) /usr/sbin/clvmd
257%{_sbindir}/lvmconf
258%{_mandir}/man8/clvmd.8.gz
259/etc/rc.d/init.d/clvmd
260%endif
261
262%files -n device-mapper
263%defattr(-,root,root,-)
264%doc COPYING COPYING.LIB WHATS_NEW_DM VERSION_DM README INSTALL
265%attr(755,root,root) /sbin/dmsetup
266%attr(755,root,root) /sbin/dmsetup.static
267%{_mandir}/man8/dmsetup.8.gz
268
269%files -n device-mapper-devel
270%defattr(-,root,root,-)
271%attr(755,root,root) /%{_lib}/libdevmapper.so
272%{_prefix}/%{_lib}/libdevmapper.a*
273%{_includedir}/libdevmapper.h
274/usr%{_libdir}/pkgconfig/*.pc
275
276%files -n device-mapper-libs
277%attr(755,root,root) /%{_lib}/libdevmapper.so.*
278
279
280%changelog
281* Sun Feb 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.02.60-1
282- new upstream release
283
284* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.48-1
285- new upstream release
286
287* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.47-1
288- new upstream release
289
290* Wed Feb 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-2
291- add libdevmapper.a
292
293* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-1
294- new upstream release
295- upstream merge of device-mapper and lvm2 source.
296- move all binaries to /sbin
297- move libraries to /%%{_lib}
298
299* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.42-1
300- new upstream release
301
302* Sun Oct 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.41-1
303- new upstream release
304
305* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.40-1
306- new upstream release
307
308* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.39-1
309- new upstream release
310
311* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.38-1
312- new upstream release
313
314* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.35-1
315- new upstream release
316
317* Sat Dec 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.28-0vl1
318- new upstream release
319
320* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.13-0vl1
321- new upstream release
322
323* Sat Aug 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.06-0vl1
324- initial build for Vine Linux
325
326* Tue Aug  1 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-3
327- require new libselinux to avoid segfaults on xen (#200783)
328
329* Thu Jul 27 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-2
330- free trip through the buildsystem
331
332* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.02.06-1.2.1
333- rebuild
334
335* Tue Jun  6 2006 Stephen C. Tweedie <sct@redhat.com> - 2.02.06-1.2
336- Rebuild to pick up new nosegneg libc.a for lvm.static
337
338* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.1
339- Reinstate archs now build system is back.
340- BuildRequires libsepol-devel.
341
342* Fri May 12 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.0
343- New upstream release.
344
345* Sat Apr 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.1
346- Exclude archs that aren't building.
347
348* Fri Apr 21 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.0
349- Fix VG uuid comparisons.
350
351* Wed Apr 19 2006 Alasdair Kergon <agk@redhat.com> - 2.02.04-1.0
352- New release upstream, including better handling of duplicated VG names.
353
354* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2.1
355- bump again for double-long bug on ppc(64)
356
357* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2
358- rebuilt for new gcc4.1 snapshot and glibc changes
359
360* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
361- rebuilt
362
363* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> - 2.02.01-1
364- update to 2.02.01
365
366* Tue Nov  8 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-4
367- add patch for xen block devices
368
369* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
370- add -lselinux -lsepol to the static linking -ldevice-mapper requires it
371
372* Wed Sep 14 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-2
373- the distro doesn't really work without a 2.6 kernel, so no need to require it
374
375* Thu Aug 4 2005 Alasdair Kergon <agk@redhat.com> - 2.01.14-1.0
376- And a few more bugs fixes.
377
378* Wed Jul 13 2005 Alasdair Kergon <agk@redhat.com> - 2.01.13-1.0
379- Fix several bugs discovered in the last release.
380
381* Tue Jun 14 2005 Alasdair Kergon <agk@redhat.com> - 2.01.12-1.0
382- New version upstream with a lot of fixes and enhancements.
383
384* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.1
385- Add /etc/lvm
386
387* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.0
388- No longer abort read operations if archive/backup directories aren't there.
389- Add runtime directories and file to the package.
390
391* Tue Mar 22 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-1.0
392- Improve detection of external changes affecting internal cache.
393- Add clustered VG attribute.
394- Suppress rmdir opendir error message.
395
396* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.3
397* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.2
398* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.1
399- Suppress some new compiler messages.
400
401* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.0
402- Remove build directory from built-in path.
403- Extra /dev scanning required for clustered operation.
404
405* Thu Mar 03 2005 Alasdair Kergon <agk@redhat.com> - 2.01.06-1.0
406- Allow anaconda to suppress warning messages.
407
408* Fri Feb 18 2005 Alasdair Kergon <agk@redhat.com> - 2.01.05-1.0
409- Upstream changes not affecting Fedora.
410
411* Wed Feb 09 2005 Alasdair Kergon <agk@redhat.com> - 2.01.04-1.0
412- Offset pool minors; lvm2cmd.so skips open fd check; pvmove -f gone.
413
414* Tue Feb 01 2005 Alasdair Kergon <agk@redhat.com> - 2.01.03-1.0
415- Fix snapshot device size & 64-bit display output.
416
417* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> - 2.01.02-1.0
418- Minor fixes.
419
420* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.01-1.0
421- Update vgcreate man page.  Preparation for snapshot origin extension fix.
422
423* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.00-1.0
424- Fix metadata auto-correction. Only request open_count when needed.
425
426* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 2.00.33-2.0
427- Rebuilt for new readline.
428
429* Fri Jan 7 2005 Alasdair Kergon <agk@redhat.com> - 2.00.33-1.0
430- pvcreate wipes ext label
431- several clvm fixes
432
433* Thu Jan 6 2005 Alasdair Kergon <agk@redhat.com> - 2.00.32-2.0
434- Remove temporary /sbin symlinks no longer needed.
435- Include read-only pool support in the build.
436
437* Wed Dec 22 2004 Alasdair Kergon <agk@redhat.com> - 2.00.32-1.0
438- More fixes (143501).
439
440* Sun Dec 12 2004 Alasdair Kergon <agk@redhat.com> - 2.00.31-1.0
441- Fix pvcreate install issues.
442
443* Fri Dec 10 2004 Alasdair Kergon <agk@redhat.com> - 2.00.30-1.0
444- Additional debugging code.
445- Some trivial man page corrections.
446
447* Tue Nov 30 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.3
448- Reinstate all archs.
449
450* Sun Nov 28 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.2
451- Try excluding more archs.
452
453* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.1
454- Exclude s390x which fails.
455
456* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1
457- Fix last fix.
458
459* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.28-1
460- Endian fix to partition/md signature detection.
461
462* Wed Nov 24 2004 Alasdair Kergon <agk@redhat.com> - 2.00.27-1
463- Fix partition table detection & an out of memory segfault.
464
465* Tue Nov 23 2004 Alasdair Kergon <agk@redhat.com> - 2.00.26-1
466- Several installation-related fixes & man page updates.
467
468* Mon Oct 25 2004 Elliot Lee <sopwith@redhat.com> - 2.00.25-1.01
469- Fix 2.6 kernel requirement
470
471* Wed Sep 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.25-1
472- Fix vgmknodes return code & vgremove locking.
473
474* Fri Sep 17 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-2
475- Obsolete old lvm1 packages; refuse install if running kernel 2.4. [bz 128185]
476
477* Thu Sep 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-1
478- More upstream fixes.  (Always check WHATS_NEW file for details.)
479- Add requested BuildRequires. [bz 124916, 132408]
480
481* Wed Sep 15 2004 Alasdair Kergon <agk@redhat.com> - 2.00.23-1
482- Various minor upstream fixes.
483
484* Thu Sep  3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.22-1
485- Permission fix included upstream; use different endian conversion macros.
486
487* Thu Sep  2 2004 Jeremy Katz <katzj@redhat.com> - 2.00.21-2
488- fix permissions on vg dirs
489
490* Thu Aug 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.21-1
491- New upstream release incorporating fixes plus minor enhancements.
492
493* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 2.00.20-2
494- add patch for iSeries viodasd support
495- add patch to check file type using stat(2) if d_type == DT_UNKNOWN (#129674)
496
497* Sat Jul 3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.20-1
498- New upstream release fixes 2.6 kernel device numbers.
499
500* Tue Jun 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.19-1
501- Latest upstream release.  Lots of changes (see WHATS_NEW).
502
503* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> - 2.00.15-5
504- rebuilt
505
506* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-4
507- clone %description from LVM rpm
508
509* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-3
510- vgscan shouldn't return error status when no VGs present
511
512* Thu May 06 2004 Warren Togami <wtogami@redhat.com> - 2.00.15-2
513- i2o patch from Markus Lidel
514
515* Tue Apr 20 2004 Bill Nottingham <notting@redhat.com> - 2.00.15-1.1
516- handle disabled SELinux correctly, so that LVMs can be detected in a
517  non-SELinux context
518 
519* Mon Apr 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-1
520- Fix non-root build with current version of 'install'.
521
522* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.14-1
523- Use 64-bit file offsets.
524
525* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.13-1
526- Avoid scanning devices containing md superblocks.
527- Integrate ENOTSUP patch.
528
529* Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 2.00.12-4
530- don't die if we get ENOTSUP setting selinux contexts
531
532* Thu Apr 15 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-3
533- Add temporary pvscan symlink for LVM1 until mkinitrd gets updated.
534
535* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-2
536- Mark config file noreplace.
537
538* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-1
539- Install default /etc/lvm/lvm.conf.
540- Move non-static binaries to /usr/sbin.
541- Add temporary links in /sbin to lvm.static until rc.sysinit gets updated.
542
543* Thu Apr 08 2004 Alasdair Kergon <agk@redhat.com> 2.00.11-1
544- Fallback to using LVM1 tools when using a 2.4 kernel without device-mapper.
545
546* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-2
547- Install the full toolset, not just 'lvm'.
548
549* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-1
550- Update to version 2.00.10, which incorporates the RH-specific patches
551  and includes various fixes and enhancements detailed in WHATS_NEW.
552
553* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.00.08-5
554- Fix sysfs patch to find sysfs
555- Take patch from dwalsh and tweak a little for setting SELinux contexts on
556  device node creation and also do it on the symlink creation. 
557  Part of this should probably be pushed down to device-mapper instead
558
559* Thu Feb 19 2004 Stephen C. Tweedie <sct@redhat.com> 2.00.08-4
560- Add sysfs filter patch
561- Allow non-root users to build RPM
562
563* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
564- rebuilt
565
566* Fri Dec  5 2003 Jeremy Katz <katzj@redhat.com> 2.00.08-2
567- add static lvm binary
568
569* Tue Dec  2 2003 Jeremy Katz <katzj@redhat.com>
570- Initial build.
571
572
Note: See TracBrowser for help on using the repository browser.