source: projects/specs/trunk/l/lvm2/lvm2-vl.spec @ 2645

Revision 2645, 22.1 KB checked in by daisuke, 13 years ago (diff)

lvm2: update to 2.02.83

Line 
1%define lvm_version 2.02.83
2%define device_mapper_version 1.02.61
3%define with_cluster 0
4
5Summary: Userland logical volume management tools
6Summary(ja): 論理ボリューム管理ツール
7Name: lvm2
8Version: %{lvm_version}
9Release: 1%{?_dist_release}
10License: GPL
11Group: System Environment/Base
12URL: http://sources.redhat.com/lvm2
13Source0: LVM2.%{lvm_version}.tgz
14BuildRoot: %{_tmppath}/%{name}-%{lvm_version}-%{release}-buildroot
15BuildRequires: libtermcap-devel
16BuildRequires: ncurses-devel
17BuildRequires: readline-devel
18BuildRequires: libudev-devel
19Requires: device-mapper >= %{device_mapper_version}-%{release}
20Requires: device-mapper-event >= %{device_mapper_version}-%{release}
21Requires: %{name}-libs = %{version}-%{release}
22Conflicts: lvm
23Obsoletes: lvm
24
25%define _exec_prefix /usr
26
27%description
28LVM2 includes all of the support for handling read/write operations on
29physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
30multiple devices (MD), see mdadd(8) or even loop devices, see
31losetup(8)), creating volume groups (kind of virtual disks) from one
32or more physical volumes and creating one or more logical volumes
33(kind of logical partitions) in volume groups.
34
35%package devel
36Summary: Development libraries and headers
37Group: Development/Libraries
38License: LGPLv2
39Requires: %{name} = %{version}-%{release}
40Requires: %{name}-libs = %{version}-%{release}
41Requires: device-mapper-devel >= %{device_mapper_version}-%{release}
42Requires: device-mapper-event-devel >= %{device_mapper_version}-%{release}
43Requires: pkgconfig
44
45%description devel
46This package contains files needed to develop applications that use
47the lvm2 libraries.
48
49%package libs
50Summary: lvm2 shared libraries
51License: LGPLv2
52Group: System Environment/Libraries
53
54%description libs
55This package contains shared lvm2 libraries for applications.
56
57%if %{with_cluster}
58# lvm2-cluster
59%package cluster
60Summary: Cluster extensions for userland logical volume management tools
61License: GPLv2
62Group: System Environment/Base
63Requires: lvm2 >= %{version}-%{lvm_release}
64Requires(post): chkconfig
65Requires(preun): chkconfig
66Requires(preun): device-mapper >= %{device_mapper_version}
67Requires(preun): lvm2 >= 2.02
68
69%description cluster
70Extensions to LVM2 to support clusters.
71%endif
72
73# device-mapper
74%package -n device-mapper
75Summary: Device mapper utility
76Version: %{device_mapper_version}
77Release: %{release}
78License: GPLv2
79Group: System Environment/Base
80URL: http://sources.redhat.com/dm
81Requires: device-mapper-libs = %{device_mapper_version}-%{release}
82Requires: libudev
83Requires: util-linux-ng >= 2.15
84
85%description -n device-mapper
86This package contains the supporting userspace utility, dmsetup,
87for the kernel device-mapper.
88
89# device-mapper-devel
90%package -n device-mapper-devel
91Summary: Development libraries and headers for device-mapper
92Version: %{device_mapper_version}
93Release: %{release}
94License: LGPLv2
95Group: Development/Libraries
96Requires: device-mapper = %{device_mapper_version}-%{release}
97Requires: device-mapper-libs = %{device_mapper_version}-%{release}
98
99%description -n device-mapper-devel
100This package contains files needed to develop applications that use
101the device-mapper libraries.
102
103%package -n device-mapper-libs
104Summary: Device-mapper shared library
105Version: %{device_mapper_version}
106Release: %{release}
107License: LGPLv2
108Group: System Environment/Libraries
109Obsoletes: device-mapper < 1.02.30-1
110
111%description -n device-mapper-libs
112This package contains the device-mapper shared library, libdevmapper.
113
114%package -n device-mapper-event
115Summary: Device-mapper event daemon
116Group: System Environment/Base
117Version: %{device_mapper_version}
118Release: %{release}
119Requires: device-mapper = %{device_mapper_version}-%{release}
120Requires: device-mapper-event-libs = %{device_mapper_version}-%{release}
121
122%description -n device-mapper-event
123This package contains the dmeventd daemon for monitoring the state
124of device-mapper devices.
125
126%package -n device-mapper-event-libs
127Summary: Device-mapper event daemon shared library
128Version: %{device_mapper_version}
129Release: %{release}
130License: LGPLv2
131Group: System Environment/Libraries
132
133%description -n device-mapper-event-libs
134This package contains the device-mapper event daemon shared library,
135libdevmapper-event.
136
137%package -n device-mapper-event-devel
138Summary: Development libraries and headers for the device-mapper event daemon
139Version: %{device_mapper_version}
140Release: %{release}
141License: LGPLv2
142Group: Development/Libraries
143Requires: device-mapper-event = %{device_mapper_version}-%{release}
144Requires: pkgconfig
145
146%description -n device-mapper-event-devel
147This package contains files needed to develop applications that use
148the device-mapper event library.
149
150%prep
151%setup -q -n LVM2.%{lvm_version}
152
153%build
154%define _exec_prefix /
155%define _bindir /bin
156%define _sbindir /sbin
157%define _libdir /%{_lib}
158%define _udevbasedir /lib/udev
159%define _udevdir %{_udevbasedir}/rules.d
160
161%configure \
162  --enable-readline \
163  --enable-lvm1_fallback \
164  --enable-fsadm \
165  --with-pool=internal \
166  --with-staticdir=/sbin \
167  --with-user= --with-group= \
168  --with-usrlibdir=/usr/%{_lib} \
169  --with-usrsbindir=/usr/sbin \
170  --with-dmdir=device-mapper.%{device_mapper_version} \
171  --with-udevdir=%{_udevdir} \
172  --with-device-uid=0 --with-device-gid=6 \
173  --with-device-mode=0660 \
174  --enable-pkgconfig \
175  --enable-applib \
176  --enable-cmdlib \
177  --enable-dmeventd \
178  --enable-udev_sync
179
180make %{?_smp_mflags}
181
182%install
183rm -rf $RPM_BUILD_ROOT
184make install DESTDIR=$RPM_BUILD_ROOT
185install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/archive
186install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/backup
187install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/cache
188install -m 0700 -d $RPM_BUILD_ROOT/var/lock/lvm
189install -m 0600 /dev/null $RPM_BUILD_ROOT/etc/lvm/cache/.cache
190mkdir -p -m755 $RPM_BUILD_ROOT/etc/rc.d/init.d
191%if %{with_cluster}
192install scripts/clvmd_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/clvmd
193install scripts/cmirrord_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/cmirrord
194%endif
195install -m 0755 scripts/lvm2_monitoring_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/lvm2-monitor
196install -m 0755 scripts/lvmconf.sh $RPM_BUILD_ROOT/sbin/lvmconf
197
198%clean
199rm -rf $RPM_BUILD_ROOT
200
201%post
202/sbin/ldconfig
203/sbin/chkconfig --add lvm2-monitor
204
205%preun
206if [ "$1" = 0 ]; then
207        /sbin/chkconfig --del lvm2-monitor
208fi
209
210%post libs -p /sbin/ldconfig
211
212%postun libs -p /sbin/ldconfig
213
214%if %{with_cluster}
215%post cluster
216/sbin/chkconfig --add clvmd
217
218/sbin/lvmconf --lockinglibdir %{_libdir}
219
220%preun cluster
221if [ "$1" = 0 ]; then
222        /sbin/chkconfig --del clvmd
223        /sbin/lvmconf --disable-cluster
224fi
225%endif
226
227%post -n device-mapper-libs -p /sbin/ldconfig
228
229%postun -n device-mapper-libs -p /sbin/ldconfig
230
231%post -n device-mapper-event-libs -p /sbin/ldconfig
232
233%postun -n device-mapper-event-libs -p /sbin/ldconfig
234
235%files
236%defattr(-,root,root,-)
237%doc COPYING COPYING.LIB INSTALL README VERSION WHATS_NEW
238%attr(555,root,root) %{_sbindir}/fsadm
239%{_sbindir}/lvchange
240%{_sbindir}/lvconvert
241%{_sbindir}/lvcreate
242%{_sbindir}/lvdisplay
243%{_sbindir}/lvextend
244%{_sbindir}/lvm
245%{_sbindir}/lvmchange
246%{_sbindir}/lvmdiskscan
247%{_sbindir}/lvmdump
248%{_sbindir}/lvmsadc
249%{_sbindir}/lvmsar
250%{_sbindir}/lvreduce
251%{_sbindir}/lvremove
252%{_sbindir}/lvrename
253%{_sbindir}/lvresize
254%{_sbindir}/lvs
255%{_sbindir}/lvscan
256%{_sbindir}/pvchange
257%{_sbindir}/pvck
258%{_sbindir}/pvcreate
259%{_sbindir}/pvdisplay
260%{_sbindir}/pvmove
261%{_sbindir}/pvremove
262%{_sbindir}/pvresize
263%{_sbindir}/pvs
264%{_sbindir}/pvscan
265%{_sbindir}/vgcfgbackup
266%{_sbindir}/vgcfgrestore
267%{_sbindir}/vgchange
268%{_sbindir}/vgck
269%{_sbindir}/vgconvert
270%{_sbindir}/vgcreate
271%{_sbindir}/vgdisplay
272%{_sbindir}/vgexport
273%{_sbindir}/vgextend
274%{_sbindir}/vgimport
275%{_sbindir}/vgimportclone
276%{_sbindir}/vgmerge
277%{_sbindir}/vgmknodes
278%{_sbindir}/vgreduce
279%{_sbindir}/vgremove
280%{_sbindir}/vgrename
281%{_sbindir}/vgs
282%{_sbindir}/vgscan
283%{_sbindir}/vgsplit
284%{_sbindir}/lvmconf
285%{_mandir}/man5/lvm.conf.5.gz
286%{_mandir}/man8/fsadm.8.gz
287%{_mandir}/man8/lvchange.8.gz
288%{_mandir}/man8/lvconvert.8.gz
289%{_mandir}/man8/lvcreate.8.gz
290%{_mandir}/man8/lvdisplay.8.gz
291%{_mandir}/man8/lvextend.8.gz
292%{_mandir}/man8/lvm.8.gz
293%{_mandir}/man8/lvmchange.8.gz
294%{_mandir}/man8/lvmconf.8.gz
295%{_mandir}/man8/lvmdiskscan.8.gz
296%{_mandir}/man8/lvmdump.8.gz
297%{_mandir}/man8/lvmsadc.8.gz
298%{_mandir}/man8/lvmsar.8.gz
299%{_mandir}/man8/lvreduce.8.gz
300%{_mandir}/man8/lvremove.8.gz
301%{_mandir}/man8/lvrename.8.gz
302%{_mandir}/man8/lvresize.8.gz
303%{_mandir}/man8/lvs.8.gz
304%{_mandir}/man8/lvscan.8.gz
305%{_mandir}/man8/pvchange.8.gz
306%{_mandir}/man8/pvck.8.gz
307%{_mandir}/man8/pvcreate.8.gz
308%{_mandir}/man8/pvdisplay.8.gz
309%{_mandir}/man8/pvmove.8.gz
310%{_mandir}/man8/pvremove.8.gz
311%{_mandir}/man8/pvresize.8.gz
312%{_mandir}/man8/pvs.8.gz
313%{_mandir}/man8/pvscan.8.gz
314%{_mandir}/man8/vgcfgbackup.8.gz
315%{_mandir}/man8/vgcfgrestore.8.gz
316%{_mandir}/man8/vgchange.8.gz
317%{_mandir}/man8/vgck.8.gz
318%{_mandir}/man8/vgconvert.8.gz
319%{_mandir}/man8/vgcreate.8.gz
320%{_mandir}/man8/vgdisplay.8.gz
321%{_mandir}/man8/vgexport.8.gz
322%{_mandir}/man8/vgextend.8.gz
323%{_mandir}/man8/vgimport.8.gz
324%{_mandir}/man8/vgimportclone.8.gz
325%{_mandir}/man8/vgmerge.8.gz
326%{_mandir}/man8/vgmknodes.8.gz
327%{_mandir}/man8/vgreduce.8.gz
328%{_mandir}/man8/vgremove.8.gz
329%{_mandir}/man8/vgrename.8.gz
330%{_mandir}/man8/vgs.8.gz
331%{_mandir}/man8/vgscan.8.gz
332%{_mandir}/man8/vgsplit.8.gz
333%{_udevdir}/11-dm-lvm.rules
334%dir /etc/lvm
335%ghost /etc/lvm/cache/.cache
336%config(noreplace) /etc/lvm/lvm.conf
337%dir /etc/lvm/backup
338%dir /etc/lvm/cache
339%dir /etc/lvm/archive
340%dir /var/lock/lvm
341/etc/rc.d/init.d/lvm2-monitor
342
343%files devel
344%defattr(-,root,root,-)
345/usr%{_libdir}/liblvm2app.so
346/usr%{_libdir}/liblvm2cmd.so
347%{_includedir}/lvm2app.h
348%{_includedir}/lvm2cmd.h
349/usr%{_libdir}/pkgconfig/lvm2app.pc
350/usr%{_libdir}/libdevmapper-event-lvm2.so
351
352%files libs
353%attr(755,root,root) %{_libdir}/liblvm2app.so.*
354%attr(755,root,root) %{_libdir}/liblvm2cmd.so.*
355%attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so.*
356%dir %{_libdir}/device-mapper
357%{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
358%{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
359%{_libdir}/libdevmapper-event-lvm2mirror.so
360%{_libdir}/libdevmapper-event-lvm2snapshot.so
361
362%if %{with_cluster}
363%files cluster
364%defattr(-,root,root,-)
365%attr(755,root,root) /usr/sbin/clvmd
366%{_mandir}/man8/clvmd.8.gz
367/etc/rc.d/init.d/clvmd
368%endif
369
370%files -n device-mapper
371%defattr(-,root,root,-)
372%doc COPYING COPYING.LIB WHATS_NEW_DM VERSION_DM README INSTALL udev/12-dm-permissions.rules
373%attr(755,root,root) /sbin/dmsetup
374%{_mandir}/man8/dmsetup.8.gz
375%dir %{_udevbasedir}
376%dir %{_udevdir}
377%{_udevdir}/10-dm.rules
378%{_udevdir}/13-dm-disk.rules
379%{_udevdir}/95-dm-notify.rules
380
381%files -n device-mapper-devel
382%defattr(-,root,root,-)
383%attr(755,root,root) /usr%{_libdir}/libdevmapper.so
384%{_includedir}/libdevmapper.h
385/usr%{_libdir}/pkgconfig/devmapper.pc
386
387%files -n device-mapper-libs
388%attr(755,root,root) %{_libdir}/libdevmapper.so.*
389
390%files -n device-mapper-event
391%defattr(-,root,root,-)
392%{_sbindir}/dmeventd
393%{_mandir}/man8/dmeventd.8.gz
394
395%files -n device-mapper-event-libs
396%{_libdir}/libdevmapper-event.so.*
397
398%files -n device-mapper-event-devel
399%defattr(-,root,root,-)
400%attr(755,root,root) /usr%{_libdir}/libdevmapper-event.so
401%{_includedir}/libdevmapper-event.h
402/usr%{_libdir}/pkgconfig/devmapper-event.pc
403
404%changelog
405* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.83-1
406- new upstream release
407
408* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.79-1
409- new upstream release
410
411* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.78-1
412- new upstream release
413- fix %%files
414
415* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.02.62-3
416- rebuilt with rpm-4.8.1 for pkg-config
417
418* Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-2
419- add missing file
420  - %{_udevdir}/11-dm-lvm.rules
421
422* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-1
423- new upstream release
424- add libs,devel subpackage
425  - liblvm2{app,cmd},libdevmapper-event-lvm2
426- enable dmeventd
427  - add device-mapper-event{,-libs,-devel}
428- enable udev sync code
429  - add BR: libudev-devel, R: libudev
430- disable static libs and binaries
431
432* Sun Feb 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.02.60-1
433- new upstream release
434
435* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.48-1
436- new upstream release
437
438* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.47-1
439- new upstream release
440
441* Wed Feb 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-2
442- add libdevmapper.a
443
444* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-1
445- new upstream release
446- upstream merge of device-mapper and lvm2 source.
447- move all binaries to /sbin
448- move libraries to /%%{_lib}
449
450* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.42-1
451- new upstream release
452
453* Sun Oct 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.41-1
454- new upstream release
455
456* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.40-1
457- new upstream release
458
459* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.39-1
460- new upstream release
461
462* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.38-1
463- new upstream release
464
465* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.35-1
466- new upstream release
467
468* Sat Dec 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.28-0vl1
469- new upstream release
470
471* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.13-0vl1
472- new upstream release
473
474* Sat Aug 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.06-0vl1
475- initial build for Vine Linux
476
477* Tue Aug  1 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-3
478- require new libselinux to avoid segfaults on xen (#200783)
479
480* Thu Jul 27 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-2
481- free trip through the buildsystem
482
483* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.02.06-1.2.1
484- rebuild
485
486* Tue Jun  6 2006 Stephen C. Tweedie <sct@redhat.com> - 2.02.06-1.2
487- Rebuild to pick up new nosegneg libc.a for lvm.static
488
489* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.1
490- Reinstate archs now build system is back.
491- BuildRequires libsepol-devel.
492
493* Fri May 12 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.0
494- New upstream release.
495
496* Sat Apr 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.1
497- Exclude archs that aren't building.
498
499* Fri Apr 21 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.0
500- Fix VG uuid comparisons.
501
502* Wed Apr 19 2006 Alasdair Kergon <agk@redhat.com> - 2.02.04-1.0
503- New release upstream, including better handling of duplicated VG names.
504
505* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2.1
506- bump again for double-long bug on ppc(64)
507
508* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2
509- rebuilt for new gcc4.1 snapshot and glibc changes
510
511* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
512- rebuilt
513
514* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> - 2.02.01-1
515- update to 2.02.01
516
517* Tue Nov  8 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-4
518- add patch for xen block devices
519
520* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
521- add -lselinux -lsepol to the static linking -ldevice-mapper requires it
522
523* Wed Sep 14 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-2
524- the distro doesn't really work without a 2.6 kernel, so no need to require it
525
526* Thu Aug 4 2005 Alasdair Kergon <agk@redhat.com> - 2.01.14-1.0
527- And a few more bugs fixes.
528
529* Wed Jul 13 2005 Alasdair Kergon <agk@redhat.com> - 2.01.13-1.0
530- Fix several bugs discovered in the last release.
531
532* Tue Jun 14 2005 Alasdair Kergon <agk@redhat.com> - 2.01.12-1.0
533- New version upstream with a lot of fixes and enhancements.
534
535* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.1
536- Add /etc/lvm
537
538* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.0
539- No longer abort read operations if archive/backup directories aren't there.
540- Add runtime directories and file to the package.
541
542* Tue Mar 22 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-1.0
543- Improve detection of external changes affecting internal cache.
544- Add clustered VG attribute.
545- Suppress rmdir opendir error message.
546
547* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.3
548* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.2
549* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.1
550- Suppress some new compiler messages.
551
552* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.0
553- Remove build directory from built-in path.
554- Extra /dev scanning required for clustered operation.
555
556* Thu Mar 03 2005 Alasdair Kergon <agk@redhat.com> - 2.01.06-1.0
557- Allow anaconda to suppress warning messages.
558
559* Fri Feb 18 2005 Alasdair Kergon <agk@redhat.com> - 2.01.05-1.0
560- Upstream changes not affecting Fedora.
561
562* Wed Feb 09 2005 Alasdair Kergon <agk@redhat.com> - 2.01.04-1.0
563- Offset pool minors; lvm2cmd.so skips open fd check; pvmove -f gone.
564
565* Tue Feb 01 2005 Alasdair Kergon <agk@redhat.com> - 2.01.03-1.0
566- Fix snapshot device size & 64-bit display output.
567
568* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> - 2.01.02-1.0
569- Minor fixes.
570
571* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.01-1.0
572- Update vgcreate man page.  Preparation for snapshot origin extension fix.
573
574* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.00-1.0
575- Fix metadata auto-correction. Only request open_count when needed.
576
577* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 2.00.33-2.0
578- Rebuilt for new readline.
579
580* Fri Jan 7 2005 Alasdair Kergon <agk@redhat.com> - 2.00.33-1.0
581- pvcreate wipes ext label
582- several clvm fixes
583
584* Thu Jan 6 2005 Alasdair Kergon <agk@redhat.com> - 2.00.32-2.0
585- Remove temporary /sbin symlinks no longer needed.
586- Include read-only pool support in the build.
587
588* Wed Dec 22 2004 Alasdair Kergon <agk@redhat.com> - 2.00.32-1.0
589- More fixes (143501).
590
591* Sun Dec 12 2004 Alasdair Kergon <agk@redhat.com> - 2.00.31-1.0
592- Fix pvcreate install issues.
593
594* Fri Dec 10 2004 Alasdair Kergon <agk@redhat.com> - 2.00.30-1.0
595- Additional debugging code.
596- Some trivial man page corrections.
597
598* Tue Nov 30 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.3
599- Reinstate all archs.
600
601* Sun Nov 28 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.2
602- Try excluding more archs.
603
604* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.1
605- Exclude s390x which fails.
606
607* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1
608- Fix last fix.
609
610* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.28-1
611- Endian fix to partition/md signature detection.
612
613* Wed Nov 24 2004 Alasdair Kergon <agk@redhat.com> - 2.00.27-1
614- Fix partition table detection & an out of memory segfault.
615
616* Tue Nov 23 2004 Alasdair Kergon <agk@redhat.com> - 2.00.26-1
617- Several installation-related fixes & man page updates.
618
619* Mon Oct 25 2004 Elliot Lee <sopwith@redhat.com> - 2.00.25-1.01
620- Fix 2.6 kernel requirement
621
622* Wed Sep 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.25-1
623- Fix vgmknodes return code & vgremove locking.
624
625* Fri Sep 17 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-2
626- Obsolete old lvm1 packages; refuse install if running kernel 2.4. [bz 128185]
627
628* Thu Sep 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-1
629- More upstream fixes.  (Always check WHATS_NEW file for details.)
630- Add requested BuildRequires. [bz 124916, 132408]
631
632* Wed Sep 15 2004 Alasdair Kergon <agk@redhat.com> - 2.00.23-1
633- Various minor upstream fixes.
634
635* Thu Sep  3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.22-1
636- Permission fix included upstream; use different endian conversion macros.
637
638* Thu Sep  2 2004 Jeremy Katz <katzj@redhat.com> - 2.00.21-2
639- fix permissions on vg dirs
640
641* Thu Aug 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.21-1
642- New upstream release incorporating fixes plus minor enhancements.
643
644* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 2.00.20-2
645- add patch for iSeries viodasd support
646- add patch to check file type using stat(2) if d_type == DT_UNKNOWN (#129674)
647
648* Sat Jul 3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.20-1
649- New upstream release fixes 2.6 kernel device numbers.
650
651* Tue Jun 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.19-1
652- Latest upstream release.  Lots of changes (see WHATS_NEW).
653
654* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> - 2.00.15-5
655- rebuilt
656
657* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-4
658- clone %description from LVM rpm
659
660* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-3
661- vgscan shouldn't return error status when no VGs present
662
663* Thu May 06 2004 Warren Togami <wtogami@redhat.com> - 2.00.15-2
664- i2o patch from Markus Lidel
665
666* Tue Apr 20 2004 Bill Nottingham <notting@redhat.com> - 2.00.15-1.1
667- handle disabled SELinux correctly, so that LVMs can be detected in a
668  non-SELinux context
669 
670* Mon Apr 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-1
671- Fix non-root build with current version of 'install'.
672
673* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.14-1
674- Use 64-bit file offsets.
675
676* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.13-1
677- Avoid scanning devices containing md superblocks.
678- Integrate ENOTSUP patch.
679
680* Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 2.00.12-4
681- don't die if we get ENOTSUP setting selinux contexts
682
683* Thu Apr 15 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-3
684- Add temporary pvscan symlink for LVM1 until mkinitrd gets updated.
685
686* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-2
687- Mark config file noreplace.
688
689* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-1
690- Install default /etc/lvm/lvm.conf.
691- Move non-static binaries to /usr/sbin.
692- Add temporary links in /sbin to lvm.static until rc.sysinit gets updated.
693
694* Thu Apr 08 2004 Alasdair Kergon <agk@redhat.com> 2.00.11-1
695- Fallback to using LVM1 tools when using a 2.4 kernel without device-mapper.
696
697* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-2
698- Install the full toolset, not just 'lvm'.
699
700* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-1
701- Update to version 2.00.10, which incorporates the RH-specific patches
702  and includes various fixes and enhancements detailed in WHATS_NEW.
703
704* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.00.08-5
705- Fix sysfs patch to find sysfs
706- Take patch from dwalsh and tweak a little for setting SELinux contexts on
707  device node creation and also do it on the symlink creation. 
708  Part of this should probably be pushed down to device-mapper instead
709
710* Thu Feb 19 2004 Stephen C. Tweedie <sct@redhat.com> 2.00.08-4
711- Add sysfs filter patch
712- Allow non-root users to build RPM
713
714* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
715- rebuilt
716
717* Fri Dec  5 2003 Jeremy Katz <katzj@redhat.com> 2.00.08-2
718- add static lvm binary
719
720* Tue Dec  2 2003 Jeremy Katz <katzj@redhat.com>
721- Initial build.
722
723
Note: See TracBrowser for help on using the repository browser.