source: projects/specs/trunk/l/lvm2/lvm2-vl.spec @ 807

Revision 807, 21.5 KB checked in by daisuke, 14 years ago (diff)

lvm2: add missing udev rules to %files

Line 
1%define lvm_version 2.02.62
2%define device_mapper_version 1.02.45
3%define with_cluster 0
4
5Summary: Userland logical volume management tools
6Summary(ja): 論理ボリューム管理ツール
7Name: lvm2
8Version: %{lvm_version}
9Release: 2%{?_dist_release}
10License: GPL
11Group: System Environment/Base
12URL: http://sources.redhat.com/lvm2
13Source0: LVM2.%{lvm_version}.tgz
14BuildRoot: %{_tmppath}/%{name}-%{lvm_version}-%{release}-buildroot
15BuildRequires: libtermcap-devel
16BuildRequires: ncurses-devel
17BuildRequires: readline-devel
18BuildRequires: libudev-devel
19Requires: device-mapper >= %{device_mapper_version}-%{release}
20Requires: device-mapper-event >= %{device_mapper_version}-%{release}
21Requires: %{name}-libs = %{version}-%{release}
22Conflicts: lvm
23Obsoletes: lvm
24
25%define _exec_prefix /usr
26
27%description
28LVM2 includes all of the support for handling read/write operations on
29physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
30multiple devices (MD), see mdadd(8) or even loop devices, see
31losetup(8)), creating volume groups (kind of virtual disks) from one
32or more physical volumes and creating one or more logical volumes
33(kind of logical partitions) in volume groups.
34
35%package devel
36Summary: Development libraries and headers
37Group: Development/Libraries
38License: LGPLv2
39Requires: %{name} = %{version}-%{release}
40Requires: %{name}-libs = %{version}-%{release}
41Requires: device-mapper-devel >= %{device_mapper_version}-%{release}
42Requires: device-mapper-event-devel >= %{device_mapper_version}-%{release}
43Requires: pkgconfig
44
45%description devel
46This package contains files needed to develop applications that use
47the lvm2 libraries.
48
49%package libs
50Summary: lvm2 shared libraries
51License: LGPLv2
52Group: System Environment/Libraries
53
54%description libs
55This package contains shared lvm2 libraries for applications.
56
57%if %{with_cluster}
58# lvm2-cluster
59%package cluster
60Summary: Cluster extensions for userland logical volume management tools
61License: GPLv2
62Group: System Environment/Base
63Requires: lvm2 >= %{version}-%{lvm_release}
64Requires(post): chkconfig
65Requires(preun): chkconfig
66Requires(preun): device-mapper >= %{device_mapper_version}
67Requires(preun): lvm2 >= 2.02
68
69%description cluster
70Extensions to LVM2 to support clusters.
71%endif
72
73# device-mapper
74%package -n device-mapper
75Summary: Device mapper utility
76Version: %{device_mapper_version}
77Release: %{release}
78License: GPLv2
79Group: System Environment/Base
80URL: http://sources.redhat.com/dm
81Requires: device-mapper-libs = %{device_mapper_version}-%{release}
82Requires: libudev
83Requires: util-linux-ng >= 2.15
84
85%description -n device-mapper
86This package contains the supporting userspace utility, dmsetup,
87for the kernel device-mapper.
88
89# device-mapper-devel
90%package -n device-mapper-devel
91Summary: Development libraries and headers for device-mapper
92Version: %{device_mapper_version}
93Release: %{release}
94License: LGPLv2
95Group: Development/Libraries
96Requires: device-mapper = %{device_mapper_version}-%{release}
97Requires: device-mapper-libs = %{device_mapper_version}-%{release}
98
99%description -n device-mapper-devel
100This package contains files needed to develop applications that use
101the device-mapper libraries.
102
103%package -n device-mapper-libs
104Summary: Device-mapper shared library
105Version: %{device_mapper_version}
106Release: %{release}
107License: LGPLv2
108Group: System Environment/Libraries
109Obsoletes: device-mapper < 1.02.30-1
110
111%description -n device-mapper-libs
112This package contains the device-mapper shared library, libdevmapper.
113
114%package -n device-mapper-event
115Summary: Device-mapper event daemon
116Group: System Environment/Base
117Version: %{device_mapper_version}
118Release: %{release}
119Requires: device-mapper = %{device_mapper_version}-%{release}
120Requires: device-mapper-event-libs = %{device_mapper_version}-%{release}
121
122%description -n device-mapper-event
123This package contains the dmeventd daemon for monitoring the state
124of device-mapper devices.
125
126%package -n device-mapper-event-libs
127Summary: Device-mapper event daemon shared library
128Version: %{device_mapper_version}
129Release: %{release}
130License: LGPLv2
131Group: System Environment/Libraries
132
133%description -n device-mapper-event-libs
134This package contains the device-mapper event daemon shared library,
135libdevmapper-event.
136
137%package -n device-mapper-event-devel
138Summary: Development libraries and headers for the device-mapper event daemon
139Version: %{device_mapper_version}
140Release: %{release}
141License: LGPLv2
142Group: Development/Libraries
143Requires: device-mapper-event = %{device_mapper_version}-%{release}
144Requires: pkgconfig
145
146%description -n device-mapper-event-devel
147This package contains files needed to develop applications that use
148the device-mapper event library.
149
150%prep
151%setup -q -n LVM2.%{lvm_version}
152
153%build
154%define _exec_prefix /
155%define _bindir /bin
156%define _sbindir /sbin
157%define _libdir /%{_lib}
158%define _udevbasedir /lib/udev
159%define _udevdir %{_udevbasedir}/rules.d
160
161%configure \
162  --enable-readline \
163  --enable-lvm1_fallback \
164  --enable-fsadm \
165  --with-pool=internal \
166  --with-staticdir=/sbin \
167  --with-user= --with-group= \
168  --with-usrlibdir=/usr/%{_lib} \
169  --with-usrsbindir=/usr/sbin \
170  --with-dmdir=device-mapper.%{device_mapper_version} \
171  --with-udevdir=%{_udevdir} \
172  --with-device-uid=0 --with-device-gid=6 \
173  --with-device-mode=0660 \
174  --enable-pkgconfig \
175  --enable-applib \
176  --enable-cmdlib \
177  --enable-dmeventd \
178  --enable-udev_sync
179
180make %{?_smp_mflags}
181
182%install
183rm -rf $RPM_BUILD_ROOT
184make install DESTDIR=$RPM_BUILD_ROOT
185install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/archive
186install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/backup
187install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/cache
188install -m 0700 -d $RPM_BUILD_ROOT/var/lock/lvm
189install -m 0600 /dev/null $RPM_BUILD_ROOT/etc/lvm/cache/.cache
190mkdir -p -m755 $RPM_BUILD_ROOT/etc/rc.d/init.d
191%if %{with_cluster}
192install scripts/clvmd_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/clvmd
193install scripts/cmirrord_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/cmirrord
194%endif
195install -m 0755 scripts/lvm2_monitoring_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/lvm2-monitor
196install -m 0755 scripts/lvmconf.sh $RPM_BUILD_ROOT/sbin/lvmconf
197
198%clean
199rm -rf $RPM_BUILD_ROOT
200
201%post
202/sbin/ldconfig
203/sbin/chkconfig --add lvm2-monitor
204
205%preun
206if [ "$1" = 0 ]; then
207        /sbin/chkconfig --del lvm2-monitor
208fi
209
210%post libs -p /sbin/ldconfig
211
212%postun libs -p /sbin/ldconfig
213
214%if %{with_cluster}
215%post cluster
216/sbin/chkconfig --add clvmd
217
218/sbin/lvmconf --lockinglibdir %{_libdir}
219
220%preun cluster
221if [ "$1" = 0 ]; then
222        /sbin/chkconfig --del clvmd
223        /sbin/lvmconf --disable-cluster
224fi
225%endif
226
227%post -n device-mapper-libs -p /sbin/ldconfig
228
229%postun -n device-mapper-libs -p /sbin/ldconfig
230
231%post -n device-mapper-event-libs -p /sbin/ldconfig
232
233%postun -n device-mapper-event-libs -p /sbin/ldconfig
234
235%files
236%defattr(-,root,root,-)
237%doc COPYING COPYING.LIB INSTALL README VERSION WHATS_NEW
238%attr(555,root,root) %{_sbindir}/fsadm
239%{_sbindir}/fsadm
240%{_sbindir}/lvchange
241%{_sbindir}/lvconvert
242%{_sbindir}/lvcreate
243%{_sbindir}/lvdisplay
244%{_sbindir}/lvextend
245%{_sbindir}/lvm
246%{_sbindir}/lvmchange
247%{_sbindir}/lvmdiskscan
248%{_sbindir}/lvmdump
249%{_sbindir}/lvmsadc
250%{_sbindir}/lvmsar
251%{_sbindir}/lvreduce
252%{_sbindir}/lvremove
253%{_sbindir}/lvrename
254%{_sbindir}/lvresize
255%{_sbindir}/lvs
256%{_sbindir}/lvscan
257%{_sbindir}/pvchange
258%{_sbindir}/pvck
259%{_sbindir}/pvcreate
260%{_sbindir}/pvdisplay
261%{_sbindir}/pvmove
262%{_sbindir}/pvremove
263%{_sbindir}/pvresize
264%{_sbindir}/pvs
265%{_sbindir}/pvscan
266%{_sbindir}/vgcfgbackup
267%{_sbindir}/vgcfgrestore
268%{_sbindir}/vgchange
269%{_sbindir}/vgck
270%{_sbindir}/vgconvert
271%{_sbindir}/vgcreate
272%{_sbindir}/vgdisplay
273%{_sbindir}/vgexport
274%{_sbindir}/vgextend
275%{_sbindir}/vgimport
276%{_sbindir}/vgimportclone
277%{_sbindir}/vgmerge
278%{_sbindir}/vgmknodes
279%{_sbindir}/vgreduce
280%{_sbindir}/vgremove
281%{_sbindir}/vgrename
282%{_sbindir}/vgs
283%{_sbindir}/vgscan
284%{_sbindir}/vgsplit
285%{_sbindir}/lvmconf
286%{_mandir}/man5/lvm.conf.5.gz
287%{_mandir}/man8/fsadm.8.gz
288%{_mandir}/man8/lvchange.8.gz
289%{_mandir}/man8/lvconvert.8.gz
290%{_mandir}/man8/lvcreate.8.gz
291%{_mandir}/man8/lvdisplay.8.gz
292%{_mandir}/man8/lvextend.8.gz
293%{_mandir}/man8/lvm.8.gz
294%{_mandir}/man8/lvmchange.8.gz
295%{_mandir}/man8/lvmdiskscan.8.gz
296%{_mandir}/man8/lvmdump.8.gz
297%{_mandir}/man8/lvreduce.8.gz
298%{_mandir}/man8/lvremove.8.gz
299%{_mandir}/man8/lvrename.8.gz
300%{_mandir}/man8/lvresize.8.gz
301%{_mandir}/man8/lvs.8.gz
302%{_mandir}/man8/lvscan.8.gz
303%{_mandir}/man8/pvchange.8.gz
304%{_mandir}/man8/pvck.8.gz
305%{_mandir}/man8/pvcreate.8.gz
306%{_mandir}/man8/pvdisplay.8.gz
307%{_mandir}/man8/pvmove.8.gz
308%{_mandir}/man8/pvremove.8.gz
309%{_mandir}/man8/pvresize.8.gz
310%{_mandir}/man8/pvs.8.gz
311%{_mandir}/man8/pvscan.8.gz
312%{_mandir}/man8/vgcfgbackup.8.gz
313%{_mandir}/man8/vgcfgrestore.8.gz
314%{_mandir}/man8/vgchange.8.gz
315%{_mandir}/man8/vgck.8.gz
316%{_mandir}/man8/vgconvert.8.gz
317%{_mandir}/man8/vgcreate.8.gz
318%{_mandir}/man8/vgdisplay.8.gz
319%{_mandir}/man8/vgexport.8.gz
320%{_mandir}/man8/vgextend.8.gz
321%{_mandir}/man8/vgimport.8.gz
322%{_mandir}/man8/vgimportclone.8.gz
323%{_mandir}/man8/vgmerge.8.gz
324%{_mandir}/man8/vgmknodes.8.gz
325%{_mandir}/man8/vgreduce.8.gz
326%{_mandir}/man8/vgremove.8.gz
327%{_mandir}/man8/vgrename.8.gz
328%{_mandir}/man8/vgs.8.gz
329%{_mandir}/man8/vgscan.8.gz
330%{_mandir}/man8/vgsplit.8.gz
331%{_udevdir}/11-dm-lvm.rules
332%dir /etc/lvm
333%ghost /etc/lvm/cache/.cache
334%config(noreplace) /etc/lvm/lvm.conf
335%dir /etc/lvm/backup
336%dir /etc/lvm/cache
337%dir /etc/lvm/archive
338%dir /var/lock/lvm
339/etc/rc.d/init.d/lvm2-monitor
340
341%files devel
342%defattr(-,root,root,-)
343%{_libdir}/liblvm2app.so
344%{_libdir}/liblvm2cmd.so
345%{_includedir}/lvm2app.h
346%{_includedir}/lvm2cmd.h
347/usr%{_libdir}/pkgconfig/lvm2app.pc
348
349%files libs
350%attr(755,root,root) %{_libdir}/liblvm2app.so.*
351%attr(755,root,root) %{_libdir}/liblvm2cmd.so.*
352%attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so.*
353%{_libdir}/libdevmapper-event-lvm2.so
354%{_libdir}/libdevmapper-event-lvm2mirror.so
355%{_libdir}/libdevmapper-event-lvm2snapshot.so
356
357%if %{with_cluster}
358%files cluster
359%defattr(-,root,root,-)
360%attr(755,root,root) /usr/sbin/clvmd
361%{_mandir}/man8/clvmd.8.gz
362/etc/rc.d/init.d/clvmd
363%endif
364
365%files -n device-mapper
366%defattr(-,root,root,-)
367%doc COPYING COPYING.LIB WHATS_NEW_DM VERSION_DM README INSTALL udev/12-dm-permissions.rules
368%attr(755,root,root) /sbin/dmsetup
369%{_mandir}/man8/dmsetup.8.gz
370%dir %{_udevbasedir}
371%dir %{_udevdir}
372%{_udevdir}/10-dm.rules
373%{_udevdir}/13-dm-disk.rules
374%{_udevdir}/95-dm-notify.rules
375
376%files -n device-mapper-devel
377%defattr(-,root,root,-)
378%attr(755,root,root) /%{_lib}/libdevmapper.so
379%{_includedir}/libdevmapper.h
380/usr%{_libdir}/pkgconfig/devmapper.pc
381
382%files -n device-mapper-libs
383%attr(755,root,root) /%{_lib}/libdevmapper.so.*
384
385%files -n device-mapper-event
386%defattr(-,root,root,-)
387%{_sbindir}/dmeventd
388
389%files -n device-mapper-event-libs
390%{_libdir}/libdevmapper-event.so.*
391
392%files -n device-mapper-event-devel
393%defattr(-,root,root,-)
394%attr(755,root,root) /%{_lib}/libdevmapper-event.so
395%{_includedir}/libdevmapper-event.h
396/usr%{_libdir}/pkgconfig/devmapper-event.pc
397
398%changelog
399* Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-2
400- add missing file
401  - %{_udevdir}/11-dm-lvm.rules
402
403* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-1
404- new upstream release
405- add libs,devel subpackage
406  - liblvm2{app,cmd},libdevmapper-event-lvm2
407- enable dmeventd
408  - add device-mapper-event{,-libs,-devel}
409- enable udev sync code
410  - add BR: libudev-devel, R: libudev
411- disable static libs and binaries
412
413* Sun Feb 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.02.60-1
414- new upstream release
415
416* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.48-1
417- new upstream release
418
419* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.47-1
420- new upstream release
421
422* Wed Feb 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-2
423- add libdevmapper.a
424
425* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-1
426- new upstream release
427- upstream merge of device-mapper and lvm2 source.
428- move all binaries to /sbin
429- move libraries to /%%{_lib}
430
431* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.42-1
432- new upstream release
433
434* Sun Oct 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.41-1
435- new upstream release
436
437* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.40-1
438- new upstream release
439
440* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.39-1
441- new upstream release
442
443* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.38-1
444- new upstream release
445
446* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.35-1
447- new upstream release
448
449* Sat Dec 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.28-0vl1
450- new upstream release
451
452* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.13-0vl1
453- new upstream release
454
455* Sat Aug 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.06-0vl1
456- initial build for Vine Linux
457
458* Tue Aug  1 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-3
459- require new libselinux to avoid segfaults on xen (#200783)
460
461* Thu Jul 27 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-2
462- free trip through the buildsystem
463
464* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.02.06-1.2.1
465- rebuild
466
467* Tue Jun  6 2006 Stephen C. Tweedie <sct@redhat.com> - 2.02.06-1.2
468- Rebuild to pick up new nosegneg libc.a for lvm.static
469
470* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.1
471- Reinstate archs now build system is back.
472- BuildRequires libsepol-devel.
473
474* Fri May 12 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.0
475- New upstream release.
476
477* Sat Apr 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.1
478- Exclude archs that aren't building.
479
480* Fri Apr 21 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.0
481- Fix VG uuid comparisons.
482
483* Wed Apr 19 2006 Alasdair Kergon <agk@redhat.com> - 2.02.04-1.0
484- New release upstream, including better handling of duplicated VG names.
485
486* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2.1
487- bump again for double-long bug on ppc(64)
488
489* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2
490- rebuilt for new gcc4.1 snapshot and glibc changes
491
492* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
493- rebuilt
494
495* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> - 2.02.01-1
496- update to 2.02.01
497
498* Tue Nov  8 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-4
499- add patch for xen block devices
500
501* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
502- add -lselinux -lsepol to the static linking -ldevice-mapper requires it
503
504* Wed Sep 14 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-2
505- the distro doesn't really work without a 2.6 kernel, so no need to require it
506
507* Thu Aug 4 2005 Alasdair Kergon <agk@redhat.com> - 2.01.14-1.0
508- And a few more bugs fixes.
509
510* Wed Jul 13 2005 Alasdair Kergon <agk@redhat.com> - 2.01.13-1.0
511- Fix several bugs discovered in the last release.
512
513* Tue Jun 14 2005 Alasdair Kergon <agk@redhat.com> - 2.01.12-1.0
514- New version upstream with a lot of fixes and enhancements.
515
516* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.1
517- Add /etc/lvm
518
519* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.0
520- No longer abort read operations if archive/backup directories aren't there.
521- Add runtime directories and file to the package.
522
523* Tue Mar 22 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-1.0
524- Improve detection of external changes affecting internal cache.
525- Add clustered VG attribute.
526- Suppress rmdir opendir error message.
527
528* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.3
529* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.2
530* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.1
531- Suppress some new compiler messages.
532
533* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.0
534- Remove build directory from built-in path.
535- Extra /dev scanning required for clustered operation.
536
537* Thu Mar 03 2005 Alasdair Kergon <agk@redhat.com> - 2.01.06-1.0
538- Allow anaconda to suppress warning messages.
539
540* Fri Feb 18 2005 Alasdair Kergon <agk@redhat.com> - 2.01.05-1.0
541- Upstream changes not affecting Fedora.
542
543* Wed Feb 09 2005 Alasdair Kergon <agk@redhat.com> - 2.01.04-1.0
544- Offset pool minors; lvm2cmd.so skips open fd check; pvmove -f gone.
545
546* Tue Feb 01 2005 Alasdair Kergon <agk@redhat.com> - 2.01.03-1.0
547- Fix snapshot device size & 64-bit display output.
548
549* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> - 2.01.02-1.0
550- Minor fixes.
551
552* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.01-1.0
553- Update vgcreate man page.  Preparation for snapshot origin extension fix.
554
555* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.00-1.0
556- Fix metadata auto-correction. Only request open_count when needed.
557
558* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 2.00.33-2.0
559- Rebuilt for new readline.
560
561* Fri Jan 7 2005 Alasdair Kergon <agk@redhat.com> - 2.00.33-1.0
562- pvcreate wipes ext label
563- several clvm fixes
564
565* Thu Jan 6 2005 Alasdair Kergon <agk@redhat.com> - 2.00.32-2.0
566- Remove temporary /sbin symlinks no longer needed.
567- Include read-only pool support in the build.
568
569* Wed Dec 22 2004 Alasdair Kergon <agk@redhat.com> - 2.00.32-1.0
570- More fixes (143501).
571
572* Sun Dec 12 2004 Alasdair Kergon <agk@redhat.com> - 2.00.31-1.0
573- Fix pvcreate install issues.
574
575* Fri Dec 10 2004 Alasdair Kergon <agk@redhat.com> - 2.00.30-1.0
576- Additional debugging code.
577- Some trivial man page corrections.
578
579* Tue Nov 30 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.3
580- Reinstate all archs.
581
582* Sun Nov 28 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.2
583- Try excluding more archs.
584
585* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.1
586- Exclude s390x which fails.
587
588* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1
589- Fix last fix.
590
591* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.28-1
592- Endian fix to partition/md signature detection.
593
594* Wed Nov 24 2004 Alasdair Kergon <agk@redhat.com> - 2.00.27-1
595- Fix partition table detection & an out of memory segfault.
596
597* Tue Nov 23 2004 Alasdair Kergon <agk@redhat.com> - 2.00.26-1
598- Several installation-related fixes & man page updates.
599
600* Mon Oct 25 2004 Elliot Lee <sopwith@redhat.com> - 2.00.25-1.01
601- Fix 2.6 kernel requirement
602
603* Wed Sep 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.25-1
604- Fix vgmknodes return code & vgremove locking.
605
606* Fri Sep 17 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-2
607- Obsolete old lvm1 packages; refuse install if running kernel 2.4. [bz 128185]
608
609* Thu Sep 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-1
610- More upstream fixes.  (Always check WHATS_NEW file for details.)
611- Add requested BuildRequires. [bz 124916, 132408]
612
613* Wed Sep 15 2004 Alasdair Kergon <agk@redhat.com> - 2.00.23-1
614- Various minor upstream fixes.
615
616* Thu Sep  3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.22-1
617- Permission fix included upstream; use different endian conversion macros.
618
619* Thu Sep  2 2004 Jeremy Katz <katzj@redhat.com> - 2.00.21-2
620- fix permissions on vg dirs
621
622* Thu Aug 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.21-1
623- New upstream release incorporating fixes plus minor enhancements.
624
625* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 2.00.20-2
626- add patch for iSeries viodasd support
627- add patch to check file type using stat(2) if d_type == DT_UNKNOWN (#129674)
628
629* Sat Jul 3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.20-1
630- New upstream release fixes 2.6 kernel device numbers.
631
632* Tue Jun 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.19-1
633- Latest upstream release.  Lots of changes (see WHATS_NEW).
634
635* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> - 2.00.15-5
636- rebuilt
637
638* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-4
639- clone %description from LVM rpm
640
641* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-3
642- vgscan shouldn't return error status when no VGs present
643
644* Thu May 06 2004 Warren Togami <wtogami@redhat.com> - 2.00.15-2
645- i2o patch from Markus Lidel
646
647* Tue Apr 20 2004 Bill Nottingham <notting@redhat.com> - 2.00.15-1.1
648- handle disabled SELinux correctly, so that LVMs can be detected in a
649  non-SELinux context
650 
651* Mon Apr 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-1
652- Fix non-root build with current version of 'install'.
653
654* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.14-1
655- Use 64-bit file offsets.
656
657* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.13-1
658- Avoid scanning devices containing md superblocks.
659- Integrate ENOTSUP patch.
660
661* Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 2.00.12-4
662- don't die if we get ENOTSUP setting selinux contexts
663
664* Thu Apr 15 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-3
665- Add temporary pvscan symlink for LVM1 until mkinitrd gets updated.
666
667* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-2
668- Mark config file noreplace.
669
670* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-1
671- Install default /etc/lvm/lvm.conf.
672- Move non-static binaries to /usr/sbin.
673- Add temporary links in /sbin to lvm.static until rc.sysinit gets updated.
674
675* Thu Apr 08 2004 Alasdair Kergon <agk@redhat.com> 2.00.11-1
676- Fallback to using LVM1 tools when using a 2.4 kernel without device-mapper.
677
678* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-2
679- Install the full toolset, not just 'lvm'.
680
681* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-1
682- Update to version 2.00.10, which incorporates the RH-specific patches
683  and includes various fixes and enhancements detailed in WHATS_NEW.
684
685* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.00.08-5
686- Fix sysfs patch to find sysfs
687- Take patch from dwalsh and tweak a little for setting SELinux contexts on
688  device node creation and also do it on the symlink creation. 
689  Part of this should probably be pushed down to device-mapper instead
690
691* Thu Feb 19 2004 Stephen C. Tweedie <sct@redhat.com> 2.00.08-4
692- Add sysfs filter patch
693- Allow non-root users to build RPM
694
695* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
696- rebuilt
697
698* Fri Dec  5 2003 Jeremy Katz <katzj@redhat.com> 2.00.08-2
699- add static lvm binary
700
701* Tue Dec  2 2003 Jeremy Katz <katzj@redhat.com>
702- Initial build.
703
704
Note: See TracBrowser for help on using the repository browser.