source: projects/specs/trunk/l/lvm2/lvm2-vl.spec @ 12361

Revision 12361, 23.5 KB checked in by tomop, 4 years ago (diff)

updated 8 packages

cryptsetup-2.3.1-1

gdisk-1.0.5-1

kernel-4.14.174-1

lvm2-2.03.09-1

libblockdev-2.23-1

libmicrohttpd-0.9.70-1

udisks-1.0.5-1

udisks2-2.8.4-1

Line 
1%define lvm_version 2.03.09
2%define device_mapper_version 1.02.171
3
4%define _unpackaged_files_terminate_build 1
5
6# Do not reset Release to 1 unless both lvm2 and device-mapper
7# versions are increased together.
8
9Summary: Userland logical volume management tools
10Summary(ja): 論理ボリューム管理ツール
11Name: lvm2
12Version: %{lvm_version}
13Release: 1%{?_dist_release}
14Group: System Environment/Base
15
16Distribution: Vine Linux
17Vendor: Project Vine
18Packager: daisuke
19
20License: GPLv2
21URL: http://sourceware.org/lvm2/
22Source0: LVM2.%{lvm_version}.tgz
23Patch0: lvm2-set-default-preferred_names.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{lvm_version}-%{release}-buildroot
26BuildRequires: libaio-devel
27BuildRequires: libtermcap-devel
28BuildRequires: libudev-devel
29BuildRequires: ncurses-devel
30BuildRequires: readline-devel
31Requires: device-mapper >= %{device_mapper_version}-%{release}
32Requires: device-mapper-event >= %{device_mapper_version}-%{release}
33Requires: %{name}-libs = %{version}-%{release}
34Conflicts: lvm
35Obsoletes: lvm
36
37%define _exec_prefix /usr
38
39%description
40LVM2 includes all of the support for handling read/write operations on
41physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
42multiple devices (MD), see mdadd(8) or even loop devices, see
43losetup(8)), creating volume groups (kind of virtual disks) from one
44or more physical volumes and creating one or more logical volumes
45(kind of logical partitions) in volume groups.
46
47%package devel
48Summary: Development libraries and headers for lvm2
49Summary(ja): LVM2 の開発用ライブラリ及びヘッダファイル
50Group: Development/Libraries
51License: LGPLv2
52Requires: %{name} = %{version}-%{release}
53Requires: %{name}-libs = %{version}-%{release}
54Requires: device-mapper-devel >= %{device_mapper_version}-%{release}
55Requires: device-mapper-event-devel >= %{device_mapper_version}-%{release}
56Requires: pkgconfig
57
58%description devel
59This package contains files needed to develop applications that use
60the lvm2 libraries.
61
62%package libs
63Summary: lvm2 shared libraries
64Summary(ja): LVM2 の共有ライブラリ
65License: LGPLv2
66Group: System Environment/Libraries
67
68%description libs
69This package contains shared lvm2 libraries for applications.
70
71# device-mapper
72%package -n device-mapper
73Summary: Device mapper utility
74Summary(ja): Device-mapper ユーティリティ集
75Version: %{device_mapper_version}
76Release: %{release}
77License: GPLv2
78Group: System Environment/Base
79URL: http://sources.redhat.com/dm
80Requires: device-mapper-libs = %{device_mapper_version}-%{release}
81Requires: eudev-libudev
82Requires: util-linux-ng >= 2.15
83
84%description -n device-mapper
85This package contains the supporting userspace utility, dmsetup,
86for the kernel device-mapper.
87
88# device-mapper-devel
89%package -n device-mapper-devel
90Summary: Development libraries and headers for device-mapper
91Summary(ja): Device-mapper の開発用ライブラリ及びヘッダファイル
92Version: %{device_mapper_version}
93Release: %{release}
94License: LGPLv2
95Group: Development/Libraries
96Requires: device-mapper = %{device_mapper_version}-%{release}
97Requires: device-mapper-libs = %{device_mapper_version}-%{release}
98
99%description -n device-mapper-devel
100This package contains files needed to develop applications that use
101the device-mapper libraries.
102
103%package -n device-mapper-libs
104Summary: Device-mapper shared library
105Summary(ja): Device-mapper の共有ライブラリ
106Version: %{device_mapper_version}
107Release: %{release}
108License: LGPLv2
109Group: System Environment/Libraries
110Obsoletes: device-mapper < 1.02.30-1
111
112%description -n device-mapper-libs
113This package contains the device-mapper shared library, libdevmapper.
114
115%package -n device-mapper-event
116Summary: Device-mapper event daemon
117Summary(ja): Device-mapper イベントデーモン
118Group: System Environment/Base
119Version: %{device_mapper_version}
120Release: %{release}
121Requires: device-mapper = %{device_mapper_version}-%{release}
122Requires: device-mapper-event-libs = %{device_mapper_version}-%{release}
123
124%description -n device-mapper-event
125This package contains the dmeventd daemon for monitoring the state
126of device-mapper devices.
127
128%package -n device-mapper-event-libs
129Summary: Device-mapper event daemon shared library
130Summary(ja): Device-mapper イベントデーモン共有ライブラリ
131Version: %{device_mapper_version}
132Release: %{release}
133License: LGPLv2
134Group: System Environment/Libraries
135
136%description -n device-mapper-event-libs
137This package contains the device-mapper event daemon shared library,
138libdevmapper-event.
139
140%package -n device-mapper-event-devel
141Summary: Development libraries and headers for the device-mapper event daemon
142Summary(ja): Device-mapper イベントデーモンの開発用ライブラリ及びヘッダファイル
143Version: %{device_mapper_version}
144Release: %{release}
145License: LGPLv2
146Group: Development/Libraries
147Requires: device-mapper-event = %{device_mapper_version}-%{release}
148Requires: pkgconfig
149
150%description -n device-mapper-event-devel
151This package contains files needed to develop applications that use
152the device-mapper event library.
153
154%prep
155%setup -q -n LVM2.%{lvm_version}
156%patch0 -p1 -b .preferred_names
157
158%build
159%define _exec_prefix /
160%define _bindir /bin
161%define _sbindir /sbin
162%define _libdir /%{_lib}
163%define _udevbasedir /lib/udev
164%define _udevdir %{_udevbasedir}/rules.d
165
166%configure \
167  --enable-readline \
168  --enable-lvm1_fallback \
169  --enable-fsadm \
170  --with-pool=internal \
171  --with-staticdir=/sbin \
172  --with-user= --with-group= \
173  --with-usrlibdir=/usr/%{_lib} \
174  --with-usrsbindir=/usr/sbin \
175  --with-dmdir=device-mapper.%{device_mapper_version} \
176  --with-udevdir=%{_udevdir} \
177  --with-device-uid=0 --with-device-gid=6 \
178  --with-device-mode=0660 \
179  --enable-pkgconfig \
180  --enable-applib \
181  --enable-cmdlib \
182  --enable-dmeventd \
183  --enable-udev_sync
184
185make %{?_smp_mflags}
186
187%install
188rm -rf $RPM_BUILD_ROOT
189make install DESTDIR=$RPM_BUILD_ROOT
190install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/archive
191install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/backup
192install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/cache
193install -m 0700 -d $RPM_BUILD_ROOT/var/lock/lvm
194install -m 0600 /dev/null $RPM_BUILD_ROOT/etc/lvm/cache/.cache
195mkdir -p -m755 $RPM_BUILD_ROOT/etc/rc.d/init.d
196install -m 0755 scripts/lvm2_monitoring_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/lvm2-monitor
197
198
199%clean
200rm -rf $RPM_BUILD_ROOT
201
202%post
203/sbin/ldconfig
204/sbin/chkconfig --add lvm2-monitor
205
206%preun
207if [ "$1" = 0 ]; then
208        /sbin/chkconfig --del lvm2-monitor
209fi
210
211%post libs -p /sbin/ldconfig
212
213%postun libs -p /sbin/ldconfig
214
215%post -n device-mapper-libs -p /sbin/ldconfig
216
217%postun -n device-mapper-libs -p /sbin/ldconfig
218
219%post -n device-mapper-event-libs -p /sbin/ldconfig
220
221%postun -n device-mapper-event-libs -p /sbin/ldconfig
222
223%files
224%defattr(-,root,root,-)
225%license COPYING COPYING.LIB
226%doc INSTALL README VERSION WHATS_NEW
227%attr(555,root,root) %{_sbindir}/fsadm
228%{_sbindir}/lvchange
229%{_sbindir}/lvconvert
230%{_sbindir}/lvcreate
231%{_sbindir}/lvdisplay
232%{_sbindir}/lvextend
233%{_sbindir}/lvm
234%{_sbindir}/lvmconfig
235%{_sbindir}/lvmdiskscan
236%{_sbindir}/lvmdump
237%{_sbindir}/lvmsadc
238%{_sbindir}/lvmsar
239%{_sbindir}/lvreduce
240%{_sbindir}/lvremove
241%{_sbindir}/lvrename
242%{_sbindir}/lvresize
243%{_sbindir}/lvs
244%{_sbindir}/lvscan
245%{_sbindir}/pvchange
246%{_sbindir}/pvck
247%{_sbindir}/pvcreate
248%{_sbindir}/pvdisplay
249%{_sbindir}/pvmove
250%{_sbindir}/pvremove
251%{_sbindir}/pvresize
252%{_sbindir}/pvs
253%{_sbindir}/pvscan
254%{_sbindir}/vgcfgbackup
255%{_sbindir}/vgcfgrestore
256%{_sbindir}/vgchange
257%{_sbindir}/vgck
258%{_sbindir}/vgconvert
259%{_sbindir}/vgcreate
260%{_sbindir}/vgdisplay
261%{_sbindir}/vgexport
262%{_sbindir}/vgextend
263%{_sbindir}/vgimport
264%{_sbindir}/vgimportclone
265%{_sbindir}/vgmerge
266%{_sbindir}/vgmknodes
267%{_sbindir}/vgreduce
268%{_sbindir}/vgremove
269%{_sbindir}/vgrename
270%{_sbindir}/vgs
271%{_sbindir}/vgscan
272%{_sbindir}/vgsplit
273%{_mandir}/man5/lvm.conf.5.gz
274%{_mandir}/man7/lvmcache.7.gz
275%{_mandir}/man7/lvmraid.7.gz
276%{_mandir}/man7/lvmreport.7.gz
277%{_mandir}/man7/lvmsystemid.7.gz
278%{_mandir}/man7/lvmthin.7.gz
279%{_mandir}/man7/lvmvdo.7.gz
280%{_mandir}/man8/fsadm.8.gz
281%{_mandir}/man8/lvchange.8.gz
282%{_mandir}/man8/lvconvert.8.gz
283%{_mandir}/man8/lvcreate.8.gz
284%{_mandir}/man8/lvdisplay.8.gz
285%{_mandir}/man8/lvextend.8.gz
286%{_mandir}/man8/lvm.8.gz
287%{_mandir}/man8/lvm-config.8.gz
288%{_mandir}/man8/lvm-dumpconfig.8.gz
289%{_mandir}/man8/lvm-fullreport.8.gz
290%{_mandir}/man8/lvm-lvpoll.8.gz
291%{_mandir}/man8/lvmconfig.8.gz
292%{_mandir}/man8/lvmdiskscan.8.gz
293%{_mandir}/man8/lvmdump.8.gz
294%{_mandir}/man8/lvmsadc.8.gz
295%{_mandir}/man8/lvmsar.8.gz
296%{_mandir}/man8/lvreduce.8.gz
297%{_mandir}/man8/lvremove.8.gz
298%{_mandir}/man8/lvrename.8.gz
299%{_mandir}/man8/lvresize.8.gz
300%{_mandir}/man8/lvs.8.gz
301%{_mandir}/man8/lvscan.8.gz
302%{_mandir}/man8/pvchange.8.gz
303%{_mandir}/man8/pvck.8.gz
304%{_mandir}/man8/pvcreate.8.gz
305%{_mandir}/man8/pvdisplay.8.gz
306%{_mandir}/man8/pvmove.8.gz
307%{_mandir}/man8/pvremove.8.gz
308%{_mandir}/man8/pvresize.8.gz
309%{_mandir}/man8/pvs.8.gz
310%{_mandir}/man8/pvscan.8.gz
311%{_mandir}/man8/vgcfgbackup.8.gz
312%{_mandir}/man8/vgcfgrestore.8.gz
313%{_mandir}/man8/vgchange.8.gz
314%{_mandir}/man8/vgck.8.gz
315%{_mandir}/man8/vgconvert.8.gz
316%{_mandir}/man8/vgcreate.8.gz
317%{_mandir}/man8/vgdisplay.8.gz
318%{_mandir}/man8/vgexport.8.gz
319%{_mandir}/man8/vgextend.8.gz
320%{_mandir}/man8/vgimport.8.gz
321%{_mandir}/man8/vgimportclone.8.gz
322%{_mandir}/man8/vgmerge.8.gz
323%{_mandir}/man8/vgmknodes.8.gz
324%{_mandir}/man8/vgreduce.8.gz
325%{_mandir}/man8/vgremove.8.gz
326%{_mandir}/man8/vgrename.8.gz
327%{_mandir}/man8/vgs.8.gz
328%{_mandir}/man8/vgscan.8.gz
329%{_mandir}/man8/vgsplit.8.gz
330%{_udevdir}/11-dm-lvm.rules
331%{_udevdir}/69-dm-lvm-metad.rules
332%dir /etc/lvm
333%ghost /etc/lvm/cache/.cache
334%config(noreplace) /etc/lvm/lvm.conf
335%config(noreplace) /etc/lvm/lvmlocal.conf
336%dir /etc/lvm/backup
337%dir /etc/lvm/cache
338%dir /etc/lvm/archive
339%dir /var/lock/lvm
340%dir /etc/lvm/profile
341/etc/lvm/profile/*.profile
342/etc/rc.d/init.d/lvm2-monitor
343
344%files devel
345%defattr(-,root,root,-)
346/usr%{_libdir}/liblvm2cmd.so
347%{_includedir}/lvm2cmd.h
348/usr%{_libdir}/libdevmapper-event-lvm2.so
349
350%files libs
351%attr(755,root,root) %{_libdir}/liblvm2cmd.so.*
352%attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so.*
353%dir %{_libdir}/device-mapper
354%{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
355%{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
356%{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
357%{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
358%{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
359%{_libdir}/libdevmapper-event-lvm2mirror.so
360%{_libdir}/libdevmapper-event-lvm2snapshot.so
361%{_libdir}/libdevmapper-event-lvm2raid.so
362%{_libdir}/libdevmapper-event-lvm2thin.so
363%{_libdir}/libdevmapper-event-lvm2vdo.so
364
365%files -n device-mapper
366%defattr(-,root,root,-)
367%license COPYING COPYING.LIB
368%doc WHATS_NEW_DM VERSION_DM README INSTALL udev/12-dm-permissions.rules
369%attr(755,root,root) /sbin/blkdeactivate
370%attr(755,root,root) /sbin/dmsetup
371%attr(755,root,root) /sbin/dmstats
372%{_mandir}/man8/blkdeactivate.8.gz
373%{_mandir}/man8/dmsetup.8.gz
374%{_mandir}/man8/dmstats.8.gz
375%dir %{_udevbasedir}
376%dir %{_udevdir}
377%{_udevdir}/10-dm.rules
378%{_udevdir}/13-dm-disk.rules
379%{_udevdir}/95-dm-notify.rules
380
381%files -n device-mapper-devel
382%defattr(-,root,root,-)
383/usr%{_libdir}/libdevmapper.so
384%{_includedir}/libdevmapper.h
385/usr%{_libdir}/pkgconfig/devmapper.pc
386
387%files -n device-mapper-libs
388%attr(755,root,root) %{_libdir}/libdevmapper.so.*
389
390%files -n device-mapper-event
391%defattr(-,root,root,-)
392%{_sbindir}/dmeventd
393%{_mandir}/man8/dmeventd.8.gz
394
395%files -n device-mapper-event-libs
396%{_libdir}/libdevmapper-event.so.*
397
398%files -n device-mapper-event-devel
399%defattr(-,root,root,-)
400/usr%{_libdir}/libdevmapper-event.so
401%{_includedir}/libdevmapper-event.h
402/usr%{_libdir}/pkgconfig/devmapper-event.pc
403
404%changelog
405* Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.03.09-1
406- new upstream release.
407- dropped Patch1, 2 and 10.
408
409* Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.02.177-1
410- updated to 2.02.177
411- dropped Patch2: fixed in upstream.
412- imported Patch1 and 2 from rawhide.
413
414* Mon Jul 14 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.02.107-1
415- add patch20 to fix duplicate 'const' in libdevmapper.h
416
417* Mon Jul 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.02.107-1
418- update to 2.02.107
419
420* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.98-3
421- change BuildRequires: eudev-libudev-devel instead of libudev-devel
422
423* Tue Dec 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.98-2
424- add missing files to %%files
425
426* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.98-1
427- new upstream release
428
429* Mon Mar 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.84-1
430- new upstream release
431- enable static libs, add device-mapper-static subpackage
432
433* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.83-1
434- new upstream release
435
436* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.79-1
437- new upstream release
438
439* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.78-1
440- new upstream release
441- fix %%files
442
443* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.02.62-3
444- rebuilt with rpm-4.8.1 for pkg-config
445
446* Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-2
447- add missing file
448  - %{_udevdir}/11-dm-lvm.rules
449
450* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-1
451- new upstream release
452- add libs,devel subpackage
453  - liblvm2{app,cmd},libdevmapper-event-lvm2
454- enable dmeventd
455  - add device-mapper-event{,-libs,-devel}
456- enable udev sync code
457  - add BR: libudev-devel, R: libudev
458- disable static libs and binaries
459
460* Sun Feb 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.02.60-1
461- new upstream release
462
463* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.48-1
464- new upstream release
465
466* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.47-1
467- new upstream release
468
469* Wed Feb 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-2
470- add libdevmapper.a
471
472* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-1
473- new upstream release
474- upstream merge of device-mapper and lvm2 source.
475- move all binaries to /sbin
476- move libraries to /%%{_lib}
477
478* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.42-1
479- new upstream release
480
481* Sun Oct 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.41-1
482- new upstream release
483
484* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.40-1
485- new upstream release
486
487* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.39-1
488- new upstream release
489
490* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.38-1
491- new upstream release
492
493* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.35-1
494- new upstream release
495
496* Sat Dec 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.28-0vl1
497- new upstream release
498
499* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.13-0vl1
500- new upstream release
501
502* Sat Aug 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.06-0vl1
503- initial build for Vine Linux
504
505* Tue Aug  1 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-3
506- require new libselinux to avoid segfaults on xen (#200783)
507
508* Thu Jul 27 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-2
509- free trip through the buildsystem
510
511* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.02.06-1.2.1
512- rebuild
513
514* Tue Jun  6 2006 Stephen C. Tweedie <sct@redhat.com> - 2.02.06-1.2
515- Rebuild to pick up new nosegneg libc.a for lvm.static
516
517* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.1
518- Reinstate archs now build system is back.
519- BuildRequires libsepol-devel.
520
521* Fri May 12 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.0
522- New upstream release.
523
524* Sat Apr 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.1
525- Exclude archs that aren't building.
526
527* Fri Apr 21 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.0
528- Fix VG uuid comparisons.
529
530* Wed Apr 19 2006 Alasdair Kergon <agk@redhat.com> - 2.02.04-1.0
531- New release upstream, including better handling of duplicated VG names.
532
533* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2.1
534- bump again for double-long bug on ppc(64)
535
536* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2
537- rebuilt for new gcc4.1 snapshot and glibc changes
538
539* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
540- rebuilt
541
542* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> - 2.02.01-1
543- update to 2.02.01
544
545* Tue Nov  8 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-4
546- add patch for xen block devices
547
548* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
549- add -lselinux -lsepol to the static linking -ldevice-mapper requires it
550
551* Wed Sep 14 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-2
552- the distro doesn't really work without a 2.6 kernel, so no need to require it
553
554* Thu Aug 4 2005 Alasdair Kergon <agk@redhat.com> - 2.01.14-1.0
555- And a few more bugs fixes.
556
557* Wed Jul 13 2005 Alasdair Kergon <agk@redhat.com> - 2.01.13-1.0
558- Fix several bugs discovered in the last release.
559
560* Tue Jun 14 2005 Alasdair Kergon <agk@redhat.com> - 2.01.12-1.0
561- New version upstream with a lot of fixes and enhancements.
562
563* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.1
564- Add /etc/lvm
565
566* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.0
567- No longer abort read operations if archive/backup directories aren't there.
568- Add runtime directories and file to the package.
569
570* Tue Mar 22 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-1.0
571- Improve detection of external changes affecting internal cache.
572- Add clustered VG attribute.
573- Suppress rmdir opendir error message.
574
575* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.3
576* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.2
577* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.1
578- Suppress some new compiler messages.
579
580* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.0
581- Remove build directory from built-in path.
582- Extra /dev scanning required for clustered operation.
583
584* Thu Mar 03 2005 Alasdair Kergon <agk@redhat.com> - 2.01.06-1.0
585- Allow anaconda to suppress warning messages.
586
587* Fri Feb 18 2005 Alasdair Kergon <agk@redhat.com> - 2.01.05-1.0
588- Upstream changes not affecting Fedora.
589
590* Wed Feb 09 2005 Alasdair Kergon <agk@redhat.com> - 2.01.04-1.0
591- Offset pool minors; lvm2cmd.so skips open fd check; pvmove -f gone.
592
593* Tue Feb 01 2005 Alasdair Kergon <agk@redhat.com> - 2.01.03-1.0
594- Fix snapshot device size & 64-bit display output.
595
596* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> - 2.01.02-1.0
597- Minor fixes.
598
599* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.01-1.0
600- Update vgcreate man page.  Preparation for snapshot origin extension fix.
601
602* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.00-1.0
603- Fix metadata auto-correction. Only request open_count when needed.
604
605* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 2.00.33-2.0
606- Rebuilt for new readline.
607
608* Fri Jan 7 2005 Alasdair Kergon <agk@redhat.com> - 2.00.33-1.0
609- pvcreate wipes ext label
610- several clvm fixes
611
612* Thu Jan 6 2005 Alasdair Kergon <agk@redhat.com> - 2.00.32-2.0
613- Remove temporary /sbin symlinks no longer needed.
614- Include read-only pool support in the build.
615
616* Wed Dec 22 2004 Alasdair Kergon <agk@redhat.com> - 2.00.32-1.0
617- More fixes (143501).
618
619* Sun Dec 12 2004 Alasdair Kergon <agk@redhat.com> - 2.00.31-1.0
620- Fix pvcreate install issues.
621
622* Fri Dec 10 2004 Alasdair Kergon <agk@redhat.com> - 2.00.30-1.0
623- Additional debugging code.
624- Some trivial man page corrections.
625
626* Tue Nov 30 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.3
627- Reinstate all archs.
628
629* Sun Nov 28 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.2
630- Try excluding more archs.
631
632* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.1
633- Exclude s390x which fails.
634
635* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1
636- Fix last fix.
637
638* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.28-1
639- Endian fix to partition/md signature detection.
640
641* Wed Nov 24 2004 Alasdair Kergon <agk@redhat.com> - 2.00.27-1
642- Fix partition table detection & an out of memory segfault.
643
644* Tue Nov 23 2004 Alasdair Kergon <agk@redhat.com> - 2.00.26-1
645- Several installation-related fixes & man page updates.
646
647* Mon Oct 25 2004 Elliot Lee <sopwith@redhat.com> - 2.00.25-1.01
648- Fix 2.6 kernel requirement
649
650* Wed Sep 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.25-1
651- Fix vgmknodes return code & vgremove locking.
652
653* Fri Sep 17 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-2
654- Obsolete old lvm1 packages; refuse install if running kernel 2.4. [bz 128185]
655
656* Thu Sep 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-1
657- More upstream fixes.  (Always check WHATS_NEW file for details.)
658- Add requested BuildRequires. [bz 124916, 132408]
659
660* Wed Sep 15 2004 Alasdair Kergon <agk@redhat.com> - 2.00.23-1
661- Various minor upstream fixes.
662
663* Fri Sep  3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.22-1
664- Permission fix included upstream; use different endian conversion macros.
665
666* Thu Sep  2 2004 Jeremy Katz <katzj@redhat.com> - 2.00.21-2
667- fix permissions on vg dirs
668
669* Thu Aug 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.21-1
670- New upstream release incorporating fixes plus minor enhancements.
671
672* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 2.00.20-2
673- add patch for iSeries viodasd support
674- add patch to check file type using stat(2) if d_type == DT_UNKNOWN (#129674)
675
676* Sat Jul 3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.20-1
677- New upstream release fixes 2.6 kernel device numbers.
678
679* Tue Jun 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.19-1
680- Latest upstream release.  Lots of changes (see WHATS_NEW).
681
682* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> - 2.00.15-5
683- rebuilt
684
685* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-4
686- clone %description from LVM rpm
687
688* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-3
689- vgscan shouldn't return error status when no VGs present
690
691* Thu May 06 2004 Warren Togami <wtogami@redhat.com> - 2.00.15-2
692- i2o patch from Markus Lidel
693
694* Tue Apr 20 2004 Bill Nottingham <notting@redhat.com> - 2.00.15-1.1
695- handle disabled SELinux correctly, so that LVMs can be detected in a
696  non-SELinux context
697 
698* Mon Apr 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-1
699- Fix non-root build with current version of 'install'.
700
701* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.14-1
702- Use 64-bit file offsets.
703
704* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.13-1
705- Avoid scanning devices containing md superblocks.
706- Integrate ENOTSUP patch.
707
708* Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 2.00.12-4
709- don't die if we get ENOTSUP setting selinux contexts
710
711* Thu Apr 15 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-3
712- Add temporary pvscan symlink for LVM1 until mkinitrd gets updated.
713
714* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-2
715- Mark config file noreplace.
716
717* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-1
718- Install default /etc/lvm/lvm.conf.
719- Move non-static binaries to /usr/sbin.
720- Add temporary links in /sbin to lvm.static until rc.sysinit gets updated.
721
722* Thu Apr 08 2004 Alasdair Kergon <agk@redhat.com> 2.00.11-1
723- Fallback to using LVM1 tools when using a 2.4 kernel without device-mapper.
724
725* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-2
726- Install the full toolset, not just 'lvm'.
727
728* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-1
729- Update to version 2.00.10, which incorporates the RH-specific patches
730  and includes various fixes and enhancements detailed in WHATS_NEW.
731
732* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.00.08-5
733- Fix sysfs patch to find sysfs
734- Take patch from dwalsh and tweak a little for setting SELinux contexts on
735  device node creation and also do it on the symlink creation. 
736  Part of this should probably be pushed down to device-mapper instead
737
738* Thu Feb 19 2004 Stephen C. Tweedie <sct@redhat.com> 2.00.08-4
739- Add sysfs filter patch
740- Allow non-root users to build RPM
741
742* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
743- rebuilt
744
745* Fri Dec  5 2003 Jeremy Katz <katzj@redhat.com> 2.00.08-2
746- add static lvm binary
747
748* Tue Dec  2 2003 Jeremy Katz <katzj@redhat.com>
749- Initial build.
750
751
Note: See TracBrowser for help on using the repository browser.