source: projects/specs/trunk/l/lsb/lsb-vl.spec @ 8570

Revision 8570, 23.3 KB checked in by daisuke, 10 years ago (diff)

lsb: require spax instead of pax (more POSIX compatible)

Line 
1# Define this to link to which library version  eg. /lib64/ld-lsb-x86-64.so.3
2%define lsbsover 3
3
4%ifarch %{ix86}
5%define ldso ld-linux.so.2
6%define lsbldso ld-lsb.so
7%endif
8
9%ifarch ia64
10%define ldso ld-linux-ia64.so.2
11%define lsbldso ld-lsb-ia64.so
12%endif
13
14%ifarch ppc
15%define ldso ld.so.1
16%define lsbldso ld-lsb-ppc32.so
17%endif
18
19%ifarch ppc64
20%define ldso ld64.so.1
21%define lsbldso ld-lsb-ppc64.so
22%endif
23
24%ifarch s390
25%define ldso ld.so.1
26%define lsbldso ld-lsb-s390.so
27%endif
28
29%ifarch s390x
30%define ldso ld64.so.1
31%define lsbldso ld-lsb-s390x.so
32%endif
33
34%ifarch x86_64
35%define ldso ld-linux-x86-64.so.2
36%define lsbldso ld-lsb-x86-64.so
37%endif
38
39%ifarch ia64 ppc64 s390x x86_64
40%define qual ()(64bit)
41%else
42%define qual %{nil}
43%endif
44
45%define upstreamlsbrelver 2.0
46%define lsbrelver 4.0
47%define srcrelease 1
48
49Summary: LSB support for Vine Linux
50Summary(ja): Vine Linux の LSB サポート
51Name: lsb
52Version: 4.0
53Release: 2%{?_dist_release}
54URL: http://www.linuxfoundation.org/
55Source0: %{name}-vine-%{version}.tar.bz2
56License: GPLv2
57Group: System Environment/Base
58BuildRoot: %{_tmppath}/%{name}-root
59BuildRequires: glibc-static
60# dependency for primary LSB application for v1.3
61Provides: lsb = %{version}
62# dependency for primary LSB application for v2.0, v3.0 and v4.0
63%ifarch %{ix86}
64%define archname ia32
65%endif
66%ifarch ia64
67%define archname ia64
68%endif
69%ifarch ppc
70%define archname ppc32
71%endif
72%ifarch ppc64
73%define archname ppc64
74%endif
75%ifarch s390
76%define archname s390
77%endif
78%ifarch s390x
79%define archname s390x
80%endif
81%ifarch x86_64
82%define archname amd64
83%endif
84Provides: lsb-core-%{archname} = %{version}
85Provides: lsb-graphics-%{archname} = %{version}
86Provides: lsb-core-noarch = %{version}
87Provides: lsb-graphics-noarch = %{version}
88Provides: lsb-printing-%{archname} = %{version}
89Provides: lsb-printing-noarch = %{version}
90
91ExclusiveArch: %{ix86} ia64 x86_64 ppc ppc64 s390 s390x
92
93%ifarch %{ix86}
94# archLSB IA32 Base Libraries
95Requires: libatk-1.0.so.0
96Requires: libc.so.6
97Requires: libcrypt.so.1
98Requires: libdl.so.2
99Requires: libgcc_s.so.1
100Requires: libgdk-x11-2.0.so.0
101Requires: libgdk_pixbuf-2.0.so.0
102Requires: libgdk_pixbuf_xlib-2.0.so.0
103Requires: libglib-2.0.so.0
104Requires: libgmodule-2.0.so.0
105Requires: libgobject-2.0.so.0
106Requires: libgthread-2.0.so.0
107Requires: libgtk-x11-2.0.so.0
108Requires: libm.so.6
109Requires: libncurses.so.5
110Requires: libpango-1.0.so.0
111Requires: libpangoft2-1.0.so.0
112Requires: libpangoxft-1.0.so.0
113Requires: libpthread.so.0
114Requires: libqt-mt.so.3
115Requires: libQtCore.so.4
116Requires: libQtGui.so.4
117Requires: libQtNetwork.so.4
118Requires: libQtOpenGL.so.4
119Requires: libQtSql.so.4
120Requires: libQtSvg.so.4
121Requires: libQtXml.so.4
122Requires: libstdc++.so.6
123Requires: libutil.so.1
124Requires: libz.so.1
125%endif
126
127%ifarch ia64
128# archLSB IA64 Base Libraries
129Requires: libatk-1.0.so.0()(64bit)
130Requires: libc.so.6.1()(64bit)
131Requires: libcrypt.so.1()(64bit)
132Requires: libdl.so.2()(64bit)
133Requires: libgcc_s.so.1()(64bit)
134Requires: libgdk-x11-2.0.so.0()(64bit)
135Requires: libgdk_pixbuf-2.0.so.0()(64bit)
136Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
137Requires: libglib-2.0.so.0()(64bit)
138Requires: libgmodule-2.0.so.0()(64bit)
139Requires: libgobject-2.0.so.0()(64bit)
140Requires: libgthread-2.0.so.0()(64bit)
141Requires: libgtk-x11-2.0.so.0()(64bit)
142Requires: libm.so.6.1()(64bit)
143Requires: libncurses.so.5()(64bit)
144Requires: libpango-1.0.so.0()(64bit)
145Requires: libpangoft2-1.0.so.0()(64bit)
146Requires: libpangoxft-1.0.so.0()(64bit)
147Requires: libpthread.so.0()(64bit)
148Requires: libqt-mt.so.3()(64bit)
149Requires: libQtCore.so.4()(64bit)
150Requires: libQtGui.so.4()(64bit)
151Requires: libQtNetwork.so.4()(64bit)
152Requires: libQtOpenGL.so.4()(64bit)
153Requires: libQtSql.so.4()(64bit)
154Requires: libQtSvg.so.4()(64bit)
155Requires: libQtXml.so.4()(64bit)
156Requires: libstdc++.so.6()(64bit)
157Requires: libutil.so.1()(64bit)
158Requires: libz.so.1()(64bit)
159%endif
160
161%ifarch ppc
162# archLSB PPC32 Base Libraries
163Requires: libatk-1.0.so.0
164Requires: libc.so.6
165Requires: libcrypt.so.1
166Requires: libdl.so.2
167Requires: libgcc_s.so.1
168Requires: libgdk-x11-2.0.so.0
169Requires: libgdk_pixbuf-2.0.so.0
170Requires: libgdk_pixbuf_xlib-2.0.so.0
171Requires: libglib-2.0.so.0
172Requires: libgmodule-2.0.so.0
173Requires: libgobject-2.0.so.0
174Requires: libgthread-2.0.so.0
175Requires: libgtk-x11-2.0.so.0
176Requires: libm.so.6
177Requires: libncurses.so.5
178Requires: libpango-1.0.so.0
179Requires: libpangoft2-1.0.so.0
180Requires: libpangoxft-1.0.so.0
181Requires: libpthread.so.0
182Requires: libqt-mt.so.3
183Requires: libQtCore.so.4
184Requires: libQtGui.so.4
185Requires: libQtNetwork.so.4
186Requires: libQtOpenGL.so.4
187Requires: libQtSql.so.4
188Requires: libQtSvg.so.4
189Requires: libQtXml.so.4
190Requires: libstdc++.so.6
191Requires: libutil.so.1
192Requires: libz.so.1
193%endif
194
195%ifarch ppc64
196# archLSB PPC64 Base Libraries
197Requires: libatk-1.0.so.0()(64bit)
198Requires: libc.so.6()(64bit)
199Requires: libcrypt.so.1()(64bit)
200Requires: libdl.so.2()(64bit)
201Requires: libgcc_s.so.1()(64bit)
202Requires: libgdk-x11-2.0.so.0()(64bit)
203Requires: libgdk_pixbuf-2.0.so.0()(64bit)
204Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
205Requires: libglib-2.0.so.0()(64bit)
206Requires: libgmodule-2.0.so.0()(64bit)
207Requires: libgobject-2.0.so.0()(64bit)
208Requires: libgthread-2.0.so.0()(64bit)
209Requires: libgtk-x11-2.0.so.0()(64bit)
210Requires: libm.so.6()(64bit)
211Requires: libncurses.so.5()(64bit)
212Requires: libpango-1.0.so.0()(64bit)
213Requires: libpangoft2-1.0.so.0()(64bit)
214Requires: libpangoxft-1.0.so.0()(64bit)
215Requires: libpthread.so.0()(64bit)
216Requires: libqt-mt.so.3()(64bit)
217Requires: libQtCore.so.4()(64bit)
218Requires: libQtGui.so.4()(64bit)
219Requires: libQtNetwork.so.4()(64bit)
220Requires: libQtOpenGL.so.4()(64bit)
221Requires: libQtSql.so.4()(64bit)
222Requires: libQtSvg.so.4()(64bit)
223Requires: libQtXml.so.4()(64bit)
224Requires: libstdc++.so.6()(64bit)
225Requires: libutil.so.1()(64bit)
226Requires: libz.so.1()(64bit)
227%endif
228
229%ifarch s390
230# archLSB S390 Base Libraries
231Requires: libatk-1.0.so.0
232Requires: libc.so.6
233Requires: libcrypt.so.1
234Requires: libdl.so.2
235Requires: libgcc_s.so.1
236Requires: libgdk-x11-2.0.so.0
237Requires: libgdk_pixbuf-2.0.so.0
238Requires: libgdk_pixbuf_xlib-2.0.so.0
239Requires: libglib-2.0.so.0
240Requires: libgmodule-2.0.so.0
241Requires: libgobject-2.0.so.0
242Requires: libgthread-2.0.so.0
243Requires: libgtk-x11-2.0.so.0
244Requires: libm.so.6
245Requires: libncurses.so.5
246Requires: libpango-1.0.so.0
247Requires: libpangoft2-1.0.so.0
248Requires: libpangoxft-1.0.so.0
249Requires: libpthread.so.0
250Requires: libqt-mt.so.3
251Requires: libQtCore.so.4
252Requires: libQtGui.so.4
253Requires: libQtNetwork.so.4
254Requires: libQtOpenGL.so.4
255Requires: libQtSql.so.4
256Requires: libQtSvg.so.4
257Requires: libQtXml.so.4
258Requires: libstdc++.so.6
259Requires: libutil.so.1
260Requires: libz.so.1
261%endif
262
263%ifarch s390x
264# archLSB S390X Base Libraries
265Requires: libatk-1.0.so.0()(64bit)
266Requires: libc.so.6()(64bit)
267Requires: libcrypt.so.1()(64bit)
268Requires: libdl.so.2()(64bit)
269Requires: libgcc_s.so.1()(64bit)
270Requires: libgdk-x11-2.0.so.0()(64bit)
271Requires: libgdk_pixbuf-2.0.so.0()(64bit)
272Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
273Requires: libglib-2.0.so.0()(64bit)
274Requires: libgmodule-2.0.so.0()(64bit)
275Requires: libgobject-2.0.so.0()(64bit)
276Requires: libgthread-2.0.so.0()(64bit)
277Requires: libgtk-x11-2.0.so.0()(64bit)
278Requires: libm.so.6()(64bit)
279Requires: libncurses.so.5()(64bit)
280Requires: libpango-1.0.so.0()(64bit)
281Requires: libpangoft2-1.0.so.0()(64bit)
282Requires: libpangoxft-1.0.so.0()(64bit)
283Requires: libpthread.so.0()(64bit)
284Requires: libqt-mt.so.3()(64bit)
285Requires: libQtCore.so.4()(64bit)
286Requires: libQtGui.so.4()(64bit)
287Requires: libQtNetwork.so.4()(64bit)
288Requires: libQtOpenGL.so.4()(64bit)
289Requires: libQtSql.so.4()(64bit)
290Requires: libQtSvg.so.4()(64bit)
291Requires: libQtXml.so.4()(64bit)
292Requires: libstdc++.so.6()(64bit)
293Requires: libutil.so.1()(64bit)
294Requires: libz.so.1()(64bit)
295%endif
296
297%ifarch x86_64
298# archLSB AMD64 Base Libraries
299Requires: libatk-1.0.so.0()(64bit)
300Requires: libc.so.6()(64bit)
301Requires: libcrypt.so.1()(64bit)
302Requires: libdl.so.2()(64bit)
303Requires: libgcc_s.so.1()(64bit)
304Requires: libgdk-x11-2.0.so.0()(64bit)
305Requires: libgdk_pixbuf-2.0.so.0()(64bit)
306Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
307Requires: libglib-2.0.so.0()(64bit)
308Requires: libgmodule-2.0.so.0()(64bit)
309Requires: libgobject-2.0.so.0()(64bit)
310Requires: libgthread-2.0.so.0()(64bit)
311Requires: libgtk-x11-2.0.so.0()(64bit)
312Requires: libm.so.6()(64bit)
313Requires: libncurses.so.5()(64bit)
314Requires: libpango-1.0.so.0()(64bit)
315Requires: libpangoft2-1.0.so.0()(64bit)
316Requires: libpangoxft-1.0.so.0()(64bit)
317Requires: libpthread.so.0()(64bit)
318Requires: libqt-mt.so.3()(64bit)
319Requires: libQtCore.so.4()(64bit)
320Requires: libQtGui.so.4()(64bit)
321Requires: libQtNetwork.so.4()(64bit)
322Requires: libQtOpenGL.so.4()(64bit)
323Requires: libQtSql.so.4()(64bit)
324Requires: libQtSvg.so.4()(64bit)
325Requires: libQtXml.so.4()(64bit)
326Requires: libstdc++.so.6()(64bit)
327Requires: libutil.so.1()(64bit)
328Requires: libz.so.1()(64bit)
329%endif
330
331# gLSB Base/Utility/Stdc++/Graphics Libraries
332Requires: libasound.so.2%{qual}
333Requires: libatk-1.0.so.0%{qual}
334Requires: libcrypt.so.1%{qual}
335Requires: libcups.so.2%{qual}
336Requires: libcupsimage.so.2%{qual}
337Requires: libdl.so.2%{qual}
338Requires: libfontconfig.so.1%{qual}
339Requires: libfreetype.so.6%{qual}
340Requires: libgcc_s.so.1%{qual}
341Requires: libgdk-x11-2.0.so.0%{qual}
342Requires: libgdk_pixbuf-2.0.so.0%{qual}
343Requires: libgdk_pixbuf_xlib-2.0.so.0%{qual}
344Requires: libGL.so.1%{qual}
345Requires: libglib-2.0.so.0%{qual}
346Requires: libgmodule-2.0.so.0%{qual}
347Requires: libgobject-2.0.so.0%{qual}
348Requires: libgthread-2.0.so.0%{qual}
349Requires: libgtk-x11-2.0.so.0%{qual}
350Requires: libICE.so.6%{qual}
351Requires: libjpeg.so.62%{qual}
352Requires: libncurses.so.5%{qual}
353Requires: libpam.so.0%{qual}
354Requires: libpango-1.0.so.0%{qual}
355Requires: libpangoft2-1.0.so.0%{qual}
356Requires: libpangoxft-1.0.so.0%{qual}
357Requires: libpng12.so.0%{qual}
358Requires: libpthread.so.0%{qual}
359Requires: libqt-mt.so.3%{qual}
360Requires: libQtCore.so.4%{qual}
361Requires: libQtGui.so.4%{qual}
362Requires: libQtNetwork.so.4%{qual}
363Requires: libQtOpenGL.so.4%{qual}
364Requires: libQtSql.so.4%{qual}
365Requires: libQtSvg.so.4%{qual}
366Requires: libQtXml.so.4%{qual}
367Requires: librt.so.1%{qual}
368Requires: libSM.so.6%{qual}
369Requires: libstdc++.so.6%{qual}
370Requires: libutil.so.1%{qual}
371Requires: libX11.so.6%{qual}
372Requires: libXext.so.6%{qual}
373Requires: libXft.so.2%{qual}
374Requires: libXi.so.6%{qual}
375Requires: libxml2.so.2%{qual}
376Requires: libXrender.so.1%{qual}
377Requires: libXt.so.6%{qual}
378Requires: libz.so.1%{qual}
379
380# gLSB Command and Utilities
381Requires: /bin/awk
382Requires: /bin/basename
383Requires: /bin/cat
384Requires: /bin/chgrp
385Requires: /bin/chmod
386Requires: /bin/chown
387Requires: /bin/cp
388Requires: /bin/cpio
389Requires: /bin/cut
390Requires: /bin/date
391Requires: /bin/dd
392Requires: /bin/df
393Requires: /bin/dmesg
394Requires: /bin/echo
395Requires: /bin/ed
396Requires: /bin/egrep
397Requires: /bin/env
398Requires: /bin/false
399Requires: /bin/fgrep
400Requires: /bin/gettext
401Requires: /bin/grep
402Requires: /bin/gunzip
403Requires: /bin/gzip
404Requires: /bin/hostname
405Requires: /bin/kill
406Requires: /bin/ln
407Requires: /bin/ls
408Requires: mailx
409Requires: /bin/mkdir
410Requires: /bin/mknod
411Requires: /bin/mktemp
412Requires: /bin/more
413Requires: /bin/mount
414Requires: /bin/mv
415Requires: /bin/nice
416Requires: /bin/ps
417Requires: /bin/pwd
418Requires: /bin/rm
419Requires: /bin/rmdir
420Requires: /bin/sed
421Requires: /bin/sh
422Requires: /bin/sleep
423Requires: /bin/sort
424Requires: /bin/stty
425Requires: /bin/su
426Requires: /bin/sync
427Requires: /bin/tar
428Requires: /bin/touch
429Requires: /bin/true
430Requires: /bin/umount
431Requires: /bin/uname
432Requires: /bin/zcat
433Requires: /sbin/fuser
434Requires: /sbin/pidof
435Requires: /sbin/shutdown
436Requires: /usr/bin/[
437Requires: /usr/bin/ar
438Requires: /usr/bin/at
439Requires: /usr/bin/batch
440Requires: /usr/bin/bc
441Requires: /usr/bin/chfn
442Requires: /usr/bin/chsh
443Requires: /usr/bin/cksum
444Requires: /usr/bin/cmp
445Requires: /usr/bin/col
446Requires: /usr/bin/comm
447Requires: /usr/bin/crontab
448Requires: /usr/bin/csplit
449Requires: /usr/bin/diff
450Requires: /usr/bin/dirname
451Requires: /usr/bin/du
452Requires: /usr/bin/expand
453Requires: /usr/bin/expr
454Requires: /usr/bin/fc-cache
455Requires: /usr/bin/fc-list
456Requires: /usr/bin/fc-match
457Requires: /usr/bin/file
458Requires: /usr/bin/find
459Requires: /usr/bin/fold
460Requires: /usr/bin/foomatic-rip
461Requires: /usr/bin/gencat
462Requires: /usr/bin/getconf
463Requires: /usr/bin/groups
464Requires: /usr/bin/gs
465Requires: /usr/bin/head
466Requires: /usr/bin/iconv
467Requires: /usr/bin/id
468Requires: /usr/bin/install
469Requires: /usr/bin/ipcrm
470Requires: /usr/bin/ipcs
471Requires: /usr/bin/join
472Requires: /usr/bin/killall
473Requires: /usr/bin/locale
474Requires: /usr/bin/localedef
475Requires: /usr/bin/logger
476Requires: /usr/bin/logname
477Requires: /usr/bin/lp
478Requires: /usr/bin/lpr
479Requires: /usr/bin/m4
480Requires: /usr/bin/make
481Requires: /usr/bin/man
482Requires: /usr/bin/md5sum
483Requires: /usr/bin/mkfifo
484Requires: /usr/bin/msgfmt
485Requires: /usr/bin/newgrp
486Requires: /usr/bin/nl
487Requires: /usr/bin/nohup
488Requires: /usr/bin/od
489Requires: /usr/bin/passwd
490Requires: /usr/bin/paste
491Requires: /usr/bin/patch
492Requires: /usr/bin/pathchk
493# better POSIX compatible
494Requires: spax
495Requires: /usr/bin/perl
496Requires: /usr/bin/pr
497Requires: /usr/bin/printf
498Requires: /usr/bin/python
499Requires: /usr/bin/renice
500Requires: /usr/bin/split
501Requires: /usr/bin/strip
502Requires: /usr/bin/tail
503Requires: /usr/bin/tee
504Requires: /usr/bin/test
505Requires: /usr/bin/time
506Requires: /usr/bin/tr
507Requires: /usr/bin/tsort
508Requires: /usr/bin/tty
509Requires: /usr/bin/unexpand
510Requires: /usr/bin/uniq
511Requires: /usr/bin/wc
512Requires: /usr/bin/xargs
513Requires: /usr/sbin/groupadd
514Requires: /usr/sbin/groupdel
515Requires: /usr/sbin/groupmod
516Requires: /usr/sbin/sendmail
517Requires: /usr/sbin/useradd
518Requires: /usr/sbin/userdel
519Requires: /usr/sbin/usermod
520
521%description
522The Linux Standard Base (LSB) is an attempt to develop a set of
523standards that will increase compatibility among Linux distributions.
524The lsb package provides utilities needed for LSB Compliant
525Applications.  It also contains requirements that will ensure that all
526components required by the LSB that are provided by Red Hat Linux are
527installed on the system.
528
529%prep
530%setup -q -n %{name}-vine-%{version}
531
532%build
533cd lsb-release-%{upstreamlsbrelver}
534make
535
536%install
537rm -rf $RPM_BUILD_ROOT
538# LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
539mkdir -p $RPM_BUILD_ROOT%{_sysconfdir} $RPM_BUILD_ROOT/%{_lib} $RPM_BUILD_ROOT%{_mandir} \
540         $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT/usr/lib/lsb \
541         $RPM_BUILD_ROOT%{_sysconfdir}/lsb-release.d/ $RPM_BUILD_ROOT%{_sbindir}
542make DESTDIR=$RPM_BUILD_ROOT install
543cd lsb-release-%{upstreamlsbrelver}
544make mandir=$RPM_BUILD_ROOT/%{_mandir} prefix=$RPM_BUILD_ROOT/%{_prefix} install
545cd ..
546touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-4.0-%{archname}
547touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-4.0-noarch
548touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-4.0-%{archname}
549touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-4.0-noarch
550touch $RPM_BUILD_ROOT/etc/lsb-release.d/printing-4.0-%{archname}
551touch $RPM_BUILD_ROOT/etc/lsb-release.d/printing-4.0-noarch
552# and claim LSB 3.1/3.2 is supported as well
553touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-%{archname}
554touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-noarch
555touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-%{archname}
556touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-noarch
557touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-%{archname}
558touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-noarch
559touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-%{archname}
560touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-noarch
561
562for LSBVER in %{lsbsover}; do
563  ln -s %{ldso} $RPM_BUILD_ROOT/%{_lib}/%{lsbldso}.$LSBVER
564done
565
566mkdir -p $RPM_BUILD_ROOT/bin
567
568# LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
569# According to the lsb-core documentation provided by
570# http://refspecs.linux-foundation.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic.pdf
571# it's OK to put non binary in /usr/lib.
572ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/install_initd
573ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/remove_initd
574ln -snf mail $RPM_BUILD_ROOT/bin/mailx
575
576gcc $RPM_OPT_FLAGS -Os -static -o lsb_vine_trigger{.%{_target_cpu},.c} -DLSBSOVER='"%{lsbsover}"' \
577  -DLDSO='"%{ldso}"' -DLSBLDSO='"/%{_lib}/%{lsbldso}"' -D_GNU_SOURCE
578install -m 700 lsb_vine_trigger.%{_target_cpu} \
579  $RPM_BUILD_ROOT%{_sbindir}/lsb_vine_trigger.%{_target_cpu}
580
581cp -p lsb_vine_init $RPM_BUILD_ROOT/bin/lsb_vine_init
582
583%clean
584rm -rf $RPM_BUILD_ROOT
585
586%triggerpostun -- glibc
587if [ -x /usr/sbin/lsb_vine_trigger.%{_target_cpu} ]; then
588  /usr/sbin/lsb_vine_trigger.%{_target_cpu}
589fi
590
591%ifnarch %{ix86}
592  /sbin/sln %{ldso} /%{_lib}/%{lsbldso} || :
593%else
594  if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
595    for LSBVER in %{lsbsover}; do
596      /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
597    done
598  else
599    for LSBVER in %{lsbsover}; do
600      /sbin/sln %{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
601    done
602  fi
603%endif
604
605%ifarch %{ix86}
606%post
607# make this softlink again for /emul
608  if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
609    for LSBVER in %{lsbsover}; do
610      /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
611    done
612  fi
613%endif
614
615%files
616%defattr(-,root,root)
617%{_sysconfdir}/lsb-vine
618%dir %{_sysconfdir}/lsb-release.d
619%{_sysconfdir}/lsb-release.d/*
620%{_mandir}/*/*
621%{_bindir}/*
622/bin/lsb_vine_init
623/usr/lib/lsb
624/%{_lib}/*so*
625/lib/lsb*
626%{_sbindir}/lsb_vine_trigger.%{_target_cpu}
627/bin/mailx
628
629%changelog
630* Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.0-2
631- require spax instead of pax (more POSIX compatible)
632
633* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-1
634- update to LSB4.0
635- add Provide lsb-printing{,-noarch}
636- add BR: glibc-static
637
638* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-1
639- initial build for Vine Linux
640
641* Thu Aug 28 2008 Hao Liu <hliu@redhat.com> 3.2-2
642- Modify "Requires: /usr/bin/mailx" to "Requires: mailx" (Bug #460249)
643
644* Mon Aug 18 2008 Hao Liu <hliu@redhat.com> 3.2-1
645- Port forward to LSB 3.2
646- Remove symlink for mailx if user is upgrading from the redhat-lsb of older version
647- Since F10 put mailx under /usr/bin, change the corresponding requires
648
649* Tue Aug 5 2008 Hao Liu <hliu@redhat.com> - 3.1-22
650- Remove 2 requires which provided by redhat-lsb
651- Add comments explaining why hard-coded path is kept
652- Resolve some hard-coded path problems
653- Add comments explaining why importing '-static' option while compiling redhat_lsb_trigger
654- Replace %{_libdir}/lsb with /usr/lib/lsb
655- Replace /%{_lib}/* with /%{_lib}/*so*
656- Replace /lib/lsb with /lib/lsb*
657
658* Thu Jul 31 2008 Lawrence Lim <llim@redhat.com> - 3.1-21
659- remove symlink for mailx (Bug #457241)
660
661* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.1-20
662- Autorebuild for GCC 4.3
663
664* Wed Oct 3 2007 Lawrence Lim <llim@redhat.com> - 3.1-19
665- fix build issue on ppc - (.opd+0x10): multiple definition of `__libc_start_main'
666
667* Fri Sep 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-18
668- fix build issue in minimal build root (Bug #265241)
669
670* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 3.1-17
671- Rebuild for selinux ppc32 issue.
672
673* Mon Aug 20 2007 Lawrence Lim <llim@redhat.com> - 3.1-16
674- update spec file in accordance to feedback provided through merge review - merge-review.patch - #226363
675
676* Wed Jul 18 2007 Lawrence Lim <llim@redhat.com> - 3.1-15.f8
677- Resolved: #239842 - /lib/lsb/init-functions shall use aliases but not functions
678- forward port the patch from 3.1-12.3.EL which fix #217566, #233530, #240916
679
680* Wed May 2 2007 Lawrence Lim <llim@redhat.com> - 3.1-14.fc7
681- fixed Bug 232918 for new glibc version
682
683* Wed Feb 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-13
684- fixed Bug 226363
685
686* Wed Nov 29 2006 Lawrence Lim <llim@redhat.com> - 3.1-12
687- replaced aliases with functions in /lib/lsb/init-functions; Bug 217566
688
689* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 3.1-11
690- rebuilt for unwind info generation, broken in gcc-4.1.1-21
691
692* Thu Sep 21 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.3
693- Fix upgrade issue; Bug 202548
694
695* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1-10.2.1
696- rebuild
697
698* Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.2
699- for some strange reason, ld-lsb-x86-64.so need to be ld-lsb-x86-64.so.3 (LSB3.0) rather than ld-lsb-x86-64.so.3.1 (LSB3.1)
700
701* Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.1
702- generate spec file on RHEL5-Alpha system
703- fix vsw4 test suite setup by creating symlink for X11 SecurityPolicy and XFontPath
704
705* Thu Jun 22 2006 Lawrence Lim <llim@redhat.com> - 3.0-10
706- Rewrite most part of the mkredhat-lsb to obtain information directly via specdb
707  rather than sniffing through sgml
708- remove redundent script and bump up tarball version
709
710* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.2
711- bump again for double-long bug on ppc(64)
712
713* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.1
714- rebuilt for new gcc4.1 snapshot and glibc changes
715
716* Fri Jan 13 2006 Leon Ho <llch@redhat.com> 3.0-9
717- Migrated back to rawhide
718
719* Wed Aug  3 2005 Leon Ho <llch@redhat.com> 3.0-8.EL
720- Added libstdc++.so.6/libGL.so.1 requirement (RH#154605)
721
722* Wed Aug  3 2005 Leon Ho <llch@redhat.com> 3.0-7.EL
723- Fixed multilib problem on lsb_release not to read /etc/lsb-release and solely
724  depends on /etc/lsb-release.d/ (Advised by LSB committee)
725- Removed /etc/lsb-release (Advised by LSB committee)
726
727* Mon Aug  1 2005 Leon Ho <llch@redhat.com> 3.0-6.EL
728- Made the /etc/lsb-release useful (RH#154605)
729- Added redhat_lsb_trigger to fix RH#160585 (Jakub Jelinek)
730- Fixed AMD64 base libraries requirement parsing (RH#154605)
731
732* Tue Jul 26 2005 Leon Ho <llch@redhat.com> 3.0-5.EL
733- Fixed redhat-lsb's mkredhat-lsb on fetching lib and
734  cmd requirements
735
736* Mon Jul 18 2005 Leon Ho <llch@redhat.com> 3.0-4.EL
737- Rebuilt
738
739* Tue Jul 05 2005 Leon Ho <llch@redhat.com> 3.0-3.EL
740- Disabled support for LSB 1.3 and 2.0
741
742* Mon Jun 20 2005 Leon Ho <llch@redhat.com> 3.0-2.EL
743- Upgraded to lsb-release 2.0
744
745* Thu Jun 09 2005 Leon Ho <llch@redhat.com> 3.0-1.EL
746- Moved to LSB 3.0
747
748* Wed Apr 13 2005 Leon Ho <llch@redhat.com> 1.3-10
749- Fixed ix86 package with ia32 emul support
750
751* Tue Feb 01 2005 Leon Ho <llch@redhat.com> 1.3-9
752- Sync what we have changed on the branches
753  Wed Nov 24 2004 Harald Hoyer <harald@redhat.com>
754  - added post section to recreate the softlink in emul mode (bug 140739)
755  Mon Nov 15 2004 Phil Knirsch <pknirsch@redhat.com>
756  Tiny correction of bug in new triggers
757
758* Mon Jan 24 2005 Leon Ho <llch@redhat.com> 1.3-8
759- Add support provide on lsb-core-* for each arch
760
761* Fri Jan 21 2005 Leon Ho <llch@redhat.com> 1.3-7
762- Add to support multiple LSB test suite version
763- Add %%endif in trigger postun
764
765* Thu Nov 11 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-6
766- Fixed invalid sln call for trigger in postun on ia64 (#137647)
767
768* Mon Aug 09 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-4
769- Bump release and rebuilt for RHEL4.
770
771* Thu Jul 24 2003 Matt Wilson <msw@redhat.com> 1.3-3
772- fix lsb ld.so name for ia64 (#100613)
773
774* Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
775- use /usr/lib/lsb for install_initd, remove_initd
776
777* Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
778- add ia64 x86_64 ppc ppc64 s390 s390x
779
780* Tue Feb 18 2003 Matt Wilson <msw@redhat.com> 1.3-1
781- 1.3
782
783* Wed Sep  4 2002 Matt Wilson <msw@redhat.com>
784- 1.2.0
785
786* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
787- automated rebuild
788
789* Thu May 23 2002 Tim Powers <timp@redhat.com>
790- automated rebuild
791
792* Wed Mar 27 2002 Matt Wilson <msw@redhat.com>
793- addeed trigger on glibc to re-establish the ld-lsb.so.1 symlink in the
794  forced downgrade case.
795
796* Tue Mar 12 2002 Bill Nottingham <notting@redhat.com>
797- add initscripts support
798
799* Thu Jan 24 2002 Matt Wilson <msw@redhat.com>
800- Initial build.
801
Note: See TracBrowser for help on using the repository browser.