source: projects/specs/trunk/l/loudmouth/loudmouth-vl.spec @ 521

Revision 521, 7.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define with_ssl   1
2%define gnutls_ver 1.4.0
3
4Summary:        Loudmouth is a Jabber programming library written in C
5
6Name:           loudmouth
7Version:        1.4.3
8Release: 1%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.loudmouth-project.org/
13Source0:        http://ftp.imendio.com/pub/imendio/%{name}/src/%{name}-%{version}.tar.bz2
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  glib2-devel >= 2.4.0
18BuildRequires:  check-devel
19BuildRequires:  libidn-devel
20BuildRequires:  libasyncns-devel
21%if %{with_ssl}
22BuildRequires:  gnutls-devel >= %{gnutls_ver}
23%endif
24
25
26%description
27Loudmouth is a lightweight and easy-to-use C library for programming
28with the Jabber protocol. It's designed to be easy to get started with
29and yet extensible to let you do anything the Jabber protocol allows.
30
31
32%package devel
33Summary:        Development files for %{name}
34Summary(ja):    Development files for %{name}
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37Requires:       glib2-devel
38Requires:       libidn-devel
39Requires:       pkgconfig
40%if %{with_ssl}
41Requires:       gnutls-devel
42%endif
43
44
45%description devel
46The %{name}-devel package contains libraries and header files for
47developing applications that use %{name}.
48
49
50%prep
51%setup -q
52
53
54%build
55%configure --enable-static=no   \
56           --with-asyncns=yes   \
57%if %{with_ssl}
58           --with-ssl=gnutls
59%else
60           --with-ssl=no
61%endif
62
63make %{?_smp_mflags}
64
65
66%install
67rm -rf $RPM_BUILD_ROOT
68make install DESTDIR=$RPM_BUILD_ROOT
69find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
70
71# Copy the files from the tarball to avoid the IDs generated by gtk-doc being
72# different on different builds
73mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/%{name}/
74cp -a docs/reference/html/* $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/%{name}/
75
76
77%check
78make check
79
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84
85%post -p /sbin/ldconfig
86
87
88%postun -p /sbin/ldconfig
89
90
91%files
92%defattr(-,root,root,-)
93%doc ChangeLog NEWS README COPYING
94%{_libdir}/libloudmouth*.so.*
95
96
97%files devel
98%defattr(-,root,root,-)
99%{_libdir}/libloudmouth*.so
100%{_libdir}/pkgconfig/%{name}-1.0.pc
101%{_includedir}/%{name}-1.0
102%{_datadir}/gtk-doc/html/%{name}
103
104
105%changelog
106* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.3-1
107- Update to 1.4.3
108- build with new gnutls
109
110* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
111- initial build for Vine Linux
112
113* Thu Aug 28 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.2-1
114- Update to 1.4.2.
115- Enable libasyncns support.
116
117* Sat Aug  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.1-1
118- Update to 1.4.1.
119
120* Wed Jun 25 2008 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
121- rebuild with new gnutls
122
123* Tue Jun 10 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.0-1
124- Update to 1.4.0.
125
126* Wed Apr  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.3.4-1
127- Update to 1.3.4.
128- Run check test.
129- Bump min version needed for gnutls-devel.
130- Drop stream-error.patch. Fixed upstream.
131- Drop eai-nodata.patch. Fixed upstream.
132- Drop connect-fail-sync.patch. Fixed upstream.
133- Drop connect-fail-async patch. Fixed upstream.
134- Update URL & Source URL.
135- Don't generate the gtk-doc docs, and use the ones in the tarball
136  to avoid having different files in different builds, fixes
137  multilib problems (#342551)
138
139* Thu Feb 21 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-4
140- Fix build with recent GNU libc
141
142* Thu Feb  7 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-3
143- Add patches fixing reentrancy problems on connection failure
144
145* Wed Jan 30 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-2
146- Add back stream-error patch, it wasn't fixed in the 1.3 branch
147
148* Fri Jan 18 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.3.3-1
149- Update to 1.3.3.
150- Drop reconnect-failure patch.
151- Drop gnutls compression patch. fixed upstream.
152
153* Thu Nov 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-6
154- Ugh.  Let's acutally use a valid e-mail addy.
155
156* Thu Nov 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-5
157- Add patch to use gnutls compression.
158
159* Mon Nov 12 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-4
160- Add reconnect-failure patch. Thanks to Robert McQueen.
161
162* Tue Aug 21 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-3
163- Rebuild.
164
165* Sun Aug  5 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-2
166- Update license tag.
167
168* Sun Jun 10 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-1
169- Update to 1.2.3.
170- Drop stream-error patch. fixed upstream.
171
172* Wed May 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-3
173- Add patch to fix stream error.
174
175* Tue May 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-2
176- Drop BR on libtasn1-devel.
177
178* Mon May 14 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-1
179- Update to 1.2.2.
180
181* Sat Feb 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-2
182- Fix typo.
183
184* Sat Feb 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-1
185- Update to 1.2.1.
186
187* Tue Feb 20 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-3
188- Add necessary requires to devel package. D'Oh!
189
190* Tue Feb 20 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-2
191- Add BR on libidn-devel.
192- Specify which ssl implementation to use.
193
194* Mon Feb  5 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-1
195- Update to 1.2.0.
196- Drop mono config option since it's been dropped from the tarball.
197
198* Mon Sep 11 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.5-2
199- Change source to .gz.
200
201* Mon Sep 11 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.5-1
202- Update to 1.0.5.
203
204* Tue Aug 29 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.4-3
205- Rebuild for FC6.
206- Simplify devel description.
207
208* Thu Jun 29 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.4-2
209- Update to 1.0.4.
210- Add devel requires on pkgconfig.
211- Drop reentrancy patch, fixed upstream.
212
213* Thu Jun 15 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-5
214- rebuild for new gnutls
215
216* Fri May 26 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.3-4
217- Add patch to fix some reentrancy crashes.  (Thanks, Havoc)
218
219* Wed Apr  5 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.3-3
220- Update to 1.0.3.
221- Add BR for gnutls-devel to devel package.
222- Disable static libs.
223- Add BR for check-devel.
224
225* Thu Feb 16 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-6
226- Remove unnecessary BR (libgcrypt-devel).
227
228* Mon Feb 13 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-5
229- rebuilt for new gcc4.1 snapshot and glibc changes
230
231* Mon Dec 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-4
232- Rebuild.
233
234* Wed Aug 31 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-3
235- Update to 1.0.1.
236
237* Sun Aug 14 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0-2
238- Update to 1.0.
239
240* Mon Aug  8 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-5
241- Rebuild due to new gnutls.
242
243* Sat Jul 30 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-4
244- Fix description.
245
246* Fri May 13 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-2
247- Add dist tag.
248
249* Fri May 13 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-1
250- Update to 0.9.
251
252* Thu May  5 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-3
253- Adde glib2-devel requires.
254
255* Thu May  5 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-2
256- added %%{_includedir}.
257- Add libgcrypt-devel BR.
258
259* Sun May  1 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-1
260- Initial Fedora build.
261
Note: See TracBrowser for help on using the repository browser.