source: projects/specs/trunk/l/loudmouth/loudmouth-vl.spec @ 9276

Revision 9276, 8.4 KB checked in by inagaki, 9 years ago (diff)

2015-01-17 Ryoichi INAGAKI <ryo1@…>

  • enscript, libksba: updated
  • loudmouth: rebuilt


Line 
1%define with_ssl   1
2%define gnutls_ver 1.4.0
3
4Summary:        Loudmouth is a Jabber programming library written in C
5Summary(ja):    C言語で書かれた Jabber プロトコルライブラリ
6
7Name:           loudmouth
8Version:        1.4.3
9Release:        3%{?_dist_release}
10
11Group:          System Environment/Libraries
12License:        LGPLv2+
13URL:            http://www.loudmouth-project.org/
14Source0:        http://ftp.imendio.com/pub/imendio/%{name}/src/%{name}-%{version}.tar.bz2
15Patch0:         %{name}-1.4.3-certs_location.patch
16Patch1:         %{name}-1.4.3-async_assertion.patch
17Patch2:         %{name}-1.4.3-fix-sasl-md5-digest-uri.patch
18Patch3:         0001-Drop-stanzas-when-failing-to-convert-them-to-LmMessa.patch
19Patch4:         %{name}-1.4.3-glib-compile-fix.patch
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
22
23BuildRequires:  glib2-devel >= 2.4.0
24BuildRequires:  check-devel
25BuildRequires:  libidn-devel
26BuildRequires:  libasyncns-devel
27%if %{with_ssl}
28BuildRequires:  gnutls-devel >= %{gnutls_ver}
29%endif
30
31
32%description
33Loudmouth is a lightweight and easy-to-use C library for programming
34with the Jabber protocol. It's designed to be easy to get started with
35and yet extensible to let you do anything the Jabber protocol allows.
36
37
38%package devel
39Summary:        Development files for %{name}
40Summary(ja):    %{name} の開発用ファイル
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43Requires:       glib2-devel
44Requires:       libidn-devel
45Requires:       pkgconfig
46%if %{with_ssl}
47Requires:       gnutls-devel
48%endif
49
50
51%description devel
52The %{name}-devel package contains libraries and header files for
53developing applications that use %{name}.
54
55
56%prep
57%setup -q
58%patch0 -p1 -b .certs
59%patch1 -p1 -b .async
60%patch2 -p1 -b .uri
61%patch3 -p1 -b .stanza
62%patch4 -p1 -b .glibincl
63
64
65%build
66%configure --enable-static=no   \
67           --with-asyncns=yes   \
68%if %{with_ssl}
69           --with-ssl=gnutls
70%else
71           --with-ssl=no
72%endif
73
74make %{?_smp_mflags}
75
76
77%install
78rm -rf $RPM_BUILD_ROOT
79make install DESTDIR=$RPM_BUILD_ROOT
80find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
81
82# Copy the files from the tarball to avoid the IDs generated by gtk-doc being
83# different on different builds
84mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/%{name}/
85cp -a docs/reference/html/* $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/%{name}/
86
87
88%check
89make check
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95
96%postun -p /sbin/ldconfig
97
98%files
99%defattr(-,root,root,-)
100%doc ChangeLog NEWS README COPYING
101%{_libdir}/libloudmouth*.so.*
102
103%files devel
104%defattr(-,root,root,-)
105%{_libdir}/libloudmouth*.so
106%{_libdir}/pkgconfig/%{name}-1.0.pc
107%{_includedir}/%{name}-1.0
108%{_datadir}/gtk-doc/html/%{name}
109
110
111%changelog
112* Sat Jan 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.3-3
113- added Patch0, 1, 2, 3 and 4 from Fedora
114  * Wed Mar  7 2012 Daniel Drake <dsd@laptop.org> - 1.4.3-10
115  - Fix compile against new glib
116  * Sun Nov 15 2009 Brian Pepple <bpepple@fedoraproject.org> - 1.4.3-7
117  - Add patch to fix parser that stops on certain stanzas. (#509341)
118  * Fri Jun 12 2009 Brian Pepple <bpepple@fedoraproject.org> - 1.4.3-5
119  - Add patch to fix digest uri bug. (#503901)
120  * Fri Nov 28 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.3-3
121  - Add patch to search correct location for ssl certs. (#473458)
122  - Add patch to fix async assertion. (#473436)
123- built with gnutls 3.2.20
124
125* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.4.3-2
126- rebuilt with rpm-4.8.1 for pkg-config
127
128* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.3-1
129- Update to 1.4.3
130- build with new gnutls
131
132* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
133- initial build for Vine Linux
134
135* Thu Aug 28 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.2-1
136- Update to 1.4.2.
137- Enable libasyncns support.
138
139* Sat Aug  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.1-1
140- Update to 1.4.1.
141
142* Wed Jun 25 2008 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
143- rebuild with new gnutls
144
145* Tue Jun 10 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.0-1
146- Update to 1.4.0.
147
148* Wed Apr  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.3.4-1
149- Update to 1.3.4.
150- Run check test.
151- Bump min version needed for gnutls-devel.
152- Drop stream-error.patch. Fixed upstream.
153- Drop eai-nodata.patch. Fixed upstream.
154- Drop connect-fail-sync.patch. Fixed upstream.
155- Drop connect-fail-async patch. Fixed upstream.
156- Update URL & Source URL.
157- Don't generate the gtk-doc docs, and use the ones in the tarball
158  to avoid having different files in different builds, fixes
159  multilib problems (#342551)
160
161* Thu Feb 21 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-4
162- Fix build with recent GNU libc
163
164* Thu Feb  7 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-3
165- Add patches fixing reentrancy problems on connection failure
166
167* Wed Jan 30 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-2
168- Add back stream-error patch, it wasn't fixed in the 1.3 branch
169
170* Fri Jan 18 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.3.3-1
171- Update to 1.3.3.
172- Drop reconnect-failure patch.
173- Drop gnutls compression patch. fixed upstream.
174
175* Thu Nov 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-6
176- Ugh.  Let's acutally use a valid e-mail addy.
177
178* Thu Nov 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-5
179- Add patch to use gnutls compression.
180
181* Mon Nov 12 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-4
182- Add reconnect-failure patch. Thanks to Robert McQueen.
183
184* Tue Aug 21 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-3
185- Rebuild.
186
187* Sun Aug  5 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-2
188- Update license tag.
189
190* Sun Jun 10 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-1
191- Update to 1.2.3.
192- Drop stream-error patch. fixed upstream.
193
194* Wed May 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-3
195- Add patch to fix stream error.
196
197* Tue May 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-2
198- Drop BR on libtasn1-devel.
199
200* Mon May 14 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-1
201- Update to 1.2.2.
202
203* Sat Feb 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-2
204- Fix typo.
205
206* Sat Feb 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-1
207- Update to 1.2.1.
208
209* Tue Feb 20 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-3
210- Add necessary requires to devel package. D'Oh!
211
212* Tue Feb 20 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-2
213- Add BR on libidn-devel.
214- Specify which ssl implementation to use.
215
216* Mon Feb  5 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-1
217- Update to 1.2.0.
218- Drop mono config option since it's been dropped from the tarball.
219
220* Mon Sep 11 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.5-2
221- Change source to .gz.
222
223* Mon Sep 11 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.5-1
224- Update to 1.0.5.
225
226* Tue Aug 29 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.4-3
227- Rebuild for FC6.
228- Simplify devel description.
229
230* Thu Jun 29 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.4-2
231- Update to 1.0.4.
232- Add devel requires on pkgconfig.
233- Drop reentrancy patch, fixed upstream.
234
235* Thu Jun 15 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-5
236- rebuild for new gnutls
237
238* Fri May 26 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.3-4
239- Add patch to fix some reentrancy crashes.  (Thanks, Havoc)
240
241* Wed Apr  5 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.3-3
242- Update to 1.0.3.
243- Add BR for gnutls-devel to devel package.
244- Disable static libs.
245- Add BR for check-devel.
246
247* Thu Feb 16 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-6
248- Remove unnecessary BR (libgcrypt-devel).
249
250* Mon Feb 13 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-5
251- rebuilt for new gcc4.1 snapshot and glibc changes
252
253* Mon Dec 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-4
254- Rebuild.
255
256* Wed Aug 31 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-3
257- Update to 1.0.1.
258
259* Sun Aug 14 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0-2
260- Update to 1.0.
261
262* Mon Aug  8 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-5
263- Rebuild due to new gnutls.
264
265* Sat Jul 30 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-4
266- Fix description.
267
268* Fri May 13 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-2
269- Add dist tag.
270
271* Fri May 13 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-1
272- Update to 0.9.
273
274* Thu May  5 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-3
275- Adde glib2-devel requires.
276
277* Thu May  5 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-2
278- added %%{_includedir}.
279- Add libgcrypt-devel BR.
280
281* Sun May  1 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-1
282- Initial Fedora build.
283
Note: See TracBrowser for help on using the repository browser.