source: projects/specs/trunk/l/lm-sensors/lm-sensors-vl.spec @ 9796

Revision 9796, 4.7 KB checked in by daisuke, 8 years ago (diff)

lm-sensors: update to 3.4.0

Line 
1Summary: Hardware monitoring tools
2Summary(ja): ハードウェア監視ツール集
3Name: lm-sensors
4Version: 3.4.0
5Release: 1%{?_dist_release}
6
7Group: Applications/System
8License: LGPLv2+ and GPLv3+ and GPLv2+ and Verbatim and Public Domain
9URL: http://www.lm-sensors.org/
10
11Source0: http://dl.lm-sensors.org/lm-sensors/releases/lm_sensors-%{version}.tar.bz2
12Source1: lm_sensors.sysconfig
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: bison
16BuildRequires: flex
17BuildRequires: gawk
18BuildRequires: kernel-headers >= 2.2.16
19%if "%{_dist_release}" >= "vl7"
20BuildRequires: libsysfs-devel
21%else
22BuildRequires: sysfsutils-devel
23%endif
24BuildRequires: rrdtool-devel
25
26Requires: perl
27Requires: initscripts
28Requires(post): /sbin/chkconfig
29Requires(preun): /sbin/chkconfig
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: shaolin, owa
34
35%description
36The lm-sensors package includes a collection of modules for general SMBus
37access and hardware monitoring.
38
39%package libs
40Summary: Lm_sensors core libraries
41Summary(ja): Lm_sensors コアライブラリ
42Group: System Environment/Libraries
43
44%description libs
45Core libraries for lm_sensors applications
46
47
48%package devel
49Summary: Development files for programs which will use lm_sensors
50Summary(ja): lm_sensors を使用するプログラムのための開発用ファイル
51Group: Development/Libraries
52Requires: %{name}-libs = %{version}-%{release}
53
54%description devel
55The %{name}-devel package includes a header files and libraries for use
56when building applications that make use of sensor data.
57
58
59%package sensord
60Summary: Daemon that periodically logs sensor readings
61Summary(ja): センサーの読み取り値を定期的に記録するデーモン
62Group: System Environment/Daemons
63Requires: %{name} = %{version}-%{release}
64
65%description sensord
66Daemon that periodically logs sensor readings to syslog or a round-robin
67database, and warns of sensor alarms.
68
69%prep
70%setup -q -n lm_sensors-%{version}
71
72%build
73export CFLAGS="%{optflags}"
74make PREFIX=%{_prefix} LIBDIR=%{_libdir} MANDIR=%{_mandir} EXLDFLAGS=  user
75
76%install
77rm -rf $RPM_BUILD_ROOT
78make user_install \
79     DESTDIR=$RPM_BUILD_ROOT \
80     PREFIX=%{_prefix} \
81     LIBDIR=%{_libdir} \
82     ETCDIR=%{_sysconfdir} \
83     MANDIR=%{_mandir}
84
85ln -s sensors.conf.5.gz $RPM_BUILD_ROOT%{_mandir}/man5/sensors3.conf.5.gz
86
87# add initscript from proc/init
88mkdir -p $RPM_BUILD_ROOT%{_initdir}
89mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sensors.d
90mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
91install -m755 prog/init/lm_sensors.init $RPM_BUILD_ROOT%{_initdir}/lm_sensors
92install -pm 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/lm_sensors
93
94# remove unuse files
95rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post
101if [ "$1" = 1 ] ; then
102        /sbin/chkconfig --add lm_sensors
103fi
104%{_initdir}/lm_sensors condrestart
105
106%preun
107if [ "$1" = 0 ] ; then
108        %{_initdir}/lm_sensors stop > /dev/null 2>&1
109    /sbin/chkconfig --del lm_sensors
110fi
111
112%post libs -p /sbin/ldconfig
113
114%postun libs -p /sbin/ldconfig
115
116
117%files
118%defattr(-,root,root,-)
119%doc CHANGES CONTRIBUTORS COPYING INSTALL README doc
120%dir %{_sysconfdir}/sensors.d
121%config(noreplace) %{_sysconfdir}/sensors3.conf
122%config(noreplace) %{_sysconfdir}/sysconfig/lm_sensors
123%config %{_initdir}/lm_sensors
124%{_bindir}/sensors
125%{_bindir}/sensors-conf-convert
126%{_sbindir}/fancontrol
127%ifarch %{ix86} x86_64
128%{_sbindir}/isadump
129%{_sbindir}/isaset
130%endif
131%{_sbindir}/pwmconfig
132%{_sbindir}/sensors-detect
133%{_mandir}/man1/*
134%{_mandir}/man5/*
135%{_mandir}/man8/*
136
137%files libs
138%{_libdir}/lib*.so.*
139
140%files devel
141%{_includedir}/sensors
142%{_libdir}/lib*.so
143%{_mandir}/man3/*
144
145
146%changelog
147* Sat Nov  7 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 3.4.0-1
148- update to 3.4.0
149
150* Mon Jan  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.3.5-1
151- updated to 3.3.5
152- built on current VineSeed
153- split libraries to libs subpackage
154
155* Tue Apr 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.0-1
156- new upstrem release 3.3.0
157
158* Tue Dec 14 2010 Shu KONNO <owa@bg.wakwak.com> 3.2.0-1
159- updated lm-sensors to 3.2.0
160- added RQ: initscripts
161
162* Tue Mar 16 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1
163- updated lm-sensors to 3.1.2
164
165* Tue Oct 20 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.1.1-2
166- isadump/isaset only available on ix86/x86_64 archs
167
168* Mon Aug 31 2009 Shu KONNO <owa@bg.wakwak.com> 3.1.1-1
169- updated lm-sensors to 3.1.1
170- added japanese summary, spec in utf-8
171- added %{_initdir}/lm_sensors to %%files
172- added %%post, %%preun, %%postun scripts
173
174* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.10.7-1vl5
175- new upstream release
176- applied new versioning policy
177
178* Sun Nov 25 2007 Shu KONNO <owa@bg.wakwak.com> - 2.10.3-0vl2
179- fixed libdir in Makefile (for support lib64)
180
181* Thu May 29 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.10.3-0vl1
182- Initial build.
183
Note: See TracBrowser for help on using the repository browser.