source: projects/specs/trunk/l/lm-sensors/lm-sensors-vl.spec @ 9229

Revision 9229, 4.6 KB checked in by inagaki, 9 years ago (diff)

2015-01-05 Ryoichi INAGAKI <ryo1@…>

  • chmlib: rebuilt
  • cpio: added patch from Vine Linux 6
  • lm-sensors, rrdtool: updated


Line 
1Summary: Hardware monitoring tools
2Summary(ja): ハードウェア監視ツール集
3Name: lm-sensors
4Version: 3.3.5
5Release: 1%{?_dist_release}
6
7Group: Applications/System
8License: LGPLv2+ and GPLv3+ and GPLv2+ and Verbatim and Public Domain
9URL: http://www.lm-sensors.org/
10
11Source0: http://dl.lm-sensors.org/lm-sensors/releases/lm_sensors-%{version}.tar.bz2
12Source1: lm_sensors.sysconfig
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: bison
16BuildRequires: flex
17BuildRequires: gawk
18BuildRequires: kernel-headers >= 2.2.16
19BuildRequires: libsysfs-devel
20BuildRequires: rrdtool-devel
21
22Requires: perl
23Requires: initscripts
24Requires(post): /sbin/chkconfig
25Requires(preun): /sbin/chkconfig
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: shaolin, owa
30
31%description
32The lm-sensors package includes a collection of modules for general SMBus
33access and hardware monitoring.
34
35%package libs
36Summary: Lm_sensors core libraries
37Summary(ja): Lm_sensors コアライブラリ
38Group: System Environment/Libraries
39
40%description libs
41Core libraries for lm_sensors applications
42
43
44%package devel
45Summary: Development files for programs which will use lm_sensors
46Summary(ja): lm_sensors を使用するプログラムのための開発用ファイル
47Group: Development/Libraries
48Requires: %{name}-libs = %{version}-%{release}
49
50%description devel
51The %{name}-devel package includes a header files and libraries for use
52when building applications that make use of sensor data.
53
54
55%package sensord
56Summary: Daemon that periodically logs sensor readings
57Summary(ja): センサーの読み取り値を定期的に記録するデーモン
58Group: System Environment/Daemons
59Requires: %{name} = %{version}-%{release}
60
61%description sensord
62Daemon that periodically logs sensor readings to syslog or a round-robin
63database, and warns of sensor alarms.
64
65%prep
66%setup -q -n lm_sensors-%{version}
67
68%build
69export CFLAGS="%{optflags}"
70make PREFIX=%{_prefix} LIBDIR=%{_libdir} MANDIR=%{_mandir} EXLDFLAGS=  user
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make user_install \
75     DESTDIR=$RPM_BUILD_ROOT \
76     PREFIX=%{_prefix} \
77     LIBDIR=%{_libdir} \
78     ETCDIR=%{_sysconfdir} \
79     MANDIR=%{_mandir}
80
81ln -s sensors.conf.5.gz $RPM_BUILD_ROOT%{_mandir}/man5/sensors3.conf.5.gz
82
83# add initscript from proc/init
84mkdir -p $RPM_BUILD_ROOT%{_initdir}
85mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sensors.d
86mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
87install -m755 prog/init/lm_sensors.init $RPM_BUILD_ROOT%{_initdir}/lm_sensors
88install -pm 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/lm_sensors
89
90# remove unuse files
91rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%post
97if [ "$1" = 1 ] ; then
98        /sbin/chkconfig --add lm_sensors
99fi
100%{_initdir}/lm_sensors condrestart
101
102%preun
103if [ "$1" = 0 ] ; then
104        %{_initdir}/lm_sensors stop > /dev/null 2>&1
105    /sbin/chkconfig --del lm_sensors
106fi
107
108%post libs -p /sbin/ldconfig
109
110%postun libs -p /sbin/ldconfig
111
112
113%files
114%defattr(-,root,root,-)
115%doc CHANGES CONTRIBUTORS COPYING INSTALL README doc
116%dir %{_sysconfdir}/sensors.d
117%config(noreplace) %{_sysconfdir}/sensors3.conf
118%config(noreplace) %{_sysconfdir}/sysconfig/lm_sensors
119%config %{_initdir}/lm_sensors
120%{_bindir}/sensors
121%{_bindir}/sensors-conf-convert
122%{_sbindir}/fancontrol
123%ifarch %{ix86} x86_64
124%{_sbindir}/isadump
125%{_sbindir}/isaset
126%endif
127%{_sbindir}/pwmconfig
128%{_sbindir}/sensors-detect
129%{_mandir}/man1/*
130%{_mandir}/man5/*
131%{_mandir}/man8/*
132
133%files libs
134%{_libdir}/lib*.so.*
135
136%files devel
137%{_includedir}/sensors
138%{_libdir}/lib*.so
139%{_mandir}/man3/*
140
141
142%changelog
143* Mon Jan  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.3.5-1
144- updated to 3.3.5
145- built on current VineSeed
146- split libraries to libs subpackage
147
148* Tue Apr 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.0-1
149- new upstrem release 3.3.0
150
151* Tue Dec 14 2010 Shu KONNO <owa@bg.wakwak.com> 3.2.0-1
152- updated lm-sensors to 3.2.0
153- added RQ: initscripts
154
155* Tue Mar 16 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1
156- updated lm-sensors to 3.1.2
157
158* Tue Oct 20 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.1.1-2
159- isadump/isaset only available on ix86/x86_64 archs
160
161* Mon Aug 31 2009 Shu KONNO <owa@bg.wakwak.com> 3.1.1-1
162- updated lm-sensors to 3.1.1
163- added japanese summary, spec in utf-8
164- added %{_initdir}/lm_sensors to %%files
165- added %%post, %%preun, %%postun scripts
166
167* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.10.7-1vl5
168- new upstream release
169- applied new versioning policy
170
171* Sun Nov 25 2007 Shu KONNO <owa@bg.wakwak.com> - 2.10.3-0vl2
172- fixed libdir in Makefile (for support lib64)
173
174* Thu May 29 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.10.3-0vl1
175- Initial build.
176
Note: See TracBrowser for help on using the repository browser.