source: projects/specs/trunk/l/linux-igd/linux-igd-vl.spec @ 521

Revision 521, 2.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name linux-igd
2%define source_name linuxigd
3%define version 1.0
4%define release 1%{?_dist_release}
5
6Summary: The Linux UPNP Internet GATEWAY DEVICE
7Summary(ja): ユニバーサルプラグアンドプレイゲートウェイデバイス
8Name: %{name}
9Version: %{version}
10Release: %{release}
11Source0: %{source_name}-%{version}.tar.gz
12Patch0: %{source_name}-%{version}.patch
13License: GPL
14Group: System Environment/Daemons
15URL: http://linux-igd.sourceforge.net/
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: libupnp-devel >= 1.3.1
19Requires: libupnp >= 1.3.1
20
21%description
22This is a deamon that emulates Microsoft's Internet Connection Service (ICS).
23It implements the UPnP Internet Gateway Device specification (IGD) and allows UPnP aware clients, such as MSN Messenger to work properly from behind a Linux NAT firewall.
24
25%prep
26%setup -q -n %{source_name}-%{version}
27%patch -p1
28
29%build
30%{__make}
31
32%install
33%{__rm} -rf ${RPM_BUILD_ROOT}
34%{__make} install DESTDIR="${RPM_BUILD_ROOT}"
35
36%post
37if [ $1 = 1 ] ; then
38    /sbin/chkconfig --add upnpd
39fi
40
41%preun
42if [ $1 = 0 ] ; then
43    /etc/rc.d/init.d/upnpd stop
44    /sbin/chkconfig --del upnpd
45fi
46
47%clean
48%__rm -rf ${RPM_BUILD_ROOT}
49
50%files
51%defattr(-, root, root)
52%doc CHANGES LICENSE doc/config_options
53%dir %{_sysconfdir}/linuxigd/
54%attr(0644, root, root) %{_sysconfdir}/linuxigd/*.xml
55%{_sbindir}/upnpd
56%{_mandir}/man8/upnpd.8.gz
57%attr(0644, root, root) %config %{_sysconfdir}/upnpd.conf
58%attr(0755, root, root) %{_sysconfdir}/rc.d/init.d/upnpd
59%attr(0644, root, root) %config %{_sysconfdir}/sysconfig/upnpd
60
61%changelog
62* Sun Mar  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-1vl5
63- applied new versioning policy, spec in UTF-8
64- fixed Group tag
65- added files to %%doc section
66
67* Tue Feb 14 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0
68- initial build for Vine Linux
69
70* Mon Aug 14 2006 Tim Brody <tdb01r@ecs.soton.ac.uk>
71- Version 0.95 Release 1
72- first build for version 0.95 (Release)
73* Sun Sep 26 2004 Watanabe Keiji <k@elt.ne.jp>
74- Version 0.99 Release ELT1
75- first build for version 0.92 (CVS Version on Sep 25, 2004.)
Note: See TracBrowser for help on using the repository browser.