source: projects/specs/trunk/l/linux-igd/linux-igd-vl.spec @ 8163

Revision 8163, 2.4 KB checked in by tomop, 10 years ago (diff)

linux-igd-1.0-3

Line 
1%define name linux-igd
2%define source_name linuxigd
3%define version 1.0
4%define release 3%{?_dist_release}
5
6Summary: The Linux UPNP Internet GATEWAY DEVICE
7Summary(ja): ユニバーサルプラグアンドプレイゲートウェイデバイス
8Name: %{name}
9Version: %{version}
10Release: %{release}
11Source0: %{source_name}-%{version}.tar.gz
12Patch0: %{source_name}-%{version}.patch
13Patch1: linux-igd-include.patch
14License: GPL
15Group: System Environment/Daemons
16URL: http://linux-igd.sourceforge.net/
17Vendor: Project Vine
18Distribution: Vine Linux
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: libupnp-devel >= 1.3.1
22Requires: libupnp >= 1.3.1
23
24%description
25This is a deamon that emulates Microsoft's Internet Connection Service (ICS).
26It implements the UPnP Internet Gateway Device specification (IGD) and allows UPnP aware clients, such as MSN Messenger to work properly from behind a Linux NAT firewall.
27
28%prep
29%setup -q -n %{source_name}-%{version}
30%patch0 -p1
31%patch1 -p1
32
33%build
34%{__make}
35
36%install
37%{__rm} -rf ${RPM_BUILD_ROOT}
38%{__make} install DESTDIR="${RPM_BUILD_ROOT}"
39
40%post
41if [ $1 = 1 ] ; then
42    /sbin/chkconfig --add upnpd
43fi
44
45%preun
46if [ $1 = 0 ] ; then
47    /etc/rc.d/init.d/upnpd stop
48    /sbin/chkconfig --del upnpd
49fi
50
51%clean
52%__rm -rf ${RPM_BUILD_ROOT}
53
54%files
55%defattr(-, root, root)
56%doc CHANGES LICENSE doc/config_options
57%dir %{_sysconfdir}/linuxigd/
58%attr(0644, root, root) %{_sysconfdir}/linuxigd/*.xml
59%{_sbindir}/upnpd
60%{_mandir}/man8/upnpd.8.gz
61%attr(0644, root, root) %config %{_sysconfdir}/upnpd.conf
62%attr(0755, root, root) %{_sysconfdir}/rc.d/init.d/upnpd
63%attr(0644, root, root) %config %{_sysconfdir}/sysconfig/upnpd
64
65%changelog
66* Mon Jan 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0-3
67- rebuilt with current environment.
68
69* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0-2
70- rebuilt with current environment.
71- added Patch1.
72
73* Sun Mar  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-1vl5
74- applied new versioning policy, spec in UTF-8
75- fixed Group tag
76- added files to %%doc section
77
78* Thu Feb 14 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0
79- initial build for Vine Linux
80
81* Mon Aug 14 2006 Tim Brody <tdb01r@ecs.soton.ac.uk>
82- Version 0.95 Release 1
83- first build for version 0.95 (Release)
84* Sun Sep 26 2004 Watanabe Keiji <k@elt.ne.jp>
85- Version 0.99 Release ELT1
86- first build for version 0.92 (CVS Version on Sep 25, 2004.)
Note: See TracBrowser for help on using the repository browser.