source: projects/specs/trunk/l/lighttpd/lighttpd-vl.spec @ 7002

Revision 7002, 12.2 KB checked in by daisuke, 12 years ago (diff)

lighttpd:

  • update to 1.4.31
  • build with pcre-8.31
  • require www-common, change docroot owner to www-data
Line 
1%define webroot /var/www/lighttpd
2
3Summary: Lightning fast webserver with light system requirements
4Summary(ja): 少ないシステムリソースで動く超高速なウェブサーバ
5Name: lighttpd
6Version: 1.4.31
7Release: 1%{?_dist_release}
8License: BSD
9Group: System Environment/Daemons
10URL: http://www.lighttpd.net/
11Source0: http://www.lighttpd.net/download/lighttpd-%{version}.tar.xz
12Source1: lighttpd.logrotate
13Source2: php.d-lighttpd.ini
14Source3: lighttpd.init
15Source10: index.html
16Source11: http://www.lighttpd.net/favicon.ico
17Source13: http://www.lighttpd.net/light_button.png
18Source14: http://www.lighttpd.net/light_logo.png
19Patch0: lighttpd-1.4.31-vine.patch
20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21Requires(pre): shadow-utils
22Requires(pre): www-common
23Requires(post): chkconfig
24Requires(preun): chkconfig
25Requires(postun): chkconfig
26BuildRequires: openssl-devel, pcre-devel, bzip2-devel, zlib-devel, gcc-c++
27%{?_with_ldap:BuildRequires: openldap-devel}
28BuildRequires: gamin-devel
29BuildRequires: gdbm-devel
30BuildRequires: lua-devel
31
32%description
33Secure, fast, compliant and very flexible web-server which has been optimized
34for high-performance environments. It has a very low memory footprint compared
35to other webservers and takes care of cpu-load. Its advanced feature-set
36(FastCGI, CGI, Auth, Output-Compression, URL-Rewriting and many more) make
37it the perfect webserver-software for every server that is suffering load
38problems.
39
40Available rpmbuild rebuild options :
41--with : memcache webdavprops ldap
42--without: lua
43
44%package mod_mysql_vhost
45Summary: Virtual host module for lighttpd that uses a MySQL database
46Group: System Environment/Daemons
47Requires: %{name} = %{version}
48BuildRequires: mysql-devel
49
50%description mod_mysql_vhost
51Virtual host module for lighttpd that uses a MySQL database.
52
53
54%package fastcgi
55Summary: FastCGI module and spawning helper for lighttpd and PHP configuration
56Group: System Environment/Daemons
57Requires: %{name} = %{version}
58Requires: spawn-fcgi
59
60%description fastcgi
61This package contains the spawn-fcgi helper for lighttpd's automatic spawning
62of local FastCGI programs. Included is also a PHP .ini file to change a few
63defaults needed for correct FastCGI behavior.
64Note that for FastCGI to work with PHP, you will most likely need to find a
65tweaked PHP package (--enable-fastcgi and --enable-discard-path added) or
66recompile PHP yourself.
67
68
69%prep
70%setup -q
71%patch0 -p1 -b .vine
72
73
74%build
75%configure \
76    --libdir="%{_libdir}/lighttpd" \
77    --with-mysql \
78    %{?_with_ldap:--with-ldap} \
79    --with-openssl \
80    --with-fam \
81    --with-gdbm \
82    --with-pcre \
83    %{?_with_memcache:--with-memcache} \
84    %{?_with_webdavprops:--with-webdav-props} \
85    %{?_with_webdavlocks:--with-webdav-locks} \
86    %{?!_without_lua:--with-lua}
87%{__make}
88
89
90%install
91%{__rm} -rf %{buildroot}
92%{__make} install DESTDIR=%{buildroot}
93
94# Install included init script and sysconfig entry
95%{__install} -D -p -m 0755 doc/initscripts/rc.lighttpd.redhat \
96    %{buildroot}%{_sysconfdir}/rc.d/init.d/lighttpd
97%{__install} -D -p -m 0644 doc/initscripts/sysconfig.lighttpd \
98    %{buildroot}%{_sysconfdir}/sysconfig/lighttpd
99
100# Install (*patched above*) sample config file
101%{__install} -D -p -m 0640 doc/config/lighttpd.conf \
102    %{buildroot}%{_sysconfdir}/lighttpd/lighttpd.conf
103%{__install} -D -p -m 0640 doc/config/modules.conf \
104    %{buildroot}%{_sysconfdir}/lighttpd/modules.conf
105
106mkdir -p %{buildroot}%{_sysconfdir}/lighttpd/conf.d/
107%{__install} -D -p -m 0640 doc/config/conf.d/*.conf \
108    %{buildroot}%{_sysconfdir}/lighttpd/conf.d/
109mkdir -p %{buildroot}%{_sysconfdir}/lighttpd/vhosts.d/
110%{__install} -D -p -m 0640 doc/config/vhosts.d/vhosts.template \
111    %{buildroot}%{_sysconfdir}/lighttpd/vhosts.d/
112
113# Install our own logrotate entry
114%{__install} -D -p -m 0644 %{SOURCE1} \
115    %{buildroot}%{_sysconfdir}/logrotate.d/lighttpd
116
117# Install our own php.d ini file
118%{__install} -D -p -m 0644 %{SOURCE2} \
119    %{buildroot}%{_sysconfdir}/php.d/lighttpd.ini
120
121# Install our own init script
122%{__install} -D -p -m 0755 %{SOURCE3} \
123    %{buildroot}%{_sysconfdir}/rc.d/init.d/lighttpd
124
125# Install our own default web page and images
126%{__mkdir_p} %{buildroot}%{webroot}
127%{__install} -p -m 0644 %{SOURCE10} %{SOURCE11} %{SOURCE13} \
128    %{SOURCE14} \
129    %{buildroot}%{webroot}/
130
131# Install empty log directory to include
132%{__mkdir_p} %{buildroot}%{_var}/log/lighttpd
133
134# Install empty run directory to include (for the example fastcgi socket)
135%{__mkdir_p} %{buildroot}%{_var}/run/lighttpd
136
137
138%clean
139%{__rm} -rf %{buildroot}
140
141
142%post
143/sbin/chkconfig --add lighttpd
144
145%preun
146if [ $1 -eq 0 ]; then
147  /sbin/service lighttpd stop &>/dev/null || :
148  /sbin/chkconfig --del lighttpd
149fi
150
151%postun
152if [ $1 -ge 1 ]; then
153    /sbin/service lighttpd condrestart &>/dev/null || :
154fi
155
156
157%files
158%defattr(-, root, root, 0755)
159%doc AUTHORS NEWS COPYING README
160%doc doc/config/lighttpd.conf
161%dir %{_sysconfdir}/lighttpd/
162%config(noreplace) %{_sysconfdir}/lighttpd/lighttpd.conf
163%config(noreplace) %{_sysconfdir}/lighttpd/conf.d/*
164%config(noreplace) %{_sysconfdir}/lighttpd/vhosts.d/*
165%config(noreplace) %{_sysconfdir}/logrotate.d/lighttpd
166%config(noreplace) %{_sysconfdir}/sysconfig/lighttpd
167%{_sysconfdir}/rc.d/init.d/lighttpd
168%{_sbindir}/lighttpd
169%{_sbindir}/lighttpd-angel
170%{_libdir}/lighttpd/
171%exclude %{_libdir}/lighttpd/*.la
172%exclude %{_libdir}/lighttpd/mod_fastcgi.so
173%exclude %{_libdir}/lighttpd/mod_mysql_vhost.so
174%exclude %{_sysconfdir}/lighttpd/conf.d/fastcgi.conf
175%exclude %{_sysconfdir}/lighttpd/conf.d/mysql_vhost.conf
176%{_mandir}/man8/lighttpd.8*
177%attr(0750, www-data, www-data) %{_var}/log/lighttpd/
178%{webroot}/
179
180%files mod_mysql_vhost
181%defattr(-, root, root, 0755)
182%doc doc/mysqlvhost.txt
183%dir %{_libdir}/lighttpd/
184%{_sysconfdir}/lighttpd/conf.d/mysql_vhost.conf
185%{_libdir}/lighttpd/mod_mysql_vhost.so
186
187%files fastcgi
188%defattr(-, root, root, 0755)
189%config(noreplace) %{_sysconfdir}/php.d/lighttpd.ini
190%dir %{_libdir}/lighttpd/
191%{_libdir}/lighttpd/mod_fastcgi.so
192%{_sysconfdir}/lighttpd/conf.d/fastcgi.conf
193
194
195%changelog
196* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.31-1
197- update to 1.4.31
198- build with pcre-8.31
199- require www-common, change docroot owner to www-data
200
201* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.22-2
202- rebuild with openssl-1.0.0c
203
204* Fri Jun 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
205- new upstream release
206- build with lua, add BR: lua-devel
207- update init script
208
209* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.20-2
210- rebuilt with MySQL-5.1.34.
211
212* Wed Oct 08 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.20-1
213- updated to 1.4.20 release with many bug/security fixes, including:
214  - CVE-2008-4298: fix memory leak in request header handling
215  - CVE-2008-4360: fix mod_userdir information disclosure
216  - CVE-2008-4359: fix bypassing rewrite/redirect rules with encoded urls
217  - CVE-2008-1531: fix DoS of ssl connections
218- modified Patch0 for version 1.4.20
219- add %{_sbindir}/lighttpd-angel to the filelist
220
221* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.16-1vl5
222- applied new versioning policy, spec in utf-8
223
224* Tue Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.16-0vl1
225- new upstream release
226
227* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.13-0vl1
228- initial build for Vine Linux
229
230* Wed Oct 11 2006 Matthias Saou <http://freshrpms.net/> 1.4.13-1
231- Update to 1.4.13, which contains the previous fix.
232
233* Tue Oct  3 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-3
234- Include fix for segfaults (lighttpd bug #876, changeset 1352).
235
236* Mon Sep 25 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-1
237- Update to 1.4.12 final.
238
239* Fri Sep 22 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-0.1.r1332
240- Update to latest 1.4.12 pre-release, fixes SSL issues and other bugs.
241- Update powered_by_fedora.png to the new logo.
242
243* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.4.11-2
244- FC6 rebuild.
245
246* Thu Mar  9 2006 Matthias Saou <http://freshrpms.net/> 1.4.11-1
247- Update to 1.4.11.
248
249* Mon Mar  6 2006 Matthias Saou <http://freshrpms.net/> 1.4.10-2
250- FC5 rebuild.
251
252* Wed Feb  8 2006 Matthias Saou <http://freshrpms.net/> 1.4.10-1
253- Update to 1.4.10.
254- Remove now included fix.
255
256* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 1.4.9-2
257- Add mod_fastcgi-fix patch to fix crash on backend overload.
258
259* Mon Jan 16 2006 Matthias Saou <http://freshrpms.net/> 1.4.9-1
260- Update to 1.4.9.
261
262* Wed Nov 23 2005 Matthias Saou <http://freshrpms.net/> 1.4.8-1
263- Update to 1.4.8.
264
265* Fri Nov  4 2005 Matthias Saou <http://freshrpms.net/> 1.4.7-1
266- Update to 1.4.7.
267
268* Wed Oct 12 2005 Matthias Saou <http://freshrpms.net/> 1.4.6-1
269- Update to 1.4.6.
270
271* Mon Oct  3 2005 Matthias Saou <http://freshrpms.net/> 1.4.5-1
272- Update to 1.4.5.
273- Disable gamin/fam support for now, it does not work.
274
275* Tue Sep 27 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-3
276- Update to current SVN to check if it fixes the remaining load problems.
277
278* Wed Sep 21 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-2
279- Patch to SVN 722 revision : Fixes a crash in mod_mysql_vhost and a problem
280  with keepalive and certain browsers.
281
282* Mon Sep 19 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-1
283- Update to 1.4.4 final.
284- Enable ldap auth, gdbm and gamin/fam support by default.
285
286* Thu Sep 15 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-0
287- Update to 1.4.4 pre-release (fixes another fastcgi memleak).
288- Enable lua (cml module) by default.
289- Add --with-webdav-props conditional option.
290
291* Tue Sep 13 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-2
292- Include lighttpd-1.4.3-stat_cache.patch to fix memleak.
293
294* Fri Sep  2 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-1.1
295- Rearrange the included index.html to include the new logo, button and
296  favicon from lighttpd.net.
297
298* Fri Sep  2 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-1
299- Update to 1.4.3.
300- No longer override libdir at make install stage, use DESTDIR instead, as
301  the resulting binary would now have referenced to %%{buildroot} :-(
302
303* Tue Aug 30 2005 Matthias Saou <http://freshrpms.net/> 1.4.2-1
304- Update to 1.4.2.
305
306* Mon Aug 22 2005 Matthias Saou <http://freshrpms.net/> 1.4.1-1
307- Update to 1.4.1.
308
309* Sun Aug 21 2005 Matthias Saou <http://freshrpms.net/> 1.4.0-1
310- Update to 1.4.0.
311- Add conditional of gamin, gdbm, memcache and lua options.
312
313* Mon Aug  1 2005 Matthias Saou <http://freshrpms.net/> 1.3.16-2
314- Update to 1.3.16, rebuild.
315
316* Mon Jul 18 2005 Matthias Saou <http://freshrpms.net/> 1.3.15-1
317- Update to 1.3.15.
318
319* Mon Jun 20 2005 Matthias Saou <http://freshrpms.net/> 1.3.14-1
320- Update to 1.3.14.
321
322* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.3.13-5
323- rebuild on all arches
324
325* Mon Apr  4 2005 Matthias Saou <http://freshrpms.net/> 1.3.13-4
326- Change signal sent from the logrotate script from USR1 to HUP, as that's the
327  correct one.
328
329* Fri Apr  1 2005 Michael Schwendt <mschwendt[AT]users.sf.net> 1.3.13-2
330- Include /etc/lighttpd directory.
331
332* Sun Mar  6 2005 Matthias Saou <http://freshrpms.net/> 1.3.13-1
333- Update to 1.3.13.
334
335* Wed Mar  2 2005 Matthias Saou <http://freshrpms.net/> 1.3.12-1
336- Update to 1.3.12.
337- Remove obsolete empty_cgi_handler patch.
338
339* Tue Mar  1 2005 Matthias Saou <http://freshrpms.net/> 1.3.11-2
340- Add missing defattr to sub-packages (#150018).
341
342* Mon Feb 21 2005 Matthias Saou <http://freshrpms.net/> 1.3.11-0
343- Update to 1.3.11.
344- Remove cleanconf and init.d patches (merged upstream).
345- Add empty_cgi_handler patch.
346
347* Fri Feb 18 2005 Matthias Saou <http://freshrpms.net/> 1.3.10-0
348- Split off -fastcgi sub-package.
349- Include php.d entry to set sane FastCGI defaults.
350
351* Wed Feb 16 2005 Matthias Saou <http://freshrpms.net/> 1.3.10-0
352- Spec file cleanup for freshrpms.net/Extras.
353- Compile OpenSSL support unconditionally.
354- Put modules in a subdirectory of libdir.
355- Don't include all of libdir's content to avoid debuginfo content.
356- Add optional LDAP support.
357- Add patch to change the default configuration.
358- Add dedicated lighttpd user/group creation.
359- Add logrotate entry.
360- Include a nice little default page for the default setup.
361- Split off mod_mysql_vhost sub-package, get dep only there.
362- Use webroot in /srv by default.
363- Exclude .la files, I doubt anyone will need them.
364
365* Thu Sep 30 2004 <jan@kneschke.de> 1.3.1
366- upgraded to 1.3.1
367
368* Tue Jun 29 2004 <jan@kneschke.de> 1.2.3
369- rpmlint'ed the package
370- added URL
371- added (noreplace) to start-script
372- change group to Networking/Daemon (like apache)
373
374* Sun Feb 23 2003 <jan@kneschke.de>
375- initial version
376
Note: See TracBrowser for help on using the repository browser.