source: projects/specs/trunk/l/lighttpd/lighttpd-vl.spec @ 521

Revision 521, 11.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define webroot /var/www/lighttpd
2
3Summary: Lightning fast webserver with light system requirements
4Summary(ja): 少ないシステムリソースで動く超高速なウェブサーバ
5Name: lighttpd
6Version: 1.4.22
7Release: 1%{?_dist_release}
8License: BSD
9Group: System Environment/Daemons
10URL: http://www.lighttpd.net/
11Source0: http://www.lighttpd.net/download/lighttpd-%{version}.tar.bz2
12Source1: lighttpd.logrotate
13Source2: php.d-lighttpd.ini
14Source3: lighttpd.init
15Source10: index.html
16Source11: http://www.lighttpd.net/favicon.ico
17Source13: http://www.lighttpd.net/light_button.png
18Source14: http://www.lighttpd.net/light_logo.png
19Patch0: lighttpd-1.4.20-defaultconf.patch
20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21Requires(pre): shadow-utils
22Requires(post): chkconfig
23Requires(preun): chkconfig
24Requires(postun): chkconfig
25BuildRequires: openssl-devel, pcre-devel, bzip2-devel, zlib-devel, gcc-c++
26%{?_with_ldap:BuildRequires: openldap-devel}
27BuildRequires: gamin-devel
28BuildRequires: gdbm-devel
29BuildRequires: lua-devel
30
31%description
32Secure, fast, compliant and very flexible web-server which has been optimized
33for high-performance environments. It has a very low memory footprint compared
34to other webservers and takes care of cpu-load. Its advanced feature-set
35(FastCGI, CGI, Auth, Output-Compression, URL-Rewriting and many more) make
36it the perfect webserver-software for every server that is suffering load
37problems.
38
39Available rpmbuild rebuild options :
40--with : memcache webdavprops ldap
41--without: lua
42
43%package mod_mysql_vhost
44Summary: Virtual host module for lighttpd that uses a MySQL database
45Group: System Environment/Daemons
46Requires: %{name} = %{version}
47BuildRequires: mysql-devel
48
49%description mod_mysql_vhost
50Virtual host module for lighttpd that uses a MySQL database.
51
52
53%package fastcgi
54Summary: FastCGI module and spawning helper for lighttpd and PHP configuration
55Group: System Environment/Daemons
56Requires: %{name} = %{version}
57
58%description fastcgi
59This package contains the spawn-fcgi helper for lighttpd's automatic spawning
60of local FastCGI programs. Included is also a PHP .ini file to change a few
61defaults needed for correct FastCGI behavior.
62Note that for FastCGI to work with PHP, you will most likely need to find a
63tweaked PHP package (--enable-fastcgi and --enable-discard-path added) or
64recompile PHP yourself.
65
66
67%prep
68%setup -q
69%patch0 -p1 -b .defaultconf
70
71
72%build
73%configure \
74    --libdir="%{_libdir}/lighttpd" \
75    --with-mysql \
76    %{?_with_ldap:--with-ldap} \
77    --with-openssl \
78    --with-fam \
79    --with-gdbm \
80    %{?_with_memcache:--with-memcache} \
81    %{?_with_webdavprops:--with-webdav-props} \
82    %{?_with_webdavlocks:--with-webdav-locks} \
83    %{?!_without_lua:--with-lua}
84%{__make}
85
86
87%install
88%{__rm} -rf %{buildroot}
89%{__make} install DESTDIR=%{buildroot}
90
91# Install included init script and sysconfig entry
92%{__install} -D -p -m 0755 doc/rc.lighttpd.redhat \
93    %{buildroot}%{_sysconfdir}/rc.d/init.d/lighttpd
94%{__install} -D -p -m 0644 doc/sysconfig.lighttpd \
95    %{buildroot}%{_sysconfdir}/sysconfig/lighttpd
96
97# Install (*patched above*) sample config file
98%{__install} -D -p -m 0640 doc/lighttpd.conf \
99    %{buildroot}%{_sysconfdir}/lighttpd/lighttpd.conf
100
101# Install our own logrotate entry
102%{__install} -D -p -m 0644 %{SOURCE1} \
103    %{buildroot}%{_sysconfdir}/logrotate.d/lighttpd
104
105# Install our own php.d ini file
106%{__install} -D -p -m 0644 %{SOURCE2} \
107    %{buildroot}%{_sysconfdir}/php.d/lighttpd.ini
108
109# Install our own init script
110%{__install} -D -p -m 0755 %{SOURCE3} \
111    %{buildroot}%{_sysconfdir}/rc.d/init.d/lighttpd
112
113# Install our own default web page and images
114%{__mkdir_p} %{buildroot}%{webroot}
115%{__install} -p -m 0644 %{SOURCE10} %{SOURCE11} %{SOURCE13} \
116    %{SOURCE14} \
117    %{buildroot}%{webroot}/
118
119# Install empty log directory to include
120%{__mkdir_p} %{buildroot}%{_var}/log/lighttpd
121
122# Install empty run directory to include (for the example fastcgi socket)
123%{__mkdir_p} %{buildroot}%{_var}/run/lighttpd
124
125
126%clean
127%{__rm} -rf %{buildroot}
128
129
130%pre
131/usr/sbin/useradd -s /sbin/nologin -M -r -d %{webroot} \
132    -c "lighttpd web server" lighttpd &>/dev/null || :
133
134%post
135/sbin/chkconfig --add lighttpd
136
137%preun
138if [ $1 -eq 0 ]; then
139  /sbin/service lighttpd stop &>/dev/null || :
140  /sbin/chkconfig --del lighttpd
141fi
142
143%postun
144if [ $1 -ge 1 ]; then
145    /sbin/service lighttpd condrestart &>/dev/null || :
146fi
147
148
149%files
150%defattr(-, root, root, 0755)
151%doc AUTHORS ChangeLog COPYING README
152%doc doc/*.txt doc/lighttpd.conf doc/lighttpd.user
153%dir %{_sysconfdir}/lighttpd/
154%config(noreplace) %{_sysconfdir}/lighttpd/lighttpd.conf
155%config(noreplace) %{_sysconfdir}/logrotate.d/lighttpd
156%config(noreplace) %{_sysconfdir}/sysconfig/lighttpd
157%{_sysconfdir}/rc.d/init.d/lighttpd
158%{_sbindir}/lighttpd
159%{_sbindir}/lighttpd-angel
160%{_libdir}/lighttpd/
161%exclude %{_libdir}/lighttpd/*.la
162%exclude %{_libdir}/lighttpd/mod_fastcgi.so
163%exclude %{_libdir}/lighttpd/mod_mysql_vhost.so
164%{_mandir}/man1/lighttpd.1*
165%attr(0750, lighttpd, lighttpd) %{_var}/log/lighttpd/
166%{webroot}/
167
168%files mod_mysql_vhost
169%defattr(-, root, root, 0755)
170%doc doc/mysqlvhost.txt
171%dir %{_libdir}/lighttpd/
172%{_libdir}/lighttpd/mod_mysql_vhost.so
173
174%files fastcgi
175%defattr(-, root, root, 0755)
176%doc doc/fastcgi*.txt
177%config(noreplace) %{_sysconfdir}/php.d/lighttpd.ini
178%{_bindir}/spawn-fcgi
179%dir %{_libdir}/lighttpd/
180%{_libdir}/lighttpd/mod_fastcgi.so
181%{_mandir}/man1/spawn-fcgi.1*
182
183
184%changelog
185* Fri Jun 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
186- new upstream release
187- build with lua, add BR: lua-devel
188- update init script
189
190* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.20-2
191- rebuilt with MySQL-5.1.34.
192
193* Wed Oct 08 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.20-1
194- updated to 1.4.20 release with many bug/security fixes, including:
195  - CVE-2008-4298: fix memory leak in request header handling
196  - CVE-2008-4360: fix mod_userdir information disclosure
197  - CVE-2008-4359: fix bypassing rewrite/redirect rules with encoded urls
198  - CVE-2008-1531: fix DoS of ssl connections
199- modified Patch0 for version 1.4.20
200- add %{_sbindir}/lighttpd-angel to the filelist
201
202* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.16-1vl5
203- applied new versioning policy, spec in utf-8
204
205* Tue Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.16-0vl1
206- new upstream release
207
208* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.13-0vl1
209- initial build for Vine Linux
210
211* Wed Oct 11 2006 Matthias Saou <http://freshrpms.net/> 1.4.13-1
212- Update to 1.4.13, which contains the previous fix.
213
214* Tue Oct  3 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-3
215- Include fix for segfaults (lighttpd bug #876, changeset 1352).
216
217* Mon Sep 25 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-1
218- Update to 1.4.12 final.
219
220* Fri Sep 22 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-0.1.r1332
221- Update to latest 1.4.12 pre-release, fixes SSL issues and other bugs.
222- Update powered_by_fedora.png to the new logo.
223
224* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.4.11-2
225- FC6 rebuild.
226
227* Thu Mar  9 2006 Matthias Saou <http://freshrpms.net/> 1.4.11-1
228- Update to 1.4.11.
229
230* Mon Mar  6 2006 Matthias Saou <http://freshrpms.net/> 1.4.10-2
231- FC5 rebuild.
232
233* Wed Feb  8 2006 Matthias Saou <http://freshrpms.net/> 1.4.10-1
234- Update to 1.4.10.
235- Remove now included fix.
236
237* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 1.4.9-2
238- Add mod_fastcgi-fix patch to fix crash on backend overload.
239
240* Mon Jan 16 2006 Matthias Saou <http://freshrpms.net/> 1.4.9-1
241- Update to 1.4.9.
242
243* Wed Nov 23 2005 Matthias Saou <http://freshrpms.net/> 1.4.8-1
244- Update to 1.4.8.
245
246* Fri Nov  4 2005 Matthias Saou <http://freshrpms.net/> 1.4.7-1
247- Update to 1.4.7.
248
249* Wed Oct 12 2005 Matthias Saou <http://freshrpms.net/> 1.4.6-1
250- Update to 1.4.6.
251
252* Mon Oct  3 2005 Matthias Saou <http://freshrpms.net/> 1.4.5-1
253- Update to 1.4.5.
254- Disable gamin/fam support for now, it does not work.
255
256* Tue Sep 27 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-3
257- Update to current SVN to check if it fixes the remaining load problems.
258
259* Wed Sep 21 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-2
260- Patch to SVN 722 revision : Fixes a crash in mod_mysql_vhost and a problem
261  with keepalive and certain browsers.
262
263* Mon Sep 19 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-1
264- Update to 1.4.4 final.
265- Enable ldap auth, gdbm and gamin/fam support by default.
266
267* Thu Sep 15 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-0
268- Update to 1.4.4 pre-release (fixes another fastcgi memleak).
269- Enable lua (cml module) by default.
270- Add --with-webdav-props conditional option.
271
272* Tue Sep 13 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-2
273- Include lighttpd-1.4.3-stat_cache.patch to fix memleak.
274
275* Fri Sep  2 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-1.1
276- Rearrange the included index.html to include the new logo, button and
277  favicon from lighttpd.net.
278
279* Fri Sep  2 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-1
280- Update to 1.4.3.
281- No longer override libdir at make install stage, use DESTDIR instead, as
282  the resulting binary would now have referenced to %%{buildroot} :-(
283
284* Tue Aug 30 2005 Matthias Saou <http://freshrpms.net/> 1.4.2-1
285- Update to 1.4.2.
286
287* Mon Aug 22 2005 Matthias Saou <http://freshrpms.net/> 1.4.1-1
288- Update to 1.4.1.
289
290* Sun Aug 21 2005 Matthias Saou <http://freshrpms.net/> 1.4.0-1
291- Update to 1.4.0.
292- Add conditional of gamin, gdbm, memcache and lua options.
293
294* Mon Aug  1 2005 Matthias Saou <http://freshrpms.net/> 1.3.16-2
295- Update to 1.3.16, rebuild.
296
297* Mon Jul 18 2005 Matthias Saou <http://freshrpms.net/> 1.3.15-1
298- Update to 1.3.15.
299
300* Mon Jun 20 2005 Matthias Saou <http://freshrpms.net/> 1.3.14-1
301- Update to 1.3.14.
302
303* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.3.13-5
304- rebuild on all arches
305
306* Mon Apr  4 2005 Matthias Saou <http://freshrpms.net/> 1.3.13-4
307- Change signal sent from the logrotate script from USR1 to HUP, as that's the
308  correct one.
309
310* Fri Apr  1 2005 Michael Schwendt <mschwendt[AT]users.sf.net> 1.3.13-2
311- Include /etc/lighttpd directory.
312
313* Sun Mar  6 2005 Matthias Saou <http://freshrpms.net/> 1.3.13-1
314- Update to 1.3.13.
315
316* Wed Mar  2 2005 Matthias Saou <http://freshrpms.net/> 1.3.12-1
317- Update to 1.3.12.
318- Remove obsolete empty_cgi_handler patch.
319
320* Tue Mar  1 2005 Matthias Saou <http://freshrpms.net/> 1.3.11-2
321- Add missing defattr to sub-packages (#150018).
322
323* Mon Feb 21 2005 Matthias Saou <http://freshrpms.net/> 1.3.11-0
324- Update to 1.3.11.
325- Remove cleanconf and init.d patches (merged upstream).
326- Add empty_cgi_handler patch.
327
328* Fri Feb 18 2005 Matthias Saou <http://freshrpms.net/> 1.3.10-0
329- Split off -fastcgi sub-package.
330- Include php.d entry to set sane FastCGI defaults.
331
332* Wed Feb 16 2005 Matthias Saou <http://freshrpms.net/> 1.3.10-0
333- Spec file cleanup for freshrpms.net/Extras.
334- Compile OpenSSL support unconditionally.
335- Put modules in a subdirectory of libdir.
336- Don't include all of libdir's content to avoid debuginfo content.
337- Add optional LDAP support.
338- Add patch to change the default configuration.
339- Add dedicated lighttpd user/group creation.
340- Add logrotate entry.
341- Include a nice little default page for the default setup.
342- Split off mod_mysql_vhost sub-package, get dep only there.
343- Use webroot in /srv by default.
344- Exclude .la files, I doubt anyone will need them.
345
346* Thu Sep 30 2004 <jan@kneschke.de> 1.3.1
347- upgraded to 1.3.1
348
349* Tue Jun 29 2004 <jan@kneschke.de> 1.2.3
350- rpmlint'ed the package
351- added URL
352- added (noreplace) to start-script
353- change group to Networking/Daemon (like apache)
354
355* Sun Feb 23 2003 <jan@kneschke.de>
356- initial version
357
Note: See TracBrowser for help on using the repository browser.