source: projects/specs/trunk/l/ldns/ldns-vl.spec @ 973

Revision 973, 8.7 KB checked in by iwaim, 14 years ago (diff)

ldns: 1.6.4-1

Line 
1%{?!with_python:      %global with_python      1}
2
3%if %{with_python}
4%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6%endif
7
8Summary: Lowlevel DNS(SEC) library with API
9Summary(ja): 低レベルな DNS(SEC) ライブラリと API
10Name: ldns
11Version: 1.6.4
12Release: 1%{?_dist_release}
13License: BSD
14Url: http://www.nlnetlabs.nl/%{name}/
15Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
16Group: System Environment/Libraries
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
19BuildRequires: perl, libpcap-devel, openssl-devel
20Requires: libpcap, openssl
21Patch1: ldns-installfix-r3167.patch
22Patch2: ldns-rpathfix.patch
23
24Distribution: Vine Linux
25Vendor: Project Vine
26Packager: iwaim
27
28%if %{with_python}
29BuildRequires:  python-devel, swig
30%endif
31
32%description
33ldns is a library with the aim to simplify DNS programing in C. All
34lowlevel DNS/DNSSEC operations are supported. We also define a higher
35level API which allows a programmer to (for instance) create or sign
36packets.
37
38%package devel
39Summary: Development package that includes the ldns header files
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44The devel package contains the ldns library and the include files
45
46%if %{with_python}
47%package python
48Summary: Python extensions for ldns
49Group: Applications/System
50Requires: %{name} = %{version}-%{release}
51
52%description python
53Python extensions for ldns
54%endif
55
56
57%prep
58%setup -q
59%patch1
60%patch2
61# To built svn snapshots
62rm config.guess config.sub ltmain.sh
63aclocal
64libtoolize -c --install
65autoreconf --install
66
67%build
68%configure --disable-rpath --disable-static --with-sha2 \
69%if %{with_python}
70 --with-pyldns
71%endif
72
73(cd drill ; %configure --disable-rpath --disable-static --with-ldns=%{buildroot}/lib/ )
74(cd examples ; %configure --disable-rpath --disable-static --with-ldns=%{buildroot}/lib/ )
75
76make %{?_smp_mflags}
77( cd drill ; make %{?_smp_mflags} )
78( cd examples ; make %{?_smp_mflags} )
79make %{?_smp_mflags} doc
80
81%install
82rm -rf %{buildroot}
83
84make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
85make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
86
87%if %{with_python}
88# remove execute perms from python files
89chmod a-x %{buildroot}%{python_sitelib}/*py
90%endif
91
92# don't package building script in doc
93rm doc/doxyparse.pl
94#remove doc stubs
95rm -rf doc/.svn
96#remove double set of man pages
97rm -rf doc/man
98
99# remove .la files
100rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitelib}/*.la
101(cd drill ; make DESTDIR=%{buildroot} install)
102(cd examples; make DESTDIR=%{buildroot} install)
103
104%clean
105rm -rf %{buildroot}
106
107%files
108%defattr(-,root,root)
109%{_libdir}/libldns*so.*
110%{_bindir}/drill
111%{_bindir}/ldnsd
112#%{_bindir}/ldns-*
113%{_bindir}/ldns-chaos
114%{_bindir}/ldns-compare-zones
115%{_bindir}/ldns-[d-z]*
116%doc README LICENSE
117%{_mandir}/*/*
118
119%files devel
120%defattr(-,root,root,-)
121%{_libdir}/libldns*so
122%{_bindir}/ldns-config
123%dir %{_includedir}/ldns
124%{_includedir}/ldns/*.h
125%doc doc Changelog README
126
127%if %{with_python}
128%files python
129%defattr(-,root,root)
130%{python_sitelib}/*
131%endif
132
133%post -p /sbin/ldconfig
134
135%postun -p /sbin/ldconfig
136
137%changelog
138* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
139- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
140
141* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
142- Fix missing _ldns.so causing ldns-python to not work
143- Patch for installing ldns-python files
144- Patch for rpath in ldns-python
145- Don't install .a file for ldns-python
146
147* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
148- Upgraded to 1.6.4.
149- Added ldns-python sub package
150
151* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
152- Upgraded to 1.6.3, which has minor bugfixes
153
154* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
155- Upgraded to 1.6.2. This fixes various bugs.
156  (upstream released mostly to default with sha2 for the imminent
157   signed root, but we already enabled that in our builds)
158
159* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
160- rebuilt with new openssl
161
162* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
163- Added openssl dependancy back in, since we get more functionality
164 when using openssl. Especially in 'drill'.
165
166* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
167- Updated to 1.6.1
168
169* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
170- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
171
172* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
173- Fixed the ssl patch so it can now compile --without-ssl
174
175* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
176- Added patch to compile with --without-ssl
177- Removed openssl dependancies
178- Recompiled with --without-ssl
179
180* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
181- Updated to 1.6.0
182- (did not yet compile with --without-ssl due to compile failures)
183
184* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
185- Updated to 1.6.0
186- Compile without openssl
187
188* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
189- Memory management bug when generating a sha256 key, see:
190  https://bugzilla.redhat.com/show_bug.cgi?id=493953
191
192* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
193- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
194
195* Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
196- Updated to new version, 1.5.0 had a bug preventing
197  zone signing.
198
199* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
200- Updated to new version
201
202* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
203- fixed configure flags
204
205* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
206- rebuild with new openssl
207
208* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
209- Updated to 1.4.0
210
211* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
212- enable SHA2 functionality
213
214* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
215- re-tag (don't do builds while renaming local repo dirs)
216
217* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
218- Updated to latest release
219
220* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
221- Autorebuild for GCC 4.3
222
223* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
224- Rebuild for new libcrypto
225
226* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
227- Upgraded to 1.2.2. Removed no longer needed race workaround
228
229* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
230- Try to fix racing ln -s statements in parallel builds
231
232* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
233- Added patch for ldns-read-zone that does not put @. in RRDATA
234
235* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
236- Use install -p to work around multilib conflicts for .h files
237
238* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
239- Updated to 1.2.1
240- Removed patches that got moved into upstream
241
242* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
243- Patch for ldns-key2ds to write to stdout
244- Again remove extra set of man pages from doc
245- own /usr/include/ldns (bug 233858)
246
247* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
248- Added sha256 DS record patch to ldns-key2ds
249- Minor tweaks for proper doc/man page installation.
250- Workaround for parallel builds
251
252* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
253- Own the /usr/include/ldns directory (bug #233858)
254- Removed obsoleted patch
255- Remove files form previous libtool run accidentally packages by upstream
256
257* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
258- Commented out 1.1.0 make targets, put make 1.0.1 targets.
259
260* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
261- Fixed changelog typo in date
262- Rebuild requested for PT_GNU_HASH support from gcc
263- Did not upgrade to 1.1.0 due to compile issues on x86_64
264
265* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
266- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
267
268* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
269- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
270
271* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
272- Patched 'make clean' target to get rid of object files shipped with 1.0.0
273
274* Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
275- added a make clean for 2.3.3 since .o files were left behind upstream,
276  causing failure on ppc platform
277
278* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
279- minor cleanups
280
281* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
282- reworked for svn version
283
284* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
285- Initial version
Note: See TracBrowser for help on using the repository browser.