source: projects/specs/trunk/l/ldns/ldns-vl.spec @ 8098

Revision 8098, 10.2 KB checked in by iwaim, 10 years ago (diff)

ldns 1.6.16-2

Line 
1%{?!with_python:      %global with_python      1}
2%{?!enable_gost:      %global enable_gost      0}
3
4%if %{with_python}
5%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
7%endif
8
9%if %{enable_gost}
10%define subdir_conf_opt --disable-rpath --disable-static
11%else
12%define subdir_conf_opt --disable-rpath --disable-static --disable-gost
13%endif
14
15
16Summary: Lowlevel DNS(SEC) library with API
17Summary(ja): 低レベルな DNS(SEC) ライブラリと API
18Name: ldns
19Version: 1.6.16
20Release: 2%{?_dist_release}
21License: BSD
22Url: http://www.nlnetlabs.nl/%{name}/
23Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
24# from Fedora
25Patch1000: ldns-1.6.16-uninitialized-value-compiler-warnings.patch
26Group: System Environment/Libraries
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
29BuildRequires: perl, libpcap-devel
30%if %{enable_gost}
31BuildRequires: openssl-devel >= 1.0.0
32%else
33BuildRequires: openssl-devel
34%endif
35
36Requires: libpcap, openssl
37
38Distribution: Vine Linux
39Vendor: Project Vine
40Packager: iwaim
41
42%if %{with_python}
43BuildRequires:  python-devel, swig
44%endif
45
46%description
47ldns is a library with the aim to simplify DNS programing in C. All
48lowlevel DNS/DNSSEC operations are supported. We also define a higher
49level API which allows a programmer to (for instance) create or sign
50packets.
51
52%package devel
53Summary: Development package that includes the ldns header files
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56
57%description devel
58The devel package contains the ldns library and the include files
59
60%if %{with_python}
61%package python
62Summary: Python extensions for ldns
63Group: Applications/System
64Requires: %{name} = %{version}-%{release}
65
66%description python
67Python extensions for ldns
68%endif
69
70
71%prep
72%setup -q
73%patch1000 -p2
74
75%build
76%configure --disable-rpath --disable-static \
77%if %{with_python}
78 --with-pyldns \
79%endif
80%if !%{enable_gost}
81 --disable-gost \
82%endif
83 --with-sha2
84
85(cd drill ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
86(cd examples ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
87
88make %{?_smp_mflags}
89( cd drill ; make %{?_smp_mflags} )
90( cd examples ; make %{?_smp_mflags} )
91make %{?_smp_mflags} doc
92
93%install
94rm -rf %{buildroot}
95
96make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
97make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
98
99%if %{with_python}
100# remove execute perms from python files
101chmod a-x %{buildroot}%{python_sitearch}/*py
102%endif
103
104# don't package building script in doc
105rm doc/doxyparse.pl
106#remove doc stubs
107rm -rf doc/.svn
108#remove double set of man pages
109rm -rf doc/man
110
111# remove .la files
112rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la
113(cd drill ; make DESTDIR=%{buildroot} install)
114(cd examples; make DESTDIR=%{buildroot} install)
115
116%clean
117rm -rf %{buildroot}
118
119%files
120%defattr(-,root,root)
121%{_libdir}/libldns*so.*
122%{_bindir}/drill
123%{_bindir}/ldnsd
124#%{_bindir}/ldns-*
125%{_bindir}/ldns-chaos
126%{_bindir}/ldns-compare-zones
127%{_bindir}/ldns-[d-z]*
128%doc README LICENSE
129%{_mandir}/*/*
130
131%files devel
132%defattr(-,root,root,-)
133%{_libdir}/libldns*so
134%{_bindir}/ldns-config
135%dir %{_includedir}/ldns
136%{_includedir}/ldns/*.h
137%doc doc Changelog README
138
139%if %{with_python}
140%files python
141%defattr(-,root,root)
142%{python_sitearch}/*
143%endif
144
145%post -p /sbin/ldconfig
146
147%postun -p /sbin/ldconfig
148
149%changelog
150* Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.16-2
151- add 'fix compiler warnings and one uninitialized value' patch (Patch1000)
152 - from Fedora ldns-1.6.16-6.fc20
153
154* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.6.16-1
155- new upstream release
156
157* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.13-1
158- new upstream release
159- move python files to sitearch from sitelib
160
161* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-2
162- rebuild with python-2.7.2
163
164* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
165- new upstream release
166
167* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
168- new upstream release
169
170* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
171- new upstream release
172
173* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
174- new upstream release
175- add enable_gost flag: default disable
176- defined subdir_conf_opt rpm macro
177
178* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
179- new upstream release
180
181* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
182- new upstream release
183- drop unnecessary installfix patch (Patch1): upstream merged
184- drop unnecessary rpathfix patch (Patch2): upstream merged
185
186* Thu Jun  3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
187- rebuild with libpcap 1.1.1 on VineSeed
188
189* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
190- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
191
192* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
193- Fix missing _ldns.so causing ldns-python to not work
194- Patch for installing ldns-python files
195- Patch for rpath in ldns-python
196- Don't install .a file for ldns-python
197
198* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
199- Upgraded to 1.6.4.
200- Added ldns-python sub package
201
202* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
203- Upgraded to 1.6.3, which has minor bugfixes
204
205* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
206- Upgraded to 1.6.2. This fixes various bugs.
207  (upstream released mostly to default with sha2 for the imminent
208   signed root, but we already enabled that in our builds)
209
210* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
211- rebuilt with new openssl
212
213* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
214- Added openssl dependancy back in, since we get more functionality
215 when using openssl. Especially in 'drill'.
216
217* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
218- Updated to 1.6.1
219
220* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
221- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
222
223* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
224- Fixed the ssl patch so it can now compile --without-ssl
225
226* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
227- Added patch to compile with --without-ssl
228- Removed openssl dependancies
229- Recompiled with --without-ssl
230
231* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
232- Updated to 1.6.0
233- (did not yet compile with --without-ssl due to compile failures)
234
235* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
236- Updated to 1.6.0
237- Compile without openssl
238
239* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
240- Memory management bug when generating a sha256 key, see:
241  https://bugzilla.redhat.com/show_bug.cgi?id=493953
242
243* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
244- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
245
246* Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
247- Updated to new version, 1.5.0 had a bug preventing
248  zone signing.
249
250* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
251- Updated to new version
252
253* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
254- fixed configure flags
255
256* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
257- rebuild with new openssl
258
259* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
260- Updated to 1.4.0
261
262* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
263- enable SHA2 functionality
264
265* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
266- re-tag (don't do builds while renaming local repo dirs)
267
268* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
269- Updated to latest release
270
271* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
272- Autorebuild for GCC 4.3
273
274* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
275- Rebuild for new libcrypto
276
277* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
278- Upgraded to 1.2.2. Removed no longer needed race workaround
279
280* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
281- Try to fix racing ln -s statements in parallel builds
282
283* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
284- Added patch for ldns-read-zone that does not put @. in RRDATA
285
286* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
287- Use install -p to work around multilib conflicts for .h files
288
289* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
290- Updated to 1.2.1
291- Removed patches that got moved into upstream
292
293* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
294- Patch for ldns-key2ds to write to stdout
295- Again remove extra set of man pages from doc
296- own /usr/include/ldns (bug 233858)
297
298* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
299- Added sha256 DS record patch to ldns-key2ds
300- Minor tweaks for proper doc/man page installation.
301- Workaround for parallel builds
302
303* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
304- Own the /usr/include/ldns directory (bug #233858)
305- Removed obsoleted patch
306- Remove files form previous libtool run accidentally packages by upstream
307
308* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
309- Commented out 1.1.0 make targets, put make 1.0.1 targets.
310
311* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
312- Fixed changelog typo in date
313- Rebuild requested for PT_GNU_HASH support from gcc
314- Did not upgrade to 1.1.0 due to compile issues on x86_64
315
316* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
317- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
318
319* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
320- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
321
322* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
323- Patched 'make clean' target to get rid of object files shipped with 1.0.0
324
325* Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
326- added a make clean for 2.3.3 since .o files were left behind upstream,
327  causing failure on ppc platform
328
329* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
330- minor cleanups
331
332* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
333- reworked for svn version
334
335* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
336- Initial version
Note: See TracBrowser for help on using the repository browser.