source: projects/specs/trunk/l/ldns/ldns-vl.spec @ 7214

Revision 7214, 9.9 KB checked in by iwaim, 12 years ago (diff)

ldns 1.6.16-1

Line 
1%{?!with_python:      %global with_python      1}
2%{?!enable_gost:      %global enable_gost      0}
3
4%if %{with_python}
5%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
7%endif
8
9%if %{enable_gost}
10%define subdir_conf_opt --disable-rpath --disable-static
11%else
12%define subdir_conf_opt --disable-rpath --disable-static --disable-gost
13%endif
14
15
16Summary: Lowlevel DNS(SEC) library with API
17Summary(ja): 低レベルな DNS(SEC) ライブラリと API
18Name: ldns
19Version: 1.6.16
20Release: 1%{?_dist_release}
21License: BSD
22Url: http://www.nlnetlabs.nl/%{name}/
23Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
24Group: System Environment/Libraries
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
27BuildRequires: perl, libpcap-devel
28%if %{enable_gost}
29BuildRequires: openssl-devel >= 1.0.0
30%else
31BuildRequires: openssl-devel
32%endif
33
34Requires: libpcap, openssl
35
36Distribution: Vine Linux
37Vendor: Project Vine
38Packager: iwaim
39
40%if %{with_python}
41BuildRequires:  python-devel, swig
42%endif
43
44%description
45ldns is a library with the aim to simplify DNS programing in C. All
46lowlevel DNS/DNSSEC operations are supported. We also define a higher
47level API which allows a programmer to (for instance) create or sign
48packets.
49
50%package devel
51Summary: Development package that includes the ldns header files
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56The devel package contains the ldns library and the include files
57
58%if %{with_python}
59%package python
60Summary: Python extensions for ldns
61Group: Applications/System
62Requires: %{name} = %{version}-%{release}
63
64%description python
65Python extensions for ldns
66%endif
67
68
69%prep
70%setup -q
71
72%build
73%configure --disable-rpath --disable-static \
74%if %{with_python}
75 --with-pyldns \
76%endif
77%if !%{enable_gost}
78 --disable-gost \
79%endif
80 --with-sha2
81
82(cd drill ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
83(cd examples ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
84
85make %{?_smp_mflags}
86( cd drill ; make %{?_smp_mflags} )
87( cd examples ; make %{?_smp_mflags} )
88make %{?_smp_mflags} doc
89
90%install
91rm -rf %{buildroot}
92
93make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
94make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
95
96%if %{with_python}
97# remove execute perms from python files
98chmod a-x %{buildroot}%{python_sitearch}/*py
99%endif
100
101# don't package building script in doc
102rm doc/doxyparse.pl
103#remove doc stubs
104rm -rf doc/.svn
105#remove double set of man pages
106rm -rf doc/man
107
108# remove .la files
109rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la
110(cd drill ; make DESTDIR=%{buildroot} install)
111(cd examples; make DESTDIR=%{buildroot} install)
112
113%clean
114rm -rf %{buildroot}
115
116%files
117%defattr(-,root,root)
118%{_libdir}/libldns*so.*
119%{_bindir}/drill
120%{_bindir}/ldnsd
121#%{_bindir}/ldns-*
122%{_bindir}/ldns-chaos
123%{_bindir}/ldns-compare-zones
124%{_bindir}/ldns-[d-z]*
125%doc README LICENSE
126%{_mandir}/*/*
127
128%files devel
129%defattr(-,root,root,-)
130%{_libdir}/libldns*so
131%{_bindir}/ldns-config
132%dir %{_includedir}/ldns
133%{_includedir}/ldns/*.h
134%doc doc Changelog README
135
136%if %{with_python}
137%files python
138%defattr(-,root,root)
139%{python_sitearch}/*
140%endif
141
142%post -p /sbin/ldconfig
143
144%postun -p /sbin/ldconfig
145
146%changelog
147* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.6.16-1
148- new upstream release
149
150* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.13-1
151- new upstream release
152- move python files to sitearch from sitelib
153
154* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-2
155- rebuild with python-2.7.2
156
157* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
158- new upstream release
159
160* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
161- new upstream release
162
163* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
164- new upstream release
165
166* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
167- new upstream release
168- add enable_gost flag: default disable
169- defined subdir_conf_opt rpm macro
170
171* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
172- new upstream release
173
174* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
175- new upstream release
176- drop unnecessary installfix patch (Patch1): upstream merged
177- drop unnecessary rpathfix patch (Patch2): upstream merged
178
179* Thu Jun  3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
180- rebuild with libpcap 1.1.1 on VineSeed
181
182* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
183- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
184
185* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
186- Fix missing _ldns.so causing ldns-python to not work
187- Patch for installing ldns-python files
188- Patch for rpath in ldns-python
189- Don't install .a file for ldns-python
190
191* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
192- Upgraded to 1.6.4.
193- Added ldns-python sub package
194
195* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
196- Upgraded to 1.6.3, which has minor bugfixes
197
198* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
199- Upgraded to 1.6.2. This fixes various bugs.
200  (upstream released mostly to default with sha2 for the imminent
201   signed root, but we already enabled that in our builds)
202
203* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
204- rebuilt with new openssl
205
206* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
207- Added openssl dependancy back in, since we get more functionality
208 when using openssl. Especially in 'drill'.
209
210* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
211- Updated to 1.6.1
212
213* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
214- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
215
216* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
217- Fixed the ssl patch so it can now compile --without-ssl
218
219* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
220- Added patch to compile with --without-ssl
221- Removed openssl dependancies
222- Recompiled with --without-ssl
223
224* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
225- Updated to 1.6.0
226- (did not yet compile with --without-ssl due to compile failures)
227
228* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
229- Updated to 1.6.0
230- Compile without openssl
231
232* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
233- Memory management bug when generating a sha256 key, see:
234  https://bugzilla.redhat.com/show_bug.cgi?id=493953
235
236* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
237- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
238
239* Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
240- Updated to new version, 1.5.0 had a bug preventing
241  zone signing.
242
243* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
244- Updated to new version
245
246* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
247- fixed configure flags
248
249* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
250- rebuild with new openssl
251
252* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
253- Updated to 1.4.0
254
255* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
256- enable SHA2 functionality
257
258* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
259- re-tag (don't do builds while renaming local repo dirs)
260
261* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
262- Updated to latest release
263
264* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
265- Autorebuild for GCC 4.3
266
267* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
268- Rebuild for new libcrypto
269
270* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
271- Upgraded to 1.2.2. Removed no longer needed race workaround
272
273* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
274- Try to fix racing ln -s statements in parallel builds
275
276* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
277- Added patch for ldns-read-zone that does not put @. in RRDATA
278
279* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
280- Use install -p to work around multilib conflicts for .h files
281
282* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
283- Updated to 1.2.1
284- Removed patches that got moved into upstream
285
286* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
287- Patch for ldns-key2ds to write to stdout
288- Again remove extra set of man pages from doc
289- own /usr/include/ldns (bug 233858)
290
291* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
292- Added sha256 DS record patch to ldns-key2ds
293- Minor tweaks for proper doc/man page installation.
294- Workaround for parallel builds
295
296* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
297- Own the /usr/include/ldns directory (bug #233858)
298- Removed obsoleted patch
299- Remove files form previous libtool run accidentally packages by upstream
300
301* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
302- Commented out 1.1.0 make targets, put make 1.0.1 targets.
303
304* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
305- Fixed changelog typo in date
306- Rebuild requested for PT_GNU_HASH support from gcc
307- Did not upgrade to 1.1.0 due to compile issues on x86_64
308
309* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
310- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
311
312* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
313- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
314
315* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
316- Patched 'make clean' target to get rid of object files shipped with 1.0.0
317
318* Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
319- added a make clean for 2.3.3 since .o files were left behind upstream,
320  causing failure on ppc platform
321
322* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
323- minor cleanups
324
325* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
326- reworked for svn version
327
328* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
329- Initial version
Note: See TracBrowser for help on using the repository browser.