source: projects/specs/trunk/l/ldns/ldns-vl.spec @ 2303

Revision 2303, 9.4 KB checked in by iwaim, 14 years ago (diff)

ldns 1.6.7-1

Line 
1%{?!with_python:      %global with_python      1}
2%{?!enable_gost:      %global enable_gost      0}
3
4%if %{with_python}
5%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
7%endif
8
9%if %{enable_gost}
10%define subdir_conf_opt --disable-rpath --disable-static
11%else
12%define subdir_conf_opt --disable-rpath --disable-static --disable-gost
13%endif
14
15
16Summary: Lowlevel DNS(SEC) library with API
17Summary(ja): 低レベルな DNS(SEC) ライブラリと API
18Name: ldns
19Version: 1.6.7
20Release: 1%{?_dist_release}
21License: BSD
22Url: http://www.nlnetlabs.nl/%{name}/
23Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
24Group: System Environment/Libraries
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
27BuildRequires: perl, libpcap-devel
28%if %{enable_gost}
29BuildRequires: openssl-devel >= 1.0.0
30%else
31BuildRequires: openssl-devel
32%endif
33
34Requires: libpcap, openssl
35
36Distribution: Vine Linux
37Vendor: Project Vine
38Packager: iwaim
39
40%if %{with_python}
41BuildRequires:  python-devel, swig
42%endif
43
44%description
45ldns is a library with the aim to simplify DNS programing in C. All
46lowlevel DNS/DNSSEC operations are supported. We also define a higher
47level API which allows a programmer to (for instance) create or sign
48packets.
49
50%package devel
51Summary: Development package that includes the ldns header files
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56The devel package contains the ldns library and the include files
57
58%if %{with_python}
59%package python
60Summary: Python extensions for ldns
61Group: Applications/System
62Requires: %{name} = %{version}-%{release}
63
64%description python
65Python extensions for ldns
66%endif
67
68
69%prep
70%setup -q
71
72%build
73%configure --disable-rpath --disable-static \
74%if %{with_python}
75 --with-pyldns \
76%endif
77%if !%{enable_gost}
78 --disable-gost \
79%endif
80 --with-sha2
81
82(cd drill ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
83(cd examples ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
84
85make %{?_smp_mflags}
86( cd drill ; make %{?_smp_mflags} )
87( cd examples ; make %{?_smp_mflags} )
88make %{?_smp_mflags} doc
89
90%install
91rm -rf %{buildroot}
92
93make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
94make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
95
96%if %{with_python}
97# remove execute perms from python files
98chmod a-x %{buildroot}%{python_sitelib}/*py
99%endif
100
101# don't package building script in doc
102rm doc/doxyparse.pl
103#remove doc stubs
104rm -rf doc/.svn
105#remove double set of man pages
106rm -rf doc/man
107
108# remove .la files
109rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitelib}/*.la
110(cd drill ; make DESTDIR=%{buildroot} install)
111(cd examples; make DESTDIR=%{buildroot} install)
112
113%clean
114rm -rf %{buildroot}
115
116%files
117%defattr(-,root,root)
118%{_libdir}/libldns*so.*
119%{_bindir}/drill
120%{_bindir}/ldnsd
121#%{_bindir}/ldns-*
122%{_bindir}/ldns-chaos
123%{_bindir}/ldns-compare-zones
124%{_bindir}/ldns-[d-z]*
125%doc README LICENSE
126%{_mandir}/*/*
127
128%files devel
129%defattr(-,root,root,-)
130%{_libdir}/libldns*so
131%{_bindir}/ldns-config
132%dir %{_includedir}/ldns
133%{_includedir}/ldns/*.h
134%doc doc Changelog README
135
136%if %{with_python}
137%files python
138%defattr(-,root,root)
139%{python_sitelib}/*
140%endif
141
142%post -p /sbin/ldconfig
143
144%postun -p /sbin/ldconfig
145
146%changelog
147* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
148- new upstream release
149- add enable_gost flag: default disable
150- defined subdir_conf_opt rpm macro
151
152* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
153- new upstream release
154
155* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
156- new upstream release
157- drop unnecessary installfix patch (Patch1): upstream merged
158- drop unnecessary rpathfix patch (Patch2): upstream merged
159
160* Thu Jun  3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
161- rebuild with libpcap 1.1.1 on VineSeed
162
163* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
164- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
165
166* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
167- Fix missing _ldns.so causing ldns-python to not work
168- Patch for installing ldns-python files
169- Patch for rpath in ldns-python
170- Don't install .a file for ldns-python
171
172* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
173- Upgraded to 1.6.4.
174- Added ldns-python sub package
175
176* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
177- Upgraded to 1.6.3, which has minor bugfixes
178
179* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
180- Upgraded to 1.6.2. This fixes various bugs.
181  (upstream released mostly to default with sha2 for the imminent
182   signed root, but we already enabled that in our builds)
183
184* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
185- rebuilt with new openssl
186
187* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
188- Added openssl dependancy back in, since we get more functionality
189 when using openssl. Especially in 'drill'.
190
191* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
192- Updated to 1.6.1
193
194* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
195- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
196
197* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
198- Fixed the ssl patch so it can now compile --without-ssl
199
200* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
201- Added patch to compile with --without-ssl
202- Removed openssl dependancies
203- Recompiled with --without-ssl
204
205* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
206- Updated to 1.6.0
207- (did not yet compile with --without-ssl due to compile failures)
208
209* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
210- Updated to 1.6.0
211- Compile without openssl
212
213* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
214- Memory management bug when generating a sha256 key, see:
215  https://bugzilla.redhat.com/show_bug.cgi?id=493953
216
217* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
218- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
219
220* Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
221- Updated to new version, 1.5.0 had a bug preventing
222  zone signing.
223
224* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
225- Updated to new version
226
227* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
228- fixed configure flags
229
230* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
231- rebuild with new openssl
232
233* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
234- Updated to 1.4.0
235
236* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
237- enable SHA2 functionality
238
239* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
240- re-tag (don't do builds while renaming local repo dirs)
241
242* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
243- Updated to latest release
244
245* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
246- Autorebuild for GCC 4.3
247
248* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
249- Rebuild for new libcrypto
250
251* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
252- Upgraded to 1.2.2. Removed no longer needed race workaround
253
254* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
255- Try to fix racing ln -s statements in parallel builds
256
257* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
258- Added patch for ldns-read-zone that does not put @. in RRDATA
259
260* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
261- Use install -p to work around multilib conflicts for .h files
262
263* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
264- Updated to 1.2.1
265- Removed patches that got moved into upstream
266
267* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
268- Patch for ldns-key2ds to write to stdout
269- Again remove extra set of man pages from doc
270- own /usr/include/ldns (bug 233858)
271
272* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
273- Added sha256 DS record patch to ldns-key2ds
274- Minor tweaks for proper doc/man page installation.
275- Workaround for parallel builds
276
277* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
278- Own the /usr/include/ldns directory (bug #233858)
279- Removed obsoleted patch
280- Remove files form previous libtool run accidentally packages by upstream
281
282* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
283- Commented out 1.1.0 make targets, put make 1.0.1 targets.
284
285* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
286- Fixed changelog typo in date
287- Rebuild requested for PT_GNU_HASH support from gcc
288- Did not upgrade to 1.1.0 due to compile issues on x86_64
289
290* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
291- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
292
293* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
294- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
295
296* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
297- Patched 'make clean' target to get rid of object files shipped with 1.0.0
298
299* Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
300- added a make clean for 2.3.3 since .o files were left behind upstream,
301  causing failure on ppc platform
302
303* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
304- minor cleanups
305
306* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
307- reworked for svn version
308
309* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
310- Initial version
Note: See TracBrowser for help on using the repository browser.