source: projects/specs/trunk/l/ldns/ldns-vl.spec @ 1461

Revision 1461, 8.8 KB checked in by iwaim, 14 years ago (diff)

ldns 1.6.5-1

Line 
1%{?!with_python:      %global with_python      1}
2
3%if %{with_python}
4%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6%endif
7
8Summary: Lowlevel DNS(SEC) library with API
9Summary(ja): 低レベルな DNS(SEC) ライブラリと API
10Name: ldns
11Version: 1.6.5
12Release: 1%{?_dist_release}
13License: BSD
14Url: http://www.nlnetlabs.nl/%{name}/
15Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
16Group: System Environment/Libraries
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
19BuildRequires: perl, libpcap-devel, openssl-devel
20Requires: libpcap, openssl
21
22Distribution: Vine Linux
23Vendor: Project Vine
24Packager: iwaim
25
26%if %{with_python}
27BuildRequires:  python-devel, swig
28%endif
29
30%description
31ldns is a library with the aim to simplify DNS programing in C. All
32lowlevel DNS/DNSSEC operations are supported. We also define a higher
33level API which allows a programmer to (for instance) create or sign
34packets.
35
36%package devel
37Summary: Development package that includes the ldns header files
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description devel
42The devel package contains the ldns library and the include files
43
44%if %{with_python}
45%package python
46Summary: Python extensions for ldns
47Group: Applications/System
48Requires: %{name} = %{version}-%{release}
49
50%description python
51Python extensions for ldns
52%endif
53
54
55%prep
56%setup -q
57
58%build
59%configure --disable-rpath --disable-static --with-sha2 \
60%if %{with_python}
61 --with-pyldns
62%endif
63
64(cd drill ; %configure --disable-rpath --disable-static --with-ldns=%{buildroot}/lib/ )
65(cd examples ; %configure --disable-rpath --disable-static --with-ldns=%{buildroot}/lib/ )
66
67make %{?_smp_mflags}
68( cd drill ; make %{?_smp_mflags} )
69( cd examples ; make %{?_smp_mflags} )
70make %{?_smp_mflags} doc
71
72%install
73rm -rf %{buildroot}
74
75make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
76make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
77
78%if %{with_python}
79# remove execute perms from python files
80chmod a-x %{buildroot}%{python_sitelib}/*py
81%endif
82
83# don't package building script in doc
84rm doc/doxyparse.pl
85#remove doc stubs
86rm -rf doc/.svn
87#remove double set of man pages
88rm -rf doc/man
89
90# remove .la files
91rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitelib}/*.la
92(cd drill ; make DESTDIR=%{buildroot} install)
93(cd examples; make DESTDIR=%{buildroot} install)
94
95%clean
96rm -rf %{buildroot}
97
98%files
99%defattr(-,root,root)
100%{_libdir}/libldns*so.*
101%{_bindir}/drill
102%{_bindir}/ldnsd
103#%{_bindir}/ldns-*
104%{_bindir}/ldns-chaos
105%{_bindir}/ldns-compare-zones
106%{_bindir}/ldns-[d-z]*
107%doc README LICENSE
108%{_mandir}/*/*
109
110%files devel
111%defattr(-,root,root,-)
112%{_libdir}/libldns*so
113%{_bindir}/ldns-config
114%dir %{_includedir}/ldns
115%{_includedir}/ldns/*.h
116%doc doc Changelog README
117
118%if %{with_python}
119%files python
120%defattr(-,root,root)
121%{python_sitelib}/*
122%endif
123
124%post -p /sbin/ldconfig
125
126%postun -p /sbin/ldconfig
127
128%changelog
129* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
130- new upstream release
131- drop unnecessary installfix patch (Patch1): upstream merged
132- drop unnecessary rpathfix patch (Patch2): upstream merged
133
134* Thu Jun  3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
135- rebuild with libpcap 1.1.1 on VineSeed
136
137* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
138- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
139
140* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
141- Fix missing _ldns.so causing ldns-python to not work
142- Patch for installing ldns-python files
143- Patch for rpath in ldns-python
144- Don't install .a file for ldns-python
145
146* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
147- Upgraded to 1.6.4.
148- Added ldns-python sub package
149
150* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
151- Upgraded to 1.6.3, which has minor bugfixes
152
153* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
154- Upgraded to 1.6.2. This fixes various bugs.
155  (upstream released mostly to default with sha2 for the imminent
156   signed root, but we already enabled that in our builds)
157
158* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
159- rebuilt with new openssl
160
161* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
162- Added openssl dependancy back in, since we get more functionality
163 when using openssl. Especially in 'drill'.
164
165* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
166- Updated to 1.6.1
167
168* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
169- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
170
171* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
172- Fixed the ssl patch so it can now compile --without-ssl
173
174* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
175- Added patch to compile with --without-ssl
176- Removed openssl dependancies
177- Recompiled with --without-ssl
178
179* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
180- Updated to 1.6.0
181- (did not yet compile with --without-ssl due to compile failures)
182
183* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
184- Updated to 1.6.0
185- Compile without openssl
186
187* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
188- Memory management bug when generating a sha256 key, see:
189  https://bugzilla.redhat.com/show_bug.cgi?id=493953
190
191* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
192- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
193
194* Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
195- Updated to new version, 1.5.0 had a bug preventing
196  zone signing.
197
198* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
199- Updated to new version
200
201* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
202- fixed configure flags
203
204* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
205- rebuild with new openssl
206
207* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
208- Updated to 1.4.0
209
210* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
211- enable SHA2 functionality
212
213* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
214- re-tag (don't do builds while renaming local repo dirs)
215
216* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
217- Updated to latest release
218
219* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
220- Autorebuild for GCC 4.3
221
222* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
223- Rebuild for new libcrypto
224
225* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
226- Upgraded to 1.2.2. Removed no longer needed race workaround
227
228* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
229- Try to fix racing ln -s statements in parallel builds
230
231* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
232- Added patch for ldns-read-zone that does not put @. in RRDATA
233
234* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
235- Use install -p to work around multilib conflicts for .h files
236
237* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
238- Updated to 1.2.1
239- Removed patches that got moved into upstream
240
241* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
242- Patch for ldns-key2ds to write to stdout
243- Again remove extra set of man pages from doc
244- own /usr/include/ldns (bug 233858)
245
246* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
247- Added sha256 DS record patch to ldns-key2ds
248- Minor tweaks for proper doc/man page installation.
249- Workaround for parallel builds
250
251* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
252- Own the /usr/include/ldns directory (bug #233858)
253- Removed obsoleted patch
254- Remove files form previous libtool run accidentally packages by upstream
255
256* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
257- Commented out 1.1.0 make targets, put make 1.0.1 targets.
258
259* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
260- Fixed changelog typo in date
261- Rebuild requested for PT_GNU_HASH support from gcc
262- Did not upgrade to 1.1.0 due to compile issues on x86_64
263
264* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
265- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
266
267* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
268- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
269
270* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
271- Patched 'make clean' target to get rid of object files shipped with 1.0.0
272
273* Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
274- added a make clean for 2.3.3 since .o files were left behind upstream,
275  causing failure on ppc platform
276
277* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
278- minor cleanups
279
280* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
281- reworked for svn version
282
283* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
284- Initial version
Note: See TracBrowser for help on using the repository browser.