source: projects/specs/trunk/l/ldns/ldns-vl.spec @ 11856

Revision 11856, 10.7 KB checked in by tomop, 5 years ago (diff)

ldns-1.7.0-2

Line 
1%{?!with_python:      %global with_python      1}
2%{?!enable_gost:      %global enable_gost      0}
3%{?!enable_dane:      %global enable_dane      0}
4
5%if %{with_python}
6%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
7%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
8%endif
9
10%if %{enable_gost}
11%define subdir_conf_opt --disable-rpath --disable-static
12%else
13%define subdir_conf_opt --disable-rpath --disable-static --disable-gost
14%endif
15
16
17Summary: Lowlevel DNS(SEC) library with API
18Summary(ja): 低レベルな DNS(SEC) ライブラリと API
19Name: ldns
20Version: 1.7.0
21Release: 2%{?_dist_release}
22License: BSD
23Url: http://www.nlnetlabs.nl/%{name}/
24Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
25Group: System Environment/Libraries
26BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
27BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
28BuildRequires: perl, libpcap-devel
29%if %{enable_gost}
30BuildRequires: openssl-devel >= 1.0.0
31%else
32BuildRequires: openssl-devel
33%endif
34
35Requires: libpcap, openssl
36
37Distribution: Vine Linux
38Vendor: Project Vine
39Packager: iwaim
40
41%if %{with_python}
42BuildRequires:  python-devel, swig
43%endif
44
45%description
46ldns is a library with the aim to simplify DNS programing in C. All
47lowlevel DNS/DNSSEC operations are supported. We also define a higher
48level API which allows a programmer to (for instance) create or sign
49packets.
50
51%package devel
52Summary: Development package that includes the ldns header files
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
55
56%description devel
57The devel package contains the ldns library and the include files
58
59%if %{with_python}
60%package python
61Summary: Python extensions for ldns
62Group: Applications/System
63Requires: %{name} = %{version}-%{release}
64
65%description python
66Python extensions for ldns
67%endif
68
69
70%prep
71%setup -q
72
73%build
74%configure --disable-rpath --disable-static \
75%if %{with_python}
76 --with-pyldns \
77%endif
78%if !%{enable_gost}
79 --disable-gost \
80%endif
81%if !%{enable_gost}
82 --disable-dane-verify \
83%endif
84 --with-sha2
85
86(cd drill ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
87(cd examples ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
88
89make %{?_smp_mflags}
90( cd drill ; make %{?_smp_mflags} )
91( cd examples ; make %{?_smp_mflags} )
92make %{?_smp_mflags} doc
93
94%install
95rm -rf %{buildroot}
96
97make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
98make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
99
100%if %{with_python}
101# remove execute perms from python files
102chmod a-x %{buildroot}%{python_sitearch}/*py
103%endif
104
105# don't package building script in doc
106rm doc/doxyparse.pl
107#remove doc stubs
108rm -rf doc/.svn
109#remove double set of man pages
110rm -rf doc/man
111
112# remove .la files
113rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la
114(cd drill ; make DESTDIR=%{buildroot} install)
115(cd examples; make DESTDIR=%{buildroot} install)
116
117%clean
118rm -rf %{buildroot}
119
120%files
121%defattr(-,root,root)
122%{_libdir}/libldns*so.*
123%{_bindir}/drill
124%{_bindir}/ldnsd
125#%{_bindir}/ldns-*
126%{_bindir}/ldns-chaos
127%{_bindir}/ldns-compare-zones
128%{_bindir}/ldns-[d-z]*
129%doc README LICENSE
130%{_mandir}/*/*
131
132%files devel
133%defattr(-,root,root,-)
134%{_libdir}/libldns*so
135%{_bindir}/ldns-config
136%dir %{_includedir}/ldns
137%{_includedir}/ldns/*.h
138%doc doc Changelog README
139
140%if %{with_python}
141%files python
142%defattr(-,root,root)
143%{python_sitearch}/*
144%endif
145
146%post -p /sbin/ldconfig
147
148%postun -p /sbin/ldconfig
149
150%changelog
151* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-2
152- rebuilt with openssl-1.1.1.
153
154* Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.0-1
155- update to 1.7.0
156- add enable_dane option
157
158* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.17-2
159- rebuilt with openssl-1.0.2g.
160
161* Mon Mar  9 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.17-1
162- update to 1.6.17
163- drop 'fix compiler warnings and one uninitialized value' patch (Patch1000)
164 - upstream merged
165
166* Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.16-2
167- add 'fix compiler warnings and one uninitialized value' patch (Patch1000)
168 - from Fedora ldns-1.6.16-6.fc20
169
170* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.6.16-1
171- new upstream release
172
173* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.13-1
174- new upstream release
175- move python files to sitearch from sitelib
176
177* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-2
178- rebuild with python-2.7.2
179
180* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
181- new upstream release
182
183* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
184- new upstream release
185
186* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
187- new upstream release
188
189* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
190- new upstream release
191- add enable_gost flag: default disable
192- defined subdir_conf_opt rpm macro
193
194* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
195- new upstream release
196
197* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
198- new upstream release
199- drop unnecessary installfix patch (Patch1): upstream merged
200- drop unnecessary rpathfix patch (Patch2): upstream merged
201
202* Thu Jun  3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
203- rebuild with libpcap 1.1.1 on VineSeed
204
205* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
206- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
207
208* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
209- Fix missing _ldns.so causing ldns-python to not work
210- Patch for installing ldns-python files
211- Patch for rpath in ldns-python
212- Don't install .a file for ldns-python
213
214* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
215- Upgraded to 1.6.4.
216- Added ldns-python sub package
217
218* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
219- Upgraded to 1.6.3, which has minor bugfixes
220
221* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
222- Upgraded to 1.6.2. This fixes various bugs.
223  (upstream released mostly to default with sha2 for the imminent
224   signed root, but we already enabled that in our builds)
225
226* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
227- rebuilt with new openssl
228
229* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
230- Added openssl dependancy back in, since we get more functionality
231 when using openssl. Especially in 'drill'.
232
233* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
234- Updated to 1.6.1
235
236* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
237- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
238
239* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
240- Fixed the ssl patch so it can now compile --without-ssl
241
242* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
243- Added patch to compile with --without-ssl
244- Removed openssl dependancies
245- Recompiled with --without-ssl
246
247* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
248- Updated to 1.6.0
249- (did not yet compile with --without-ssl due to compile failures)
250
251* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
252- Updated to 1.6.0
253- Compile without openssl
254
255* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
256- Memory management bug when generating a sha256 key, see:
257  https://bugzilla.redhat.com/show_bug.cgi?id=493953
258
259* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
260- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
261
262* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
263- Updated to new version, 1.5.0 had a bug preventing
264  zone signing.
265
266* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
267- Updated to new version
268
269* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
270- fixed configure flags
271
272* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
273- rebuild with new openssl
274
275* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
276- Updated to 1.4.0
277
278* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
279- enable SHA2 functionality
280
281* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
282- re-tag (don't do builds while renaming local repo dirs)
283
284* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
285- Updated to latest release
286
287* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
288- Autorebuild for GCC 4.3
289
290* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
291- Rebuild for new libcrypto
292
293* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
294- Upgraded to 1.2.2. Removed no longer needed race workaround
295
296* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
297- Try to fix racing ln -s statements in parallel builds
298
299* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
300- Added patch for ldns-read-zone that does not put @. in RRDATA
301
302* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
303- Use install -p to work around multilib conflicts for .h files
304
305* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
306- Updated to 1.2.1
307- Removed patches that got moved into upstream
308
309* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
310- Patch for ldns-key2ds to write to stdout
311- Again remove extra set of man pages from doc
312- own /usr/include/ldns (bug 233858)
313
314* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
315- Added sha256 DS record patch to ldns-key2ds
316- Minor tweaks for proper doc/man page installation.
317- Workaround for parallel builds
318
319* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
320- Own the /usr/include/ldns directory (bug #233858)
321- Removed obsoleted patch
322- Remove files form previous libtool run accidentally packages by upstream
323
324* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
325- Commented out 1.1.0 make targets, put make 1.0.1 targets.
326
327* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
328- Fixed changelog typo in date
329- Rebuild requested for PT_GNU_HASH support from gcc
330- Did not upgrade to 1.1.0 due to compile issues on x86_64
331
332* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
333- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
334
335* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
336- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
337
338* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
339- Patched 'make clean' target to get rid of object files shipped with 1.0.0
340
341* Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
342- added a make clean for 2.3.3 since .o files were left behind upstream,
343  causing failure on ppc platform
344
345* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
346- minor cleanups
347
348* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
349- reworked for svn version
350
351* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
352- Initial version
Note: See TracBrowser for help on using the repository browser.