source: projects/specs/trunk/l/ldns/ldns-vl.spec @ 10085

Revision 10085, 10.4 KB checked in by tomop, 8 years ago (diff)

ldns-1.6.17-2

Line 
1%{?!with_python:      %global with_python      1}
2%{?!enable_gost:      %global enable_gost      0}
3
4%if %{with_python}
5%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
7%endif
8
9%if %{enable_gost}
10%define subdir_conf_opt --disable-rpath --disable-static
11%else
12%define subdir_conf_opt --disable-rpath --disable-static --disable-gost
13%endif
14
15
16Summary: Lowlevel DNS(SEC) library with API
17Summary(ja): 低レベルな DNS(SEC) ライブラリと API
18Name: ldns
19Version: 1.6.17
20Release: 2%{?_dist_release}
21License: BSD
22Url: http://www.nlnetlabs.nl/%{name}/
23Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
24Group: System Environment/Libraries
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
27BuildRequires: perl, libpcap-devel
28%if %{enable_gost}
29BuildRequires: openssl-devel >= 1.0.0
30%else
31BuildRequires: openssl-devel
32%endif
33
34Requires: libpcap, openssl
35
36Distribution: Vine Linux
37Vendor: Project Vine
38Packager: iwaim
39
40%if %{with_python}
41BuildRequires:  python-devel, swig
42%endif
43
44%description
45ldns is a library with the aim to simplify DNS programing in C. All
46lowlevel DNS/DNSSEC operations are supported. We also define a higher
47level API which allows a programmer to (for instance) create or sign
48packets.
49
50%package devel
51Summary: Development package that includes the ldns header files
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56The devel package contains the ldns library and the include files
57
58%if %{with_python}
59%package python
60Summary: Python extensions for ldns
61Group: Applications/System
62Requires: %{name} = %{version}-%{release}
63
64%description python
65Python extensions for ldns
66%endif
67
68
69%prep
70%setup -q
71
72%build
73%configure --disable-rpath --disable-static \
74%if %{with_python}
75 --with-pyldns \
76%endif
77%if !%{enable_gost}
78 --disable-gost \
79%endif
80 --with-sha2
81
82(cd drill ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
83(cd examples ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
84
85make %{?_smp_mflags}
86( cd drill ; make %{?_smp_mflags} )
87( cd examples ; make %{?_smp_mflags} )
88make %{?_smp_mflags} doc
89
90%install
91rm -rf %{buildroot}
92
93make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
94make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
95
96%if %{with_python}
97# remove execute perms from python files
98chmod a-x %{buildroot}%{python_sitearch}/*py
99%endif
100
101# don't package building script in doc
102rm doc/doxyparse.pl
103#remove doc stubs
104rm -rf doc/.svn
105#remove double set of man pages
106rm -rf doc/man
107
108# remove .la files
109rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la
110(cd drill ; make DESTDIR=%{buildroot} install)
111(cd examples; make DESTDIR=%{buildroot} install)
112
113%clean
114rm -rf %{buildroot}
115
116%files
117%defattr(-,root,root)
118%{_libdir}/libldns*so.*
119%{_bindir}/drill
120%{_bindir}/ldnsd
121#%{_bindir}/ldns-*
122%{_bindir}/ldns-chaos
123%{_bindir}/ldns-compare-zones
124%{_bindir}/ldns-[d-z]*
125%doc README LICENSE
126%{_mandir}/*/*
127
128%files devel
129%defattr(-,root,root,-)
130%{_libdir}/libldns*so
131%{_bindir}/ldns-config
132%dir %{_includedir}/ldns
133%{_includedir}/ldns/*.h
134%doc doc Changelog README
135
136%if %{with_python}
137%files python
138%defattr(-,root,root)
139%{python_sitearch}/*
140%endif
141
142%post -p /sbin/ldconfig
143
144%postun -p /sbin/ldconfig
145
146%changelog
147* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.17-2
148- rebuilt with openssl-1.0.2g.
149
150* Mon Mar  9 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.17-1
151- update to 1.6.17
152- drop 'fix compiler warnings and one uninitialized value' patch (Patch1000)
153 - upstream merged
154
155* Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.16-2
156- add 'fix compiler warnings and one uninitialized value' patch (Patch1000)
157 - from Fedora ldns-1.6.16-6.fc20
158
159* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.6.16-1
160- new upstream release
161
162* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.13-1
163- new upstream release
164- move python files to sitearch from sitelib
165
166* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-2
167- rebuild with python-2.7.2
168
169* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
170- new upstream release
171
172* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
173- new upstream release
174
175* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
176- new upstream release
177
178* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
179- new upstream release
180- add enable_gost flag: default disable
181- defined subdir_conf_opt rpm macro
182
183* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
184- new upstream release
185
186* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
187- new upstream release
188- drop unnecessary installfix patch (Patch1): upstream merged
189- drop unnecessary rpathfix patch (Patch2): upstream merged
190
191* Thu Jun  3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
192- rebuild with libpcap 1.1.1 on VineSeed
193
194* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
195- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
196
197* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
198- Fix missing _ldns.so causing ldns-python to not work
199- Patch for installing ldns-python files
200- Patch for rpath in ldns-python
201- Don't install .a file for ldns-python
202
203* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
204- Upgraded to 1.6.4.
205- Added ldns-python sub package
206
207* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
208- Upgraded to 1.6.3, which has minor bugfixes
209
210* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
211- Upgraded to 1.6.2. This fixes various bugs.
212  (upstream released mostly to default with sha2 for the imminent
213   signed root, but we already enabled that in our builds)
214
215* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
216- rebuilt with new openssl
217
218* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
219- Added openssl dependancy back in, since we get more functionality
220 when using openssl. Especially in 'drill'.
221
222* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
223- Updated to 1.6.1
224
225* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
226- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
227
228* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
229- Fixed the ssl patch so it can now compile --without-ssl
230
231* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
232- Added patch to compile with --without-ssl
233- Removed openssl dependancies
234- Recompiled with --without-ssl
235
236* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
237- Updated to 1.6.0
238- (did not yet compile with --without-ssl due to compile failures)
239
240* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
241- Updated to 1.6.0
242- Compile without openssl
243
244* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
245- Memory management bug when generating a sha256 key, see:
246  https://bugzilla.redhat.com/show_bug.cgi?id=493953
247
248* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
249- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
250
251* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
252- Updated to new version, 1.5.0 had a bug preventing
253  zone signing.
254
255* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
256- Updated to new version
257
258* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
259- fixed configure flags
260
261* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
262- rebuild with new openssl
263
264* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
265- Updated to 1.4.0
266
267* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
268- enable SHA2 functionality
269
270* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
271- re-tag (don't do builds while renaming local repo dirs)
272
273* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
274- Updated to latest release
275
276* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
277- Autorebuild for GCC 4.3
278
279* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
280- Rebuild for new libcrypto
281
282* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
283- Upgraded to 1.2.2. Removed no longer needed race workaround
284
285* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
286- Try to fix racing ln -s statements in parallel builds
287
288* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
289- Added patch for ldns-read-zone that does not put @. in RRDATA
290
291* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
292- Use install -p to work around multilib conflicts for .h files
293
294* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
295- Updated to 1.2.1
296- Removed patches that got moved into upstream
297
298* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
299- Patch for ldns-key2ds to write to stdout
300- Again remove extra set of man pages from doc
301- own /usr/include/ldns (bug 233858)
302
303* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
304- Added sha256 DS record patch to ldns-key2ds
305- Minor tweaks for proper doc/man page installation.
306- Workaround for parallel builds
307
308* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
309- Own the /usr/include/ldns directory (bug #233858)
310- Removed obsoleted patch
311- Remove files form previous libtool run accidentally packages by upstream
312
313* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
314- Commented out 1.1.0 make targets, put make 1.0.1 targets.
315
316* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
317- Fixed changelog typo in date
318- Rebuild requested for PT_GNU_HASH support from gcc
319- Did not upgrade to 1.1.0 due to compile issues on x86_64
320
321* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
322- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
323
324* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
325- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
326
327* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
328- Patched 'make clean' target to get rid of object files shipped with 1.0.0
329
330* Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
331- added a make clean for 2.3.3 since .o files were left behind upstream,
332  causing failure on ppc platform
333
334* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
335- minor cleanups
336
337* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
338- reworked for svn version
339
340* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
341- Initial version
Note: See TracBrowser for help on using the repository browser.