source: projects/specs/trunk/l/ldns/ldns-vl.spec @ 1133

Revision 1133, 8.8 KB checked in by iwaim, 14 years ago (diff)

ldns: 1.6.4-2

Line 
1%{?!with_python:      %global with_python      1}
2
3%if %{with_python}
4%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6%endif
7
8Summary: Lowlevel DNS(SEC) library with API
9Summary(ja): 低レベルな DNS(SEC) ライブラリと API
10Name: ldns
11Version: 1.6.4
12Release: 2%{?_dist_release}
13License: BSD
14Url: http://www.nlnetlabs.nl/%{name}/
15Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
16Group: System Environment/Libraries
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
19BuildRequires: perl, libpcap-devel, openssl-devel
20Requires: libpcap, openssl
21Patch1: ldns-installfix-r3167.patch
22Patch2: ldns-rpathfix.patch
23
24Distribution: Vine Linux
25Vendor: Project Vine
26Packager: iwaim
27
28%if %{with_python}
29BuildRequires:  python-devel, swig
30%endif
31
32%description
33ldns is a library with the aim to simplify DNS programing in C. All
34lowlevel DNS/DNSSEC operations are supported. We also define a higher
35level API which allows a programmer to (for instance) create or sign
36packets.
37
38%package devel
39Summary: Development package that includes the ldns header files
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44The devel package contains the ldns library and the include files
45
46%if %{with_python}
47%package python
48Summary: Python extensions for ldns
49Group: Applications/System
50Requires: %{name} = %{version}-%{release}
51
52%description python
53Python extensions for ldns
54%endif
55
56
57%prep
58%setup -q
59%patch1
60%patch2
61# To built svn snapshots
62rm config.guess config.sub ltmain.sh
63aclocal
64libtoolize -c --install
65autoreconf --install
66
67%build
68%configure --disable-rpath --disable-static --with-sha2 \
69%if %{with_python}
70 --with-pyldns
71%endif
72
73(cd drill ; %configure --disable-rpath --disable-static --with-ldns=%{buildroot}/lib/ )
74(cd examples ; %configure --disable-rpath --disable-static --with-ldns=%{buildroot}/lib/ )
75
76make %{?_smp_mflags}
77( cd drill ; make %{?_smp_mflags} )
78( cd examples ; make %{?_smp_mflags} )
79make %{?_smp_mflags} doc
80
81%install
82rm -rf %{buildroot}
83
84make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
85make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
86
87%if %{with_python}
88# remove execute perms from python files
89chmod a-x %{buildroot}%{python_sitelib}/*py
90%endif
91
92# don't package building script in doc
93rm doc/doxyparse.pl
94#remove doc stubs
95rm -rf doc/.svn
96#remove double set of man pages
97rm -rf doc/man
98
99# remove .la files
100rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitelib}/*.la
101(cd drill ; make DESTDIR=%{buildroot} install)
102(cd examples; make DESTDIR=%{buildroot} install)
103
104%clean
105rm -rf %{buildroot}
106
107%files
108%defattr(-,root,root)
109%{_libdir}/libldns*so.*
110%{_bindir}/drill
111%{_bindir}/ldnsd
112#%{_bindir}/ldns-*
113%{_bindir}/ldns-chaos
114%{_bindir}/ldns-compare-zones
115%{_bindir}/ldns-[d-z]*
116%doc README LICENSE
117%{_mandir}/*/*
118
119%files devel
120%defattr(-,root,root,-)
121%{_libdir}/libldns*so
122%{_bindir}/ldns-config
123%dir %{_includedir}/ldns
124%{_includedir}/ldns/*.h
125%doc doc Changelog README
126
127%if %{with_python}
128%files python
129%defattr(-,root,root)
130%{python_sitelib}/*
131%endif
132
133%post -p /sbin/ldconfig
134
135%postun -p /sbin/ldconfig
136
137%changelog
138* Thu Jun  3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
139- rebuild with libpcap 1.1.1 on VineSeed
140
141* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
142- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
143
144* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
145- Fix missing _ldns.so causing ldns-python to not work
146- Patch for installing ldns-python files
147- Patch for rpath in ldns-python
148- Don't install .a file for ldns-python
149
150* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
151- Upgraded to 1.6.4.
152- Added ldns-python sub package
153
154* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
155- Upgraded to 1.6.3, which has minor bugfixes
156
157* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
158- Upgraded to 1.6.2. This fixes various bugs.
159  (upstream released mostly to default with sha2 for the imminent
160   signed root, but we already enabled that in our builds)
161
162* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
163- rebuilt with new openssl
164
165* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
166- Added openssl dependancy back in, since we get more functionality
167 when using openssl. Especially in 'drill'.
168
169* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
170- Updated to 1.6.1
171
172* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
174
175* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
176- Fixed the ssl patch so it can now compile --without-ssl
177
178* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
179- Added patch to compile with --without-ssl
180- Removed openssl dependancies
181- Recompiled with --without-ssl
182
183* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
184- Updated to 1.6.0
185- (did not yet compile with --without-ssl due to compile failures)
186
187* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
188- Updated to 1.6.0
189- Compile without openssl
190
191* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
192- Memory management bug when generating a sha256 key, see:
193  https://bugzilla.redhat.com/show_bug.cgi?id=493953
194
195* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
196- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
197
198* Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
199- Updated to new version, 1.5.0 had a bug preventing
200  zone signing.
201
202* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
203- Updated to new version
204
205* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
206- fixed configure flags
207
208* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
209- rebuild with new openssl
210
211* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
212- Updated to 1.4.0
213
214* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
215- enable SHA2 functionality
216
217* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
218- re-tag (don't do builds while renaming local repo dirs)
219
220* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
221- Updated to latest release
222
223* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
224- Autorebuild for GCC 4.3
225
226* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
227- Rebuild for new libcrypto
228
229* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
230- Upgraded to 1.2.2. Removed no longer needed race workaround
231
232* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
233- Try to fix racing ln -s statements in parallel builds
234
235* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
236- Added patch for ldns-read-zone that does not put @. in RRDATA
237
238* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
239- Use install -p to work around multilib conflicts for .h files
240
241* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
242- Updated to 1.2.1
243- Removed patches that got moved into upstream
244
245* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
246- Patch for ldns-key2ds to write to stdout
247- Again remove extra set of man pages from doc
248- own /usr/include/ldns (bug 233858)
249
250* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
251- Added sha256 DS record patch to ldns-key2ds
252- Minor tweaks for proper doc/man page installation.
253- Workaround for parallel builds
254
255* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
256- Own the /usr/include/ldns directory (bug #233858)
257- Removed obsoleted patch
258- Remove files form previous libtool run accidentally packages by upstream
259
260* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
261- Commented out 1.1.0 make targets, put make 1.0.1 targets.
262
263* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
264- Fixed changelog typo in date
265- Rebuild requested for PT_GNU_HASH support from gcc
266- Did not upgrade to 1.1.0 due to compile issues on x86_64
267
268* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
269- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
270
271* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
272- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
273
274* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
275- Patched 'make clean' target to get rid of object files shipped with 1.0.0
276
277* Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
278- added a make clean for 2.3.3 since .o files were left behind upstream,
279  causing failure on ppc platform
280
281* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
282- minor cleanups
283
284* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
285- reworked for svn version
286
287* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
288- Initial version
Note: See TracBrowser for help on using the repository browser.