source: projects/specs/trunk/l/ldns/ldns-vl.spec @ 6245

Revision 6245, 9.8 KB checked in by daisuke, 12 years ago (diff)

update to 1.6.13

RevLine 
[972]1%{?!with_python:      %global with_python      1}
[2303]2%{?!enable_gost:      %global enable_gost      0}
[972]3
4%if %{with_python}
5%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
7%endif
8
[2303]9%if %{enable_gost}
10%define subdir_conf_opt --disable-rpath --disable-static
11%else
12%define subdir_conf_opt --disable-rpath --disable-static --disable-gost
13%endif
14
15
[972]16Summary: Lowlevel DNS(SEC) library with API
[973]17Summary(ja): 低レベルな DNS(SEC) ライブラリと API
[972]18Name: ldns
[6245]19Version: 1.6.13
20Release: 1%{?_dist_release}
[972]21License: BSD
22Url: http://www.nlnetlabs.nl/%{name}/
23Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
24Group: System Environment/Libraries
[973]25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
[972]26BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
[2303]27BuildRequires: perl, libpcap-devel
28%if %{enable_gost}
29BuildRequires: openssl-devel >= 1.0.0
30%else
31BuildRequires: openssl-devel
32%endif
33
[973]34Requires: libpcap, openssl
[972]35
[973]36Distribution: Vine Linux
37Vendor: Project Vine
38Packager: iwaim
39
[972]40%if %{with_python}
41BuildRequires:  python-devel, swig
42%endif
43
44%description
45ldns is a library with the aim to simplify DNS programing in C. All
46lowlevel DNS/DNSSEC operations are supported. We also define a higher
47level API which allows a programmer to (for instance) create or sign
48packets.
49
50%package devel
51Summary: Development package that includes the ldns header files
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56The devel package contains the ldns library and the include files
57
58%if %{with_python}
59%package python
60Summary: Python extensions for ldns
61Group: Applications/System
62Requires: %{name} = %{version}-%{release}
63
64%description python
65Python extensions for ldns
66%endif
67
68
69%prep
70%setup -q
71
72%build
[2303]73%configure --disable-rpath --disable-static \
[972]74%if %{with_python}
[2303]75 --with-pyldns \
[972]76%endif
[2303]77%if !%{enable_gost}
78 --disable-gost \
79%endif
80 --with-sha2
[972]81
[2303]82(cd drill ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
83(cd examples ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
[972]84
85make %{?_smp_mflags}
86( cd drill ; make %{?_smp_mflags} )
87( cd examples ; make %{?_smp_mflags} )
88make %{?_smp_mflags} doc
89
90%install
91rm -rf %{buildroot}
92
93make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
94make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
95
96%if %{with_python}
97# remove execute perms from python files
[6245]98chmod a-x %{buildroot}%{python_sitearch}/*py
[972]99%endif
100
101# don't package building script in doc
102rm doc/doxyparse.pl
103#remove doc stubs
104rm -rf doc/.svn
105#remove double set of man pages
106rm -rf doc/man
107
108# remove .la files
[6245]109rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la
[972]110(cd drill ; make DESTDIR=%{buildroot} install)
111(cd examples; make DESTDIR=%{buildroot} install)
112
113%clean
114rm -rf %{buildroot}
115
116%files
117%defattr(-,root,root)
118%{_libdir}/libldns*so.*
119%{_bindir}/drill
120%{_bindir}/ldnsd
121#%{_bindir}/ldns-*
122%{_bindir}/ldns-chaos
123%{_bindir}/ldns-compare-zones
124%{_bindir}/ldns-[d-z]*
125%doc README LICENSE
126%{_mandir}/*/*
127
128%files devel
129%defattr(-,root,root,-)
130%{_libdir}/libldns*so
131%{_bindir}/ldns-config
132%dir %{_includedir}/ldns
133%{_includedir}/ldns/*.h
134%doc doc Changelog README
135
136%if %{with_python}
137%files python
138%defattr(-,root,root)
[6245]139%{python_sitearch}/*
[972]140%endif
141
142%post -p /sbin/ldconfig
143
144%postun -p /sbin/ldconfig
145
146%changelog
[6245]147* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.13-1
148- new upstream release
149- move python files to sitearch from sitelib
150
[5787]151* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-2
152- rebuild with python-2.7.2
153
[4906]154* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
155- new upstream release
156
[3247]157* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
158- new upstream release
159
[3138]160* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
161- new upstream release
162
[2303]163* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
164- new upstream release
165- add enable_gost flag: default disable
166- defined subdir_conf_opt rpm macro
167
[1799]168* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
169- new upstream release
170
[1461]171* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
172- new upstream release
173- drop unnecessary installfix patch (Patch1): upstream merged
174- drop unnecessary rpathfix patch (Patch2): upstream merged
175
[1133]176* Thu Jun  3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
177- rebuild with libpcap 1.1.1 on VineSeed
178
[973]179* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
180- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
181
[972]182* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
183- Fix missing _ldns.so causing ldns-python to not work
184- Patch for installing ldns-python files
185- Patch for rpath in ldns-python
186- Don't install .a file for ldns-python
187
188* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
189- Upgraded to 1.6.4.
190- Added ldns-python sub package
191
192* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
193- Upgraded to 1.6.3, which has minor bugfixes
194
195* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
196- Upgraded to 1.6.2. This fixes various bugs.
197  (upstream released mostly to default with sha2 for the imminent
198   signed root, but we already enabled that in our builds)
199
200* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
201- rebuilt with new openssl
202
203* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
204- Added openssl dependancy back in, since we get more functionality
205 when using openssl. Especially in 'drill'.
206
207* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
208- Updated to 1.6.1
209
210* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
211- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
212
213* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
214- Fixed the ssl patch so it can now compile --without-ssl
215
216* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
217- Added patch to compile with --without-ssl
218- Removed openssl dependancies
219- Recompiled with --without-ssl
220
221* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
222- Updated to 1.6.0
223- (did not yet compile with --without-ssl due to compile failures)
224
225* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
226- Updated to 1.6.0
227- Compile without openssl
228
229* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
230- Memory management bug when generating a sha256 key, see:
231  https://bugzilla.redhat.com/show_bug.cgi?id=493953
232
233* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
235
236* Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
237- Updated to new version, 1.5.0 had a bug preventing
238  zone signing.
239
240* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
241- Updated to new version
242
243* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
244- fixed configure flags
245
246* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
247- rebuild with new openssl
248
249* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
250- Updated to 1.4.0
251
252* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
253- enable SHA2 functionality
254
255* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
256- re-tag (don't do builds while renaming local repo dirs)
257
258* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
259- Updated to latest release
260
261* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
262- Autorebuild for GCC 4.3
263
264* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
265- Rebuild for new libcrypto
266
267* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
268- Upgraded to 1.2.2. Removed no longer needed race workaround
269
270* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
271- Try to fix racing ln -s statements in parallel builds
272
273* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
274- Added patch for ldns-read-zone that does not put @. in RRDATA
275
276* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
277- Use install -p to work around multilib conflicts for .h files
278
279* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
280- Updated to 1.2.1
281- Removed patches that got moved into upstream
282
283* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
284- Patch for ldns-key2ds to write to stdout
285- Again remove extra set of man pages from doc
286- own /usr/include/ldns (bug 233858)
287
288* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
289- Added sha256 DS record patch to ldns-key2ds
290- Minor tweaks for proper doc/man page installation.
291- Workaround for parallel builds
292
293* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
294- Own the /usr/include/ldns directory (bug #233858)
295- Removed obsoleted patch
296- Remove files form previous libtool run accidentally packages by upstream
297
298* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
299- Commented out 1.1.0 make targets, put make 1.0.1 targets.
300
301* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
302- Fixed changelog typo in date
303- Rebuild requested for PT_GNU_HASH support from gcc
304- Did not upgrade to 1.1.0 due to compile issues on x86_64
305
306* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
307- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
308
309* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
310- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
311
312* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
313- Patched 'make clean' target to get rid of object files shipped with 1.0.0
314
315* Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
316- added a make clean for 2.3.3 since .o files were left behind upstream,
317  causing failure on ppc platform
318
319* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
320- minor cleanups
321
322* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
323- reworked for svn version
324
325* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
326- Initial version
Note: See TracBrowser for help on using the repository browser.