source: projects/specs/trunk/k/konq-plugins/konq-plugins-vl.spec @ 3006

Revision 3006, 9.2 KB checked in by inagaki, 13 years ago (diff)

update: KDE 4.6.1

Line 
1# The 4.6.1 tarball is missing all documentation, keep the old one for now.
2%global docversion 4.4.0
3
4Name:           konq-plugins
5Summary:        Additional plugins that interact with konqueror
6Version:        4.6.1
7Release:        2%{?_dist_release}
8
9Group:          Applications/Internet
10License:        GPLv2+ and LGPLv2+
11URL:            http://extragear.kde.org
12
13Source0:        ftp://ftp.kde.org/pub/kde/stable/%{version}/src/konq-plugins-%{version}.tar.bz2
14Source1:        ftp://ftp.kde.org/pub/kde/stable/%{docversion}/src/extragear/konq-plugins-%{docversion}.tar.bz2
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18## upstream patches
19
20BuildRequires: cmake
21BuildRequires: gettext
22BuildRequires: kdebase4-devel >= %{version}
23BuildRequires: libtidy-devel
24
25#{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
26Requires: kdebase4 >= %{version}
27
28%description
29Some additional plugins that interact with konqueror
30* adblock: AdBlock plugin
31* akregator: Add feeds directly to akregator (kdepim is needed)
32* autorefresh: Refresh websites after a specifig period
33* babelfish: Translate a website with babelfish
34* crashes: Crash monitor
35* dirfilter: Filter the current directory in many ways
36* domtreeviewer: Displays the document object model in a box
37* fsview: Graphical Disk Usage for inode/directory
38* imagerotation: service menu to image operations
39* khtmlsettingsplugin: Enable/disable some HTML settings
40* kimggalleryplugin:  Creates an HTML page with thumbnails of
41  all the images in the current directory.
42* mediarealfolder:  service menu to open a medium mountpoints
43* minitools: Implement bookmarklets into konqueror
44* rellinks: Allows access to relations defined in the header of a document
45* searchbar: Search Bar
46* sidebar: a small embedded mediaplayer, for songs/video preview
47* smbmounter: provides two menus items to smbmount/umount samba shares
48* uachanger: Change the user agent for websites
49* validators: Website validators
50* webarchiver: Web Archiver
51
52
53%prep
54%setup -q -a 1
55# use documentation from the old tarball
56mv -f %{name}-%{docversion}/doc* .
57tail -n 2 %{name}-%{docversion}/CMakeLists.txt >>CMakeLists.txt
58rm -rf %{name}-%{docversion}
59
60
61%build
62mkdir -p %{_target_platform}
63pushd %{_target_platform}
64unset QTDIR || : ; . /etc/profile.d/qt4.sh
65%cmake \
66    -DCMAKE_BUILD_TYPE=release \
67    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
68    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
69    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
70    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
71    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
72    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
73    ..
74popd
75
76make %{?_smp_mflags} -C %{_target_platform}
77
78
79%install
80rm -rf %{buildroot}
81
82make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
83
84# don't install kwebkitpart stuff on RHEL
85#rm -rf %{buildroot}%{_kde4_appsdir}/kwebkitpart/
86
87#find_lang %{name}
88#--with-kde
89
90
91%clean
92rm -rf %{buildroot}
93
94
95%post
96touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
97touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
98
99%postun
100if [ $1 -eq 0 ] ; then
101  touch --no-create %{_datadir}/icons/hicolor &> /dev/null
102  touch --no-create %{_datadir}/icons/oxygen &> /dev/null
103  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
104  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
105fi
106
107%posttrans
108gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
109gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
110
111
112#-f %{name}.lang
113%files
114%defattr(-,root,root,-)
115%doc COPYING COPYING.DOC COPYING.LIB README
116%{_bindir}/fsview
117%{_datadir}/config/translaterc
118# co-owned with kdepim, since there's no shared dep
119%{_datadir}/kde4/apps/akregator/
120%{_datadir}/kde4/apps/dolphinpart/kpartplugins/*
121%{_datadir}/kde4/apps/domtreeviewer/
122%{_datadir}/kde4/apps/fsview/
123%{_datadir}/kde4/apps/khtml/kpartplugins/*
124%{_datadir}/kde4/apps/konqueror/icons/*
125%{_datadir}/kde4/apps/konqueror/kpartplugins/*
126%{_datadir}/kde4/apps/konqueror/opensearch/*
127%{_datadir}/kde4/apps/kwebkitpart/kpartplugins/*
128%{_datadir}/config.kcfg/validators.kcfg
129%{_datadir}/kde4/services/*.desktop
130%{_datadir}/kde4/services/ServiceMenus/*.desktop
131%{_datadir}/icons/hicolor/*/*/*
132%{_datadir}/icons/oxygen/*/*/*
133%{_libdir}/kde4/*.so
134%{_docdir}/HTML/*/konq-plugins
135
136
137%changelog
138* Mon Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.1-2
139- initial build for Vine Linux
140
141* Sat Mar 05 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.1-1
142- update to 4.6.1, fixes file conflict with kde-l10n
143- drop upstreamed patches
144- use documentation from 4.4.0 because it's missing in 4.6.1
145- drop old commented-out translation-finding code
146- drop no longer needed BR webkitpart-devel, code uses abstract interfaces now
147
148* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.0-7
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
150
151* Tue Oct 26 2010 Alexey Kurov <nucleo@fedoraproject.org> - 4.4.0-6
152- Fix the window.close regression in adblock (kde#253921)
153
154* Tue Sep 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-5
155- Embeddable Image Viewer permanently messes up status bar (kde#234624)
156
157* Tue Sep 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-4
158- ftbfs qt47 issues (#599830)
159
160* Tue Feb 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-3
161- Requires: kdebase4 (it's not multilib'd, no need for arch'd dep)
162
163* Sat Feb 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.4.0-2
164- backport upstream patch to fix BabelFish plugin WebKitPart support (#564552)
165
166* Fri Feb 12 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-1
167- konq-plugins-4.4.0 for real
168
169* Thu Feb 11 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-0.1.20100211
170- home-brew konq-plugins-4.4.0 (20100211 create_tarball.rb snapshot)
171
172* Thu Dec 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.3-5
173- BR libtidy-devel (Fedora only)
174
175* Thu Dec 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.3-4
176- fix build with KDE 4.3.80's version of webkitkde (upstream patch)
177
178* Wed Nov 25 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.3-3
179- rebuild for Qt 4.6.0 RC1 in F13 (was built against Beta 1 with unstable ABI)
180
181* Mon Nov 09 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.3-2
182- BR: webkitpart-devel >= 0.0.2
183
184* Sat Nov 07 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.3-1
185- 4.3.3
186
187* Mon Oct 26 2009 Than Ngo <than@redhat.com> - 4.3.1-3
188- rhel cleanup
189
190* Sun Sep 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-2
191- BR: webkitpart-devel
192- use %%find_lang --all-names --with-kde
193- Requires: kdebase4%%{_?isa} >= %%version
194
195* Tue Sep 01 2009 Sebastian Vahl <svahl@fedoraproject.org> - 4.3.1-1
196- 4.3.1
197- use scriplet for HTML docdirs
198
199* Tue Aug 11 2009 Sebastian Vahl <fedora@deadbabylon.de> 4.3.0-1
200* KDE 4.3.0
201
202* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.3-2
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
204
205* Fri May 08 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.3-1
206- 4.2.3
207
208* Tue Apr  7 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
209- KDE 4.2.2
210
211* Wed Mar 25 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.0-4
212- fixup handbook install
213- optimize scriptlets
214
215* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-3
216- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
217
218* Wed Feb 18 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.0-2
219- update %%description
220- Requires: kdebase4 >= 4.2
221
222* Fri Jan 23 2009 Than Ngo <than@redhat.com> - 4.2.0-1
223- 4.2.0
224
225* Mon Jan 05 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.3-4
226- make install/fast
227- jpegorient is not installed (#478736, kdebug#178612)
228
229* Sun Dec 14 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.3-3
230- rebuild for Python 2.6 (contains Python bytecode despite no dependencies)
231
232* Tue Nov 11 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.1.3-2
233- include adblock language files
234
235* Tue Nov 11 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.1.3-1
236- 4.1.3
237
238* Sat Oct 04 2008 Than Ngo <than@redhat.com> 4.1.2-1
239- 4.1.2
240
241* Fri Aug 29 2008 Than Ngo <than@redhat.com> 4.1.1-1
242- 4.1.1
243
244* Thu Aug 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.1.0-2
245- fix data files from akregator plugin not getting installed
246
247* Wed Aug 06 2008 Rex Dieter <rdieter@fedoraproject.org> - 4.1.0-1
248- 4.1.0
249- drop searchbar-crash patch (no longer needed with Konqueror 4.1)
250
251* Sun May 04 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.0.3-0.3.20080409svn
252- fix searchbar plugin crash (#445144)
253
254* Wed Apr 16 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.0.3-0.2.20080409svn
255- rebuild because of corrupt PPC RPM causing signing failure (#442761)
256
257* Wed Apr 09 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.3-0.1.20080409svn
258- new svn checkout
259- some minor spec cleanups
260- License: GPLv2+ and LGPLv2+
261- drop icons patch
262
263* Tue Apr 01 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.2-0.2.20080303svn
264- rebuild for NDEBUG and _kde4_libexecdir
265- enhance %%description a bit
266
267* Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.2-0.1.20080303svn
268- new svn checkout (for KDE 4.0.2)
269- update cmakelists patch
270- remove icons patch (not needed anymore)
271- add "svn" to release
272
273* Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.1-0.2.20080214svn
274- added konq-plugins-4.0.1-icons.patch
275- add .po files to tarball
276
277* Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.1-0.1.20080213svn
278- initial version
Note: See TracBrowser for help on using the repository browser.