source: projects/specs/trunk/k/konq-plugins/konq-plugins-vl.spec @ 3881

Revision 3881, 9.4 KB checked in by Takemikaduchi, 13 years ago (diff)

add BuildRequires?

Line 
1# The 4.6.1 tarball is missing all documentation, keep the old one for now.
2%global docversion 4.4.0
3
4Name:           konq-plugins
5Summary:        Additional plugins that interact with konqueror
6Version:        4.6.1
7Release:        3%{?_dist_release}
8
9Group:          Applications/Internet
10License:        GPLv2+ and LGPLv2+
11URL:            http://extragear.kde.org
12
13Source0:        ftp://ftp.kde.org/pub/kde/stable/%{version}/src/konq-plugins-%{version}.tar.bz2
14Source1:        ftp://ftp.kde.org/pub/kde/stable/%{docversion}/src/extragear/konq-plugins-%{docversion}.tar.bz2
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18## upstream patches
19
20BuildRequires: cmake
21BuildRequires: gettext
22BuildRequires: kdebase4-devel >= %{version}
23BuildRequires: libtidy-devel
24BuildRequires: soprano-devel
25
26#{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
27Requires: kdebase4 >= %{version}
28
29%description
30Some additional plugins that interact with konqueror
31* adblock: AdBlock plugin
32* akregator: Add feeds directly to akregator (kdepim is needed)
33* autorefresh: Refresh websites after a specifig period
34* babelfish: Translate a website with babelfish
35* crashes: Crash monitor
36* dirfilter: Filter the current directory in many ways
37* domtreeviewer: Displays the document object model in a box
38* fsview: Graphical Disk Usage for inode/directory
39* imagerotation: service menu to image operations
40* khtmlsettingsplugin: Enable/disable some HTML settings
41* kimggalleryplugin:  Creates an HTML page with thumbnails of
42  all the images in the current directory.
43* mediarealfolder:  service menu to open a medium mountpoints
44* minitools: Implement bookmarklets into konqueror
45* rellinks: Allows access to relations defined in the header of a document
46* searchbar: Search Bar
47* sidebar: a small embedded mediaplayer, for songs/video preview
48* smbmounter: provides two menus items to smbmount/umount samba shares
49* uachanger: Change the user agent for websites
50* validators: Website validators
51* webarchiver: Web Archiver
52
53
54%prep
55%setup -q -a 1
56# use documentation from the old tarball
57mv -f %{name}-%{docversion}/doc* .
58tail -n 2 %{name}-%{docversion}/CMakeLists.txt >>CMakeLists.txt
59rm -rf %{name}-%{docversion}
60
61
62%build
63mkdir -p %{_target_platform}
64pushd %{_target_platform}
65unset QTDIR || : ; . /etc/profile.d/qt4.sh
66%cmake \
67    -DCMAKE_BUILD_TYPE=release \
68    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
69    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
70    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
71    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
72    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
73    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
74    ..
75popd
76
77make %{?_smp_mflags} -C %{_target_platform}
78
79
80%install
81rm -rf %{buildroot}
82
83make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
84
85# don't install kwebkitpart stuff on RHEL
86#rm -rf %{buildroot}%{_kde4_appsdir}/kwebkitpart/
87
88#find_lang %{name}
89#--with-kde
90
91
92%clean
93rm -rf %{buildroot}
94
95
96%post
97touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
98touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
99
100%postun
101if [ $1 -eq 0 ] ; then
102  touch --no-create %{_datadir}/icons/hicolor &> /dev/null
103  touch --no-create %{_datadir}/icons/oxygen &> /dev/null
104  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
105  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
106fi
107
108%posttrans
109gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
110gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
111
112
113#-f %{name}.lang
114%files
115%defattr(-,root,root,-)
116%doc COPYING COPYING.DOC COPYING.LIB README
117%{_bindir}/fsview
118%{_datadir}/config/translaterc
119# co-owned with kdepim, since there's no shared dep
120%{_datadir}/kde4/apps/akregator/
121%{_datadir}/kde4/apps/dolphinpart/kpartplugins/*
122%{_datadir}/kde4/apps/domtreeviewer/
123%{_datadir}/kde4/apps/fsview/
124%{_datadir}/kde4/apps/khtml/kpartplugins/*
125%{_datadir}/kde4/apps/konqueror/icons/*
126%{_datadir}/kde4/apps/konqueror/kpartplugins/*
127%{_datadir}/kde4/apps/konqueror/opensearch/*
128%{_datadir}/kde4/apps/kwebkitpart/kpartplugins/*
129%{_datadir}/config.kcfg/validators.kcfg
130%{_datadir}/kde4/services/*.desktop
131%{_datadir}/kde4/services/ServiceMenus/*.desktop
132%{_datadir}/icons/hicolor/*/*/*
133%{_datadir}/icons/oxygen/*/*/*
134%{_libdir}/kde4/*.so
135%{_docdir}/HTML/*/konq-plugins
136
137
138%changelog
139* Sun May 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.6.1-3
140- add BuildRequires: soprano-devel
141
142* Mon Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.1-2
143- initial build for Vine Linux
144
145* Sat Mar 05 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.1-1
146- update to 4.6.1, fixes file conflict with kde-l10n
147- drop upstreamed patches
148- use documentation from 4.4.0 because it's missing in 4.6.1
149- drop old commented-out translation-finding code
150- drop no longer needed BR webkitpart-devel, code uses abstract interfaces now
151
152* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.0-7
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
154
155* Tue Oct 26 2010 Alexey Kurov <nucleo@fedoraproject.org> - 4.4.0-6
156- Fix the window.close regression in adblock (kde#253921)
157
158* Tue Sep 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-5
159- Embeddable Image Viewer permanently messes up status bar (kde#234624)
160
161* Tue Sep 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-4
162- ftbfs qt47 issues (#599830)
163
164* Tue Feb 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-3
165- Requires: kdebase4 (it's not multilib'd, no need for arch'd dep)
166
167* Sat Feb 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.4.0-2
168- backport upstream patch to fix BabelFish plugin WebKitPart support (#564552)
169
170* Fri Feb 12 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-1
171- konq-plugins-4.4.0 for real
172
173* Thu Feb 11 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-0.1.20100211
174- home-brew konq-plugins-4.4.0 (20100211 create_tarball.rb snapshot)
175
176* Thu Dec 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.3-5
177- BR libtidy-devel (Fedora only)
178
179* Thu Dec 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.3-4
180- fix build with KDE 4.3.80's version of webkitkde (upstream patch)
181
182* Wed Nov 25 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.3-3
183- rebuild for Qt 4.6.0 RC1 in F13 (was built against Beta 1 with unstable ABI)
184
185* Mon Nov 09 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.3-2
186- BR: webkitpart-devel >= 0.0.2
187
188* Sat Nov 07 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.3-1
189- 4.3.3
190
191* Mon Oct 26 2009 Than Ngo <than@redhat.com> - 4.3.1-3
192- rhel cleanup
193
194* Sun Sep 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-2
195- BR: webkitpart-devel
196- use %%find_lang --all-names --with-kde
197- Requires: kdebase4%%{_?isa} >= %%version
198
199* Tue Sep 01 2009 Sebastian Vahl <svahl@fedoraproject.org> - 4.3.1-1
200- 4.3.1
201- use scriplet for HTML docdirs
202
203* Tue Aug 11 2009 Sebastian Vahl <fedora@deadbabylon.de> 4.3.0-1
204* KDE 4.3.0
205
206* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.3-2
207- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
208
209* Fri May 08 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.3-1
210- 4.2.3
211
212* Tue Apr  7 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
213- KDE 4.2.2
214
215* Wed Mar 25 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.0-4
216- fixup handbook install
217- optimize scriptlets
218
219* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-3
220- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
221
222* Wed Feb 18 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.0-2
223- update %%description
224- Requires: kdebase4 >= 4.2
225
226* Fri Jan 23 2009 Than Ngo <than@redhat.com> - 4.2.0-1
227- 4.2.0
228
229* Mon Jan 05 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.3-4
230- make install/fast
231- jpegorient is not installed (#478736, kdebug#178612)
232
233* Sun Dec 14 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.3-3
234- rebuild for Python 2.6 (contains Python bytecode despite no dependencies)
235
236* Tue Nov 11 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.1.3-2
237- include adblock language files
238
239* Tue Nov 11 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.1.3-1
240- 4.1.3
241
242* Sat Oct 04 2008 Than Ngo <than@redhat.com> 4.1.2-1
243- 4.1.2
244
245* Fri Aug 29 2008 Than Ngo <than@redhat.com> 4.1.1-1
246- 4.1.1
247
248* Thu Aug 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.1.0-2
249- fix data files from akregator plugin not getting installed
250
251* Wed Aug 06 2008 Rex Dieter <rdieter@fedoraproject.org> - 4.1.0-1
252- 4.1.0
253- drop searchbar-crash patch (no longer needed with Konqueror 4.1)
254
255* Sun May 04 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.0.3-0.3.20080409svn
256- fix searchbar plugin crash (#445144)
257
258* Wed Apr 16 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.0.3-0.2.20080409svn
259- rebuild because of corrupt PPC RPM causing signing failure (#442761)
260
261* Wed Apr 09 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.3-0.1.20080409svn
262- new svn checkout
263- some minor spec cleanups
264- License: GPLv2+ and LGPLv2+
265- drop icons patch
266
267* Tue Apr 01 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.2-0.2.20080303svn
268- rebuild for NDEBUG and _kde4_libexecdir
269- enhance %%description a bit
270
271* Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.2-0.1.20080303svn
272- new svn checkout (for KDE 4.0.2)
273- update cmakelists patch
274- remove icons patch (not needed anymore)
275- add "svn" to release
276
277* Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.1-0.2.20080214svn
278- added konq-plugins-4.0.1-icons.patch
279- add .po files to tarball
280
281* Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.1-0.1.20080213svn
282- initial version
Note: See TracBrowser for help on using the repository browser.