source: projects/specs/trunk/k/koffice/koffice-vl.spec @ 941

Revision 941, 15.2 KB checked in by inagaki, 14 years ago (diff)

updated: ImageMagicj?, libfprint, dvdauthor, inkscape, koffice, pstoedit, xine-lib

Line 
1%define sourcedir stable/koffice-%{version}/src
2
3Name: koffice
4URL: http://koffice.kde.org/
5Summary: Integrated office suite for KDE
6Summary(ja): KDE 向け統合オフィススイート
7Version: 1.6.3
8Release: 3%{?_dist_release}
9Epoch: 1
10Group: Applications/Productivity
11License: GPL
12Source: ftp://ftp.kde.org/pub/kde/{sourcedir}/%{name}-%{version}.tar.bz2
13Source1: %{name}-l10n-ja-%{version}.tar.bz2
14Patch0: koffice-1.6.3-gcc43.patch
15Patch1: koffice-1.6.3-gcc44-elif.patch
16Patch2: koffice-1.6.3-gcc44-glibc210.patch
17
18# security fix
19Patch100: koffice-xpdf-CVE-2007-3387.diff
20Patch101: koffice-1.6.3-xpdf2-CVE-2007-4352-5392-5393.diff
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: qt-devel >= 3.3.2, kdelibs3-devel >= 3.3, arts-devel >= 1:1.3
24BuildRequires: aspell-devel >= 0.50.2, wv2-devel >= 0.1.8
25BuildRequires: libjpeg-devel libmng-devel libtiff-devel zlib-devel
26BuildRequires: libxml2-devel libxslt-devel freetype2-devel libart_lgpl-devel
27BuildRequires: jasper-devel doxygen ImageMagick-devel pkgconfig
28BuildRequires: libpng-devel libgsf-devel lcms-devel libexif-devel
29BuildRequires: MySQL-devel postgresql-devel
30BuildRequires: poppler-qt-devel
31BuildRequires: python-devel
32BuildRequires: libwpd-devel >= 0.8.0
33#if %{?_dist_release}
34#BuildConflicts: ruby-devel
35#else
36BuildRequires: libpqxx-devel libtool-ltdl-devel ruby-devel
37#endif
38Requires: qt >= 3.3.2, kdelibs3 >= 3.3, arts >= 1:1.3
39Requires: freetype2 libjpeg libtiff libmng libpng
40Requires: zlib audiofile libxml2 libxslt
41Requires: libart_lgpl aspell wv2
42Requires(post): kdelibs3
43
44Obsoletes: killustrator kivio
45
46
47%description
48KOffice is a collection of office applications linked together by a common
49basis. This common basis assures that all office application can work
50together. You can, for instance, insert a spreadsheet in your thesis without
51leaving your document. Editing the spreadsheet happens _inside_ your thesis.
52
53The applications currently included in KOffice are:
54- KWord (Professional text editing)
55- KSpread (Professional number cruncher/spreadsheet)
56- KPresenter (Professional presentation program)
57- KChart (Graphing of your abstract data)
58- Karbon (Vector graphics tool)
59- Kugar (Database report creation)
60- Kivio (Flowcharting program)
61- Kexi (a database management tool)
62- KOffice Workspace (A combination of all of the above)
63
64%prep
65%setup -q -n %{name}-%{version}
66%if %{?_dist_release} == "vl6"
67%patch0 -p1 -b .gcc43
68%patch1 -p1 -b .elif
69%patch2 -p3 -b .glibc210
70%endif
71
72%patch100 -p0 -b .CVE-2007-3387
73%patch101 -p0 -b .xpdf
74
75# for Python 2.6
76%if %{?_dist_release} == "vl6"
77sed -i -e 's|""2\.5""|""2\.6""|g' configure
78%endif
79
80
81%build
82#only for beta
83#make -f Makefile.cvs
84
85unset QTDIR || : ; . /etc/profile.d/qt.sh
86export KDEDIR=%{_prefix}
87
88./configure --prefix=%{_prefix} \
89  --includedir=%{_includedir}/kde \
90  --with-qt-libraries=$QTDIR/lib \
91  --disable-rpath --disable-dependency-tracking \
92  --enable-new-ldflags \
93  --disable-debug --disable-warnings \
94  --with-pic --enable-shared --disable-static \
95  --with-extra-libs=%{_libdir} \
96  --with-pgsqllibdir=%{_libdir} --with-pgsqlincdir=%{_includedir} \
97  --with-pqxxlibdir=%{_libdir} --with-pqxxincdir=%{_includedir} \
98  --disable-final
99
100make %{?_smp_mflags}
101
102tar xjf %{SOURCE1}
103cd %{name}-l10n-ja-%{version}
104./configure --prefix=%{_prefix}
105make %{?_smp_mflags}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109make RUN_KAPPFINDER=no DESTDIR=$RPM_BUILD_ROOT install
110
111# Drop -x
112chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/kross/python/kexiapp/*
113chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/copycenter/*
114chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/exportxhtml/*
115chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/importxhtml/*
116chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/projectdocumentor/*
117chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/changecs/*
118chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/filterstest/*
119chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/invertpython/*
120chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/invertruby/*
121chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/randompaint/*
122chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/reshapehisto/*
123chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/torturefilters/*
124chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/torturepainting/*
125chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kross/python/*.py
126chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kross/python/RestrictedPython/*.py
127chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kspread/scripts/exporthtml/*
128chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kspread/scripts/scripteditor/*
129
130# Replace absolute symlinks with relative ones
131pushd $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en
132for i in *; do
133    if [ -d $i -a -L $i/common ]; then
134        rm -f $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en/$i/common
135        ln -s ../common $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en/$i
136    fi
137done
138popd
139
140cd %{name}-l10n-ja-%{version}
141make DESTDIR=$RPM_BUILD_ROOT install
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%post
147/sbin/ldconfig
148kbuildsycoca &>/dev/null || :
149
150%postun -p /sbin/ldconfig
151
152%files
153%defattr(-,root,root)
154%doc AUTHORS COPYING INSTALL README
155%doc %{_datadir}/doc/HTML/en/*
156%{_bindir}/*
157%{_includedir}/kde/*
158%{_libdir}/*
159%{_datadir}/applications
160%{_datadir}/applnk
161%{_datadir}/apps
162%config %{_datadir}/config
163%{_datadir}/config.kcfg
164%{_datadir}/icons
165%{_datadir}/locale/ja/LC_MESSAGES/*
166%{_datadir}/mimelnk
167%{_datadir}/services
168%{_datadir}/servicetypes
169%{_datadir}/templates
170
171%changelog
172* Tue May  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-3
173- rebuilt with new toolchain and ImageMagick-6.6.1.5
174- fixed configure for building with python-2.6
175- added Patch0-2 for building new toolchain
176  (Gentoo#228839, Debian#504870, Gentoo#270960)
177
178* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.3-2
179- added libtiff(-devel) to dependency.
180- rebuilt with MySQL-5.1.34.
181
182* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-1
183- applied new versioning policy
184- spec in UTF-8
185
186* Mon Nov 12 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl6
187- rebuild for VineSeed
188
189* Mon Nov 12 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl5
190- add Patch1 (CVE-2007-4352, 5392, 5393)
191
192* Thu Aug  2 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl4
193- add Patch0 (CVE-2007-3387)
194
195* Sat Jul 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.3-0vl3
196- added --with-qt-libraries configure option
197
198* Thu Jun 28 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl2
199- rebuild for VineSeed
200
201* Wed Jun 27 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl1
202- new upstream release
203
204* Tue Oct 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.0-0vl1
205- new upstream release
206
207* Mon Sep 11 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.91-0vl1
208- new upstream release
209
210* Mon Jul 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl2
211- rebuild for VineSeed
212
213* Mon Jul 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
214- new upstream release
215- drop obsolete patches
216
217* Mon May 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl2
218- rebuild for VineSeed
219
220* Mon May 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl1
221- new upstream release
222- drop obsolete patches
223- add BuildPrereq: libexif-devel
224- add --disable-final to configure option
225- add Patch0 and Patch1
226
227* Tue Apr 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl3
228- build with ruby-1.8.4-0vl1 on VineSeed
229- add Buildprereq: ruby-devel for VineSeed
230
231* Thu Apr  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl2
232- rebuild for VineSeed
233
234* Thu Apr  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl1
235- new upstream release
236- drop Patch1
237
238* Fri Mar 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl0.rc1
239- new upstream release
240- drop Patch0
241- add --disable-pie and --includedir=%%{_includedir}/kde to configure option
242- add BuildConflicts: ruby-devel
243- add Patch1
244- update %%files
245
246* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl4
247- rebuild with libgsf-1.14.0-0vl1
248- add Japanese summary
249
250* Thu Jan  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl3
251- add Patch0 (CAN-2005-3193)
252
253* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl2
254- rebuild with libgsf-1.13.3-0vl1 and python-2.4.2-0vl4
255
256* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl1
257- new upstream release
258- remove all patches
259- add SOURCE1 from snapshot
260
261* Mon Sep 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl2
262- add Patch0 - Patch8 to build with qt-3.3.5
263- add BuildPrereq: libtool-ltdl-devel
264
265* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
266- new upstream release
267
268* Thu Jul  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0a-0vl1
269- new upstream release
270- remove i18n files
271- add BuildPrereq: automake17
272- add --disable-rpath to configure option
273
274* Tue Apr 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.91-0vl1
275- new upstream release
276- remove all patches
277- add BuildPrereq: lcms-devel MySQL-devel postgresql-devel libpqxx-devel
278- change Group to Applications/Productivity
279- update Summary and description
280
281* Mon Mar 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl8
282- rebuild with KDE-3.4.0 (VineSeed)
283
284* Mon Mar 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl7
285- rebuild with KDE-3.4.0 (Vine3.1)
286- clean up changelog to use (double-percent) everywhere
287
288* Sat Jan 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl6
289- rebuild for VineSeed
290
291* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl5
292- add Patch1 (CAN-2005-0064)
293
294* Fri Jan  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl4
295- rebuild for VineSeed
296
297* Fri Jan  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl3
298- add patch0 (http://www.koffice.org/security/2004_xpdf_integer_overflow_2.php)
299
300* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl2
301- rebuild for VineSeed
302
303* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl1
304- new upstream release
305- remove about ia64
306- remove patch0
307
308* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.4-0vl1
309- source upgrade
310- add Patch0 (security patch)
311
312* Thu Aug 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl1
313- source upgrade
314- remove lines about vine26
315- add BuildPrereq: libgsf-devel
316
317* Thu May  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
318- source upgrade
319
320* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl3
321- rebuild with kde-3.2.2
322
323* Wed Mar 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl2
324- rebuild with kde-3.2.1
325
326* Wed Jan 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl1
327- source upgrade
328
329* Mon Dec 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.95-0vl1
330- source upgrade
331- add BuildPrereq: jasper-devel doxygen ImageMagick-devel pkgconfig
332
333* Mon Sep 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.93-0vl1
334- source upgrade
335
336* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.92-0vl2
337- rebuild with kdelibs-3.1.4 and gcc-3.2.3
338
339* Fri Aug 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.92-0vl1
340- source upgrade
341- BuildPrereq: wv2-devel >= 0.1.8 and add Requires: wv2
342
343* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.91-0vl1
344- source upgrade
345- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
346- change spec to build with gcc295
347- remove patch
348- add BuildPrereq: aspell-devel >= 0.50.2 and Requires: aspell
349- add BuildPrereq: wv2-devel
350
351* Mon May 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl4
352- rebuild with kdelibs-3.1.2
353
354* Thu Apr  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl3
355- rebuild with kdelibs-3.1.1
356
357* Sat Feb  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl2
358- add patch
359
360* Fri Feb  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl1
361- source upgrade
362- change spec to build both VineSeed and Vine2.5/2.6
363
364* Wed Oct 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl3
365- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
366
367* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl2
368- rebuild with qt-3.0.5-0vl1
369- BuildPrereq: autoconf253
370
371* Mon Sep 23 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl1
372- source upgrade
373- no file conflicts from other package (maybe)
374- add BuildPrereq: objprelink2 instead of objprelink (obsolete)
375- add BuildPrereq: libart_lgpl-devel and Requires: libart_lgpl
376- add %%doc section
377
378* Fri Jul  5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl3
379- add koffice-i18n-ja-1.1.1
380
381* Thu May  2 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl2
382- source upgrade to 1.1.1
383- delete some .desktop files (they conflict files from kdelibs)
384
385* Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl1
386- merged with rawhide 1.1-0.cvs20010725.1
387- source update to cvs-20020329
388- add BuildPrereq: autoconf252 automake15
389- add Epoch:1
390- There is Vine's previous changes, hacked for Vine
391 -- Wed Dec 5 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1-6vl1
392  - Delete Epoch
393  - Change BuildRequires and Requires
394  - Build for VineSeed
395
396* Wed Jul 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.1-0.cvs20010725.1
397- Increase Epoch
398
399* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.1-0.cvs20010724.1
400- Don't build kivio on ia64 ATM (compiler bug)
401
402* Tue Feb 20 2001 Than Ngo <than@redhat.com>
403- update 2.1
404- fix dangling symlinks
405
406* Fri Feb  2 2001 Bernhard Rosenkraenzer <bero@redhat.com>
407- Add ldconfig in %%post and %%postun, replace absolute symlinks
408  with relative symlinks (#24878)
409
410* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
411- Update
412
413* Thu Jan 11 2001 Bernhard Rosenkraenzer <bero@redhat.com>
414- Update
415- Don't build on sparc and ia64 (Bug #23809)
416
417* Sun Dec  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
418- 2.0.1
419
420* Fri Nov  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
421- Update to KDE_2_0_BRANCH
422
423* Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
424- 2.0 final
425
426* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
427- 2.0
428
429* Mon Oct  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
430- new CVS
431- fix compilation
432
433* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
434- kill dupes from kdelibs
435
436* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
437- 1.93
438
439* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
440- update (fixed compilation with gcc 2.96 in CVS)
441- work around compiler bugs on alpha
442
443* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
444- new snapshot
445- move to /usr/lib/kde2
446
447* Thu Jul 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
448- rebuild
449
450* Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
451- new snapshot
452
453* Sun Jul 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
454- new snapshot, new Qt
455
456* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
457- Don't hardcode Qt version
458- obsolete killustrator (powertools 6.x)
459- SMPify
460
461* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
462- use gcc 2.96
463- new snapshot
464
465* Mon Jul  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
466- use kernelcc
467- new snapshot
468
469* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
470- new snapshot
471- ExcludeArch ia64
472
473* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
474- new snapshot
475- move it to /usr, where it belongs
476
477* Sat Oct 23 1999 Bernhard Rosenkraenzer <bero@redhat.de>
478- Initial RPM
Note: See TracBrowser for help on using the repository browser.