source: projects/specs/trunk/k/koffice/koffice-vl.spec @ 521

Revision 521, 14.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define sourcedir stable/koffice-%{version}/src
2
3Name: koffice
4URL: http://koffice.kde.org/
5Summary: Integrated office suite for KDE
6Summary(ja): KDE 向け統合オフィススイート
7Version: 1.6.3
8Release: 2%{?_dist_release}
9Epoch: 1
10Source: ftp://ftp.kde.org/pub/kde/{sourcedir}/%{name}-%{version}.tar.bz2
11Source1: %{name}-l10n-ja-%{version}.tar.bz2
12Patch0: koffice-xpdf-CVE-2007-3387.diff
13Patch1: koffice-1.6.3-xpdf2-CVE-2007-4352-5392-5393.diff
14Group: Applications/Productivity
15Obsoletes: killustrator kivio
16License: GPL
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: qt-devel >= 3.3.2, kdelibs-devel >= 3.3, arts-devel >= 1:1.3
20BuildRequires: aspell-devel >= 0.50.2, wv2-devel >= 0.1.8
21BuildRequires: libjpeg-devel libmng-devel libtiff-devel zlib-devel
22BuildRequires: libxml2-devel libxslt-devel freetype2-devel libart_lgpl-devel
23BuildRequires: jasper-devel doxygen ImageMagick-devel pkgconfig
24BuildRequires: libpng-devel libgsf-devel lcms-devel libexif-devel
25BuildRequires: MySQL-devel postgresql-devel
26#if %{?_dist_release}
27#BuildConflicts: ruby-devel
28#else
29BuildRequires: libpqxx-devel libtool-ltdl-devel ruby-devel
30#endif
31Requires: qt >= 3.3.2, kdelibs >= 3.3, arts >= 1:1.3
32Requires: freetype2 libjpeg libtiff libmng libpng
33Requires: zlib audiofile libxml2 libxslt
34Requires: libart_lgpl aspell wv2
35Prereq: ldconfig kdelibs
36
37%description
38KOffice is a collection of office applications linked together by a common
39basis. This common basis assures that all office application can work
40together. You can, for instance, insert a spreadsheet in your thesis without
41leaving your document. Editing the spreadsheet happens _inside_ your thesis.
42
43The applications currently included in KOffice are:
44- KWord (Professional text editing)
45- KSpread (Professional number cruncher/spreadsheet)
46- KPresenter (Professional presentation program)
47- KChart (Graphing of your abstract data)
48- Karbon (Vector graphics tool)
49- Kugar (Database report creation)
50- Kivio (Flowcharting program)
51- Kexi (a database management tool)
52- KOffice Workspace (A combination of all of the above)
53
54%prep
55%setup -q -n %{name}-%{version}
56%patch0 -p0 -b .CVE-2007-3387
57%patch1 -p0 -b .xpdf
58
59%build
60#only for beta
61#make -f Makefile.cvs
62
63unset QTDIR || : ; . /etc/profile.d/qt.sh
64export KDEDIR=%{_prefix}
65
66#CFLAGS="-D_GNU_SOURCE $RPM_OPT_FLAGS" \
67#CXXFLAGS="-D_GNU_SOURCE $RPM_OPT_FLAGS -DNO_DEBUG -DNDEBUG -fno-check-new" \
68#./configure --prefix=%{_prefix} \
69#    --with-qt-libraries=$QTDIR/lib \
70#    --disable-final \
71#    --disable-pie \
72#    --includedir=%{_includedir}/kde \
73#    --disable-rpath
74./configure --prefix=%{_prefix} \
75  --includedir=%{_includedir}/kde \
76  --with-qt-libraries=$QTDIR/lib \
77  --disable-rpath --disable-dependency-tracking \
78  --enable-new-ldflags \
79  --disable-debug --disable-warnings \
80  --with-pic --enable-shared --disable-static \
81  --with-extra-libs=%{_libdir} \
82  --with-pgsqllibdir=%{_libdir} --with-pgsqlincdir=%{_includedir} \
83  --with-pqxxlibdir=%{_libdir} --with-pqxxincdir=%{_includedir} \
84  --disable-final
85
86make %{?_smp_mflags}
87
88tar xjf %{SOURCE1}
89cd %{name}-l10n-ja-%{version}
90./configure --prefix=%{_prefix}
91make %{?_smp_mflags}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95make RUN_KAPPFINDER=no DESTDIR=$RPM_BUILD_ROOT install
96
97# Drop -x
98chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/kross/python/kexiapp/*
99chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/copycenter/*
100chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/exportxhtml/*
101chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/importxhtml/*
102chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/projectdocumentor/*
103chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/changecs/*
104chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/filterstest/*
105chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/invertpython/*
106chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/invertruby/*
107chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/randompaint/*
108chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/reshapehisto/*
109chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/torturefilters/*
110chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/torturepainting/*
111chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kross/python/*.py
112chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kross/python/RestrictedPython/*.py
113chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kspread/scripts/exporthtml/*
114chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kspread/scripts/scripteditor/*
115
116# Replace absolute symlinks with relative ones
117pushd $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en
118for i in *; do
119    if [ -d $i -a -L $i/common ]; then
120        rm -f $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en/$i/common
121        ln -s ../common $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en/$i
122    fi
123done
124popd
125
126cd %{name}-l10n-ja-%{version}
127make DESTDIR=$RPM_BUILD_ROOT install
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%post
133/sbin/ldconfig
134kbuildsycoca &>/dev/null || :
135
136%postun -p /sbin/ldconfig
137
138%files
139%defattr(-,root,root)
140%doc AUTHORS COPYING INSTALL README
141%doc %{_datadir}/doc/HTML/en/*
142%{_bindir}/*
143%{_includedir}/kde/*
144%{_libdir}/*
145%{_datadir}/applications
146%{_datadir}/applnk
147%{_datadir}/apps
148%config %{_datadir}/config
149%{_datadir}/config.kcfg
150%{_datadir}/icons
151%{_datadir}/locale/ja/LC_MESSAGES/*
152%{_datadir}/mimelnk
153%{_datadir}/services
154%{_datadir}/servicetypes
155%{_datadir}/templates
156
157%changelog
158* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.3-2
159- added libtiff(-devel) to dependency.
160- rebuilt with MySQL-5.1.34.
161
162* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-1
163- applied new versioning policy
164- spec in UTF-8
165
166* Mon Nov 12 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl6
167- rebuild for VineSeed
168
169* Mon Nov 12 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl5
170- add Patch1 (CVE-2007-4352, 5392, 5393)
171
172* Thu Aug  2 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl4
173- add Patch0 (CVE-2007-3387)
174
175* Sat Jul 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.3-0vl3
176- added --with-qt-libraries configure option
177
178* Thu Jun 28 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl2
179- rebuild for VineSeed
180
181* Wed Jun 27 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl1
182- new upstream release
183
184* Tue Oct 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.0-0vl1
185- new upstream release
186
187* Mon Sep 11 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.91-0vl1
188- new upstream release
189
190* Mon Jul 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl2
191- rebuild for VineSeed
192
193* Mon Jul 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
194- new upstream release
195- drop obsolete patches
196
197* Mon May 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl2
198- rebuild for VineSeed
199
200* Mon May 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl1
201- new upstream release
202- drop obsolete patches
203- add BuildPrereq: libexif-devel
204- add --disable-final to configure option
205- add Patch0 and Patch1
206
207* Tue Apr 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl3
208- build with ruby-1.8.4-0vl1 on VineSeed
209- add Buildprereq: ruby-devel for VineSeed
210
211* Thu Apr  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl2
212- rebuild for VineSeed
213
214* Thu Apr  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl1
215- new upstream release
216- drop Patch1
217
218* Fri Mar 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl0.rc1
219- new upstream release
220- drop Patch0
221- add --disable-pie and --includedir=%%{_includedir}/kde to configure option
222- add BuildConflicts: ruby-devel
223- add Patch1
224- update %%files
225
226* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl4
227- rebuild with libgsf-1.14.0-0vl1
228- add Japanese summary
229
230* Thu Jan  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl3
231- add Patch0 (CAN-2005-3193)
232
233* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl2
234- rebuild with libgsf-1.13.3-0vl1 and python-2.4.2-0vl4
235
236* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl1
237- new upstream release
238- remove all patches
239- add SOURCE1 from snapshot
240
241* Mon Sep 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl2
242- add Patch0 - Patch8 to build with qt-3.3.5
243- add BuildPrereq: libtool-ltdl-devel
244
245* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
246- new upstream release
247
248* Thu Jul  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0a-0vl1
249- new upstream release
250- remove i18n files
251- add BuildPrereq: automake17
252- add --disable-rpath to configure option
253
254* Tue Apr 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.91-0vl1
255- new upstream release
256- remove all patches
257- add BuildPrereq: lcms-devel MySQL-devel postgresql-devel libpqxx-devel
258- change Group to Applications/Productivity
259- update Summary and description
260
261* Mon Mar 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl8
262- rebuild with KDE-3.4.0 (VineSeed)
263
264* Mon Mar 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl7
265- rebuild with KDE-3.4.0 (Vine3.1)
266- clean up changelog to use (double-percent) everywhere
267
268* Sat Jan 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl6
269- rebuild for VineSeed
270
271* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl5
272- add Patch1 (CAN-2005-0064)
273
274* Fri Jan  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl4
275- rebuild for VineSeed
276
277* Fri Jan  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl3
278- add patch0 (http://www.koffice.org/security/2004_xpdf_integer_overflow_2.php)
279
280* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl2
281- rebuild for VineSeed
282
283* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl1
284- new upstream release
285- remove about ia64
286- remove patch0
287
288* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.4-0vl1
289- source upgrade
290- add Patch0 (security patch)
291
292* Thu Aug 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl1
293- source upgrade
294- remove lines about vine26
295- add BuildPrereq: libgsf-devel
296
297* Thu May  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
298- source upgrade
299
300* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl3
301- rebuild with kde-3.2.2
302
303* Wed Mar 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl2
304- rebuild with kde-3.2.1
305
306* Wed Jan 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl1
307- source upgrade
308
309* Mon Dec 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.95-0vl1
310- source upgrade
311- add BuildPrereq: jasper-devel doxygen ImageMagick-devel pkgconfig
312
313* Mon Sep 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.93-0vl1
314- source upgrade
315
316* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.92-0vl2
317- rebuild with kdelibs-3.1.4 and gcc-3.2.3
318
319* Fri Aug 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.92-0vl1
320- source upgrade
321- BuildPrereq: wv2-devel >= 0.1.8 and add Requires: wv2
322
323* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.91-0vl1
324- source upgrade
325- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
326- change spec to build with gcc295
327- remove patch
328- add BuildPrereq: aspell-devel >= 0.50.2 and Requires: aspell
329- add BuildPrereq: wv2-devel
330
331* Mon May 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl4
332- rebuild with kdelibs-3.1.2
333
334* Thu Apr  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl3
335- rebuild with kdelibs-3.1.1
336
337* Sat Feb  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl2
338- add patch
339
340* Fri Feb  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl1
341- source upgrade
342- change spec to build both VineSeed and Vine2.5/2.6
343
344* Wed Oct 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl3
345- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
346
347* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl2
348- rebuild with qt-3.0.5-0vl1
349- BuildPrereq: autoconf253
350
351* Mon Sep 23 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl1
352- source upgrade
353- no file conflicts from other package (maybe)
354- add BuildPrereq: objprelink2 instead of objprelink (obsolete)
355- add BuildPrereq: libart_lgpl-devel and Requires: libart_lgpl
356- add %%doc section
357
358* Fri Jul  5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl3
359- add koffice-i18n-ja-1.1.1
360
361* Thu May  2 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl2
362- source upgrade to 1.1.1
363- delete some .desktop files (they conflict files from kdelibs)
364
365* Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl1
366- merged with rawhide 1.1-0.cvs20010725.1
367- source update to cvs-20020329
368- add BuildPrereq: autoconf252 automake15
369- add Epoch:1
370- There is Vine's previous changes, hacked for Vine
371 -- Wed Dec 5 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1-6vl1
372  - Delete Epoch
373  - Change BuildRequires and Requires
374  - Build for VineSeed
375
376* Wed Jul 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.1-0.cvs20010725.1
377- Increase Epoch
378
379* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.1-0.cvs20010724.1
380- Don't build kivio on ia64 ATM (compiler bug)
381
382* Tue Feb 20 2001 Than Ngo <than@redhat.com>
383- update 2.1
384- fix dangling symlinks
385
386* Fri Feb  2 2001 Bernhard Rosenkraenzer <bero@redhat.com>
387- Add ldconfig in %%post and %%postun, replace absolute symlinks
388  with relative symlinks (#24878)
389
390* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
391- Update
392
393* Thu Jan 11 2001 Bernhard Rosenkraenzer <bero@redhat.com>
394- Update
395- Don't build on sparc and ia64 (Bug #23809)
396
397* Sun Dec  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
398- 2.0.1
399
400* Fri Nov  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
401- Update to KDE_2_0_BRANCH
402
403* Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
404- 2.0 final
405
406* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
407- 2.0
408
409* Mon Oct  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
410- new CVS
411- fix compilation
412
413* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
414- kill dupes from kdelibs
415
416* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
417- 1.93
418
419* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
420- update (fixed compilation with gcc 2.96 in CVS)
421- work around compiler bugs on alpha
422
423* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
424- new snapshot
425- move to /usr/lib/kde2
426
427* Thu Jul 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
428- rebuild
429
430* Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
431- new snapshot
432
433* Sun Jul 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
434- new snapshot, new Qt
435
436* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
437- Don't hardcode Qt version
438- obsolete killustrator (powertools 6.x)
439- SMPify
440
441* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
442- use gcc 2.96
443- new snapshot
444
445* Mon Jul  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
446- use kernelcc
447- new snapshot
448
449* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
450- new snapshot
451- ExcludeArch ia64
452
453* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
454- new snapshot
455- move it to /usr, where it belongs
456
457* Sat Oct 23 1999 Bernhard Rosenkraenzer <bero@redhat.de>
458- Initial RPM
Note: See TracBrowser for help on using the repository browser.