source: projects/specs/trunk/k/kimono/kimono-vl.spec @ 9075

Revision 9075, 7.3 KB checked in by inagaki, 9 years ago (diff)

2014-11-09 Ryoichi INAGAKI <ryo1@…>

  • QtRuby?, kimono, korundum, qwt, qyoto, smokegen, smokekde, smokeqt: NEW
  • kdebindings: updated


Line 
1%global monodir /usr/lib/mono
2%global _kde4_version 4.12.5
3
4Name:    kimono
5Summary: .NET/Mono KDE bindings
6Summary(ja): KDE の .NET/Mono バインディング
7Version: 4.12.5
8Release: 1%{?_dist_release}
9
10# most items are pure GPLv2+
11# plasma bindings mix LGPLv2+ and GPLv2+ (combined result is GPLv2+ too)
12License: GPLv2+
13Group:   System Environment/Libraries
14URL:     https://projects.kde.org/projects/kde/kdebindings/csharp/kimono
15
16Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
17
18BuildRequires: kdelibs4-devel >= %{version}
19BuildRequires: kdepimlibs-devel >= %{version}
20BuildRequires: akonadi-devel
21BuildRequires: mono-devel
22BuildRequires: monodoc
23BuildRequires: qyoto-devel >= %{version}
24BuildRequires: smokekde-devel >= %{version}
25
26Requires: qyoto >= %{_kde4_version}
27Requires: smokekde >= %{_kde4_version}
28
29%{?mono_arches:ExclusiveArch: %{mono_arches}}
30
31
32%description
33%{summary}.
34
35%package akonadi
36Summary: Akonadi runtime support for %{name}
37Summary(ja): %{name} の Akonadi ランタイムサポート
38Group:   System Environment/Libraries
39Requires: %{name} = %{version}-%{release}
40Requires: smokekde-akonadi >= %{version}
41
42%description akonadi
43%{summary}.
44
45
46%prep
47%setup -q
48
49
50%build
51mkdir -p %{_target_platform}
52pushd %{_target_platform}
53%cmake \
54    -DCMAKE_BUILD_TYPE=release \
55    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
56    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
57    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
58    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
59    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
60    ..
61popd
62
63make %{?_smp_mflags} -C %{_target_platform}
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%files
73%defattr(-,root,root,-)
74%doc ChangeLog COPYING.GPLv2 COPYING.LGPLv2
75%{_libdir}/kde4/kimonopluginfactory.so
76%{_libdir}/libkhtml-sharp.so
77%{_libdir}/libkimono.so
78%{_libdir}/libktexteditor-sharp.so
79%{_libdir}/libnepomuk-sharp.so
80%{_libdir}/libplasma-sharp.so
81%{_libdir}/libsoprano-sharp.so
82%{monodir}/qyoto/kde-dotnet.dll
83%{monodir}/qyoto/khtml-dll.dll
84%{monodir}/qyoto/ktexteditor-dotnet.dll
85%{monodir}/qyoto/nepomuk-dll.dll
86%{monodir}/qyoto/plasma-dll.dll
87%{monodir}/qyoto/soprano.dll
88%{monodir}/gac/kde-dotnet/
89%{monodir}/gac/khtml-dll/
90%{monodir}/gac/ktexteditor-dotnet/
91%{monodir}/gac/nepomuk-dll/
92%{monodir}/gac/plasma-dll/
93%{monodir}/gac/soprano/
94%{_datadir}/kde4/apps/plasma_scriptengine_kimono/
95%{_datadir}/kde4/services/plasma-scriptengine-kimono-applet.desktop
96%{_datadir}/kde4/services/plasma-scriptengine-kimono-dataengine.desktop
97
98%files akonadi
99%defattr(-,root,root,-)
100%{_libdir}/libakonadi-sharp.so
101%{monodir}/qyoto/akonadi.dll
102%{monodir}/gac/akonadi/
103
104
105%changelog
106* Sun Nov  9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.2-1
107- splitted from kdebindings
108
109* Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
110- new upstream release
111
112* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
113- updated to 4.6.1
114- added BR: kdesdk-devel
115- disabled attica plugins temporaly
116- rebuilt with mono-2.10.1
117
118* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
119- rebuilt with rpm-4.8.1 for pkg-config
120
121* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
122- new upstream release
123- added Patch50
124- added more japanese summaries
125
126* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
127- new upstream release
128
129* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
130- new upstream release
131
132* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
133- new upstream release
134
135* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
136- new upstream release
137
138* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
139- new upstream release
140- added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
141  (see https://bugs.kde.org/show_bug.cgi?id=214824)
142- built with new toolchain
143
144* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
145- new upstream release
146
147* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
148- merged 4.3.1-2 %changelog
149- re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
150
151* Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
152- use %%{_prefix}/lib for mono-dll (for x86_64)
153
154* Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
155- new upstream release
156- built with PyQt4-4.6
157
158* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
159- define %%{mono_dir} to specify mono library install path
160
161* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
162- new upstream release
163- fixed ruby modules installation path
164
165* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
166- new upstream release
167- spilt sub package based on Fedora
168
169* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
170- applied new versioning policy
171- added Patch1
172  (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
173
174* Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
175- added --with-qt-libraries option
176
177* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
178- rebuild for VineSeed
179
180* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
181- new upstream release
182
183* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
184- rebuild for VineSeed
185
186* Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
187- new upstream release
188- update Patch0
189- drop Patch1
190
191* Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
192- new upstream release
193- add Patch1
194- add --enable-libsuffix option
195
196* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
197- rebuild for VineSeed
198
199* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
200- new upstream release
201
202* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
203- rebuild for VineSeed
204
205* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
206- new upstream release
207
208* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
209- rebuild for VineSeed
210
211* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
212- new upstream release
213
214* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
215- rebuild for VineSeed
216
217* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
218- new upstream release
219
220* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
221- rebuild for VineSeed
222
223* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
224- new upstream release
225- renew BuildPrereq and build section
226- renew %%files
227- enable python
228- change spec to make main and devel package
229- add BuildPrereq: ruby ruby-devel
230- add Patch0 to install ruby-bindings under /usr/lib/ruby
231
232* Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
233- build for VineSeed
234- disable python and mozilla
235- objprelink (i386 only)
236
237* Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
238- 2.2.2
239- build kmozilla binding only on x86/alpha
240
241* Thu Aug  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
242- Make sure %%{name}-kmozilla isn't built on ia64
243
244* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
245- Move python bindings to separate package
246- Add perl bindings
247- Shut up rpmlint
248
249* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
250- 2.1
251
252* Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
253- initial RPM
Note: See TracBrowser for help on using the repository browser.