source: projects/specs/trunk/k/kimono/kimono-vl.spec @ 10570

Revision 10570, 7.7 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%global monodir %{_prefix}/lib/mono
2%global _kde4_version 4.14.3
3
4Name:    kimono
5Summary: .NET/Mono KDE bindings
6Summary(ja): KDE の .NET/Mono バインディング
7Version: 4.14.3
8Release: 3%{?_dist_release}
9
10# most items are pure GPLv2+
11# plasma bindings mix LGPLv2+ and GPLv2+ (combined result is GPLv2+ too)
12License: GPLv2+
13Group:   System Environment/Libraries
14URL:     https://projects.kde.org/projects/kde/kdebindings/csharp/kimono
15
16Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: kdelibs4-devel >= %{version}
20BuildRequires: kdepimlibs-devel >= %{version}
21BuildRequires: nepomuk-core-devel
22BuildRequires: soprano-devel
23BuildRequires: akonadi-devel
24BuildRequires: mono-devel
25BuildRequires: monodoc
26BuildRequires: qyoto-devel >= %{version}
27BuildRequires: smokekde-devel >= %{version}
28
29Requires: qyoto >= %{_kde4_version}
30Requires: smokekde >= %{_kde4_version}
31
32%{?mono_arches:ExclusiveArch: %{mono_arches}}
33
34
35%description
36%{summary}.
37
38%package akonadi
39Summary: Akonadi runtime support for %{name}
40Summary(ja): %{name} の Akonadi ランタイムサポート
41Group:   System Environment/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: smokekde-akonadi >= %{version}
44
45%description akonadi
46%{summary}.
47
48
49%prep
50%setup -q
51
52
53%build
54mkdir -p %{_target_platform}
55pushd %{_target_platform}
56%cmake \
57    -DCMAKE_BUILD_TYPE=release \
58    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
59    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
60    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
61    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
62    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
63    ..
64popd
65
66make %{?_smp_mflags} -C %{_target_platform}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%post -p /sbin/ldconfig
76%postun -p /sbin/ldconfig
77
78%files
79%defattr(-,root,root,-)
80%doc ChangeLog COPYING.GPLv2 COPYING.LGPLv2
81%{_libdir}/kde4/kimonopluginfactory.so
82%{_libdir}/libkhtml-sharp.so
83%{_libdir}/libkimono.so
84%{_libdir}/libktexteditor-sharp.so
85%{_libdir}/libnepomuk-sharp.so
86%{_libdir}/libplasma-sharp.so
87%{_libdir}/libsoprano-sharp.so
88%{monodir}/qyoto/kde-dotnet.dll
89%{monodir}/qyoto/khtml-dll.dll
90%{monodir}/qyoto/ktexteditor-dotnet.dll
91%{monodir}/qyoto/nepomuk-dll.dll
92%{monodir}/qyoto/plasma-dll.dll
93%{monodir}/qyoto/soprano.dll
94%{monodir}/gac/kde-dotnet/
95%{monodir}/gac/khtml-dll/
96%{monodir}/gac/ktexteditor-dotnet/
97%{monodir}/gac/nepomuk-dll/
98%{monodir}/gac/plasma-dll/
99%{monodir}/gac/soprano/
100%{_datadir}/kde4/apps/plasma_scriptengine_kimono/
101%{_datadir}/kde4/services/plasma-scriptengine-kimono-applet.desktop
102%{_datadir}/kde4/services/plasma-scriptengine-kimono-dataengine.desktop
103
104%files akonadi
105%defattr(-,root,root,-)
106%{_libdir}/libakonadi-sharp.so
107%{monodir}/qyoto/akonadi.dll
108%{monodir}/gac/akonadi/
109
110
111%changelog
112* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-3
113- rebuild with gcc-5.4.0
114
115* Sat Mar 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-2
116- rebuilt with mono 3.12.1
117
118* Sun Jan 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-1
119- updated to 4.14.3
120- added BR: nepomuk-devel and soprano-devel
121
122* Sun Nov  9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-1
123- splitted from kdebindings
124
125* Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
126- new upstream release
127
128* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
129- updated to 4.6.1
130- added BR: kdesdk-devel
131- disabled attica plugins temporaly
132- rebuilt with mono-2.10.1
133
134* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
135- rebuilt with rpm-4.8.1 for pkg-config
136
137* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
138- new upstream release
139- added Patch50
140- added more japanese summaries
141
142* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
143- new upstream release
144
145* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
146- new upstream release
147
148* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
149- new upstream release
150
151* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
152- new upstream release
153
154* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
155- new upstream release
156- added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
157  (see https://bugs.kde.org/show_bug.cgi?id=214824)
158- built with new toolchain
159
160* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
161- new upstream release
162
163* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
164- merged 4.3.1-2 %changelog
165- re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
166
167* Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
168- use %%{_prefix}/lib for mono-dll (for x86_64)
169
170* Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
171- new upstream release
172- built with PyQt4-4.6
173
174* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
175- define %%{mono_dir} to specify mono library install path
176
177* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
178- new upstream release
179- fixed ruby modules installation path
180
181* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
182- new upstream release
183- spilt sub package based on Fedora
184
185* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
186- applied new versioning policy
187- added Patch1
188  (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
189
190* Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
191- added --with-qt-libraries option
192
193* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
194- rebuild for VineSeed
195
196* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
197- new upstream release
198
199* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
200- rebuild for VineSeed
201
202* Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
203- new upstream release
204- update Patch0
205- drop Patch1
206
207* Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
208- new upstream release
209- add Patch1
210- add --enable-libsuffix option
211
212* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
213- rebuild for VineSeed
214
215* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
216- new upstream release
217
218* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
219- rebuild for VineSeed
220
221* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
222- new upstream release
223
224* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
225- rebuild for VineSeed
226
227* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
228- new upstream release
229
230* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
231- rebuild for VineSeed
232
233* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
234- new upstream release
235
236* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
237- rebuild for VineSeed
238
239* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
240- new upstream release
241- renew BuildPrereq and build section
242- renew %%files
243- enable python
244- change spec to make main and devel package
245- add BuildPrereq: ruby ruby-devel
246- add Patch0 to install ruby-bindings under /usr/lib/ruby
247
248* Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
249- build for VineSeed
250- disable python and mozilla
251- objprelink (i386 only)
252
253* Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
254- 2.2.2
255- build kmozilla binding only on x86/alpha
256
257* Thu Aug  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
258- Make sure %%{name}-kmozilla isn't built on ia64
259
260* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
261- Move python bindings to separate package
262- Add perl bindings
263- Shut up rpmlint
264
265* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
266- 2.1
267
268* Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
269- initial RPM
Note: See TracBrowser for help on using the repository browser.