source: projects/specs/trunk/k/kdevelop/kdevelop-vl.spec @ 8154

Revision 8154, 15.4 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Name: kdevelop
2Summary: Integrated Development Environment for C++/C
3Summary(ja): C++/C 向け統合開発環境
4Version: 4.6.0
5Release: 1%{?_dist_release}
6
7License: GPLv2
8URL: http://www.kdevelop.org/
9Group: Applications/Development
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.xz
12
13# fixing https://bugs.kde.org/show_bug.cgi?id=236315
14Patch100: kdevelop-4.0.0-qmake_qt4.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: desktop-file-utils
18BuildRequires: gettext
19BuildRequires: kdebase-workspace-devel
20BuildRequires: kdevplatform-devel >= 1.4.0
21BuildRequires: kdelibs-devel
22BuildRequires: kdesdk-devel
23BuildRequires: soprano-devel
24BuildRequires: qjson-devel
25BuildRequires: valgrind
26
27Requires: %{name}-libs = %{version}-%{release}
28Requires: kdevplatform >= 1.4.0
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34The KDevelop Integrated Development Environment provides many features
35that developers need as well as providing a unified interface to programs
36like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
37
38All development tools needed for C++ programming like Compiler,
39Linker, automake and autoconf; KAppWizard, which generates complete,
40ready-to-go sample applications; Classgenerator, for creating new
41classes and integrating them into the current project; File management
42for sources, headers, documentation etc. to be included in the
43project; The creation of User-Handbooks written with SGML and the
44automatic generation of HTML-output with the KDE look and feel;
45Automatic HTML-based API-documentation for your project's classes with
46cross-references to the used libraries; Internationalization support
47for your application, allowing translators to easily add their target
48language to a project;
49
50KDevelop also includes WYSIWYG (What you see is what you get)-creation
51of user interfaces with a built-in dialog editor; Debugging your
52application by integrating KDbg; Editing of project-specific pixmaps
53with KIconEdit; The inclusion of any other program you need for
54development by adding it to the "Tools"-menu according to your
55individual needs.
56
57%package libs
58Summary: %{name} runtime libraries
59Summary(ja): %{name} のランタイムライブラリ
60Group:   System Environment/Libraries
61#Requires: %{name} = %{version}-%{release}
62Requires: kdelibs4
63
64%description libs
65%{summary}.
66
67
68%package devel
69Summary: Development files for %{name}
70Summary(ja): %{name} の開発用ファイル
71Group: Development/Libraries
72Requires: %{name}-libs = %{version}-%{release}
73
74%description devel
75%{summary}.
76
77
78%prep
79%setup -q -n kdevelop-%{version}
80#patch100 -p1 -b .qmake_qt4
81
82%build
83mkdir -p %{_target_platform}
84pushd %{_target_platform}
85%cmake \
86    -DCMAKE_BUILD_TYPE=release \
87    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
88    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
89    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
90    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
91    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
92    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
93    ..
94popd
95
96make %{?_smp_mflags} -C %{_target_platform}
97
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
103
104%find_lang %{name} --all-name --with-kde
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109
110%post
111touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
112
113%postun
114if [ $1 -eq 0 ] ; then
115touch --no-create %{_datadir}/icons/hicolor &> /dev/null
116gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
117update-desktop-database -q &> /dev/null
118update-mime-database %{_datadir}/mime &> /dev/null
119fi
120
121%posttrans
122gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
123update-desktop-database -q &> /dev/null
124update-mime-database %{_datadir}/mime &> /dev/null
125
126%post libs -p /sbin/ldconfig
127
128%postun libs -p /sbin/ldconfig
129
130%files -f %{name}.lang
131%defattr(-,root,root)
132%{_bindir}/*
133%config %{_datadir}/config/kdeveloprc
134%{_datadir}/applications/kde4/*.desktop
135%{_datadir}/config/kdevelop-qthelp.knsrc
136%{_datadir}/kde4/apps/kdev*/
137%{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/contents/ui/kdevelopsessions.qml
138%{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/metadata.desktop
139%{_datadir}/kde4/apps/plasma/services/org.kde.plasma.dataengine.kdevelopsessions.operations
140%{_datadir}/kde4/services/*.desktop
141%{_datadir}/icons/hicolor/*/*/*
142%{_datadir}/mime/packages/kdevelop.xml
143#{_datadir}/servicetypes/*
144#doc %{_datadir}/doc/HTML/en/*
145
146%files libs
147%defattr(-,root,root,-)
148%{_libdir}/lib*.so
149%{_libdir}/kde4/*.so
150
151%files devel
152%defattr(-,root,root,-)
153%{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
154%{_includedir}/kde4/kdevelop/
155
156
157%changelog
158* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.0-1
159- new upstream release
160- add BuildRequires: qjson-devel
161
162* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.1-1
163- new upstream release
164
165* Sat Oct 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.0-1
166- new upstream release
167
168* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.1-1
169- new upstream release
170
171* Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.3-1
172- new upstream release
173
174* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-2
175- add BuildRequires: kdesdk-devel, soprano-devel
176
177* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
178- new upstream release
179
180* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
181- new upstream release
182
183* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
184- new upstream release
185- split shared libraries and header files
186
187* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
188- new upstream release
189- applied new versioning policy, spec in UTF-8
190- changed Group to Applications/Development
191
192* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
193- rebuild for VineSeed
194
195* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
196- new upstream release
197
198* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
199- rebuild for VineSeed
200
201* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
202- new upstream release
203
204* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
205- rebuild for VineSeed
206
207* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
208- new upstream release
209- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
210
211* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
212- rebuild for VineSeed
213
214* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
215- new upstream release
216
217* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
218- rebuild for VineSeed
219
220* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
221- new upstream release
222
223* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
224- rebuild for VineSeed
225
226* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
227- new upstream release
228- add BuildPrereq: apache2-devel subversion-devel
229
230* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
231- new upstream release
232
233* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
234- new upstream release
235- delete Patch0
236
237* Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
238- new upstream release
239- add Patch0
240- update %%files
241
242* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
243- rebuild for VineSeed
244
245* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
246- new upstream release
247
248* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
249- rebuild for VineSeed
250
251* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
252- new upstream release
253- add --disable-rpath to configure option
254- remove BuildPrereq: qt-static
255
256* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
257- rebuild for VineSeed
258
259* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
260- new upstream release
261- update %%files
262- add +w to %%{_prefix}/kdevbdb/*
263
264* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
265- rebuild for VineSeed
266
267* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
268- new upstream release
269- update %%files
270
271* Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
272- source upgrade
273- add BuildPrereq: qt-static
274
275* Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
276- rebuild with qt32
277
278* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
279- source upgrade
280- remove lines about vine26
281
282* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
283- source upgrade
284- add Requires: ctags
285
286* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
287- source upgrade
288- remove all patches
289- remove c references
290- add Requires: htdig
291
292* Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
293- change spec to build both VineSeed and Vine2.5/2.6
294- change configure options
295- add %%clean section
296- add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
297
298* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
299- source upgrade
300- change spec to build both VineSeed and Vine2.5/2.6
301- change configure option (add -enable--final, remove -enable--debug)
302- update %%files section
303
304* Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
305- source upgrade
306- remove patch1 (rejected)
307
308* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
309- BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
310
311* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
312- source upgrade
313- revised Source1
314- remove Patch1 and Patch4
315
316* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
317- merged with rawhide 2.1.1-3
318- clean up spec
319- add BuildPrereq: objprelink (i386 only)
320- remove Obsoletes: kdevelop-c_c++_ref
321- add BuildPrereq: autoconf252 automake15
322- There is Vine's previous changes, hacked for Vine
323 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
324  - build for VineSeed
325  - delete Epoch
326  - update Patch1 and delete Patch2
327
328* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
329- automated rebuild
330
331* Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
332- don't forcibly strip binaries
333
334* Sun Jun  2 2002 Than Ngo <than@redhat.com> 2.1.1-1
335- 2.1.1
336
337* Sun May 26 2002 Tim Powers <timp@redhat.com>
338- automated rebuild
339
340* Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
341- Use automake15
342
343* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
344- Change sonames
345
346* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
347- final
348
349* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
350- update
351
352* Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
353- update to 2.1rc3
354
355* Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
356- update to 2.1rc2
357
358* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
359- rebuild against new kdelibs
360
361* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
362- fixed Strange characters appear in the output window (bug #59217)
363- fixed return-line feed sign in Kdevelop setup tool (bug #55032)
364
365* Fri Mar  8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
366- update to 2.1beta2
367
368* Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
369- rebuild against new kdelibs
370
371* Wed Jan  9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
372- update to 2.1 beta1
373- fix build against gcc 3
374- fix some typo bugs
375- get rid of libkfile
376- update c_cpp_reference to 2.0.1
377
378* Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
379- add patch to show non lattin1 font in build-in editor correct (bug #54457)
380
381* Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
382- fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
383- backport some major bugfixes from 2.0.1
384
385* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
386- Don't crash on startup
387
388* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
389- Fix file list
390
391* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
392- Update
393
394* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
395- Yet another respin - printing was broken.
396
397* Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
398- Update the C/C++ reference guide docs. The older version had a
399  couple of examples that won't work with gcc 2.96-*
400
401* Thu Feb 22 2001 Than Ngo <than@redhat.com>
402- fix version number
403
404* Wed Feb 21 2001 Than Ngo <than@redhat.com>
405- 1.4-respin
406
407* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
408- 1.4
409
410* Wed Feb 14 2001 Than Ngo <than@redhat.com>
411- update (only bugfixes)
412- fix up kdelibs documentation path
413- fix a dependency problem with kde-i18n package (Bug #27675)
414- add qt-designer into requires
415
416* Sun Feb 11 2001 Than Ngo <than@redhat.com>
417- fixed to build on s390
418
419* Tue Feb 06 2001 Than Ngo <than@redhat.com>
420- update, only bugfixes
421
422* Wed Jan 24 2001 Than Ngo <than@redhat.com>
423- hacked for building of KDE references
424
425* Tue Jan 23 2001 Than Ngo <than@redhat.com>
426- work-around to build on alpha
427
428* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
429- Update
430
431* Wed Jan 10 2001 Than Ngo <than@redhat.com>
432- update new snapshot, only require KDE2/Qt2
433
434* Fri Dec 22 2000 Than Ngo <than@redhat.com>
435- fixed dependency problem with kde-i18n
436
437* Thu Dec 21 2000 Than Ngo <than@redhat.com>
438- updated to 1.4beta1 with KDE2 support
439- fixed to build on s390
440- fixed some broken codes
441 
442* Fri Dec 8 2000 Than Ngo <than@redhat.com>
443- fixed for building on ia64
444 
445* Wed Nov 15 2000 Than Ngo <than@redhat.com>
446- build snapshot 20001112, it works now with KDE2 and kde1-compat
447- fix libtool to build on sparc and alpha
448- don't use make -j
449 
450* Sun Aug 13 2000 Than Ngo <than@redhat.com>
451- fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
452 
453* Tue Aug 01 2000 Than Ngo <than@redhat.de>
454- add missing ldconfig in %post and %postun section (Bug #14924)
455- add missing C references stuff to kdevelop
456 
457* Sun Jul 30 2000 Than Ngo <than@redhat.de>
458- rebuilt against compat-egcs-c++, put KDE1 under /usr
459- cleanup specfile
460 
461* Tue Jul 25 2000 Than Ngo <than@redhat.de>
462- fix dependency problem
463 
464* Wed Jul 19 2000 Than Ngo <than@redhat.de>
465- rebuilt against compat-libstdc++
466 
467* Mon Jul 17 2000 Than Ngo <than@redhat.de>
468- install under /usr/share instead /usr/lib/kde1-compat/share,
469  fix dependency problem
470 
471* Sat Jul 15 2000 Than Ngo <than@redhat.de>
472- rebuilt with egcs-c++-1.1.2
473
474* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
475- automatic rebuild
476 
477* Mon Jul 03 2000 Than Ngo <than@redhat.de>
478- fix docdir
479- add requires kdebase
480 
481* Sun Jul 02 2000 Than Ngo <than@redhat.de>
482- rebuilt with  kde1-compat
483 
484* Sun Jun 18 2000 Than Ngo <than@redhat.de>
485- rebuilt in the new build environment, fix docdir
486- FHS packaging
487 
488* Thu Jun 08 2000 Than Ngo <than@redhat.de>
489- update to 1.2
490- move from powertools to main CD
491- use %%configure
492 
493* Mon Apr 3 2000 Ngo Than <than@redhat.de>
494- fix up reference (Bug #10368)
495 
496* Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
497- Fix up documentation path (Bug #7291)
498- Update to current stable branch - this should fix up the debugger problem
499- clean up spec file
500 
501* Thu Jan  6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
502- Update to current stable branch
503- Adapt to 6.2 Qt libraries
504- Use BuildPrereq
505 
506* Wed Jan 05 2000 Ngo Than <than@redhat.de>
507- added patch for alpha
508 
509* Tue Dec 21 1999 Ngo Than <than@redhat.de>
510- updated kdevelop-1.0 release
511 
512* Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
513- kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
514 
515* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
516- initial packaging for 6.1.
Note: See TracBrowser for help on using the repository browser.