source: projects/specs/trunk/k/kdevelop/kdevelop-vl.spec @ 7065

Revision 7065, 15.2 KB checked in by Takemikaduchi, 12 years ago (diff)

thunderbird: change configure options
others: new upstream release

Line 
1Name: kdevelop
2Summary: Integrated Development Environment for C++/C
3Summary(ja): C++/C 向け統合開発環境
4Version: 4.4.1
5Release: 1%{?_dist_release}
6
7License: GPLv2
8URL: http://www.kdevelop.org/
9Group: Applications/Development
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.bz2
12
13# fixing https://bugs.kde.org/show_bug.cgi?id=236315
14Patch100: kdevelop-4.0.0-qmake_qt4.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: desktop-file-utils
18BuildRequires: gettext
19BuildRequires: kdebase-workspace-devel
20BuildRequires: kdevplatform-devel >= 1.4.0
21BuildRequires: kdelibs-devel
22BuildRequires: kdesdk-devel
23BuildRequires: soprano-devel
24BuildRequires: valgrind
25
26Requires: %{name}-libs = %{version}-%{release}
27Requires: kdevplatform >= 1.4.0
28
29#Conflicts: kdevelop
30
31%description
32The KDevelop Integrated Development Environment provides many features
33that developers need as well as providing a unified interface to programs
34like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
35
36All development tools needed for C++ programming like Compiler,
37Linker, automake and autoconf; KAppWizard, which generates complete,
38ready-to-go sample applications; Classgenerator, for creating new
39classes and integrating them into the current project; File management
40for sources, headers, documentation etc. to be included in the
41project; The creation of User-Handbooks written with SGML and the
42automatic generation of HTML-output with the KDE look and feel;
43Automatic HTML-based API-documentation for your project's classes with
44cross-references to the used libraries; Internationalization support
45for your application, allowing translators to easily add their target
46language to a project;
47
48KDevelop also includes WYSIWYG (What you see is what you get)-creation
49of user interfaces with a built-in dialog editor; Debugging your
50application by integrating KDbg; Editing of project-specific pixmaps
51with KIconEdit; The inclusion of any other program you need for
52development by adding it to the "Tools"-menu according to your
53individual needs.
54
55%package libs
56Summary: %{name} runtime libraries
57Summary(ja): %{name} のランタイムライブラリ
58Group:   System Environment/Libraries
59#Requires: %{name} = %{version}-%{release}
60Requires: kdelibs4
61
62%description libs
63%{summary}.
64
65
66%package devel
67Summary: Development files for %{name}
68Summary(ja): %{name} の開発用ファイル
69Group: Development/Libraries
70Requires: %{name}-libs = %{version}-%{release}
71
72%description devel
73%{summary}.
74
75
76%prep
77%setup -q -n kdevelop-%{version}
78#patch100 -p1 -b .qmake_qt4
79
80%build
81mkdir -p %{_target_platform}
82pushd %{_target_platform}
83%cmake \
84    -DCMAKE_BUILD_TYPE=release \
85    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
86    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
87    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
88    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
89    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
90    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
91    ..
92popd
93
94make %{?_smp_mflags} -C %{_target_platform}
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
101
102%find_lang %{name} --all-name --with-kde
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107
108%post
109touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
110
111%postun
112if [ $1 -eq 0 ] ; then
113touch --no-create %{_datadir}/icons/hicolor &> /dev/null
114gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
115update-desktop-database -q &> /dev/null
116update-mime-database %{_datadir}/mime &> /dev/null
117fi
118
119%posttrans
120gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
121update-desktop-database -q &> /dev/null
122update-mime-database %{_datadir}/mime &> /dev/null
123
124%post libs -p /sbin/ldconfig
125
126%postun libs -p /sbin/ldconfig
127
128%files -f %{name}.lang
129%defattr(-,root,root)
130%{_bindir}/*
131%config %{_datadir}/config/kdeveloprc
132%{_datadir}/applications/kde4/*.desktop
133%{_datadir}/config/kdevelop-qthelp.knsrc
134%{_datadir}/kde4/apps/kdev*/
135%{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/contents/ui/kdevelopsessions.qml
136%{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/metadata.desktop
137%{_datadir}/kde4/apps/plasma/services/org.kde.plasma.dataengine.kdevelopsessions.operations
138%{_datadir}/kde4/services/*.desktop
139%{_datadir}/icons/hicolor/*/*/*
140%{_datadir}/mime/packages/kdevelop.xml
141#{_datadir}/servicetypes/*
142#doc %{_datadir}/doc/HTML/en/*
143
144%files libs
145%defattr(-,root,root,-)
146%{_libdir}/lib*.so
147%{_libdir}/kde4/*.so
148
149%files devel
150%defattr(-,root,root,-)
151%{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
152%{_includedir}/kde4/kdevelop/
153
154
155%changelog
156* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.1-1
157- new upstream release
158
159* Sat Oct 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.0-1
160- new upstream release
161
162* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.1-1
163- new upstream release
164
165* Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.3-1
166- new upstream release
167
168* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-2
169- add BuildRequires: kdesdk-devel, soprano-devel
170
171* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
172- new upstream release
173
174* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
175- new upstream release
176
177* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
178- new upstream release
179- split shared libraries and header files
180
181* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
182- new upstream release
183- applied new versioning policy, spec in UTF-8
184- changed Group to Applications/Development
185
186* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
187- rebuild for VineSeed
188
189* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
190- new upstream release
191
192* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
193- rebuild for VineSeed
194
195* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
196- new upstream release
197
198* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
199- rebuild for VineSeed
200
201* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
202- new upstream release
203- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
204
205* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
206- rebuild for VineSeed
207
208* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
209- new upstream release
210
211* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
212- rebuild for VineSeed
213
214* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
215- new upstream release
216
217* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
218- rebuild for VineSeed
219
220* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
221- new upstream release
222- add BuildPrereq: apache2-devel subversion-devel
223
224* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
225- new upstream release
226
227* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
228- new upstream release
229- delete Patch0
230
231* Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
232- new upstream release
233- add Patch0
234- update %%files
235
236* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
237- rebuild for VineSeed
238
239* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
240- new upstream release
241
242* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
243- rebuild for VineSeed
244
245* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
246- new upstream release
247- add --disable-rpath to configure option
248- remove BuildPrereq: qt-static
249
250* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
251- rebuild for VineSeed
252
253* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
254- new upstream release
255- update %%files
256- add +w to %%{_prefix}/kdevbdb/*
257
258* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
259- rebuild for VineSeed
260
261* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
262- new upstream release
263- update %%files
264
265* Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
266- source upgrade
267- add BuildPrereq: qt-static
268
269* Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
270- rebuild with qt32
271
272* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
273- source upgrade
274- remove lines about vine26
275
276* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
277- source upgrade
278- add Requires: ctags
279
280* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
281- source upgrade
282- remove all patches
283- remove c references
284- add Requires: htdig
285
286* Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
287- change spec to build both VineSeed and Vine2.5/2.6
288- change configure options
289- add %%clean section
290- add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
291
292* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
293- source upgrade
294- change spec to build both VineSeed and Vine2.5/2.6
295- change configure option (add -enable--final, remove -enable--debug)
296- update %%files section
297
298* Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
299- source upgrade
300- remove patch1 (rejected)
301
302* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
303- BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
304
305* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
306- source upgrade
307- revised Source1
308- remove Patch1 and Patch4
309
310* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
311- merged with rawhide 2.1.1-3
312- clean up spec
313- add BuildPrereq: objprelink (i386 only)
314- remove Obsoletes: kdevelop-c_c++_ref
315- add BuildPrereq: autoconf252 automake15
316- There is Vine's previous changes, hacked for Vine
317 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
318  - build for VineSeed
319  - delete Epoch
320  - update Patch1 and delete Patch2
321
322* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
323- automated rebuild
324
325* Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
326- don't forcibly strip binaries
327
328* Sun Jun  2 2002 Than Ngo <than@redhat.com> 2.1.1-1
329- 2.1.1
330
331* Sun May 26 2002 Tim Powers <timp@redhat.com>
332- automated rebuild
333
334* Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
335- Use automake15
336
337* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
338- Change sonames
339
340* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
341- final
342
343* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
344- update
345
346* Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
347- update to 2.1rc3
348
349* Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
350- update to 2.1rc2
351
352* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
353- rebuild against new kdelibs
354
355* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
356- fixed Strange characters appear in the output window (bug #59217)
357- fixed return-line feed sign in Kdevelop setup tool (bug #55032)
358
359* Wed Mar  8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
360- update to 2.1beta2
361
362* Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
363- rebuild against new kdelibs
364
365* Wed Jan  9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
366- update to 2.1 beta1
367- fix build against gcc 3
368- fix some typo bugs
369- get rid of libkfile
370- update c_cpp_reference to 2.0.1
371
372* Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
373- add patch to show non lattin1 font in build-in editor correct (bug #54457)
374
375* Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
376- fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
377- backport some major bugfixes from 2.0.1
378
379* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
380- Don't crash on startup
381
382* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
383- Fix file list
384
385* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
386- Update
387
388* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
389- Yet another respin - printing was broken.
390
391* Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
392- Update the C/C++ reference guide docs. The older version had a
393  couple of examples that won't work with gcc 2.96-*
394
395* Thu Feb 22 2001 Than Ngo <than@redhat.com>
396- fix version number
397
398* Wed Feb 21 2001 Than Ngo <than@redhat.com>
399- 1.4-respin
400
401* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
402- 1.4
403
404* Wed Feb 14 2001 Than Ngo <than@redhat.com>
405- update (only bugfixes)
406- fix up kdelibs documentation path
407- fix a dependency problem with kde-i18n package (Bug #27675)
408- add qt-designer into requires
409
410* Sun Feb 11 2001 Than Ngo <than@redhat.com>
411- fixed to build on s390
412
413* Tue Feb 06 2001 Than Ngo <than@redhat.com>
414- update, only bugfixes
415
416* Wed Jan 24 2001 Than Ngo <than@redhat.com>
417- hacked for building of KDE references
418
419* Tue Jan 23 2001 Than Ngo <than@redhat.com>
420- work-around to build on alpha
421
422* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
423- Update
424
425* Wed Jan 10 2001 Than Ngo <than@redhat.com>
426- update new snapshot, only require KDE2/Qt2
427
428* Fri Dec 22 2000 Than Ngo <than@redhat.com>
429- fixed dependency problem with kde-i18n
430
431* Thu Dec 21 2000 Than Ngo <than@redhat.com>
432- updated to 1.4beta1 with KDE2 support
433- fixed to build on s390
434- fixed some broken codes
435 
436* Fri Dec 8 2000 Than Ngo <than@redhat.com>
437- fixed for building on ia64
438 
439* Wed Nov 15 2000 Than Ngo <than@redhat.com>
440- build snapshot 20001112, it works now with KDE2 and kde1-compat
441- fix libtool to build on sparc and alpha
442- don't use make -j
443 
444* Sun Aug 13 2000 Than Ngo <than@redhat.com>
445- fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
446 
447* Tue Aug 01 2000 Than Ngo <than@redhat.de>
448- add missing ldconfig in %post and %postun section (Bug #14924)
449- add missing C references stuff to kdevelop
450 
451* Sun Jul 30 2000 Than Ngo <than@redhat.de>
452- rebuilt against compat-egcs-c++, put KDE1 under /usr
453- cleanup specfile
454 
455* Tue Jul 25 2000 Than Ngo <than@redhat.de>
456- fix dependency problem
457 
458* Wed Jul 19 2000 Than Ngo <than@redhat.de>
459- rebuilt against compat-libstdc++
460 
461* Mon Jul 17 2000 Than Ngo <than@redhat.de>
462- install under /usr/share instead /usr/lib/kde1-compat/share,
463  fix dependency problem
464 
465* Sat Jul 15 2000 Than Ngo <than@redhat.de>
466- rebuilt with egcs-c++-1.1.2
467
468* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
469- automatic rebuild
470 
471* Mon Jul 03 2000 Than Ngo <than@redhat.de>
472- fix docdir
473- add requires kdebase
474 
475* Sun Jul 02 2000 Than Ngo <than@redhat.de>
476- rebuilt with  kde1-compat
477 
478* Sun Jun 18 2000 Than Ngo <than@redhat.de>
479- rebuilt in the new build environment, fix docdir
480- FHS packaging
481 
482* Thu Jun 08 2000 Than Ngo <than@redhat.de>
483- update to 1.2
484- move from powertools to main CD
485- use %%configure
486 
487* Mon Apr 3 2000 Ngo Than <than@redhat.de>
488- fix up reference (Bug #10368)
489 
490* Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
491- Fix up documentation path (Bug #7291)
492- Update to current stable branch - this should fix up the debugger problem
493- clean up spec file
494 
495* Fri Jan  6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
496- Update to current stable branch
497- Adapt to 6.2 Qt libraries
498- Use BuildPrereq
499 
500* Wed Jan 05 2000 Ngo Than <than@redhat.de>
501- added patch for alpha
502 
503* Tue Dec 21 1999 Ngo Than <than@redhat.de>
504- updated kdevelop-1.0 release
505 
506* Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
507- kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
508 
509* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
510- initial packaging for 6.1.
Note: See TracBrowser for help on using the repository browser.