source: projects/specs/trunk/k/kdevelop/kdevelop-vl.spec @ 9226

Revision 9226, 15.5 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1Name: kdevelop
2Summary: Integrated Development Environment for C++/C
3Summary(ja): C++/C 向け統合開発環境
4Version: 4.7.0
5Release: 1%{?_dist_release}
6
7License: GPLv2
8URL: http://www.kdevelop.org/
9Group: Applications/Development
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.xz
12
13# fixing https://bugs.kde.org/show_bug.cgi?id=236315
14Patch100: kdevelop-4.0.0-qmake_qt4.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: desktop-file-utils
18BuildRequires: gettext
19BuildRequires: kdebase-workspace-devel
20BuildRequires: kdevplatform-devel >= 1.4.0
21BuildRequires: kdelibs-devel
22BuildRequires: kdesdk-devel
23BuildRequires: soprano-devel
24BuildRequires: qjson-devel
25BuildRequires: valgrind
26
27Requires: %{name}-libs = %{version}-%{release}
28Requires: kdevplatform >= 1.4.0
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34The KDevelop Integrated Development Environment provides many features
35that developers need as well as providing a unified interface to programs
36like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
37
38All development tools needed for C++ programming like Compiler,
39Linker, automake and autoconf; KAppWizard, which generates complete,
40ready-to-go sample applications; Classgenerator, for creating new
41classes and integrating them into the current project; File management
42for sources, headers, documentation etc. to be included in the
43project; The creation of User-Handbooks written with SGML and the
44automatic generation of HTML-output with the KDE look and feel;
45Automatic HTML-based API-documentation for your project's classes with
46cross-references to the used libraries; Internationalization support
47for your application, allowing translators to easily add their target
48language to a project;
49
50KDevelop also includes WYSIWYG (What you see is what you get)-creation
51of user interfaces with a built-in dialog editor; Debugging your
52application by integrating KDbg; Editing of project-specific pixmaps
53with KIconEdit; The inclusion of any other program you need for
54development by adding it to the "Tools"-menu according to your
55individual needs.
56
57%package libs
58Summary: %{name} runtime libraries
59Summary(ja): %{name} のランタイムライブラリ
60Group:   System Environment/Libraries
61#Requires: %{name} = %{version}-%{release}
62Requires: kdelibs
63
64%description libs
65%{summary}.
66
67
68%package devel
69Summary: Development files for %{name}
70Summary(ja): %{name} の開発用ファイル
71Group: Development/Libraries
72Requires: %{name}-libs = %{version}-%{release}
73
74%description devel
75%{summary}.
76
77
78%prep
79%setup -q -n kdevelop-%{version}
80#patch100 -p1 -b .qmake_qt4
81
82%build
83mkdir -p %{_target_platform}
84pushd %{_target_platform}
85%cmake \
86    -DCMAKE_BUILD_TYPE=release \
87    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
88    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
89    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
90    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
91    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
92    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
93    ..
94popd
95
96make %{?_smp_mflags} -C %{_target_platform}
97
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
103
104%find_lang %{name} --all-name --with-kde
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109
110%post
111touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
112
113%postun
114if [ $1 -eq 0 ] ; then
115touch --no-create %{_datadir}/icons/hicolor &> /dev/null
116gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
117update-desktop-database -q &> /dev/null
118update-mime-database %{_datadir}/mime &> /dev/null
119fi
120
121%posttrans
122gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
123update-desktop-database -q &> /dev/null
124update-mime-database %{_datadir}/mime &> /dev/null
125
126%post libs -p /sbin/ldconfig
127
128%postun libs -p /sbin/ldconfig
129
130%files -f %{name}.lang
131%defattr(-,root,root)
132%{_bindir}/*
133%config %{_datadir}/config/kdeveloprc
134%{_datadir}/applications/kde4/*.desktop
135%{_datadir}/config/kdevelop-qthelp.knsrc
136%{_datadir}/kde4/apps/kdev*/
137%{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/contents/ui/kdevelopsessions.qml
138%{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/metadata.desktop
139%{_datadir}/kde4/apps/plasma/services/org.kde.plasma.dataengine.kdevelopsessions.operations
140%{_datadir}/kde4/services/*.desktop
141%{_datadir}/icons/hicolor/*/*/*
142%{_datadir}/mime/packages/kdevelop.xml
143#{_datadir}/servicetypes/*
144#doc %{_datadir}/doc/HTML/en/*
145
146%files libs
147%defattr(-,root,root,-)
148%{_libdir}/lib*.so
149%{_libdir}/kde4/*.so
150
151%files devel
152%defattr(-,root,root,-)
153%{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
154%{_includedir}/kde4/kdevelop/
155
156
157%changelog
158* Sun Jan 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.0-1
159- new upstream release
160
161* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.0-1
162- new upstream release
163- add BuildRequires: qjson-devel
164
165* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.1-1
166- new upstream release
167
168* Sat Oct 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.0-1
169- new upstream release
170
171* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.1-1
172- new upstream release
173
174* Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.3-1
175- new upstream release
176
177* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-2
178- add BuildRequires: kdesdk-devel, soprano-devel
179
180* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
181- new upstream release
182
183* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
184- new upstream release
185
186* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
187- new upstream release
188- split shared libraries and header files
189
190* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
191- new upstream release
192- applied new versioning policy, spec in UTF-8
193- changed Group to Applications/Development
194
195* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
196- rebuild for VineSeed
197
198* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
199- new upstream release
200
201* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
202- rebuild for VineSeed
203
204* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
205- new upstream release
206
207* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
208- rebuild for VineSeed
209
210* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
211- new upstream release
212- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
213
214* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
215- rebuild for VineSeed
216
217* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
218- new upstream release
219
220* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
221- rebuild for VineSeed
222
223* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
224- new upstream release
225
226* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
227- rebuild for VineSeed
228
229* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
230- new upstream release
231- add BuildPrereq: apache2-devel subversion-devel
232
233* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
234- new upstream release
235
236* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
237- new upstream release
238- delete Patch0
239
240* Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
241- new upstream release
242- add Patch0
243- update %%files
244
245* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
246- rebuild for VineSeed
247
248* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
249- new upstream release
250
251* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
252- rebuild for VineSeed
253
254* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
255- new upstream release
256- add --disable-rpath to configure option
257- remove BuildPrereq: qt-static
258
259* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
260- rebuild for VineSeed
261
262* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
263- new upstream release
264- update %%files
265- add +w to %%{_prefix}/kdevbdb/*
266
267* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
268- rebuild for VineSeed
269
270* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
271- new upstream release
272- update %%files
273
274* Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
275- source upgrade
276- add BuildPrereq: qt-static
277
278* Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
279- rebuild with qt32
280
281* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
282- source upgrade
283- remove lines about vine26
284
285* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
286- source upgrade
287- add Requires: ctags
288
289* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
290- source upgrade
291- remove all patches
292- remove c references
293- add Requires: htdig
294
295* Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
296- change spec to build both VineSeed and Vine2.5/2.6
297- change configure options
298- add %%clean section
299- add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
300
301* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
302- source upgrade
303- change spec to build both VineSeed and Vine2.5/2.6
304- change configure option (add -enable--final, remove -enable--debug)
305- update %%files section
306
307* Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
308- source upgrade
309- remove patch1 (rejected)
310
311* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
312- BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
313
314* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
315- source upgrade
316- revised Source1
317- remove Patch1 and Patch4
318
319* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
320- merged with rawhide 2.1.1-3
321- clean up spec
322- add BuildPrereq: objprelink (i386 only)
323- remove Obsoletes: kdevelop-c_c++_ref
324- add BuildPrereq: autoconf252 automake15
325- There is Vine's previous changes, hacked for Vine
326 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
327  - build for VineSeed
328  - delete Epoch
329  - update Patch1 and delete Patch2
330
331* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
332- automated rebuild
333
334* Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
335- don't forcibly strip binaries
336
337* Sun Jun  2 2002 Than Ngo <than@redhat.com> 2.1.1-1
338- 2.1.1
339
340* Sun May 26 2002 Tim Powers <timp@redhat.com>
341- automated rebuild
342
343* Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
344- Use automake15
345
346* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
347- Change sonames
348
349* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
350- final
351
352* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
353- update
354
355* Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
356- update to 2.1rc3
357
358* Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
359- update to 2.1rc2
360
361* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
362- rebuild against new kdelibs
363
364* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
365- fixed Strange characters appear in the output window (bug #59217)
366- fixed return-line feed sign in Kdevelop setup tool (bug #55032)
367
368* Fri Mar  8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
369- update to 2.1beta2
370
371* Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
372- rebuild against new kdelibs
373
374* Wed Jan  9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
375- update to 2.1 beta1
376- fix build against gcc 3
377- fix some typo bugs
378- get rid of libkfile
379- update c_cpp_reference to 2.0.1
380
381* Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
382- add patch to show non lattin1 font in build-in editor correct (bug #54457)
383
384* Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
385- fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
386- backport some major bugfixes from 2.0.1
387
388* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
389- Don't crash on startup
390
391* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
392- Fix file list
393
394* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
395- Update
396
397* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
398- Yet another respin - printing was broken.
399
400* Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
401- Update the C/C++ reference guide docs. The older version had a
402  couple of examples that won't work with gcc 2.96-*
403
404* Thu Feb 22 2001 Than Ngo <than@redhat.com>
405- fix version number
406
407* Wed Feb 21 2001 Than Ngo <than@redhat.com>
408- 1.4-respin
409
410* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
411- 1.4
412
413* Wed Feb 14 2001 Than Ngo <than@redhat.com>
414- update (only bugfixes)
415- fix up kdelibs documentation path
416- fix a dependency problem with kde-i18n package (Bug #27675)
417- add qt-designer into requires
418
419* Sun Feb 11 2001 Than Ngo <than@redhat.com>
420- fixed to build on s390
421
422* Tue Feb 06 2001 Than Ngo <than@redhat.com>
423- update, only bugfixes
424
425* Wed Jan 24 2001 Than Ngo <than@redhat.com>
426- hacked for building of KDE references
427
428* Tue Jan 23 2001 Than Ngo <than@redhat.com>
429- work-around to build on alpha
430
431* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
432- Update
433
434* Wed Jan 10 2001 Than Ngo <than@redhat.com>
435- update new snapshot, only require KDE2/Qt2
436
437* Fri Dec 22 2000 Than Ngo <than@redhat.com>
438- fixed dependency problem with kde-i18n
439
440* Thu Dec 21 2000 Than Ngo <than@redhat.com>
441- updated to 1.4beta1 with KDE2 support
442- fixed to build on s390
443- fixed some broken codes
444 
445* Fri Dec 8 2000 Than Ngo <than@redhat.com>
446- fixed for building on ia64
447 
448* Wed Nov 15 2000 Than Ngo <than@redhat.com>
449- build snapshot 20001112, it works now with KDE2 and kde1-compat
450- fix libtool to build on sparc and alpha
451- don't use make -j
452 
453* Sun Aug 13 2000 Than Ngo <than@redhat.com>
454- fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
455 
456* Tue Aug 01 2000 Than Ngo <than@redhat.de>
457- add missing ldconfig in %post and %postun section (Bug #14924)
458- add missing C references stuff to kdevelop
459 
460* Sun Jul 30 2000 Than Ngo <than@redhat.de>
461- rebuilt against compat-egcs-c++, put KDE1 under /usr
462- cleanup specfile
463 
464* Tue Jul 25 2000 Than Ngo <than@redhat.de>
465- fix dependency problem
466 
467* Wed Jul 19 2000 Than Ngo <than@redhat.de>
468- rebuilt against compat-libstdc++
469 
470* Mon Jul 17 2000 Than Ngo <than@redhat.de>
471- install under /usr/share instead /usr/lib/kde1-compat/share,
472  fix dependency problem
473 
474* Sat Jul 15 2000 Than Ngo <than@redhat.de>
475- rebuilt with egcs-c++-1.1.2
476
477* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
478- automatic rebuild
479 
480* Mon Jul 03 2000 Than Ngo <than@redhat.de>
481- fix docdir
482- add requires kdebase
483 
484* Sun Jul 02 2000 Than Ngo <than@redhat.de>
485- rebuilt with  kde1-compat
486 
487* Sun Jun 18 2000 Than Ngo <than@redhat.de>
488- rebuilt in the new build environment, fix docdir
489- FHS packaging
490 
491* Thu Jun 08 2000 Than Ngo <than@redhat.de>
492- update to 1.2
493- move from powertools to main CD
494- use %%configure
495 
496* Mon Apr 3 2000 Ngo Than <than@redhat.de>
497- fix up reference (Bug #10368)
498 
499* Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
500- Fix up documentation path (Bug #7291)
501- Update to current stable branch - this should fix up the debugger problem
502- clean up spec file
503 
504* Thu Jan  6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
505- Update to current stable branch
506- Adapt to 6.2 Qt libraries
507- Use BuildPrereq
508 
509* Wed Jan 05 2000 Ngo Than <than@redhat.de>
510- added patch for alpha
511 
512* Tue Dec 21 1999 Ngo Than <than@redhat.de>
513- updated kdevelop-1.0 release
514 
515* Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
516- kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
517 
518* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
519- initial packaging for 6.1.
Note: See TracBrowser for help on using the repository browser.