source: projects/specs/trunk/k/kdepim3/kdepim3-vl.spec @ 636

Revision 636, 17.9 KB checked in by inagaki, 14 years ago (diff)

updated: KDE 3 stuffs

Line 
1%define beta 0
2%define vine4 %(grep -c 4. /etc/vine-release)
3
4Name: kdepim3
5Summary: Compatibility support for kdepim3
6Version: 3.5.10
7Release: 1%{?_dist_release}
8Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.bz2
9# KDE.org patches
10# KDE.gr.jp patches
11
12URL: http://www.kde.org/
13Group: Applications/Productivity
14License: GPLv2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: bison flex
18BuildRequires: desktop-file-utils
19BuildRequires: kdelibs3-devel >= %{version}
20BuildRequires: zlib-devel
21BuildRequires: libart_lgpl-devel
22BuildRequires: cyrus-sasl-devel
23BuildRequires: gpgme-devel
24BuildRequires: libXpm-devel libXScrnSaver-devel
25BuildRequires: libmal-devel
26BuildRequires: pilot-link-devel >= 0.9.5
27
28%description
29%{summary}, including libkcal.
30
31%package libs
32Summary: Runtime files for %{name}
33Group: System Environment/Libraries
34Requires: kdelibs3 >= %{version}
35
36%description libs
37%{summary}, including libkcal.
38
39%package devel
40Summary: Development files for %{name}
41Group: Development/Libraries
42Requires: %{name}-libs = %{version}-%{release}
43Requires: kdelibs3-devel
44
45%description devel
46Development files for %{name}.
47Install %{name}-devel if you want to write or compile %{name} plugins.
48
49%prep
50%setup -q -n kdepim-%{version}
51
52%ifarch ia64 s390 s390x
53rm -rf kpilot doc/kpilot
54%endif
55
56%build
57unset QTDIR || : ; . /etc/profile.d/qt.sh
58
59%configure \
60    --with-qt-libraries=$QTDIR/lib \
61    --enable-new-ldflags \
62    --disable-dependency-tracking \
63    --disable-rpath \
64    --disable-debug --disable-warnings \
65    --enable-final \
66    --includedir=%{_includedir}/kde \
67    --with-gpg=%{_bindir}/gpg \
68    --with-gpgsm=%{_bindir}/gpgsm \
69    --with-sasl \
70    --without-gnokii \
71    --with-mal \
72    --with-pilot-link
73
74for lib in ktnef libkmime libemailfunctions libkcal libkdepim; do
75make %{?_smp_mflags} -C ${lib}
76done
77
78%install
79rm -rf $RPM_BUILD_ROOT
80for lib in ktnef libkmime libemailfunctions libkcal libkdepim; do
81    make install DESTDIR=$RPM_BUILD_ROOT -C $lib
82done
83
84#unpackaged files
85rm -f  $RPM_BUILD_ROOT%{_libdir}/lib*.la
86rm -f  $RPM_BUILD_ROOT%{_libdir}/libkdepim*
87rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/libkdepim/
88rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/kdepimwidgets/
89rm -f  $RPM_BUILD_ROOT%{_libdir}/kde3/plugins/designer/*
90rm -f  $RPM_BUILD_ROOT%{_libdir}/lib{kmime,ktnef}.so
91rm -rf $RPM_BUILD_ROOT%{_includedir}/kde/ktnef/
92rm -rf $RPM_BUILD_ROOT%{_datadir}/applications
93rm -rf $RPM_BUILD_ROOT%{_datadir}/icons
94rm -rf $RPM_BUILD_ROOT%{_datadir}/mimelnk
95rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/ktnef
96rm -f  $RPM_BUILD_ROOT%{_bindir}/ktnef
97
98#cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/config/
99
100%post libs -p /sbin/ldconfig
101
102%postun libs -p /sbin/ldconfig
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%files libs
108%defattr(-,root,root)
109%doc README korganizer/COPYING
110%{_datadir}/config.kcfg/pimemoticons.kcfg
111%{_datadir}/apps/libical/
112%{_datadir}/services/kresources/kcal*
113%{_libdir}/libkcal.so.2*
114%{_libdir}/kde3/kcal*
115%{_libdir}/libkmime.so.2*
116%{_libdir}/libktnef.so.1*
117
118%files devel
119%defattr(-,root,root)
120%{_includedir}/kde/kdepimmacros.h
121%{_includedir}/kde/libemailfunctions
122%{_includedir}/kde/libkcal
123%{_libdir}/libkcal.so
124
125%changelog
126* Sun Mar 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-1
127- updated to 3.5.10
128- built with new toolchain
129
130* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-2
131- renamed kdepim3
132
133* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
134- applied new versioning policy, spec in UTF-8
135- added Japnaese summary
136
137* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
138- rebuild for VineSeed
139
140* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
141- new upstream release
142
143* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
144- rebuild for VineSeed
145
146* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
147- new upstream release
148- remove all patches
149
150* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
151- new upstream release
152- add Patch0, 1 , 2 and 3
153
154* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
155- added --with-qt-libraries and --enable-libsuffix option
156
157* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
158- rebuild for VineSeed
159
160* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
161- new upstream release
162
163* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
164- rebuild with pilot-link-0.12.0-0vl1
165
166* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
167- rebuild for VineSeed
168
169* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
170- new upstream release
171
172* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
173- rebuild for VineSeed
174
175* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
176- new upstream release
177
178* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
179- rebuild for VineSeed
180
181* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
182- new upstream release
183
184* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
185- rebuild for VineSeed
186
187* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
188- new upstream release
189- delete BuildPrereq: libmal-devel and Requires: libmal
190
191* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
192- rebuild for VineSeed
193
194* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
195- new upstream release
196
197* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
198- new upstream release
199
200* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
201- new upstream release
202- delete all patches
203- add Requires: kdeaccessibility  >= %%{version}
204- add --enable-indexlib to configure option
205
206* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
207- new upstream release
208- remove Patch0
209- add Patch0 - Patch1
210
211* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
212- rebuild for VineSeed
213
214* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
215- new upstream release
216- remove Patch0
217- add BuildPrereq: gpgme-devel >= 0.4.5
218- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
219
220* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
221- rebuild for VineSeed
222- add --disable-rpath to configure option
223
224* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
225- new upstream release (delete old patch and add new security patch)
226- use %%{?_smp_mflags} for make option
227
228* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
229- rebuild for VineSeed
230
231* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
232- new upstream release
233- add patch0
234
235* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
236- new upstream release (3.4.0-rc1)
237
238* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
239- new upstream release
240
241* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
242- new upstream release
243
244* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
245- rebuild for VineSeed
246
247* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
248- new upstream release
249
250* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
251- source upgrade
252- update %%files
253- all sub-packages are integrated into main package (exclude devel)
254
255* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
256- rebuild with qt32
257
258* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
259- source upgrade
260- remove lines about vine26
261
262* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
263- source upgrade
264- update %%files
265
266* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
267- source upgrade
268- update %%description
269- add Obsoletes: kdenetwork < 3.2.0
270
271* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
272- rebuild for VineSeedPlus
273
274* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
275- source upgrade
276- build for VinePlus/2.6
277- (VinePlus/2.6) BuildPrereq: autoconf258
278- remove Patch
279
280* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
281- build for VineSeed with new toolchain and qt-3.2.3
282- add configure option --with-xinerama --enable-final
283
284* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
285- rebuild with qt-3.2.1-0.26vl3
286
287* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
288- rebuild with qt-3.2.1-0vl3
289
290* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
291- build with gcc-3.2.3
292
293* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
294- source upgrade
295- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
296
297* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
298- rebuild for Vine2.6
299
300* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
301- source upgrade
302- change spec to build with gcc295
303- change make option for SMP and add script
304- add BuildPrereq: libmal-devel
305- add Requires: libmal for pilot
306
307* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
308- source upgrade
309- remove Patch800 (included in this source)
310- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
311
312* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
313- source upgrade
314- change spec to build both VineSeed and Vine2.5/2.6
315- revised description and files section
316- remove source900
317- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
318- add patch800 (Kdeveloper:02753)
319
320* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
321- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
322
323* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
324- source upgrade
325
326* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
327- rebuild with qt-3.0.5-0vl1
328- BuildPrereq: autoconf253 objprelink2
329
330* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
331- source upgrade
332
333* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
334- source upgrade
335- add BuildPrereq: autoconf252 automake15
336
337* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
338- merged with rawhide 3.0.1-1
339- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
340- add Requires: for each package
341- There is Vine's previous changes, hacked for Vine
342 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
343  - build for VineSeed
344  - delete Epoch
345  - objprelink (i386 only)
346
347* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
348- 3.0.1
349- fixed bug #67303
350
351* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
352- automated rebuild
353
354* Thu May 23 2002 Tim Powers <timp@redhat.com>
355- automated rebuild
356
357* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
358- Rename libraries
359
360* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
361- Fix #61901
362
363* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
364- final
365
366* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
367- Update
368- Fix build on ia64
369
370* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
371- Update, fixes korganizer (#50006)
372
373* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
374- Update to get rid of abbrowser (moved to kdebase)
375
376* Thu Feb 22 2001 Than Ngo <than@redhat.com>
377- add missing ldconfig in %post anf %postun again
378- clean up specfile
379
380* Wed Feb 21 2001 Than Ngo <than@redhat.com>
381- 2.1-respin
382- fix dangling symlink
383- remove excludearch ia64, some hacks to build on ia64
384
385* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
386- 2.1
387
388* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
389- Update
390
391* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
392- Update
393
394* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
395- Update to CVS
396- Enable building kpilot
397- Obsolete kpilot
398- Don't exclude ia64, use -O0 on ia64
399- Disable building kpilot on ia64 (compiler breakage)
400
401* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
402- 2.0 final
403
404* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
405- 2.0
406
407* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
408- new CVS
409- fix installation of fonts
410
411* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
412- new CVS snapshot
413- fix up spec file
414
415* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
416- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
417  there's no need to keep them separate to avoid the dependency.
418
419* Mon Aug 21 2000 Than Ngo <than@redhat.com>
420- fix gnome-session so that KDE2 can be started from gdm
421- pam/kde2 instead pam/kde to avoid problem with KDE1
422- don't requires qt-GL, It's now in qt
423
424* Sun Aug 20 2000 Than Ngo <than@redhat.com>
425- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
426  at the same time
427- add missing ldconfig in %post anf %postun
428- fix for reading config files in /etc/X11/xdm, add Xsession to requires
429
430* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
431- Fix keytable in konsole (Bug #15682)
432
433* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
434- rebuild, now that kdelibs2 works on alpha
435- use the same ugly hack to get kdebase to compile
436- remove ksysguard on alpha (even more compiler problems)
437
438* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
439- new snapshot (fixed libGL detection in CVS)
440
441* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
442- move to /usr/lib/kde2
443- new snapshot
444
445* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
446- fix the --xdmdir arg to be correct (oops)
447
448* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
449- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
450
451* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
452- new snapshot
453- some fixes to spec file
454
455* Tue Jul 18 2000 Than Ngo <than@redhat.de>
456- rebuilt against glibc-2.1.92-14, gcc-2.96-40
457
458* Sun Jul 16 2000 Than Ngo <than@redhat.de>
459- use new snapshot
460- disable Motif
461
462* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
463- use gcc 2.96
464- new snapshot
465
466* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
467- Epoch 3
468- Update to current
469- Use egcs++
470
471* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
472- Update (I put the fixes directly to CVS rather than collecting them
473  in the spec)
474
475* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
476- remove man2html; we get that from man
477- new snapshot
478
479* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
480- new snapshot
481- ExcludeArch ia64 for now
482- remove gnome .desktop file, we get it from gnome-core now.
483
484* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
485- remove dependency on xpm (now in XFree86)
486
487* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
488- new snapshot
489- move it to /usr, where it belongs
490
491* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
492- Build the OpenGL screensavers, and move them to a separate package
493- Improve the spec file (BuildPrereqs etc.)
494
495* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
496- remove patch #3 (obsoleted by kwin)
497
498* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
499- 2.0 CVS snapshot
500- fix compilation
501
502* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
503- clean up files in /tmp from startkde
504- mark doc files as such
505
506* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
507- start autorun if present in startkde
508- check for configured soundcard before running sound services
509
510* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
511- made kdelnks display Name property if they are of type Link
512
513* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
514- moved png handling here (from kdelibs)
515- changed low color icon directory name to locolor
516
517* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
518- added optional session management to logout dialog
519- include GNOME menus
520
521* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
522- added link to /etc/X11/applnk, .directory file
523- included lowcolor icon sub-package
524- enable .desktop file access
525
526* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
527- customized startkde script to set up user environment if not present.
528- mention kthememgr in description.
529
530* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
531- upgraded to 1.1.2 release
532- kvt is back
533- kde icon included
534- linux console fonts included
535
536* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
537- PAM console logout problem solved.
538
539* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
540- now includes screensaver password security fix
541
542* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
543- snapshot, includes kde 1.1.1 + fixes
544- kvt removed for security reasons.  It is a steaming pile of...
545
546* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
547- last snapshot before release
548
549* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
550- today's snapshot makes kfm a bit nicer and some other fixes
551- moved default rc files to kdesupport
552
553* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
554- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
555
556* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
557- built with today's snapshot -- had to rebuild to fix pam problems.
558
559* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
560- new snapshot fixes mimetype video/x-flic problem
561
562* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
563- latest stable snapshot
564
565* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
566- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
567- this previous connection and autoselect kdebase for upgrade).
568
569* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
570- moved gdm patch
571
572* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
573- added gdm session control file
574
575* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
576- added pam-console stuff to kde pam file
577
578* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
579- Injected new description and group.
580
581* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
582- upgraded to KDE 1.1 final.
583
584* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
585- updated macros for RPM 3.0, removed red hat logo.
586
587* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
588- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.