source: projects/specs/trunk/k/kdepim/kdepim-vl.spec @ 560

Revision 560, 20.4 KB checked in by inagaki, 14 years ago (diff)

2010-03-13 Ryoichi INAGAKI <ryo1@…>

updated for KDE 4.4.1

Line 
1%define beta 0
2%define vine4 %(grep -c 4. /etc/vine-release)
3
4Name: kdepim
5Version: 4.4.1
6Release: 1%{?_dist_release}
7Summary: PIM (Personal Information Manager) for KDE
8Summary(ja): KDE の個人情報管理(PIM)アプリケーション集
9Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
10Patch0:  kdepim-4.1.80-libqgpgme-link-fix.patch
11# http://bugzilla.redhat.com/show_bug.cgi?id=496988
12Patch1:  kdepim-4.3.1-kmail-saveAttachments.patch
13## upstream
14
15# KDE.org patches
16# KDE.gr.jp patches
17
18URL: http://www.kde.org/
19Group: Applications/Productivity
20License: GPLv2
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: akonadi-devel
24BuildRequires: bison flex
25BuildRequires: libboost-devel
26BuildRequires: cyrus-sasl-devel
27BuildRequires: desktop-file-utils
28BuildRequires: gnokii-devel
29BuildRequires: gpgme-devel
30BuildRequires: kdepimlibs-devel >= %{version}
31BuildRequires: kdelibs-experimental-devel
32BuildRequires: libassuan-devel
33BuildRequires: libical-devel
34BuildRequires: libXpm-devel libXScrnSaver-devel
35# TODO: libmapi from http://www.openchange.org/
36#BuildRequires: libmapi-devel
37BuildRequires: libxslt-devel
38# libmal currently not used, recheck with kdepim-4.3
39BuildRequires: pilot-link-devel >= 0.12.4
40BuildRequires: python-devel
41BuildRequires: soprano-devel
42BuildRequires: qca2-devel
43BuildRequires: zlib-devel
44
45Provides: kdepim4 = %{version}-%{release}
46Requires: %{name}-libs = %{version}-%{release}
47
48%description
49A PIM (Personal Information Manager) for KDE.
50
51What it is
52----------
53* kmail: email client
54* knode: newsreader
55* knotes: sticky notes for the desktop
56* kontact: integrated PIM management
57* korganizer: journal, appointments, events, todos
58%{?_with_pilot_link:* kpilot: HotSync® software for Palm OS® devices}
59
60%package libs
61Summary: %{name} runtime libraries
62Group:   System Environment/Libraries
63Requires: kdelibs4 >= %{version}
64
65%description libs
66%{summary}.
67
68%package devel
69Summary: Development files for kdepim
70Group: Development/Libraries
71Provides: kdepim4-devel = %{version}-%{release}
72Requires: %{name}-libs = %{version}-%{release}
73Requires: kdelibs4-devel
74
75%description devel
76Development files for %{name}.
77Install %{name}-devel if you want to write or compile %{name} plugins.
78
79%prep
80%setup -q
81%patch0 -p1 -b .libqgpgme-link-fix
82%patch1 -p0 -b .kmail-saveAttachments
83
84%build
85mkdir -p %{_target_platform}
86pushd %{_target_platform}
87unset QTDIR || : ; . /etc/profile.d/qt4.sh
88%cmake \
89    -DCMAKE_BUILD_TYPE=release \
90    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
91    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
92    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
93    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
94    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
95    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
96    ..
97popd
98
99make %{?_smp_mflags} -C %{_target_platform}
100
101%install
102rm -rf $RPM_BUILD_ROOT
103make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
104
105# make symlinks relative
106mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
107pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
108for i in *; do
109   if [ -d $i -a -L $i/common ]; then
110      rm -f $i/common
111      ln -nfs ../common $i
112   fi
113done
114popd
115
116%check
117for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
118  desktop-file-validate $f
119done
120
121%post
122touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
123touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
124
125%posttrans
126gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
127gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
128update-desktop-database -q &> /dev/null ||:
129
130%postun
131if [ $1 -eq 0 ] ; then
132  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
133  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
134  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
135  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
136  update-desktop-database -q &> /dev/null ||:
137fi
138
139%post libs -p /sbin/ldconfig
140
141%postun libs -p /sbin/ldconfig
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%files
147%defattr(-,root,root)
148%{_bindir}/*
149#{_libdir}/libkpilot_*.so
150%{_libdir}/kde4/*.so
151%{_libdir}/strigi/*.so
152%{_libdir}/akonadi/*
153%{_datadir}/applications/kde4/*.desktop
154%{_datadir}/kde4/apps/akregator
155#{_datadir}/kde4/apps/akonadi/*
156%{_datadir}/kde4/apps/akonadiconsole/*
157%{_datadir}/kde4/apps/blogilo/*
158%{_datadir}/kde4/apps/kaddressbook
159%{_datadir}/kde4/apps/kalarm
160%{_datadir}/kde4/apps/kconf_update/*
161%{_datadir}/kde4/apps/kdepimwidgets
162%{_datadir}/kde4/apps/kjots
163%{_datadir}/kde4/apps/kleopatra
164%{_datadir}/kde4/apps/kmail
165%{_datadir}/kde4/apps/kmailcvt
166%{_datadir}/kde4/apps/knode
167%{_datadir}/kde4/apps/knotes
168%{_datadir}/kde4/apps/konsolekalendar
169%{_datadir}/kde4/apps/kontact
170%{_datadir}/kde4/apps/kontactsummary
171%{_datadir}/kde4/apps/korgac
172%{_datadir}/kde4/apps/korganizer
173#{_datadir}/kde4/apps/kpilot
174%{_datadir}/kde4/apps/ktimetracker
175%{_datadir}/kde4/apps/kwatchgnupg
176%{_datadir}/kde4/apps/libkdepim
177%{_datadir}/kde4/apps/libkleopatra
178%{_datadir}/dbus-1/interfaces/*.xml
179%{_datadir}/autostart/*
180%{_datadir}/akonadi/*
181%{_datadir}/config/*
182%{_datadir}/config.kcfg/*
183%{_datadir}/icons/hicolor/*/*/*
184%{_datadir}/icons/oxygen/*/*/*
185%{_datadir}/kde4/services/*
186%{_datadir}/kde4/servicetypes/*
187%doc %{_docdir}/HTML/en/*
188%{_mandir}/man1/*
189
190%files libs
191%defattr(-,root,root)
192%{_libdir}/lib*.so.*
193%{_libdir}/kde4/plugins/designer/*.so
194
195%files devel
196%defattr(-,root,root)
197#{_includedir}/kde4/*
198%{_libdir}/lib*.so
199#exclude %{_libdir}/libkpilot_*.so
200
201%changelog
202* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
203- new upstream release
204
205* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
206- new upstream release
207- built with new toolchain
208
209* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
210- new upstream release
211
212* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
213- new upstream release
214- dropped Patch100 (merged into upstream)
215- used %%cmake macro
216
217* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
218- new upstream release
219
220* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
221- applied new versioning policy, spec in UTF-8
222- added Japnaese summary
223
224* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
225- rebuild for VineSeed
226
227* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
228- new upstream release
229
230* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
231- rebuild for VineSeed
232
233* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
234- new upstream release
235- remove all patches
236
237* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
238- new upstream release
239- add Patch0, 1 , 2 and 3
240
241* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
242- added --with-qt-libraries and --enable-libsuffix option
243
244* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
245- rebuild for VineSeed
246
247* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
248- new upstream release
249
250* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
251- rebuild with pilot-link-0.12.0-0vl1
252
253* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
254- rebuild for VineSeed
255
256* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
257- new upstream release
258
259* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
260- rebuild for VineSeed
261
262* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
263- new upstream release
264
265* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
266- rebuild for VineSeed
267
268* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
269- new upstream release
270
271* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
272- rebuild for VineSeed
273
274* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
275- new upstream release
276- delete BuildPrereq: libmal-devel and Requires: libmal
277
278* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
279- rebuild for VineSeed
280
281* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
282- new upstream release
283
284* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
285- new upstream release
286
287* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
288- new upstream release
289- delete all patches
290- add Requires: kdeaccessibility  >= %%{version}
291- add --enable-indexlib to configure option
292
293* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
294- new upstream release
295- remove Patch0
296- add Patch0 - Patch1
297
298* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
299- rebuild for VineSeed
300
301* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
302- new upstream release
303- remove Patch0
304- add BuildPrereq: gpgme-devel >= 0.4.5
305- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
306
307* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
308- rebuild for VineSeed
309- add --disable-rpath to configure option
310
311* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
312- new upstream release (delete old patch and add new security patch)
313- use %%{?_smp_mflags} for make option
314
315* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
316- rebuild for VineSeed
317
318* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
319- new upstream release
320- add patch0
321
322* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
323- new upstream release (3.4.0-rc1)
324
325* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
326- new upstream release
327
328* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
329- new upstream release
330
331* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
332- rebuild for VineSeed
333
334* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
335- new upstream release
336
337* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
338- source upgrade
339- update %%files
340- all sub-packages are integrated into main package (exclude devel)
341
342* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
343- rebuild with qt32
344
345* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
346- source upgrade
347- remove lines about vine26
348
349* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
350- source upgrade
351- update %%files
352
353* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
354- source upgrade
355- update %%description
356- add Obsoletes: kdenetwork < 3.2.0
357
358* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
359- rebuild for VineSeedPlus
360
361* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
362- source upgrade
363- build for VinePlus/2.6
364- (VinePlus/2.6) BuildPrereq: autoconf258
365- remove Patch
366
367* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
368- build for VineSeed with new toolchain and qt-3.2.3
369- add configure option --with-xinerama --enable-final
370
371* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
372- rebuild with qt-3.2.1-0.26vl3
373
374* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
375- rebuild with qt-3.2.1-0vl3
376
377* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
378- build with gcc-3.2.3
379
380* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
381- source upgrade
382- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
383
384* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
385- rebuild for Vine2.6
386
387* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
388- source upgrade
389- change spec to build with gcc295
390- change make option for SMP and add script
391- add BuildPrereq: libmal-devel
392- add Requires: libmal for pilot
393
394* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
395- source upgrade
396- remove Patch800 (included in this source)
397- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
398
399* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
400- source upgrade
401- change spec to build both VineSeed and Vine2.5/2.6
402- revised description and files section
403- remove source900
404- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
405- add patch800 (Kdeveloper:02753)
406
407* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
408- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
409
410* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
411- source upgrade
412
413* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
414- rebuild with qt-3.0.5-0vl1
415- BuildPrereq: autoconf253 objprelink2
416
417* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
418- source upgrade
419
420* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
421- source upgrade
422- add BuildPrereq: autoconf252 automake15
423
424* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
425- merged with rawhide 3.0.1-1
426- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
427- add Requires: for each package
428- There is Vine's previous changes, hacked for Vine
429 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
430  - build for VineSeed
431  - delete Epoch
432  - objprelink (i386 only)
433
434* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
435- 3.0.1
436- fixed bug #67303
437
438* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
439- automated rebuild
440
441* Thu May 23 2002 Tim Powers <timp@redhat.com>
442- automated rebuild
443
444* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
445- Rename libraries
446
447* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
448- Fix #61901
449
450* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
451- final
452
453* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
454- Update
455- Fix build on ia64
456
457* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
458- Update, fixes korganizer (#50006)
459
460* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
461- Update to get rid of abbrowser (moved to kdebase)
462
463* Thu Feb 22 2001 Than Ngo <than@redhat.com>
464- add missing ldconfig in %post anf %postun again
465- clean up specfile
466
467* Wed Feb 21 2001 Than Ngo <than@redhat.com>
468- 2.1-respin
469- fix dangling symlink
470- remove excludearch ia64, some hacks to build on ia64
471
472* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
473- 2.1
474
475* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
476- Update
477
478* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
479- Update
480
481* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
482- Update to CVS
483- Enable building kpilot
484- Obsolete kpilot
485- Don't exclude ia64, use -O0 on ia64
486- Disable building kpilot on ia64 (compiler breakage)
487
488* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
489- 2.0 final
490
491* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
492- 2.0
493
494* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
495- new CVS
496- fix installation of fonts
497
498* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
499- new CVS snapshot
500- fix up spec file
501
502* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
503- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
504  there's no need to keep them separate to avoid the dependency.
505
506* Mon Aug 21 2000 Than Ngo <than@redhat.com>
507- fix gnome-session so that KDE2 can be started from gdm
508- pam/kde2 instead pam/kde to avoid problem with KDE1
509- don't requires qt-GL, It's now in qt
510
511* Sun Aug 20 2000 Than Ngo <than@redhat.com>
512- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
513  at the same time
514- add missing ldconfig in %post anf %postun
515- fix for reading config files in /etc/X11/xdm, add Xsession to requires
516
517* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
518- Fix keytable in konsole (Bug #15682)
519
520* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
521- rebuild, now that kdelibs2 works on alpha
522- use the same ugly hack to get kdebase to compile
523- remove ksysguard on alpha (even more compiler problems)
524
525* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
526- new snapshot (fixed libGL detection in CVS)
527
528* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
529- move to /usr/lib/kde2
530- new snapshot
531
532* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
533- fix the --xdmdir arg to be correct (oops)
534
535* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
536- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
537
538* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
539- new snapshot
540- some fixes to spec file
541
542* Tue Jul 18 2000 Than Ngo <than@redhat.de>
543- rebuilt against glibc-2.1.92-14, gcc-2.96-40
544
545* Sun Jul 16 2000 Than Ngo <than@redhat.de>
546- use new snapshot
547- disable Motif
548
549* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
550- use gcc 2.96
551- new snapshot
552
553* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
554- Epoch 3
555- Update to current
556- Use egcs++
557
558* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
559- Update (I put the fixes directly to CVS rather than collecting them
560  in the spec)
561
562* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
563- remove man2html; we get that from man
564- new snapshot
565
566* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
567- new snapshot
568- ExcludeArch ia64 for now
569- remove gnome .desktop file, we get it from gnome-core now.
570
571* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
572- remove dependency on xpm (now in XFree86)
573
574* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
575- new snapshot
576- move it to /usr, where it belongs
577
578* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
579- Build the OpenGL screensavers, and move them to a separate package
580- Improve the spec file (BuildPrereqs etc.)
581
582* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
583- remove patch #3 (obsoleted by kwin)
584
585* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
586- 2.0 CVS snapshot
587- fix compilation
588
589* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
590- clean up files in /tmp from startkde
591- mark doc files as such
592
593* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
594- start autorun if present in startkde
595- check for configured soundcard before running sound services
596
597* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
598- made kdelnks display Name property if they are of type Link
599
600* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
601- moved png handling here (from kdelibs)
602- changed low color icon directory name to locolor
603
604* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
605- added optional session management to logout dialog
606- include GNOME menus
607
608* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
609- added link to /etc/X11/applnk, .directory file
610- included lowcolor icon sub-package
611- enable .desktop file access
612
613* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
614- customized startkde script to set up user environment if not present.
615- mention kthememgr in description.
616
617* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
618- upgraded to 1.1.2 release
619- kvt is back
620- kde icon included
621- linux console fonts included
622
623* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
624- PAM console logout problem solved.
625
626* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
627- now includes screensaver password security fix
628
629* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
630- snapshot, includes kde 1.1.1 + fixes
631- kvt removed for security reasons.  It is a steaming pile of...
632
633* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
634- last snapshot before release
635
636* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
637- today's snapshot makes kfm a bit nicer and some other fixes
638- moved default rc files to kdesupport
639
640* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
641- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
642
643* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
644- built with today's snapshot -- had to rebuild to fix pam problems.
645
646* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
647- new snapshot fixes mimetype video/x-flic problem
648
649* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
650- latest stable snapshot
651
652* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
653- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
654- this previous connection and autoselect kdebase for upgrade).
655
656* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
657- moved gdm patch
658
659* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
660- added gdm session control file
661
662* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
663- added pam-console stuff to kde pam file
664
665* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
666- Injected new description and group.
667
668* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
669- upgraded to KDE 1.1 final.
670
671* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
672- updated macros for RPM 3.0, removed red hat logo.
673
674* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
675- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.