source: projects/specs/trunk/k/kdepim/kdepim-vl.spec @ 521

Revision 521, 20.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define beta 0
2%define vine4 %(grep -c 4. /etc/vine-release)
3
4Name: kdepim
5Version: 4.3.3
6Release: 1%{?_dist_release}
7Summary: PIM (Personal Information Manager) for KDE
8Summary(ja): KDE の個人情報管理(PIM)アプリケーション集
9Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
10Patch0:  kdepim-4.1.80-libqgpgme-link-fix.patch
11# http://bugzilla.redhat.com/show_bug.cgi?id=496988
12Patch1:  kdepim-4.3.1-kmail-saveAttachments.patch
13## upstream
14
15# KDE.org patches
16# KDE.gr.jp patches
17
18URL: http://www.kde.org/
19Group: Applications/Productivity
20License: GPLv2
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: akonadi-devel
24BuildRequires: bison flex
25BuildRequires: libboost-devel
26BuildRequires: cyrus-sasl-devel
27BuildRequires: desktop-file-utils
28BuildRequires: gnokii-devel
29BuildRequires: gpgme-devel
30BuildRequires: kdepimlibs-devel >= %{version}
31BuildRequires: kdelibs-experimental-devel
32BuildRequires: libassuan-devel
33BuildRequires: libical-devel
34BuildRequires: libXpm-devel libXScrnSaver-devel
35# TODO: libmapi from http://www.openchange.org/
36#BuildRequires: libmapi-devel
37BuildRequires: libxslt-devel
38# libmal currently not used, recheck with kdepim-4.3
39BuildRequires: pilot-link-devel >= 0.12.4
40BuildRequires: python-devel
41BuildRequires: soprano-devel
42BuildRequires: qca2-devel
43BuildRequires: zlib-devel
44
45Provides: kdepim4 = %{version}-%{release}
46Requires: %{name}-libs = %{version}-%{release}
47
48%description
49A PIM (Personal Information Manager) for KDE.
50
51What it is
52----------
53* kmail: email client
54* knode: newsreader
55* knotes: sticky notes for the desktop
56* kontact: integrated PIM management
57* korganizer: journal, appointments, events, todos
58%{?_with_pilot_link:* kpilot: HotSync® software for Palm OS® devices}
59
60%package libs
61Summary: %{name} runtime libraries
62Group:   System Environment/Libraries
63Requires: kdelibs4 >= %{version}
64
65%description libs
66%{summary}.
67
68%package devel
69Summary: Development files for kdepim
70Group: Development/Libraries
71Provides: kdepim4-devel = %{version}-%{release}
72Requires: %{name}-libs = %{version}-%{release}
73Requires: kdelibs4-devel
74
75%description devel
76Development files for %{name}.
77Install %{name}-devel if you want to write or compile %{name} plugins.
78
79%prep
80%setup -q
81%patch0 -p1 -b .libqgpgme-link-fix
82%patch1 -p0 -b .kmail-saveAttachments
83
84%build
85mkdir -p %{_target_platform}
86pushd %{_target_platform}
87unset QTDIR || : ; . /etc/profile.d/qt4.sh
88%cmake \
89    -DCMAKE_BUILD_TYPE=release \
90    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
91    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
92    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
93    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
94    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
95    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
96    ..
97popd
98
99make %{?_smp_mflags} -C %{_target_platform}
100
101%install
102rm -rf $RPM_BUILD_ROOT
103make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
104
105# make symlinks relative
106mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
107pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
108for i in *; do
109   if [ -d $i -a -L $i/common ]; then
110      rm -f $i/common
111      ln -nfs ../common $i
112   fi
113done
114popd
115
116%check
117for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
118  desktop-file-validate $f
119done
120
121%post
122touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
123touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
124
125%posttrans
126gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
127gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
128update-desktop-database -q &> /dev/null ||:
129
130%postun
131if [ $1 -eq 0 ] ; then
132  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
133  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
134  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
135  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
136  update-desktop-database -q &> /dev/null ||:
137fi
138
139%post libs -p /sbin/ldconfig
140
141%postun libs -p /sbin/ldconfig
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%files
147%defattr(-,root,root)
148%{_bindir}/*
149%{_libdir}/libkpilot_*.so
150%{_libdir}/kde4/*.so
151%{_libdir}/strigi/*.so
152%{_datadir}/applications/kde4/*.desktop
153%{_datadir}/kde4/apps/akregator
154%{_datadir}/kde4/apps/kaddressbook
155%{_datadir}/kde4/apps/kalarm
156%{_datadir}/kde4/apps/kconf_update/*
157%{_datadir}/kde4/apps/kdepimwidgets
158%{_datadir}/kde4/apps/kjots
159%{_datadir}/kde4/apps/kleopatra
160%{_datadir}/kde4/apps/kmail
161%{_datadir}/kde4/apps/kmailcvt
162%{_datadir}/kde4/apps/knode
163%{_datadir}/kde4/apps/knotes
164%{_datadir}/kde4/apps/konsolekalendar
165%{_datadir}/kde4/apps/kontact
166%{_datadir}/kde4/apps/kontactsummary
167%{_datadir}/kde4/apps/korgac
168%{_datadir}/kde4/apps/korganizer
169%{_datadir}/kde4/apps/kpilot
170%{_datadir}/kde4/apps/ktimetracker
171%{_datadir}/kde4/apps/kwatchgnupg
172%{_datadir}/kde4/apps/libkdepim
173%{_datadir}/kde4/apps/libkleopatra
174%{_datadir}/dbus-1/interfaces/*.xml
175%{_datadir}/autostart/*
176%{_datadir}/config/*
177%{_datadir}/config.kcfg/*
178%{_datadir}/icons/hicolor/*/*/*
179%{_datadir}/icons/oxygen/*/*/*
180%{_datadir}/kde4/services/*
181%{_datadir}/kde4/servicetypes/*
182%doc %{_docdir}/HTML/en/*
183
184%files libs
185%defattr(-,root,root)
186%{_libdir}/lib*.so.*
187%{_libdir}/kde4/plugins/designer/*.so
188
189%files devel
190%defattr(-,root,root)
191%{_includedir}/kde4/*
192%{_libdir}/lib*.so
193%exclude %{_libdir}/libkpilot_*.so
194
195%changelog
196* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
197- new upstream release
198
199* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
200- new upstream release
201- dropped Patch100 (merged into upstream)
202- used %%cmake macro
203
204* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
205- new upstream release
206
207* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
208- applied new versioning policy, spec in UTF-8
209- added Japnaese summary
210
211* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
212- rebuild for VineSeed
213
214* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
215- new upstream release
216
217* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
218- rebuild for VineSeed
219
220* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
221- new upstream release
222- remove all patches
223
224* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
225- new upstream release
226- add Patch0, 1 , 2 and 3
227
228* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
229- added --with-qt-libraries and --enable-libsuffix option
230
231* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
232- rebuild for VineSeed
233
234* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
235- new upstream release
236
237* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
238- rebuild with pilot-link-0.12.0-0vl1
239
240* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
241- rebuild for VineSeed
242
243* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
244- new upstream release
245
246* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
247- rebuild for VineSeed
248
249* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
250- new upstream release
251
252* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
253- rebuild for VineSeed
254
255* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
256- new upstream release
257
258* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
259- rebuild for VineSeed
260
261* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
262- new upstream release
263- delete BuildPrereq: libmal-devel and Requires: libmal
264
265* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
266- rebuild for VineSeed
267
268* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
269- new upstream release
270
271* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
272- new upstream release
273
274* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
275- new upstream release
276- delete all patches
277- add Requires: kdeaccessibility  >= %%{version}
278- add --enable-indexlib to configure option
279
280* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
281- new upstream release
282- remove Patch0
283- add Patch0 - Patch1
284
285* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
286- rebuild for VineSeed
287
288* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
289- new upstream release
290- remove Patch0
291- add BuildPrereq: gpgme-devel >= 0.4.5
292- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
293
294* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
295- rebuild for VineSeed
296- add --disable-rpath to configure option
297
298* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
299- new upstream release (delete old patch and add new security patch)
300- use %%{?_smp_mflags} for make option
301
302* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
303- rebuild for VineSeed
304
305* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
306- new upstream release
307- add patch0
308
309* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
310- new upstream release (3.4.0-rc1)
311
312* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
313- new upstream release
314
315* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
316- new upstream release
317
318* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
319- rebuild for VineSeed
320
321* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
322- new upstream release
323
324* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
325- source upgrade
326- update %%files
327- all sub-packages are integrated into main package (exclude devel)
328
329* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
330- rebuild with qt32
331
332* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
333- source upgrade
334- remove lines about vine26
335
336* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
337- source upgrade
338- update %%files
339
340* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
341- source upgrade
342- update %%description
343- add Obsoletes: kdenetwork < 3.2.0
344
345* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
346- rebuild for VineSeedPlus
347
348* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
349- source upgrade
350- build for VinePlus/2.6
351- (VinePlus/2.6) BuildPrereq: autoconf258
352- remove Patch
353
354* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
355- build for VineSeed with new toolchain and qt-3.2.3
356- add configure option --with-xinerama --enable-final
357
358* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
359- rebuild with qt-3.2.1-0.26vl3
360
361* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
362- rebuild with qt-3.2.1-0vl3
363
364* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
365- build with gcc-3.2.3
366
367* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
368- source upgrade
369- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
370
371* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
372- rebuild for Vine2.6
373
374* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
375- source upgrade
376- change spec to build with gcc295
377- change make option for SMP and add script
378- add BuildPrereq: libmal-devel
379- add Requires: libmal for pilot
380
381* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
382- source upgrade
383- remove Patch800 (included in this source)
384- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
385
386* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
387- source upgrade
388- change spec to build both VineSeed and Vine2.5/2.6
389- revised description and files section
390- remove source900
391- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
392- add patch800 (Kdeveloper:02753)
393
394* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
395- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
396
397* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
398- source upgrade
399
400* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
401- rebuild with qt-3.0.5-0vl1
402- BuildPrereq: autoconf253 objprelink2
403
404* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
405- source upgrade
406
407* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
408- source upgrade
409- add BuildPrereq: autoconf252 automake15
410
411* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
412- merged with rawhide 3.0.1-1
413- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
414- add Requires: for each package
415- There is Vine's previous changes, hacked for Vine
416 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
417  - build for VineSeed
418  - delete Epoch
419  - objprelink (i386 only)
420
421* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
422- 3.0.1
423- fixed bug #67303
424
425* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
426- automated rebuild
427
428* Thu May 23 2002 Tim Powers <timp@redhat.com>
429- automated rebuild
430
431* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
432- Rename libraries
433
434* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
435- Fix #61901
436
437* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
438- final
439
440* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
441- Update
442- Fix build on ia64
443
444* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
445- Update, fixes korganizer (#50006)
446
447* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
448- Update to get rid of abbrowser (moved to kdebase)
449
450* Thu Feb 22 2001 Than Ngo <than@redhat.com>
451- add missing ldconfig in %post anf %postun again
452- clean up specfile
453
454* Wed Feb 21 2001 Than Ngo <than@redhat.com>
455- 2.1-respin
456- fix dangling symlink
457- remove excludearch ia64, some hacks to build on ia64
458
459* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
460- 2.1
461
462* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
463- Update
464
465* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
466- Update
467
468* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
469- Update to CVS
470- Enable building kpilot
471- Obsolete kpilot
472- Don't exclude ia64, use -O0 on ia64
473- Disable building kpilot on ia64 (compiler breakage)
474
475* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
476- 2.0 final
477
478* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
479- 2.0
480
481* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
482- new CVS
483- fix installation of fonts
484
485* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
486- new CVS snapshot
487- fix up spec file
488
489* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
490- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
491  there's no need to keep them separate to avoid the dependency.
492
493* Mon Aug 21 2000 Than Ngo <than@redhat.com>
494- fix gnome-session so that KDE2 can be started from gdm
495- pam/kde2 instead pam/kde to avoid problem with KDE1
496- don't requires qt-GL, It's now in qt
497
498* Sun Aug 20 2000 Than Ngo <than@redhat.com>
499- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
500  at the same time
501- add missing ldconfig in %post anf %postun
502- fix for reading config files in /etc/X11/xdm, add Xsession to requires
503
504* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
505- Fix keytable in konsole (Bug #15682)
506
507* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
508- rebuild, now that kdelibs2 works on alpha
509- use the same ugly hack to get kdebase to compile
510- remove ksysguard on alpha (even more compiler problems)
511
512* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
513- new snapshot (fixed libGL detection in CVS)
514
515* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
516- move to /usr/lib/kde2
517- new snapshot
518
519* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
520- fix the --xdmdir arg to be correct (oops)
521
522* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
523- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
524
525* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
526- new snapshot
527- some fixes to spec file
528
529* Tue Jul 18 2000 Than Ngo <than@redhat.de>
530- rebuilt against glibc-2.1.92-14, gcc-2.96-40
531
532* Sun Jul 16 2000 Than Ngo <than@redhat.de>
533- use new snapshot
534- disable Motif
535
536* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
537- use gcc 2.96
538- new snapshot
539
540* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
541- Epoch 3
542- Update to current
543- Use egcs++
544
545* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
546- Update (I put the fixes directly to CVS rather than collecting them
547  in the spec)
548
549* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
550- remove man2html; we get that from man
551- new snapshot
552
553* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
554- new snapshot
555- ExcludeArch ia64 for now
556- remove gnome .desktop file, we get it from gnome-core now.
557
558* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
559- remove dependency on xpm (now in XFree86)
560
561* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
562- new snapshot
563- move it to /usr, where it belongs
564
565* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
566- Build the OpenGL screensavers, and move them to a separate package
567- Improve the spec file (BuildPrereqs etc.)
568
569* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
570- remove patch #3 (obsoleted by kwin)
571
572* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
573- 2.0 CVS snapshot
574- fix compilation
575
576* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
577- clean up files in /tmp from startkde
578- mark doc files as such
579
580* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
581- start autorun if present in startkde
582- check for configured soundcard before running sound services
583
584* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
585- made kdelnks display Name property if they are of type Link
586
587* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
588- moved png handling here (from kdelibs)
589- changed low color icon directory name to locolor
590
591* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
592- added optional session management to logout dialog
593- include GNOME menus
594
595* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
596- added link to /etc/X11/applnk, .directory file
597- included lowcolor icon sub-package
598- enable .desktop file access
599
600* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
601- customized startkde script to set up user environment if not present.
602- mention kthememgr in description.
603
604* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
605- upgraded to 1.1.2 release
606- kvt is back
607- kde icon included
608- linux console fonts included
609
610* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
611- PAM console logout problem solved.
612
613* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
614- now includes screensaver password security fix
615
616* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
617- snapshot, includes kde 1.1.1 + fixes
618- kvt removed for security reasons.  It is a steaming pile of...
619
620* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
621- last snapshot before release
622
623* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
624- today's snapshot makes kfm a bit nicer and some other fixes
625- moved default rc files to kdesupport
626
627* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
628- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
629
630* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
631- built with today's snapshot -- had to rebuild to fix pam problems.
632
633* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
634- new snapshot fixes mimetype video/x-flic problem
635
636* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
637- latest stable snapshot
638
639* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
640- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
641- this previous connection and autoselect kdebase for upgrade).
642
643* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
644- moved gdm patch
645
646* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
647- added gdm session control file
648
649* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
650- added pam-console stuff to kde pam file
651
652* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
653- Injected new description and group.
654
655* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
656- upgraded to KDE 1.1 final.
657
658* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
659- updated macros for RPM 3.0, removed red hat logo.
660
661* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
662- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.