source: projects/specs/trunk/k/kdepim/kdepim-vl.spec @ 3929

Revision 3929, 21.4 KB checked in by inagaki, 13 years ago (diff)

update: kdepim, kdepim-runtime, magicpoint

Line 
1Name: kdepim
2Summary: PIM (Personal Information Manager) for KDE
3Summary(ja): KDE の個人情報管理(PIM)アプリケーション集
4Version: 4.4.11.1
5Release: 1%{?_dist_release}
6
7Group: Applications/Productivity
8License: GPLv2
9URL: http://pim.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.bz2
12
13Patch0:  kdepim-4.1.80-libqgpgme-link-fix.patch
14# http://bugzilla.redhat.com/show_bug.cgi?id=496988
15Patch1:  kdepim-4.3.1-kmail-saveAttachments.patch
16## upstream
17
18# KDE.org patches
19# KDE.gr.jp patches
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: akonadi-devel
23BuildRequires: bison flex
24BuildRequires: libboost-devel
25BuildRequires: cyrus-sasl-devel
26BuildRequires: desktop-file-utils
27BuildRequires: gnokii-devel
28BuildRequires: gpgme-devel
29BuildRequires: kdepimlibs-devel >= %{version}
30BuildRequires: kdelibs-experimental-devel
31BuildRequires: libassuan-devel
32BuildRequires: libical-devel
33BuildRequires: libindicate-qt-devel
34BuildRequires: libXpm-devel libXScrnSaver-devel
35# TODO: libmapi from http://www.openchange.org/
36#BuildRequires: libmapi-devel
37BuildRequires: libxslt-devel
38# libmal currently not used, recheck with kdepim-4.3
39BuildRequires: pilot-link-devel >= 0.12.4
40BuildRequires: python-devel
41BuildRequires: soprano-devel
42BuildRequires: qca2-devel
43BuildRequires: zlib-devel
44Requires: %{name}-libs = %{version}-%{release}
45
46Obsoletes: kdepim4 < %{version}-%{release}
47Provides: kdepim4 = %{version}-%{release}
48
49Conflicts: kdepim3
50Conflicts: kdeutils3
51
52%description
53A PIM (Personal Information Manager) for KDE.
54
55What it is
56----------
57* kmail: email client
58* knode: newsreader
59* knotes: sticky notes for the desktop
60* kontact: integrated PIM management
61* korganizer: journal, appointments, events, todos
62%{?_with_pilot_link:* kpilot: HotSync® software for Palm OS® devices}
63
64%package libs
65Summary: %{name} runtime libraries
66Summary(ja): %{name} のラインタイムライブラリ
67Group:   System Environment/Libraries
68Requires: kdelibs4 >= %{version}
69
70%description libs
71%{summary}.
72
73%package devel
74Summary: Development files for kdepim
75Summary(ja): %{name} の開発用ファイル
76Group: Development/Libraries
77Requires: %{name}-libs = %{version}-%{release}
78Requires: kdelibs4-devel
79Obsoletes: kdepim4-devel < %{version}-%{release}
80Provides:  kdepim4-devel = %{version}-%{release}
81Conflicts: kdepim3-devel
82
83%description devel
84Development files for %{name}.
85Install %{name}-devel if you want to write or compile %{name} plugins.
86
87%prep
88%setup -q -n kdepim-%{version}
89%patch0 -p1 -b .libqgpgme-link-fix
90%patch1 -p0 -b .kmail-saveAttachments
91
92%build
93mkdir -p %{_target_platform}
94pushd %{_target_platform}
95unset QTDIR || : ; . /etc/profile.d/qt4.sh
96%cmake \
97    -DCMAKE_BUILD_TYPE=release \
98    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
99    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
100    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
101    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
102    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
103    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
104    ..
105popd
106
107make %{?_smp_mflags} -C %{_target_platform}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
112
113# make symlinks relative
114mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
115pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
116for i in *; do
117    if [ -d $i -a -L $i/common ]; then
118        rm -f $i/common
119        ln -nfs ../common $i
120    fi
121done
122popd
123
124%check
125for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
126    desktop-file-validate $f
127done
128
129%post
130touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
131touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
132
133%posttrans
134gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
135gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
136update-desktop-database -q &> /dev/null ||:
137
138%postun
139if [ $1 -eq 0 ] ; then
140  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
141  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
142  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
143  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
144  update-desktop-database -q &> /dev/null ||:
145fi
146
147%post libs -p /sbin/ldconfig
148
149%postun libs -p /sbin/ldconfig
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
154%files
155%defattr(-,root,root)
156%{_bindir}/*
157#{_libdir}/libkpilot_*.so
158%{_libdir}/kde4/*.so
159%{_libdir}/strigi/*.so
160%{_libdir}/akonadi/*
161%{_datadir}/applications/kde4/*.desktop
162%{_datadir}/kde4/apps/akregator
163#{_datadir}/kde4/apps/akonadi/*
164%{_datadir}/kde4/apps/akonadiconsole/*
165%{_datadir}/kde4/apps/blogilo/*
166%{_datadir}/kde4/apps/kaddressbook
167%{_datadir}/kde4/apps/kalarm
168%{_datadir}/kde4/apps/kconf_update/*
169%{_datadir}/kde4/apps/kdepimwidgets
170%{_datadir}/kde4/apps/kjots
171%{_datadir}/kde4/apps/kleopatra
172%{_datadir}/kde4/apps/kmail
173%{_datadir}/kde4/apps/kmailcvt
174%{_datadir}/kde4/apps/knode
175%{_datadir}/kde4/apps/knotes
176%{_datadir}/kde4/apps/konsolekalendar
177%{_datadir}/kde4/apps/kontact
178%{_datadir}/kde4/apps/kontactsummary
179%{_datadir}/kde4/apps/korgac
180%{_datadir}/kde4/apps/korganizer
181#{_datadir}/kde4/apps/kpilot
182%{_datadir}/kde4/apps/ktimetracker
183%{_datadir}/kde4/apps/kwatchgnupg
184%{_datadir}/kde4/apps/libkdepim
185%{_datadir}/kde4/apps/libkleopatra
186%{_datadir}/dbus-1/interfaces/*.xml
187%{_datadir}/autostart/*
188#{_datadir}/akonadi/*
189%{_datadir}/config/*
190%{_datadir}/config.kcfg/*
191%{_datadir}/icons/hicolor/*/*/*
192%{_datadir}/icons/oxygen/*/*/*
193%{_datadir}/kde4/services/*
194%{_datadir}/kde4/servicetypes/*
195%doc %{_docdir}/HTML/en/*
196%{_mandir}/man1/*
197
198%files libs
199%defattr(-,root,root)
200%{_libdir}/lib*.so.*
201%{_libdir}/kde4/plugins/designer/*.so
202
203%files devel
204%defattr(-,root,root)
205#{_includedir}/kde4/*
206%{_libdir}/lib*.so
207#exclude %{_libdir}/libkpilot_*.so
208
209%changelog
210* Sat May 21 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.11.1-1
211- new upstream release
212
213* Fri Feb 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.10-1
214- new upstream release
215- added BR: libindicate-qt-devel
216
217* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.6-1
218- new upstream release
219- built with rpm-4.8.1
220
221* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-2
222- rebuilt for VineSeed
223
224* Mon Jul  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
225- new upstream release
226- added Conflicts: kdepim3, kdeutils3
227
228* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
229- new upstream release
230
231* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
232- new upstream release
233
234* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
235- new upstream release
236
237* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
238- new upstream release
239- built with new toolchain
240
241* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
242- new upstream release
243
244* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
245- new upstream release
246- dropped Patch100 (merged into upstream)
247- used %%cmake macro
248
249* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
250- new upstream release
251
252* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
253- applied new versioning policy, spec in UTF-8
254- added Japnaese summary
255
256* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
257- rebuild for VineSeed
258
259* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
260- new upstream release
261
262* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
263- rebuild for VineSeed
264
265* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
266- new upstream release
267- remove all patches
268
269* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
270- new upstream release
271- add Patch0, 1 , 2 and 3
272
273* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
274- added --with-qt-libraries and --enable-libsuffix option
275
276* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
277- rebuild for VineSeed
278
279* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
280- new upstream release
281
282* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
283- rebuild with pilot-link-0.12.0-0vl1
284
285* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
286- rebuild for VineSeed
287
288* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
289- new upstream release
290
291* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
292- rebuild for VineSeed
293
294* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
295- new upstream release
296
297* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
298- rebuild for VineSeed
299
300* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
301- new upstream release
302
303* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
304- rebuild for VineSeed
305
306* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
307- new upstream release
308- delete BuildPrereq: libmal-devel and Requires: libmal
309
310* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
311- rebuild for VineSeed
312
313* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
314- new upstream release
315
316* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
317- new upstream release
318
319* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
320- new upstream release
321- delete all patches
322- add Requires: kdeaccessibility  >= %%{version}
323- add --enable-indexlib to configure option
324
325* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
326- new upstream release
327- remove Patch0
328- add Patch0 - Patch1
329
330* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
331- rebuild for VineSeed
332
333* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
334- new upstream release
335- remove Patch0
336- add BuildPrereq: gpgme-devel >= 0.4.5
337- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
338
339* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
340- rebuild for VineSeed
341- add --disable-rpath to configure option
342
343* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
344- new upstream release (delete old patch and add new security patch)
345- use %%{?_smp_mflags} for make option
346
347* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
348- rebuild for VineSeed
349
350* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
351- new upstream release
352- add patch0
353
354* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
355- new upstream release (3.4.0-rc1)
356
357* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
358- new upstream release
359
360* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
361- new upstream release
362
363* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
364- rebuild for VineSeed
365
366* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
367- new upstream release
368
369* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
370- source upgrade
371- update %%files
372- all sub-packages are integrated into main package (exclude devel)
373
374* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
375- rebuild with qt32
376
377* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
378- source upgrade
379- remove lines about vine26
380
381* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
382- source upgrade
383- update %%files
384
385* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
386- source upgrade
387- update %%description
388- add Obsoletes: kdenetwork < 3.2.0
389
390* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
391- rebuild for VineSeedPlus
392
393* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
394- source upgrade
395- build for VinePlus/2.6
396- (VinePlus/2.6) BuildPrereq: autoconf258
397- remove Patch
398
399* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
400- build for VineSeed with new toolchain and qt-3.2.3
401- add configure option --with-xinerama --enable-final
402
403* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
404- rebuild with qt-3.2.1-0.26vl3
405
406* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
407- rebuild with qt-3.2.1-0vl3
408
409* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
410- build with gcc-3.2.3
411
412* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
413- source upgrade
414- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
415
416* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
417- rebuild for Vine2.6
418
419* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
420- source upgrade
421- change spec to build with gcc295
422- change make option for SMP and add script
423- add BuildPrereq: libmal-devel
424- add Requires: libmal for pilot
425
426* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
427- source upgrade
428- remove Patch800 (included in this source)
429- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
430
431* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
432- source upgrade
433- change spec to build both VineSeed and Vine2.5/2.6
434- revised description and files section
435- remove source900
436- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
437- add patch800 (Kdeveloper:02753)
438
439* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
440- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
441
442* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
443- source upgrade
444
445* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
446- rebuild with qt-3.0.5-0vl1
447- BuildPrereq: autoconf253 objprelink2
448
449* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
450- source upgrade
451
452* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
453- source upgrade
454- add BuildPrereq: autoconf252 automake15
455
456* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
457- merged with rawhide 3.0.1-1
458- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
459- add Requires: for each package
460- There is Vine's previous changes, hacked for Vine
461 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
462  - build for VineSeed
463  - delete Epoch
464  - objprelink (i386 only)
465
466* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
467- 3.0.1
468- fixed bug #67303
469
470* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
471- automated rebuild
472
473* Thu May 23 2002 Tim Powers <timp@redhat.com>
474- automated rebuild
475
476* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
477- Rename libraries
478
479* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
480- Fix #61901
481
482* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
483- final
484
485* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
486- Update
487- Fix build on ia64
488
489* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
490- Update, fixes korganizer (#50006)
491
492* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
493- Update to get rid of abbrowser (moved to kdebase)
494
495* Thu Feb 22 2001 Than Ngo <than@redhat.com>
496- add missing ldconfig in %post anf %postun again
497- clean up specfile
498
499* Wed Feb 21 2001 Than Ngo <than@redhat.com>
500- 2.1-respin
501- fix dangling symlink
502- remove excludearch ia64, some hacks to build on ia64
503
504* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
505- 2.1
506
507* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
508- Update
509
510* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
511- Update
512
513* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
514- Update to CVS
515- Enable building kpilot
516- Obsolete kpilot
517- Don't exclude ia64, use -O0 on ia64
518- Disable building kpilot on ia64 (compiler breakage)
519
520* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
521- 2.0 final
522
523* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
524- 2.0
525
526* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
527- new CVS
528- fix installation of fonts
529
530* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
531- new CVS snapshot
532- fix up spec file
533
534* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
535- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
536  there's no need to keep them separate to avoid the dependency.
537
538* Mon Aug 21 2000 Than Ngo <than@redhat.com>
539- fix gnome-session so that KDE2 can be started from gdm
540- pam/kde2 instead pam/kde to avoid problem with KDE1
541- don't requires qt-GL, It's now in qt
542
543* Sun Aug 20 2000 Than Ngo <than@redhat.com>
544- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
545  at the same time
546- add missing ldconfig in %post anf %postun
547- fix for reading config files in /etc/X11/xdm, add Xsession to requires
548
549* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
550- Fix keytable in konsole (Bug #15682)
551
552* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
553- rebuild, now that kdelibs2 works on alpha
554- use the same ugly hack to get kdebase to compile
555- remove ksysguard on alpha (even more compiler problems)
556
557* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
558- new snapshot (fixed libGL detection in CVS)
559
560* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
561- move to /usr/lib/kde2
562- new snapshot
563
564* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
565- fix the --xdmdir arg to be correct (oops)
566
567* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
568- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
569
570* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
571- new snapshot
572- some fixes to spec file
573
574* Tue Jul 18 2000 Than Ngo <than@redhat.de>
575- rebuilt against glibc-2.1.92-14, gcc-2.96-40
576
577* Sun Jul 16 2000 Than Ngo <than@redhat.de>
578- use new snapshot
579- disable Motif
580
581* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
582- use gcc 2.96
583- new snapshot
584
585* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
586- Epoch 3
587- Update to current
588- Use egcs++
589
590* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
591- Update (I put the fixes directly to CVS rather than collecting them
592  in the spec)
593
594* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
595- remove man2html; we get that from man
596- new snapshot
597
598* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
599- new snapshot
600- ExcludeArch ia64 for now
601- remove gnome .desktop file, we get it from gnome-core now.
602
603* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
604- remove dependency on xpm (now in XFree86)
605
606* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
607- new snapshot
608- move it to /usr, where it belongs
609
610* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
611- Build the OpenGL screensavers, and move them to a separate package
612- Improve the spec file (BuildPrereqs etc.)
613
614* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
615- remove patch #3 (obsoleted by kwin)
616
617* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
618- 2.0 CVS snapshot
619- fix compilation
620
621* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
622- clean up files in /tmp from startkde
623- mark doc files as such
624
625* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
626- start autorun if present in startkde
627- check for configured soundcard before running sound services
628
629* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
630- made kdelnks display Name property if they are of type Link
631
632* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
633- moved png handling here (from kdelibs)
634- changed low color icon directory name to locolor
635
636* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
637- added optional session management to logout dialog
638- include GNOME menus
639
640* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
641- added link to /etc/X11/applnk, .directory file
642- included lowcolor icon sub-package
643- enable .desktop file access
644
645* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
646- customized startkde script to set up user environment if not present.
647- mention kthememgr in description.
648
649* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
650- upgraded to 1.1.2 release
651- kvt is back
652- kde icon included
653- linux console fonts included
654
655* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
656- PAM console logout problem solved.
657
658* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
659- now includes screensaver password security fix
660
661* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
662- snapshot, includes kde 1.1.1 + fixes
663- kvt removed for security reasons.  It is a steaming pile of...
664
665* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
666- last snapshot before release
667
668* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
669- today's snapshot makes kfm a bit nicer and some other fixes
670- moved default rc files to kdesupport
671
672* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
673- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
674
675* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
676- built with today's snapshot -- had to rebuild to fix pam problems.
677
678* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
679- new snapshot fixes mimetype video/x-flic problem
680
681* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
682- latest stable snapshot
683
684* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
685- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
686- this previous connection and autoselect kdebase for upgrade).
687
688* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
689- moved gdm patch
690
691* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
692- added gdm session control file
693
694* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
695- added pam-console stuff to kde pam file
696
697* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
698- Injected new description and group.
699
700* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
701- upgraded to KDE 1.1 final.
702
703* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
704- updated macros for RPM 3.0, removed red hat logo.
705
706* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
707- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.