source: projects/specs/trunk/k/kdepim/kdepim-vl.spec @ 2717

Revision 2717, 21.3 KB checked in by inagaki, 13 years ago (diff)

NEW: dbusmenu, libindicate, libindicate-qt
updated: kdepim

Line 
1Name: kdepim
2Summary: PIM (Personal Information Manager) for KDE
3Summary(ja): KDE の個人情報管理(PIM)アプリケーション集
4Version: 4.4.10
5Release: 1%{?_dist_release}
6
7Group: Applications/Productivity
8License: GPLv2
9URL: http://pim.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.bz2
12
13Patch0:  kdepim-4.1.80-libqgpgme-link-fix.patch
14# http://bugzilla.redhat.com/show_bug.cgi?id=496988
15Patch1:  kdepim-4.3.1-kmail-saveAttachments.patch
16## upstream
17
18# KDE.org patches
19# KDE.gr.jp patches
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: akonadi-devel
23BuildRequires: bison flex
24BuildRequires: libboost-devel
25BuildRequires: cyrus-sasl-devel
26BuildRequires: desktop-file-utils
27BuildRequires: gnokii-devel
28BuildRequires: gpgme-devel
29BuildRequires: kdepimlibs-devel >= %{version}
30BuildRequires: kdelibs-experimental-devel
31BuildRequires: libassuan-devel
32BuildRequires: libical-devel
33BuildRequires: libindicate-qt-devel
34BuildRequires: libXpm-devel libXScrnSaver-devel
35# TODO: libmapi from http://www.openchange.org/
36#BuildRequires: libmapi-devel
37BuildRequires: libxslt-devel
38# libmal currently not used, recheck with kdepim-4.3
39BuildRequires: pilot-link-devel >= 0.12.4
40BuildRequires: python-devel
41BuildRequires: soprano-devel
42BuildRequires: qca2-devel
43BuildRequires: zlib-devel
44Requires: %{name}-libs = %{version}-%{release}
45
46Obsoletes: kdepim4 < %{version}-%{release}
47Provides: kdepim4 = %{version}-%{release}
48
49Conflicts: kdepim3
50Conflicts: kdeutils3
51
52%description
53A PIM (Personal Information Manager) for KDE.
54
55What it is
56----------
57* kmail: email client
58* knode: newsreader
59* knotes: sticky notes for the desktop
60* kontact: integrated PIM management
61* korganizer: journal, appointments, events, todos
62%{?_with_pilot_link:* kpilot: HotSync® software for Palm OS® devices}
63
64%package libs
65Summary: %{name} runtime libraries
66Summary(ja): %{name} のラインタイムライブラリ
67Group:   System Environment/Libraries
68Requires: kdelibs4 >= %{version}
69
70%description libs
71%{summary}.
72
73%package devel
74Summary: Development files for kdepim
75Summary(ja): %{name} の開発用ファイル
76Group: Development/Libraries
77Requires: %{name}-libs = %{version}-%{release}
78Requires: kdelibs4-devel
79Obsoletes: kdepim4-devel < %{version}-%{release}
80Provides:  kdepim4-devel = %{version}-%{release}
81Conflicts: kdepim3-devel
82
83%description devel
84Development files for %{name}.
85Install %{name}-devel if you want to write or compile %{name} plugins.
86
87%prep
88%setup -q -n kdepim-%{version}
89%patch0 -p1 -b .libqgpgme-link-fix
90%patch1 -p0 -b .kmail-saveAttachments
91
92%build
93mkdir -p %{_target_platform}
94pushd %{_target_platform}
95unset QTDIR || : ; . /etc/profile.d/qt4.sh
96%cmake \
97    -DCMAKE_BUILD_TYPE=release \
98    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
99    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
100    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
101    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
102    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
103    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
104    ..
105popd
106
107make %{?_smp_mflags} -C %{_target_platform}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
112
113# make symlinks relative
114mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
115pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
116for i in *; do
117    if [ -d $i -a -L $i/common ]; then
118        rm -f $i/common
119        ln -nfs ../common $i
120    fi
121done
122popd
123
124%check
125for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
126    desktop-file-validate $f
127done
128
129%post
130touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
131touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
132
133%posttrans
134gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
135gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
136update-desktop-database -q &> /dev/null ||:
137
138%postun
139if [ $1 -eq 0 ] ; then
140  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
141  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
142  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
143  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
144  update-desktop-database -q &> /dev/null ||:
145fi
146
147%post libs -p /sbin/ldconfig
148
149%postun libs -p /sbin/ldconfig
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
154%files
155%defattr(-,root,root)
156%{_bindir}/*
157#{_libdir}/libkpilot_*.so
158%{_libdir}/kde4/*.so
159%{_libdir}/strigi/*.so
160%{_libdir}/akonadi/*
161%{_datadir}/applications/kde4/*.desktop
162%{_datadir}/kde4/apps/akregator
163#{_datadir}/kde4/apps/akonadi/*
164%{_datadir}/kde4/apps/akonadiconsole/*
165%{_datadir}/kde4/apps/blogilo/*
166%{_datadir}/kde4/apps/kaddressbook
167%{_datadir}/kde4/apps/kalarm
168%{_datadir}/kde4/apps/kconf_update/*
169%{_datadir}/kde4/apps/kdepimwidgets
170%{_datadir}/kde4/apps/kjots
171%{_datadir}/kde4/apps/kleopatra
172%{_datadir}/kde4/apps/kmail
173%{_datadir}/kde4/apps/kmailcvt
174%{_datadir}/kde4/apps/knode
175%{_datadir}/kde4/apps/knotes
176%{_datadir}/kde4/apps/konsolekalendar
177%{_datadir}/kde4/apps/kontact
178%{_datadir}/kde4/apps/kontactsummary
179%{_datadir}/kde4/apps/korgac
180%{_datadir}/kde4/apps/korganizer
181#{_datadir}/kde4/apps/kpilot
182%{_datadir}/kde4/apps/ktimetracker
183%{_datadir}/kde4/apps/kwatchgnupg
184%{_datadir}/kde4/apps/libkdepim
185%{_datadir}/kde4/apps/libkleopatra
186%{_datadir}/dbus-1/interfaces/*.xml
187%{_datadir}/autostart/*
188#{_datadir}/akonadi/*
189%{_datadir}/config/*
190%{_datadir}/config.kcfg/*
191%{_datadir}/icons/hicolor/*/*/*
192%{_datadir}/icons/oxygen/*/*/*
193%{_datadir}/kde4/services/*
194%{_datadir}/kde4/servicetypes/*
195%doc %{_docdir}/HTML/en/*
196%{_mandir}/man1/*
197
198%files libs
199%defattr(-,root,root)
200%{_libdir}/lib*.so.*
201%{_libdir}/kde4/plugins/designer/*.so
202
203%files devel
204%defattr(-,root,root)
205#{_includedir}/kde4/*
206%{_libdir}/lib*.so
207#exclude %{_libdir}/libkpilot_*.so
208
209%changelog
210* Fri Feb 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.10-1
211- new upstream release
212- added BR: libindicate-qt-devel
213
214* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.6-1
215- new upstream release
216- built with rpm-4.8.1
217
218* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-2
219- rebuilt for VineSeed
220
221* Mon Jul  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
222- new upstream release
223- added Conflicts: kdepim3, kdeutils3
224
225* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
226- new upstream release
227
228* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
229- new upstream release
230
231* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
232- new upstream release
233
234* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
235- new upstream release
236- built with new toolchain
237
238* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
239- new upstream release
240
241* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
242- new upstream release
243- dropped Patch100 (merged into upstream)
244- used %%cmake macro
245
246* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
247- new upstream release
248
249* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
250- applied new versioning policy, spec in UTF-8
251- added Japnaese summary
252
253* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
254- rebuild for VineSeed
255
256* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
257- new upstream release
258
259* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
260- rebuild for VineSeed
261
262* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
263- new upstream release
264- remove all patches
265
266* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
267- new upstream release
268- add Patch0, 1 , 2 and 3
269
270* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
271- added --with-qt-libraries and --enable-libsuffix option
272
273* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
274- rebuild for VineSeed
275
276* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
277- new upstream release
278
279* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
280- rebuild with pilot-link-0.12.0-0vl1
281
282* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
283- rebuild for VineSeed
284
285* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
286- new upstream release
287
288* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
289- rebuild for VineSeed
290
291* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
292- new upstream release
293
294* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
295- rebuild for VineSeed
296
297* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
298- new upstream release
299
300* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
301- rebuild for VineSeed
302
303* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
304- new upstream release
305- delete BuildPrereq: libmal-devel and Requires: libmal
306
307* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
308- rebuild for VineSeed
309
310* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
311- new upstream release
312
313* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
314- new upstream release
315
316* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
317- new upstream release
318- delete all patches
319- add Requires: kdeaccessibility  >= %%{version}
320- add --enable-indexlib to configure option
321
322* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
323- new upstream release
324- remove Patch0
325- add Patch0 - Patch1
326
327* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
328- rebuild for VineSeed
329
330* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
331- new upstream release
332- remove Patch0
333- add BuildPrereq: gpgme-devel >= 0.4.5
334- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
335
336* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
337- rebuild for VineSeed
338- add --disable-rpath to configure option
339
340* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
341- new upstream release (delete old patch and add new security patch)
342- use %%{?_smp_mflags} for make option
343
344* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
345- rebuild for VineSeed
346
347* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
348- new upstream release
349- add patch0
350
351* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
352- new upstream release (3.4.0-rc1)
353
354* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
355- new upstream release
356
357* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
358- new upstream release
359
360* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
361- rebuild for VineSeed
362
363* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
364- new upstream release
365
366* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
367- source upgrade
368- update %%files
369- all sub-packages are integrated into main package (exclude devel)
370
371* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
372- rebuild with qt32
373
374* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
375- source upgrade
376- remove lines about vine26
377
378* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
379- source upgrade
380- update %%files
381
382* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
383- source upgrade
384- update %%description
385- add Obsoletes: kdenetwork < 3.2.0
386
387* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
388- rebuild for VineSeedPlus
389
390* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
391- source upgrade
392- build for VinePlus/2.6
393- (VinePlus/2.6) BuildPrereq: autoconf258
394- remove Patch
395
396* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
397- build for VineSeed with new toolchain and qt-3.2.3
398- add configure option --with-xinerama --enable-final
399
400* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
401- rebuild with qt-3.2.1-0.26vl3
402
403* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
404- rebuild with qt-3.2.1-0vl3
405
406* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
407- build with gcc-3.2.3
408
409* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
410- source upgrade
411- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
412
413* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
414- rebuild for Vine2.6
415
416* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
417- source upgrade
418- change spec to build with gcc295
419- change make option for SMP and add script
420- add BuildPrereq: libmal-devel
421- add Requires: libmal for pilot
422
423* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
424- source upgrade
425- remove Patch800 (included in this source)
426- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
427
428* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
429- source upgrade
430- change spec to build both VineSeed and Vine2.5/2.6
431- revised description and files section
432- remove source900
433- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
434- add patch800 (Kdeveloper:02753)
435
436* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
437- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
438
439* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
440- source upgrade
441
442* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
443- rebuild with qt-3.0.5-0vl1
444- BuildPrereq: autoconf253 objprelink2
445
446* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
447- source upgrade
448
449* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
450- source upgrade
451- add BuildPrereq: autoconf252 automake15
452
453* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
454- merged with rawhide 3.0.1-1
455- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
456- add Requires: for each package
457- There is Vine's previous changes, hacked for Vine
458 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
459  - build for VineSeed
460  - delete Epoch
461  - objprelink (i386 only)
462
463* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
464- 3.0.1
465- fixed bug #67303
466
467* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
468- automated rebuild
469
470* Thu May 23 2002 Tim Powers <timp@redhat.com>
471- automated rebuild
472
473* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
474- Rename libraries
475
476* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
477- Fix #61901
478
479* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
480- final
481
482* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
483- Update
484- Fix build on ia64
485
486* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
487- Update, fixes korganizer (#50006)
488
489* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
490- Update to get rid of abbrowser (moved to kdebase)
491
492* Thu Feb 22 2001 Than Ngo <than@redhat.com>
493- add missing ldconfig in %post anf %postun again
494- clean up specfile
495
496* Wed Feb 21 2001 Than Ngo <than@redhat.com>
497- 2.1-respin
498- fix dangling symlink
499- remove excludearch ia64, some hacks to build on ia64
500
501* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
502- 2.1
503
504* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
505- Update
506
507* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
508- Update
509
510* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
511- Update to CVS
512- Enable building kpilot
513- Obsolete kpilot
514- Don't exclude ia64, use -O0 on ia64
515- Disable building kpilot on ia64 (compiler breakage)
516
517* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
518- 2.0 final
519
520* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
521- 2.0
522
523* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
524- new CVS
525- fix installation of fonts
526
527* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
528- new CVS snapshot
529- fix up spec file
530
531* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
532- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
533  there's no need to keep them separate to avoid the dependency.
534
535* Mon Aug 21 2000 Than Ngo <than@redhat.com>
536- fix gnome-session so that KDE2 can be started from gdm
537- pam/kde2 instead pam/kde to avoid problem with KDE1
538- don't requires qt-GL, It's now in qt
539
540* Sun Aug 20 2000 Than Ngo <than@redhat.com>
541- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
542  at the same time
543- add missing ldconfig in %post anf %postun
544- fix for reading config files in /etc/X11/xdm, add Xsession to requires
545
546* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
547- Fix keytable in konsole (Bug #15682)
548
549* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
550- rebuild, now that kdelibs2 works on alpha
551- use the same ugly hack to get kdebase to compile
552- remove ksysguard on alpha (even more compiler problems)
553
554* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
555- new snapshot (fixed libGL detection in CVS)
556
557* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
558- move to /usr/lib/kde2
559- new snapshot
560
561* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
562- fix the --xdmdir arg to be correct (oops)
563
564* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
565- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
566
567* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
568- new snapshot
569- some fixes to spec file
570
571* Tue Jul 18 2000 Than Ngo <than@redhat.de>
572- rebuilt against glibc-2.1.92-14, gcc-2.96-40
573
574* Sun Jul 16 2000 Than Ngo <than@redhat.de>
575- use new snapshot
576- disable Motif
577
578* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
579- use gcc 2.96
580- new snapshot
581
582* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
583- Epoch 3
584- Update to current
585- Use egcs++
586
587* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
588- Update (I put the fixes directly to CVS rather than collecting them
589  in the spec)
590
591* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
592- remove man2html; we get that from man
593- new snapshot
594
595* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
596- new snapshot
597- ExcludeArch ia64 for now
598- remove gnome .desktop file, we get it from gnome-core now.
599
600* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
601- remove dependency on xpm (now in XFree86)
602
603* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
604- new snapshot
605- move it to /usr, where it belongs
606
607* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
608- Build the OpenGL screensavers, and move them to a separate package
609- Improve the spec file (BuildPrereqs etc.)
610
611* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
612- remove patch #3 (obsoleted by kwin)
613
614* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
615- 2.0 CVS snapshot
616- fix compilation
617
618* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
619- clean up files in /tmp from startkde
620- mark doc files as such
621
622* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
623- start autorun if present in startkde
624- check for configured soundcard before running sound services
625
626* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
627- made kdelnks display Name property if they are of type Link
628
629* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
630- moved png handling here (from kdelibs)
631- changed low color icon directory name to locolor
632
633* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
634- added optional session management to logout dialog
635- include GNOME menus
636
637* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
638- added link to /etc/X11/applnk, .directory file
639- included lowcolor icon sub-package
640- enable .desktop file access
641
642* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
643- customized startkde script to set up user environment if not present.
644- mention kthememgr in description.
645
646* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
647- upgraded to 1.1.2 release
648- kvt is back
649- kde icon included
650- linux console fonts included
651
652* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
653- PAM console logout problem solved.
654
655* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
656- now includes screensaver password security fix
657
658* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
659- snapshot, includes kde 1.1.1 + fixes
660- kvt removed for security reasons.  It is a steaming pile of...
661
662* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
663- last snapshot before release
664
665* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
666- today's snapshot makes kfm a bit nicer and some other fixes
667- moved default rc files to kdesupport
668
669* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
670- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
671
672* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
673- built with today's snapshot -- had to rebuild to fix pam problems.
674
675* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
676- new snapshot fixes mimetype video/x-flic problem
677
678* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
679- latest stable snapshot
680
681* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
682- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
683- this previous connection and autoselect kdebase for upgrade).
684
685* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
686- moved gdm patch
687
688* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
689- added gdm session control file
690
691* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
692- added pam-console stuff to kde pam file
693
694* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
695- Injected new description and group.
696
697* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
698- upgraded to KDE 1.1 final.
699
700* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
701- updated macros for RPM 3.0, removed red hat logo.
702
703* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
704- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.