source: projects/specs/trunk/k/kdepim/kdepim-vl.spec @ 1894

Revision 1894, 21.0 KB checked in by inagaki, 14 years ago (diff)

update: kdepim, kdepim-runtime, kdebase-workspace, kdeedu, kdeplasma-addons

Line 
1Name: kdepim
2Summary: PIM (Personal Information Manager) for KDE
3Summary(ja): KDE の個人情報管理(PIM)アプリケーション集
4Version: 4.4.6
5Release: 1%{?_dist_release}
6
7Group: Applications/Productivity
8License: GPLv2
9URL: http://pim.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.bz2
12
13Patch0:  kdepim-4.1.80-libqgpgme-link-fix.patch
14# http://bugzilla.redhat.com/show_bug.cgi?id=496988
15Patch1:  kdepim-4.3.1-kmail-saveAttachments.patch
16## upstream
17
18# KDE.org patches
19# KDE.gr.jp patches
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: akonadi-devel
23BuildRequires: bison flex
24BuildRequires: libboost-devel
25BuildRequires: cyrus-sasl-devel
26BuildRequires: desktop-file-utils
27BuildRequires: gnokii-devel
28BuildRequires: gpgme-devel
29BuildRequires: kdepimlibs-devel >= %{version}
30BuildRequires: kdelibs-experimental-devel
31BuildRequires: libassuan-devel
32BuildRequires: libical-devel
33BuildRequires: libXpm-devel libXScrnSaver-devel
34# TODO: libmapi from http://www.openchange.org/
35#BuildRequires: libmapi-devel
36BuildRequires: libxslt-devel
37# libmal currently not used, recheck with kdepim-4.3
38BuildRequires: pilot-link-devel >= 0.12.4
39BuildRequires: python-devel
40BuildRequires: soprano-devel
41BuildRequires: qca2-devel
42BuildRequires: zlib-devel
43Requires: %{name}-libs = %{version}-%{release}
44
45Obsoletes: kdepim4 < %{version}-%{release}
46Provides: kdepim4 = %{version}-%{release}
47
48Conflicts: kdepim3
49Conflicts: kdeutils3
50
51%description
52A PIM (Personal Information Manager) for KDE.
53
54What it is
55----------
56* kmail: email client
57* knode: newsreader
58* knotes: sticky notes for the desktop
59* kontact: integrated PIM management
60* korganizer: journal, appointments, events, todos
61%{?_with_pilot_link:* kpilot: HotSync® software for Palm OS® devices}
62
63%package libs
64Summary: %{name} runtime libraries
65Group:   System Environment/Libraries
66Requires: kdelibs4 >= %{version}
67
68%description libs
69%{summary}.
70
71%package devel
72Summary: Development files for kdepim
73Group: Development/Libraries
74Requires: %{name}-libs = %{version}-%{release}
75Requires: kdelibs4-devel
76Obsoletes: kdepim4-devel < %{version}-%{release}
77Provides: kdepim4-devel = %{version}-%{release}
78Conflicts: kdepim3-devel
79
80%description devel
81Development files for %{name}.
82Install %{name}-devel if you want to write or compile %{name} plugins.
83
84%prep
85%setup -q -n kdepim-%{version}
86%patch0 -p1 -b .libqgpgme-link-fix
87%patch1 -p0 -b .kmail-saveAttachments
88
89%build
90mkdir -p %{_target_platform}
91pushd %{_target_platform}
92unset QTDIR || : ; . /etc/profile.d/qt4.sh
93%cmake \
94    -DCMAKE_BUILD_TYPE=release \
95    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
96    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
97    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
98    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
99    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
100    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
101    ..
102popd
103
104make %{?_smp_mflags} -C %{_target_platform}
105
106%install
107rm -rf $RPM_BUILD_ROOT
108make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
109
110# make symlinks relative
111mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
112pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
113for i in *; do
114   if [ -d $i -a -L $i/common ]; then
115      rm -f $i/common
116      ln -nfs ../common $i
117   fi
118done
119popd
120
121%check
122for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
123  desktop-file-validate $f
124done
125
126%post
127touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
128touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
129
130%posttrans
131gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
132gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
133update-desktop-database -q &> /dev/null ||:
134
135%postun
136if [ $1 -eq 0 ] ; then
137  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
138  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
139  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
140  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
141  update-desktop-database -q &> /dev/null ||:
142fi
143
144%post libs -p /sbin/ldconfig
145
146%postun libs -p /sbin/ldconfig
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%files
152%defattr(-,root,root)
153%{_bindir}/*
154#{_libdir}/libkpilot_*.so
155%{_libdir}/kde4/*.so
156%{_libdir}/strigi/*.so
157%{_libdir}/akonadi/*
158%{_datadir}/applications/kde4/*.desktop
159%{_datadir}/kde4/apps/akregator
160#{_datadir}/kde4/apps/akonadi/*
161%{_datadir}/kde4/apps/akonadiconsole/*
162%{_datadir}/kde4/apps/blogilo/*
163%{_datadir}/kde4/apps/kaddressbook
164%{_datadir}/kde4/apps/kalarm
165%{_datadir}/kde4/apps/kconf_update/*
166%{_datadir}/kde4/apps/kdepimwidgets
167%{_datadir}/kde4/apps/kjots
168%{_datadir}/kde4/apps/kleopatra
169%{_datadir}/kde4/apps/kmail
170%{_datadir}/kde4/apps/kmailcvt
171%{_datadir}/kde4/apps/knode
172%{_datadir}/kde4/apps/knotes
173%{_datadir}/kde4/apps/konsolekalendar
174%{_datadir}/kde4/apps/kontact
175%{_datadir}/kde4/apps/kontactsummary
176%{_datadir}/kde4/apps/korgac
177%{_datadir}/kde4/apps/korganizer
178#{_datadir}/kde4/apps/kpilot
179%{_datadir}/kde4/apps/ktimetracker
180%{_datadir}/kde4/apps/kwatchgnupg
181%{_datadir}/kde4/apps/libkdepim
182%{_datadir}/kde4/apps/libkleopatra
183%{_datadir}/dbus-1/interfaces/*.xml
184%{_datadir}/autostart/*
185#{_datadir}/akonadi/*
186%{_datadir}/config/*
187%{_datadir}/config.kcfg/*
188%{_datadir}/icons/hicolor/*/*/*
189%{_datadir}/icons/oxygen/*/*/*
190%{_datadir}/kde4/services/*
191%{_datadir}/kde4/servicetypes/*
192%doc %{_docdir}/HTML/en/*
193%{_mandir}/man1/*
194
195%files libs
196%defattr(-,root,root)
197%{_libdir}/lib*.so.*
198%{_libdir}/kde4/plugins/designer/*.so
199
200%files devel
201%defattr(-,root,root)
202#{_includedir}/kde4/*
203%{_libdir}/lib*.so
204#exclude %{_libdir}/libkpilot_*.so
205
206%changelog
207* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.6-1
208- new upstream release
209- built with rpm-4.8.1
210
211* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-2
212- rebuilt for VineSeed
213
214* Mon Jul  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
215- new upstream release
216- added Conflicts: kdepim3, kdeutils3
217
218* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
219- new upstream release
220
221* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
222- new upstream release
223
224* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
225- new upstream release
226
227* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
228- new upstream release
229- built with new toolchain
230
231* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
232- new upstream release
233
234* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
235- new upstream release
236- dropped Patch100 (merged into upstream)
237- used %%cmake macro
238
239* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
240- new upstream release
241
242* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
243- applied new versioning policy, spec in UTF-8
244- added Japnaese summary
245
246* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
247- rebuild for VineSeed
248
249* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
250- new upstream release
251
252* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
253- rebuild for VineSeed
254
255* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
256- new upstream release
257- remove all patches
258
259* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
260- new upstream release
261- add Patch0, 1 , 2 and 3
262
263* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
264- added --with-qt-libraries and --enable-libsuffix option
265
266* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
267- rebuild for VineSeed
268
269* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
270- new upstream release
271
272* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
273- rebuild with pilot-link-0.12.0-0vl1
274
275* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
276- rebuild for VineSeed
277
278* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
279- new upstream release
280
281* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
282- rebuild for VineSeed
283
284* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
285- new upstream release
286
287* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
288- rebuild for VineSeed
289
290* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
291- new upstream release
292
293* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
294- rebuild for VineSeed
295
296* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
297- new upstream release
298- delete BuildPrereq: libmal-devel and Requires: libmal
299
300* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
301- rebuild for VineSeed
302
303* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
304- new upstream release
305
306* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
307- new upstream release
308
309* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
310- new upstream release
311- delete all patches
312- add Requires: kdeaccessibility  >= %%{version}
313- add --enable-indexlib to configure option
314
315* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
316- new upstream release
317- remove Patch0
318- add Patch0 - Patch1
319
320* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
321- rebuild for VineSeed
322
323* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
324- new upstream release
325- remove Patch0
326- add BuildPrereq: gpgme-devel >= 0.4.5
327- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
328
329* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
330- rebuild for VineSeed
331- add --disable-rpath to configure option
332
333* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
334- new upstream release (delete old patch and add new security patch)
335- use %%{?_smp_mflags} for make option
336
337* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
338- rebuild for VineSeed
339
340* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
341- new upstream release
342- add patch0
343
344* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
345- new upstream release (3.4.0-rc1)
346
347* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
348- new upstream release
349
350* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
351- new upstream release
352
353* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
354- rebuild for VineSeed
355
356* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
357- new upstream release
358
359* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
360- source upgrade
361- update %%files
362- all sub-packages are integrated into main package (exclude devel)
363
364* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
365- rebuild with qt32
366
367* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
368- source upgrade
369- remove lines about vine26
370
371* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
372- source upgrade
373- update %%files
374
375* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
376- source upgrade
377- update %%description
378- add Obsoletes: kdenetwork < 3.2.0
379
380* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
381- rebuild for VineSeedPlus
382
383* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
384- source upgrade
385- build for VinePlus/2.6
386- (VinePlus/2.6) BuildPrereq: autoconf258
387- remove Patch
388
389* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
390- build for VineSeed with new toolchain and qt-3.2.3
391- add configure option --with-xinerama --enable-final
392
393* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
394- rebuild with qt-3.2.1-0.26vl3
395
396* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
397- rebuild with qt-3.2.1-0vl3
398
399* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
400- build with gcc-3.2.3
401
402* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
403- source upgrade
404- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
405
406* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
407- rebuild for Vine2.6
408
409* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
410- source upgrade
411- change spec to build with gcc295
412- change make option for SMP and add script
413- add BuildPrereq: libmal-devel
414- add Requires: libmal for pilot
415
416* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
417- source upgrade
418- remove Patch800 (included in this source)
419- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
420
421* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
422- source upgrade
423- change spec to build both VineSeed and Vine2.5/2.6
424- revised description and files section
425- remove source900
426- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
427- add patch800 (Kdeveloper:02753)
428
429* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
430- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
431
432* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
433- source upgrade
434
435* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
436- rebuild with qt-3.0.5-0vl1
437- BuildPrereq: autoconf253 objprelink2
438
439* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
440- source upgrade
441
442* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
443- source upgrade
444- add BuildPrereq: autoconf252 automake15
445
446* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
447- merged with rawhide 3.0.1-1
448- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
449- add Requires: for each package
450- There is Vine's previous changes, hacked for Vine
451 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
452  - build for VineSeed
453  - delete Epoch
454  - objprelink (i386 only)
455
456* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
457- 3.0.1
458- fixed bug #67303
459
460* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
461- automated rebuild
462
463* Thu May 23 2002 Tim Powers <timp@redhat.com>
464- automated rebuild
465
466* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
467- Rename libraries
468
469* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
470- Fix #61901
471
472* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
473- final
474
475* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
476- Update
477- Fix build on ia64
478
479* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
480- Update, fixes korganizer (#50006)
481
482* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
483- Update to get rid of abbrowser (moved to kdebase)
484
485* Thu Feb 22 2001 Than Ngo <than@redhat.com>
486- add missing ldconfig in %post anf %postun again
487- clean up specfile
488
489* Wed Feb 21 2001 Than Ngo <than@redhat.com>
490- 2.1-respin
491- fix dangling symlink
492- remove excludearch ia64, some hacks to build on ia64
493
494* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
495- 2.1
496
497* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
498- Update
499
500* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
501- Update
502
503* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
504- Update to CVS
505- Enable building kpilot
506- Obsolete kpilot
507- Don't exclude ia64, use -O0 on ia64
508- Disable building kpilot on ia64 (compiler breakage)
509
510* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
511- 2.0 final
512
513* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
514- 2.0
515
516* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
517- new CVS
518- fix installation of fonts
519
520* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
521- new CVS snapshot
522- fix up spec file
523
524* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
525- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
526  there's no need to keep them separate to avoid the dependency.
527
528* Mon Aug 21 2000 Than Ngo <than@redhat.com>
529- fix gnome-session so that KDE2 can be started from gdm
530- pam/kde2 instead pam/kde to avoid problem with KDE1
531- don't requires qt-GL, It's now in qt
532
533* Sun Aug 20 2000 Than Ngo <than@redhat.com>
534- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
535  at the same time
536- add missing ldconfig in %post anf %postun
537- fix for reading config files in /etc/X11/xdm, add Xsession to requires
538
539* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
540- Fix keytable in konsole (Bug #15682)
541
542* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
543- rebuild, now that kdelibs2 works on alpha
544- use the same ugly hack to get kdebase to compile
545- remove ksysguard on alpha (even more compiler problems)
546
547* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
548- new snapshot (fixed libGL detection in CVS)
549
550* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
551- move to /usr/lib/kde2
552- new snapshot
553
554* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
555- fix the --xdmdir arg to be correct (oops)
556
557* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
558- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
559
560* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
561- new snapshot
562- some fixes to spec file
563
564* Tue Jul 18 2000 Than Ngo <than@redhat.de>
565- rebuilt against glibc-2.1.92-14, gcc-2.96-40
566
567* Sun Jul 16 2000 Than Ngo <than@redhat.de>
568- use new snapshot
569- disable Motif
570
571* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
572- use gcc 2.96
573- new snapshot
574
575* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
576- Epoch 3
577- Update to current
578- Use egcs++
579
580* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
581- Update (I put the fixes directly to CVS rather than collecting them
582  in the spec)
583
584* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
585- remove man2html; we get that from man
586- new snapshot
587
588* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
589- new snapshot
590- ExcludeArch ia64 for now
591- remove gnome .desktop file, we get it from gnome-core now.
592
593* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
594- remove dependency on xpm (now in XFree86)
595
596* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
597- new snapshot
598- move it to /usr, where it belongs
599
600* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
601- Build the OpenGL screensavers, and move them to a separate package
602- Improve the spec file (BuildPrereqs etc.)
603
604* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
605- remove patch #3 (obsoleted by kwin)
606
607* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
608- 2.0 CVS snapshot
609- fix compilation
610
611* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
612- clean up files in /tmp from startkde
613- mark doc files as such
614
615* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
616- start autorun if present in startkde
617- check for configured soundcard before running sound services
618
619* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
620- made kdelnks display Name property if they are of type Link
621
622* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
623- moved png handling here (from kdelibs)
624- changed low color icon directory name to locolor
625
626* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
627- added optional session management to logout dialog
628- include GNOME menus
629
630* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
631- added link to /etc/X11/applnk, .directory file
632- included lowcolor icon sub-package
633- enable .desktop file access
634
635* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
636- customized startkde script to set up user environment if not present.
637- mention kthememgr in description.
638
639* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
640- upgraded to 1.1.2 release
641- kvt is back
642- kde icon included
643- linux console fonts included
644
645* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
646- PAM console logout problem solved.
647
648* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
649- now includes screensaver password security fix
650
651* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
652- snapshot, includes kde 1.1.1 + fixes
653- kvt removed for security reasons.  It is a steaming pile of...
654
655* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
656- last snapshot before release
657
658* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
659- today's snapshot makes kfm a bit nicer and some other fixes
660- moved default rc files to kdesupport
661
662* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
663- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
664
665* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
666- built with today's snapshot -- had to rebuild to fix pam problems.
667
668* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
669- new snapshot fixes mimetype video/x-flic problem
670
671* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
672- latest stable snapshot
673
674* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
675- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
676- this previous connection and autoselect kdebase for upgrade).
677
678* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
679- moved gdm patch
680
681* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
682- added gdm session control file
683
684* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
685- added pam-console stuff to kde pam file
686
687* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
688- Injected new description and group.
689
690* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
691- upgraded to KDE 1.1 final.
692
693* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
694- updated macros for RPM 3.0, removed red hat logo.
695
696* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
697- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.