source: projects/specs/trunk/k/kdegraphics/kdegraphics-vl.spec @ 1775

Revision 1775, 19.4 KB checked in by inagaki, 14 years ago (diff)

updated: KDE 4.5.1 stuffs

Line 
1Name: kdegraphics
2Summary: KDE Graphics Applications
3Summary(ja): KDE グラフィックアプリケーション集
4Version: 4.5.1
5Release: 1%{?_dist_release}
6
7URL: http://www.kde.org/
8License: GPLv2
9Group: Applications/Graphics
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegraphics-%{version}.tar.bz2
12
13# Security fix
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: kdelibs4-devel >= %{version}
17BuildRequires: kdepimlibs-devel >= %{version}
18BuildRequires: chmlib-devel
19BuildRequires: djvulibre-devel
20BuildRequires: ebook-tools-devel
21BuildRequires: exiv2-devel
22BuildRequires: giflib-devel
23BuildRequires: lcms-devel
24BuildRequires: libgphoto2-devel
25BuildRequires: sane-devel
26BuildRequires: libspectre-devel
27BuildRequires: libtiff-devel
28BuildRequires: libXxf86vm-devel
29BuildRequires: pcre-devel
30BuildRequires: poppler-qt4-devel
31BuildRequires: qca2-devel
32BuildRequires: qimageblitz-devel
33BuildRequires: soprano-devel
34
35Requires: %{name}-libs = %{version}-%{release}
36# used by okular
37Requires: kio_msits = %{version}-%{release}
38Requires: cups
39
40Obsoletes: kdegraphics4 < %{version}-%{release}
41Obsoletes: kdegraphics-extras < 4.0.0
42Obsoletes: gwenview < 2
43Provides: gwenview = 2
44Provides: kdegraphics4 = %{version}-%{release}
45Conflicts: kdegraphics3
46
47Vendor: Project Vine
48Distribution: Vine Linux
49Packager: inagaki
50
51%description
52Graphics applications for KDE.
53
54What it is
55----------
56* gwenview (an image viewer)
57* kamera (digital camera support)
58* kcolorchooser (a color chooser)
59* kolourpaint4 (an easy-to-use paint program)
60* kruler (screen ruler and color measurement tool)
61* ksnapshot (screen capture utility)
62* okular (a document viewer)
63
64%description -l ja
65KDE 向けのグラフィックアプリケーション集です.
66
67以下のアプリケーションを含んでいます.
68----------
69* gwenview (画像ビューア)
70* kamera (デジタル・カメラのサポート)
71* kcolorchooser (色選択ツール)
72* kolourpaint4 (簡単に操作できるペイントプログラム)
73* kruler (スクリーン上で用いる定規、色測定ツール)
74* ksnapshot (スクリーンショットを撮るためのツール)
75* okular (ドキュメントビューア)
76
77%package libs
78Summary: Runtime libraries for %{name}
79Summary(ja): %{name} のランタイムライブラリ
80Group:   System Environment/Libraries
81Obsoletes: libkdcraw < 0.2.0, libkexiv2 < 0.4.0, libkipi < 0.2.0
82Requires: kdelibs4 >= %{version}
83
84%description libs
85%{summary}.
86
87%description -l ja libs
88%{summary}.
89
90%package devel
91Summary: Development files for kdegraphics
92Summary(ja): %{name} の開発用ファイル集
93Group: Development/Libraries
94Requires: %{name}-libs = %{version}-%{release}
95Requires: kdelibs4-devel
96Requires: pkgconfig
97Obsoletes: libkdcraw-devel < 0.4.0
98Obsoletes: libkexiv2-devel < 0.4.0
99Obsoletes: libkipi-devel < 0.2.0
100Obsoletes: kdegraphics4-devel < %{version}-%{release}
101Provides:  libkdcraw-devel = 0.4.0-2
102Provides:  libkexiv2-devel = 0.5.0-1
103Provides:  libkipi-devel = 0.3.0-1
104Provides:  kdegraphics4-devel = %{version}-%{release}
105
106%description devel
107Header files for developing applications using kdegraphics.
108Install kdegraphics-devel if you wish to develop or compile
109applications using kdegraphics.
110
111%package -n kio_msits
112Summary: A kioslave for displaying WinHelp files
113Group: System Environment/Libraries
114
115%description -n kio_msits
116%{summary}.
117
118
119%prep
120%setup -q -n kdegraphics-%{version}
121
122# security fix
123
124
125%build
126mkdir -p %{_target_platform}
127pushd %{_target_platform}
128unset QTDIR || : ; . /etc/profile.d/qt4.sh
129%cmake \
130    -DCMAKE_BUILD_TYPE=release \
131    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
132    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
133    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
134    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
135    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
136    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
137    ..
138popd
139
140make %{?_smp_mflags} -C %{_target_platform}
141
142%install
143rm -rf $RPM_BUILD_ROOT
144make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
145
146%post
147touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
148
149%posttrans
150gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
151update-desktop-database -q &> /dev/null ||:
152
153%postun
154if [ $1 -eq 0 ] ; then
155    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
156    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
157    update-desktop-database -q &> /dev/null ||:
158fi
159
160%post libs
161/sbin/ldconfig
162touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
163
164%posttrans libs
165gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
166
167%postun libs
168/sbin/ldconfig
169if [ $1 -eq 0 ] ; then
170    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
171    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
172fi
173
174%clean
175rm -rf $RPM_BUILD_ROOT
176
177%files
178%defattr(-,root,root)
179%doc COPYING README
180%doc %{_datadir}/doc/HTML/en/*
181%{_bindir}/*
182#{_datadir}/config/*
183%{_datadir}/applications/kde4/*
184%{_datadir}/config.kcfg/*
185%{_datadir}/kde4/services/*.desktop
186%{_datadir}/kde4/services/camera.protocol
187%{_libdir}/kde4/kcm_kamera.so
188%{_libdir}/kde4/kio_kamera.so
189%{_datadir}/kde4/services/ServiceMenus/slideshow.desktop
190%{_datadir}/kde4/servicetypes/okularGenerator.desktop
191%{_datadir}/kde4/apps/okular
192%{_datadir}/kde4/apps/kgamma
193%{_datadir}/kde4/apps/gvpart
194%{_datadir}/kde4/apps/gwenview
195%{_datadir}/kde4/apps/kolourpaint
196%{_datadir}/kde4/apps/kruler
197%{_datadir}/kde4/apps/solid/actions/*
198%{_datadir}/kde4/apps/svgpart
199%{_libdir}/kde4/gsthumbnail.so
200%{_libdir}/kde4/gvpart.so
201%{_libdir}/kde4/ksaneplugin.so
202%{_libdir}/kde4/kcm_kgamma.so
203%{_libdir}/kde4/mobithumbnail.so
204%{_libdir}/kde4/okularGenerator_*.so
205%{_libdir}/kde4/okularpart.so
206%{_libdir}/kde4/rawthumbnail.so
207%{_libdir}/kde4/svgpart.so
208%{_datadir}/dbus-1/interfaces/*.xml
209%{_datadir}/icons/hicolor/*/apps/gwenview.*
210%{_datadir}/icons/hicolor/*/apps/kcolorchooser.*
211#{_datadir}/icons/hicolor/*/apps/kgamma.*
212%{_datadir}/icons/hicolor/*/apps/kolourpaint.*
213%{_datadir}/icons/hicolor/*/apps/kruler.*
214%{_datadir}/icons/hicolor/*/apps/ksnapshot.*
215%{_datadir}/icons/hicolor/*/apps/okular.*
216%{_datadir}/icons/hicolor/*/actions/*
217
218%files libs
219%defattr(-,root,root)
220%{_datadir}/kde4/apps/kipi
221%{_datadir}/kde4/apps/libkdcraw
222%{_datadir}/kde4/apps/libkexiv2
223%{_datadir}/icons/hicolor/*/apps/kipi.*
224%{_datadir}/icons/hicolor/*/apps/kdcraw.*
225%{_datadir}/kde4/servicetypes/kipiplugin.desktop
226%{_libdir}/libgwenviewlib.so.*
227%{_libdir}/libkdcraw.so.*
228%{_libdir}/libkexiv2.so.*
229%{_libdir}/libkipi.so.*
230%{_libdir}/libkolourpaint_lgpl.so.*
231%{_libdir}/libksane.so.*
232%{_libdir}/libokularcore.so.*
233%{_libdir}/strigi/strigiea_dvi.so
234%{_libdir}/strigi/strigiea_tiff.so
235%{_libdir}/strigi/strigila_mobi.so
236
237%files devel
238%defattr(-,root,root)
239%{_includedir}/kde4/libkdcraw
240%{_includedir}/kde4/libkexiv2
241%{_includedir}/kde4/libkipi
242%{_includedir}/kde4/libksane
243%{_includedir}/kde4/okular
244%{_libdir}/lib*.so
245%{_datadir}/kde4/apps/cmake/modules/FindKSane.cmake
246%{_datadir}/kde4/apps/cmake/modules/FindOkular.cmake
247%{_libdir}/pkgconfig/*.pc
248
249%files -n kio_msits
250%defattr(-,root,root,-)
251%{_libdir}/kde4/kio_msits.so
252%{_datadir}/kde4/services/msits.protocol
253
254%changelog
255* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
256- new upstream release
257- dropt Patch100 (merged into upstream)
258
259* Sun Aug 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
260- added Patch100 for CVE-2010-2575
261- updated Japanese summary
262- added Japanese description
263
264* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
265- new upstream release
266
267* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
268- new upstream release
269- added Conflicts: kdegraphics3
270
271* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
272- new upstream release
273
274* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
275- rebuilt with exiv2-0.19
276
277* Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
278- new upstream release
279
280* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
281- new upstream release
282
283* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
284- new upstream release
285- built with new toolchain
286
287* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
288- new upstream release
289
290* Tue Nov  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
291- rebuilt with poppler-qt4-devel 0.12.1
292
293* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
294- new upstream release
295
296* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
297- new upstream release
298- used %cmake macro
299
300* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
301- new upstream release
302- changed Group to Applications/Graphics
303
304* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-3
305- rebuilt with kdelibs-3.5.8-2
306- added Japanese summary, spec in UTF-8
307- added %%post, %%postun section
308
309* Wed Apr 29 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 3.5.8-2vl4
310- add Patch100 (CVE-2009-0166,CVE-2009-1180)
311- add Patch101 (CVE-2009-1182,CVE-2009-1183)
312- add BuildPrereq: arts-devel gamin-devel libidn-devel libart_lgpl-devel
313- applied vine versioning policy.
314
315* Thu Oct 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
316- rebuild for VineSeed
317
318* Thu Oct 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
319- new upstream release
320- drop Patch0
321- add Patch1 (CVE-2007-5393)
322
323* Thu Aug  2 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl4
324- add Patch0 (CVE-2007-3387)
325
326* Mon Jul 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.7-0vl3
327- added --with-qt-libraries configure option
328
329* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
330- rebuild for VineSeed
331
332* Sat May 26 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
333- new upstream release
334
335* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
336- new upstream release
337
338* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
339- rebuild for VineSeed
340
341* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
342- new upstream release
343
344* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
345- rebuild for VineSeed
346
347* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
348- new upstream release
349
350* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
351- rebuild for VineSeed
352
353* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
354- new upstream release
355
356* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
357- rebuild for VineSeed
358
359* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
360- new upstream release
361- drop Patch0
362
363* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
364- add BuildPrereq: libexif-devel for VineSeed
365
366* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
367- new upstream release
368- update Patch0
369
370* Thu Jan  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl3
371- rebuild for VineSeed
372
373* Thu Jan  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl3
374- update Patch0 (http://www.kde.org/info/security/advisory-20051207-2.txt)
375
376* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
377- rebuild for VineSeed
378
379* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
380- new upstream release
381- add Patch0 (post-3.5.0-kdegraphics-CAN-2005-3193.diff)
382
383* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
384- new upstream release
385
386* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
387- new upstream release
388- delete all patches
389
390* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
391- new upstream release
392- add Patch1 - Patch2
393- drop Patch0
394
395* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
396- rebuild for VineSeed
397
398* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
399- new upstream release
400
401* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
402- build for VineSeed
403- add --disable-rpath to configure option
404
405* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
406- new upstream release
407- use %%{?_smp_mflags} for make option
408
409* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
410- rebuild for VineSeed
411
412* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
413- new upstream release
414- remove patch1 and patch2
415- build kamera, remove source1 and add Requires: gphoto2
416- update %%files
417
418* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl4
419- build for VineSeed
420- add BuildPrereq: libusb-devel
421
422* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl3
423- add Patch2 (http://www.kde.org/info/security/advisory-20050119-1.txt)
424
425* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
426- rebuild for VineSeed
427
428* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
429- new upstream release
430- add patch1 (http://www.kde.org/info/security/advisory-20041223-1.txt)
431
432* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
433- source upgrade
434
435* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
436- rebuild with qt32
437
438* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
439- source upgrade
440- remove lines about vine26
441
442* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
443- source upgrade
444- add URL: http://www.kde.org
445- add BuildPrereq: lcms-devel >= 1.09 fribidi-devel >= 0.10.4
446
447* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
448- add patch0 and Requires: xpdf (http://bugs.kde.org/76302)
449
450* Sun Mar 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
451- source upgrade
452
453* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
454- rebuild for VineSeedPlus
455
456* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
457- source upgrade
458- build for VinePlus/2.6
459- (VinePlus/2.6) BuildPrereq: autoconf258
460
461* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
462- build for VineSeed with new toolchain and qt-3.2.3
463
464* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
465- rebuild with qt-3.2.1-0.26vl3
466
467* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
468- rebuild with qt-3.2.1-0vl3
469
470* Tue Sep 23 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
471- source upgrade
472- change spec to build with gcc-3.2.3
473
474* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
475- source upgrade
476- change spec to build with gcc295
477- change make option for SMP and add script
478
479* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
480- source upgrade
481- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
482
483* Sat Apr 12 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1a-0vl1
484- source upgrade
485- change spec to build both VineSeed and Vine2.5/2.6
486- change spec to make monolithic package only
487- revised description and files section
488
489* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
490- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
491
492* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
493- source upgrade
494- BuildPrereq: autoconf253 objprelink2
495
496* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
497- source upgrade
498
499* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
500- source upgrade
501
502* Wed May  8 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
503- source update to 3.0
504- add BuildPrereq: xpdf
505- some files are divided to kdegraphics-devel
506- kdvi now works
507
508* Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
509- merged with rawhide 3.0.0-0.cvs20020306.1
510- source update to cvs-20020329
511- add BuildPrereq: autoconf252 automake15
512- add %define with_kamera 0
513- add %define monolithic 1
514- delete kdvi (it is broken)
515- There is Vine's previous changes, hacked for Vine
516 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
517  - update to 2.2.2
518  - stop removing kpaint (it works now)
519 -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
520  - Delete Epoch
521  - Change BuildRequires and Requires
522  - objprelink (i386 only)
523  - Build for VineSeed
524  - remove kpaint (it does not work)
525
526* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
527- Update
528- Rename subpackages
529- Don't build kamera on alpha
530
531* Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
532- Update
533- Reorganize package
534
535* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
536- The -devel package has kscan-related files -n only. Since kscan isn't built
537  on s390/s390x, don't build the devel package there.
538
539* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010724.1
540- Add more build dependencies (#48970)
541- Remove ia64 workarounds, no longer needed
542- Update
543
544* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.1
545- Restore -devel package, got lost during the update
546- Fix build on s390/s390x
547- Update
548
549* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.2
550- Make symlinks relative
551- Update
552
553* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
554- 2.1-respin
555
556* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
557- 2.1
558
559* Fri Feb 16 2001 Than Ngo <than@redhat.com>
560- fix to build against glibc
561
562* Tue Feb  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
563- Get rid of libkdefakes.so.0 dependency
564
565* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
566- Update
567
568* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
569- Update
570
571* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
572- Update
573- Stop excluding ia64
574
575* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
576- Update to HEAD
577
578* Fri Nov  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
579- Update to KDE_2_0_BRANCH
580
581* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
582- 2.0 final
583
584* Thu Aug 24 2000 Than Ngo <than@redhat.com>
585- update to kdegraphics-1.93
586
587* Sun Aug 20 2000 Than Ngo <than@redhat.com>
588- add missing kdegraphic2 package
589
590* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
591- new version
592
593* Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
594- new snapshot
595- work around compiler bug by disabling kcoloredit for now, FIXME
596
597* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
598- new snapshot
599- SMPify build
600
601* Sun Jul 16 2000 Than Ngo <than@redhat.de>
602- use gcc 2.96
603- new snapshot
604- fix docdir
605
606* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
607- Add Epoch - for some reason, rpm thinks 1.1.2 > 1.92.20000623.
608
609* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
610- new snapshot
611- ExcludeArch ia64 for now
612
613* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
614- new snapshot
615- move it to /usr, where it belongs
616
617* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
618- Fix compilation
619
620* Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
621- 2.0 CVS
622
623* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
624- mark doc files as such
625
626* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
627- upgraded to 1.1.2 release
628
629* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
630- snapshot, includes kde 1.1.1 + fixes
631
632* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
633- last snapshot before release
634
635* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
636- latest stable snapshot
637
638* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
639- Injected new description and group.
640
641* Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
642- upgraded to KDE 1.1 final.
643
644* Sat Feb 06 1999 Preston Brown <pbrown@redhat.com>
645- updates to new libstdc++ and rpm standards.
646
647* Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
648- re-merged in updates from Duncan Haldane
649
Note: See TracBrowser for help on using the repository browser.