source: projects/specs/trunk/k/kdegraphics/kdegraphics-vl.spec @ 1705

Revision 1705, 19.4 KB checked in by inagaki, 14 years ago (diff)

update: kdegraphics

Line 
1Name: kdegraphics
2Summary: KDE Graphics Applications
3Summary(ja): KDE グラフィックアプリケーション集
4Version: 4.5.0
5Release: 2%{?_dist_release}
6
7URL: http://www.kde.org/
8License: GPLv2
9Group: Applications/Graphics
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegraphics-%{version}.tar.bz2
12
13# Security fix
14Patch100: kdegraphics-4.5.0-CVE-2010-2575.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: kdelibs4-devel >= %{version}
18BuildRequires: kdepimlibs-devel >= %{version}
19BuildRequires: chmlib-devel
20BuildRequires: djvulibre-devel
21BuildRequires: ebook-tools-devel
22BuildRequires: exiv2-devel
23BuildRequires: giflib-devel
24BuildRequires: lcms-devel
25BuildRequires: libgphoto2-devel
26BuildRequires: sane-devel
27BuildRequires: libspectre-devel
28BuildRequires: libtiff-devel
29BuildRequires: libXxf86vm-devel
30BuildRequires: pcre-devel
31BuildRequires: poppler-qt4-devel
32BuildRequires: qca2-devel
33BuildRequires: qimageblitz-devel
34BuildRequires: soprano-devel
35
36Requires: %{name}-libs = %{version}-%{release}
37# used by okular
38Requires: kio_msits = %{version}-%{release}
39Requires: cups
40
41Obsoletes: kdegraphics4 < %{version}-%{release}
42Obsoletes: kdegraphics-extras < 4.0.0
43Obsoletes: gwenview < 2
44Provides: gwenview = 2
45Provides: kdegraphics4 = %{version}-%{release}
46Conflicts: kdegraphics3
47
48Vendor: Project Vine
49Distribution: Vine Linux
50Packager: inagaki
51
52%description
53Graphics applications for KDE.
54
55What it is
56----------
57* gwenview (an image viewer)
58* kamera (digital camera support)
59* kcolorchooser (a color chooser)
60* kolourpaint4 (an easy-to-use paint program)
61* kruler (screen ruler and color measurement tool)
62* ksnapshot (screen capture utility)
63* okular (a document viewer)
64
65%description -l ja
66KDE 向けのグラフィックアプリケーション集です.
67
68以下のアプリケーションを含んでいます.
69----------
70* gwenview (画像ビューア)
71* kamera (デジタル・カメラのサポート)
72* kcolorchooser (色選択ツール)
73* kolourpaint4 (簡単に操作できるペイントプログラム)
74* kruler (スクリーン上で用いる定規、色測定ツール)
75* ksnapshot (スクリーンショットを撮るためのツール)
76* okular (ドキュメントビューア)
77
78%package libs
79Summary: Runtime libraries for %{name}
80Summary(ja): %{name} のランタイムライブラリ
81Group:   System Environment/Libraries
82Obsoletes: libkdcraw < 0.2.0, libkexiv2 < 0.4.0, libkipi < 0.2.0
83Requires: kdelibs4 >= %{version}
84
85%description libs
86%{summary}.
87
88%description -l ja libs
89%{summary}.
90
91%package devel
92Summary: Development files for kdegraphics
93Summary(ja): %{name} の開発用ファイル集
94Group: Development/Libraries
95Requires: %{name}-libs = %{version}-%{release}
96Requires: kdelibs4-devel
97Requires: pkgconfig
98Obsoletes: libkdcraw-devel < 0.4.0
99Obsoletes: libkexiv2-devel < 0.4.0
100Obsoletes: libkipi-devel < 0.2.0
101Obsoletes: kdegraphics4-devel < %{version}-%{release}
102Provides:  libkdcraw-devel = 0.4.0-2
103Provides:  libkexiv2-devel = 0.5.0-1
104Provides:  libkipi-devel = 0.3.0-1
105Provides:  kdegraphics4-devel = %{version}-%{release}
106
107%description devel
108Header files for developing applications using kdegraphics.
109Install kdegraphics-devel if you wish to develop or compile
110applications using kdegraphics.
111
112%package -n kio_msits
113Summary: A kioslave for displaying WinHelp files
114Group: System Environment/Libraries
115
116%description -n kio_msits
117%{summary}.
118
119
120%prep
121%setup -q -n kdegraphics-%{version}
122
123# security fix
124%patch100 -p0 -b .cve-2010-2575
125
126%build
127mkdir -p %{_target_platform}
128pushd %{_target_platform}
129unset QTDIR || : ; . /etc/profile.d/qt4.sh
130%cmake \
131    -DCMAKE_BUILD_TYPE=release \
132    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
133    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
134    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
135    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
136    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
137    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
138    ..
139popd
140
141make %{?_smp_mflags} -C %{_target_platform}
142
143%install
144rm -rf $RPM_BUILD_ROOT
145make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
146
147%post
148touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
149
150%posttrans
151gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
152update-desktop-database -q &> /dev/null ||:
153
154%postun
155if [ $1 -eq 0 ] ; then
156    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
157    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
158    update-desktop-database -q &> /dev/null ||:
159fi
160
161%post libs
162/sbin/ldconfig
163touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
164
165%posttrans libs
166gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
167
168%postun libs
169/sbin/ldconfig
170if [ $1 -eq 0 ] ; then
171    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
172    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
173fi
174
175%clean
176rm -rf $RPM_BUILD_ROOT
177
178%files
179%defattr(-,root,root)
180%doc COPYING README
181%doc %{_datadir}/doc/HTML/en/*
182%{_bindir}/*
183#{_datadir}/config/*
184%{_datadir}/applications/kde4/*
185%{_datadir}/config.kcfg/*
186%{_datadir}/kde4/services/*.desktop
187%{_datadir}/kde4/services/camera.protocol
188%{_libdir}/kde4/kcm_kamera.so
189%{_libdir}/kde4/kio_kamera.so
190%{_datadir}/kde4/services/ServiceMenus/slideshow.desktop
191%{_datadir}/kde4/servicetypes/okularGenerator.desktop
192%{_datadir}/kde4/apps/okular
193%{_datadir}/kde4/apps/kgamma
194%{_datadir}/kde4/apps/gvpart
195%{_datadir}/kde4/apps/gwenview
196%{_datadir}/kde4/apps/kolourpaint
197%{_datadir}/kde4/apps/kruler
198%{_datadir}/kde4/apps/solid/actions/*
199%{_datadir}/kde4/apps/svgpart
200%{_libdir}/kde4/gsthumbnail.so
201%{_libdir}/kde4/gvpart.so
202%{_libdir}/kde4/ksaneplugin.so
203%{_libdir}/kde4/kcm_kgamma.so
204%{_libdir}/kde4/mobithumbnail.so
205%{_libdir}/kde4/okularGenerator_*.so
206%{_libdir}/kde4/okularpart.so
207%{_libdir}/kde4/rawthumbnail.so
208%{_libdir}/kde4/svgpart.so
209%{_datadir}/dbus-1/interfaces/*.xml
210%{_datadir}/icons/hicolor/*/apps/gwenview.*
211%{_datadir}/icons/hicolor/*/apps/kcolorchooser.*
212#{_datadir}/icons/hicolor/*/apps/kgamma.*
213%{_datadir}/icons/hicolor/*/apps/kolourpaint.*
214%{_datadir}/icons/hicolor/*/apps/kruler.*
215%{_datadir}/icons/hicolor/*/apps/ksnapshot.*
216%{_datadir}/icons/hicolor/*/apps/okular.*
217%{_datadir}/icons/hicolor/*/actions/*
218
219%files libs
220%defattr(-,root,root)
221%{_datadir}/kde4/apps/kipi
222%{_datadir}/kde4/apps/libkdcraw
223%{_datadir}/kde4/apps/libkexiv2
224%{_datadir}/icons/hicolor/*/apps/kipi.*
225%{_datadir}/icons/hicolor/*/apps/kdcraw.*
226%{_datadir}/kde4/servicetypes/kipiplugin.desktop
227%{_libdir}/libgwenviewlib.so.*
228%{_libdir}/libkdcraw.so.*
229%{_libdir}/libkexiv2.so.*
230%{_libdir}/libkipi.so.*
231%{_libdir}/libkolourpaint_lgpl.so.*
232%{_libdir}/libksane.so.*
233%{_libdir}/libokularcore.so.*
234%{_libdir}/strigi/strigiea_dvi.so
235%{_libdir}/strigi/strigiea_tiff.so
236%{_libdir}/strigi/strigila_mobi.so
237
238%files devel
239%defattr(-,root,root)
240%{_includedir}/kde4/libkdcraw
241%{_includedir}/kde4/libkexiv2
242%{_includedir}/kde4/libkipi
243%{_includedir}/kde4/libksane
244%{_includedir}/kde4/okular
245%{_libdir}/lib*.so
246%{_datadir}/kde4/apps/cmake/modules/FindKSane.cmake
247%{_datadir}/kde4/apps/cmake/modules/FindOkular.cmake
248%{_libdir}/pkgconfig/*.pc
249
250%files -n kio_msits
251%defattr(-,root,root,-)
252%{_libdir}/kde4/kio_msits.so
253%{_datadir}/kde4/services/msits.protocol
254
255%changelog
256* Sun Aug 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
257- added Patch100 for CVE-2010-2575
258- updated Japanese summary
259- added Japanese description
260
261* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
262- new upstream release
263
264* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
265- new upstream release
266- added Conflicts: kdegraphics3
267
268* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
269- new upstream release
270
271* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
272- rebuilt with exiv2-0.19
273
274* Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
275- new upstream release
276
277* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
278- new upstream release
279
280* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
281- new upstream release
282- built with new toolchain
283
284* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
285- new upstream release
286
287* Tue Nov  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
288- rebuilt with poppler-qt4-devel 0.12.1
289
290* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
291- new upstream release
292
293* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
294- new upstream release
295- used %cmake macro
296
297* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
298- new upstream release
299- changed Group to Applications/Graphics
300
301* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-3
302- rebuilt with kdelibs-3.5.8-2
303- added Japanese summary, spec in UTF-8
304- added %%post, %%postun section
305
306* Wed Apr 29 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 3.5.8-2vl4
307- add Patch100 (CVE-2009-0166,CVE-2009-1180)
308- add Patch101 (CVE-2009-1182,CVE-2009-1183)
309- add BuildPrereq: arts-devel gamin-devel libidn-devel libart_lgpl-devel
310- applied vine versioning policy.
311
312* Thu Oct 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
313- rebuild for VineSeed
314
315* Thu Oct 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
316- new upstream release
317- drop Patch0
318- add Patch1 (CVE-2007-5393)
319
320* Thu Aug  2 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl4
321- add Patch0 (CVE-2007-3387)
322
323* Mon Jul 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.7-0vl3
324- added --with-qt-libraries configure option
325
326* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
327- rebuild for VineSeed
328
329* Sat May 26 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
330- new upstream release
331
332* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
333- new upstream release
334
335* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
336- rebuild for VineSeed
337
338* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
339- new upstream release
340
341* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
342- rebuild for VineSeed
343
344* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
345- new upstream release
346
347* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
348- rebuild for VineSeed
349
350* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
351- new upstream release
352
353* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
354- rebuild for VineSeed
355
356* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
357- new upstream release
358- drop Patch0
359
360* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
361- add BuildPrereq: libexif-devel for VineSeed
362
363* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
364- new upstream release
365- update Patch0
366
367* Thu Jan  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl3
368- rebuild for VineSeed
369
370* Thu Jan  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl3
371- update Patch0 (http://www.kde.org/info/security/advisory-20051207-2.txt)
372
373* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
374- rebuild for VineSeed
375
376* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
377- new upstream release
378- add Patch0 (post-3.5.0-kdegraphics-CAN-2005-3193.diff)
379
380* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
381- new upstream release
382
383* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
384- new upstream release
385- delete all patches
386
387* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
388- new upstream release
389- add Patch1 - Patch2
390- drop Patch0
391
392* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
393- rebuild for VineSeed
394
395* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
396- new upstream release
397
398* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
399- build for VineSeed
400- add --disable-rpath to configure option
401
402* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
403- new upstream release
404- use %%{?_smp_mflags} for make option
405
406* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
407- rebuild for VineSeed
408
409* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
410- new upstream release
411- remove patch1 and patch2
412- build kamera, remove source1 and add Requires: gphoto2
413- update %%files
414
415* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl4
416- build for VineSeed
417- add BuildPrereq: libusb-devel
418
419* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl3
420- add Patch2 (http://www.kde.org/info/security/advisory-20050119-1.txt)
421
422* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
423- rebuild for VineSeed
424
425* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
426- new upstream release
427- add patch1 (http://www.kde.org/info/security/advisory-20041223-1.txt)
428
429* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
430- source upgrade
431
432* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
433- rebuild with qt32
434
435* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
436- source upgrade
437- remove lines about vine26
438
439* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
440- source upgrade
441- add URL: http://www.kde.org
442- add BuildPrereq: lcms-devel >= 1.09 fribidi-devel >= 0.10.4
443
444* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
445- add patch0 and Requires: xpdf (http://bugs.kde.org/76302)
446
447* Sun Mar 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
448- source upgrade
449
450* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
451- rebuild for VineSeedPlus
452
453* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
454- source upgrade
455- build for VinePlus/2.6
456- (VinePlus/2.6) BuildPrereq: autoconf258
457
458* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
459- build for VineSeed with new toolchain and qt-3.2.3
460
461* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
462- rebuild with qt-3.2.1-0.26vl3
463
464* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
465- rebuild with qt-3.2.1-0vl3
466
467* Tue Sep 23 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
468- source upgrade
469- change spec to build with gcc-3.2.3
470
471* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
472- source upgrade
473- change spec to build with gcc295
474- change make option for SMP and add script
475
476* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
477- source upgrade
478- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
479
480* Sat Apr 12 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1a-0vl1
481- source upgrade
482- change spec to build both VineSeed and Vine2.5/2.6
483- change spec to make monolithic package only
484- revised description and files section
485
486* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
487- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
488
489* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
490- source upgrade
491- BuildPrereq: autoconf253 objprelink2
492
493* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
494- source upgrade
495
496* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
497- source upgrade
498
499* Wed May  8 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
500- source update to 3.0
501- add BuildPrereq: xpdf
502- some files are divided to kdegraphics-devel
503- kdvi now works
504
505* Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
506- merged with rawhide 3.0.0-0.cvs20020306.1
507- source update to cvs-20020329
508- add BuildPrereq: autoconf252 automake15
509- add %define with_kamera 0
510- add %define monolithic 1
511- delete kdvi (it is broken)
512- There is Vine's previous changes, hacked for Vine
513 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
514  - update to 2.2.2
515  - stop removing kpaint (it works now)
516 -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
517  - Delete Epoch
518  - Change BuildRequires and Requires
519  - objprelink (i386 only)
520  - Build for VineSeed
521  - remove kpaint (it does not work)
522
523* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
524- Update
525- Rename subpackages
526- Don't build kamera on alpha
527
528* Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
529- Update
530- Reorganize package
531
532* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
533- The -devel package has kscan-related files -n only. Since kscan isn't built
534  on s390/s390x, don't build the devel package there.
535
536* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010724.1
537- Add more build dependencies (#48970)
538- Remove ia64 workarounds, no longer needed
539- Update
540
541* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.1
542- Restore -devel package, got lost during the update
543- Fix build on s390/s390x
544- Update
545
546* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.2
547- Make symlinks relative
548- Update
549
550* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
551- 2.1-respin
552
553* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
554- 2.1
555
556* Fri Feb 16 2001 Than Ngo <than@redhat.com>
557- fix to build against glibc
558
559* Tue Feb  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
560- Get rid of libkdefakes.so.0 dependency
561
562* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
563- Update
564
565* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
566- Update
567
568* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
569- Update
570- Stop excluding ia64
571
572* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
573- Update to HEAD
574
575* Fri Nov  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
576- Update to KDE_2_0_BRANCH
577
578* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
579- 2.0 final
580
581* Thu Aug 24 2000 Than Ngo <than@redhat.com>
582- update to kdegraphics-1.93
583
584* Sun Aug 20 2000 Than Ngo <than@redhat.com>
585- add missing kdegraphic2 package
586
587* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
588- new version
589
590* Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
591- new snapshot
592- work around compiler bug by disabling kcoloredit for now, FIXME
593
594* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
595- new snapshot
596- SMPify build
597
598* Sun Jul 16 2000 Than Ngo <than@redhat.de>
599- use gcc 2.96
600- new snapshot
601- fix docdir
602
603* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
604- Add Epoch - for some reason, rpm thinks 1.1.2 > 1.92.20000623.
605
606* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
607- new snapshot
608- ExcludeArch ia64 for now
609
610* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
611- new snapshot
612- move it to /usr, where it belongs
613
614* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
615- Fix compilation
616
617* Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
618- 2.0 CVS
619
620* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
621- mark doc files as such
622
623* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
624- upgraded to 1.1.2 release
625
626* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
627- snapshot, includes kde 1.1.1 + fixes
628
629* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
630- last snapshot before release
631
632* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
633- latest stable snapshot
634
635* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
636- Injected new description and group.
637
638* Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
639- upgraded to KDE 1.1 final.
640
641* Sat Feb 06 1999 Preston Brown <pbrown@redhat.com>
642- updates to new libstdc++ and rpm standards.
643
644* Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
645- re-merged in updates from Duncan Haldane
646
Note: See TracBrowser for help on using the repository browser.