source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 8430

Revision 8430, 28.7 KB checked in by Takemikaduchi, 10 years ago (diff)

KDE-4.12.5

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.12.5
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.xz
15
16# add shortcuts for search provider
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18
19# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
20Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
21
22# correct path for htsearch
23Patch7:        kdebase-runtime-4.5.3-htsearch.patch
24
25# Launch compiz via compiz-manager so we get window decorations and
26# other such decadent luxuries (AdamW 2011/01)
27Patch8:        kdebase-runtime-4.5.95-compiz.patch
28
29# add overrides in default manpath
30Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
31
32## upstreamable patches
33# make installdbgsymbols.sh use pkexec instead of su
34# increase some timeouts in an effort to see (some) errors before close
35Patch51: kde-runtime-4.9.0-installdbgsymbols.patch
36
37## upstream patches
38
39
40Provides:  kdebase4-runtime = %{version}-%{release}
41Provides:  kde-runtime = %{version}-%{release}
42Obsoletes: kdebase4-runtime < %{version}-%{release}
43
44Obsoletes: nepomukcontroller
45Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
46
47# knotify4 provides dbus service org.freedesktop.Notifications too
48Provides: desktop-notification-daemon
49
50BuildRoot:     %{_tmppath}/%{name}-%{version}-root
51BuildRequires: alsa-lib-devel
52BuildRequires: attica-devel >= 0.1.4
53BuildRequires: bzip2-devel
54BuildRequires: chrpath
55BuildRequires: clucene-core-devel
56BuildRequires: doxygen
57BuildRequires: exiv2-devel >= 0.12
58BuildRequires: glib2-devel
59BuildRequires: gpgme-devel
60BuildRequires: kdelibs-devel >= %{version}
61BuildRequires: kdepimlibs-devel >= %{version}
62BuildRequires: kactivities-devel >= %{version}
63BuildRequires: libcanberra-devel
64#BuildRequires: libqzeitgeist-devel
65BuildRequires: libsmbclient-devel
66BuildRequires: libssh-devel >= 0.4.2
67BuildRequires: libXpm-devel
68BuildRequires: libXScrnSaver-devel
69BuildRequires: NetworkManager-devel
70BuildRequires: nepomuk-core
71BuildRequires: nepomuk-core-devel
72BuildRequires: OpenEXR-devel
73BuildRequires: openslp-devel
74BuildRequires: openssl-devel
75BuildRequires: pkgconfig
76BuildRequires: polkit-qt-devel
77BuildRequires: pulseaudio-libs-devel
78BuildRequires: qca2-devel
79BuildRequires: qimageblitz-devel
80BuildRequires: shared-mime-info >= 0.40
81BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
82BuildRequires: soprano-devel >= 2.6.50
83BuildRequires: xine-lib-devel libxcb-devel
84BuildRequires: xorg-x11-font-utils
85BuildRequires: xorg-x11-proto-devel
86BuildRequires: xz-devel
87BuildRequires: zlib-devel
88
89Requires: eject
90Requires: %{name}-libs = %{version}-%{release}
91Requires: %{name}-flags = %{version}-%{release}
92# KHelpcenter requires htdig for building search indices
93Requires: htdig
94# ensure default/fallback icon theme present
95# beware of bootstrapping, there be dragons
96Requires: oxygen-icon-theme >= %{version}
97
98# some items moved -workspace -> -runtime
99Conflicts: kdebase-workspace < 4.5.80
100
101Vendor: Project Vine
102Distribution: Vine Linux
103
104%description
105Core runtime for KDE 4.
106
107%description -l ja
108KDE 4 の中心となるランタイム部分です.
109
110%package devel
111Summary:  Developer files for %{name}
112Summary(ja): %{name} の開発用ファイル
113Group:    Development/Libraries
114Requires: %{name}-libs = %{version}-%{release}
115
116%description devel
117%{summary}.
118
119%description -l ja devel
120%{name} の開発用ファイルです.
121
122%package libs
123Summary: Runtime libraries for %{name}
124Summary(ja): %{name} のランタイムライブラリ
125Group:   System Environment/Libraries
126Requires: kdelibs4 >= %{version}
127Requires: kdepimlibs >= %{version}
128# cagibi is runtime dep, a dbus service
129Requires: cagibi
130
131%description libs
132%{summary}.
133
134%description -l ja libs
135%{name} のランタイムライブラリです.
136
137%package flags
138Summary: Geopolitical flags
139Group: User Interface/Desktops
140Requires: %{name}-libs = %{version}-%{release}
141BuildArch: noarch
142
143%description flags
144%{summary}.
145
146
147%prep
148%setup -q -n kde-runtime-%{version}
149
150%patch1 -p1 -b .searchproviders-shortcuts
151%patch6 -p1 -b .home_onlyshowin_kde
152%patch7 -p1 -b .htsearch
153%patch8 -p1 -b .config
154%patch9 -p1 -b .man-overrides
155%patch51 -p1 -b .installdgbsymbols
156
157
158%build
159mkdir -p %{_target_platform}
160pushd %{_target_platform}
161%cmake \
162    -DCMAKE_BUILD_TYPE=release \
163    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
164    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
165    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
166    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
167    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
168    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
169    ..
170popd
171
172make %{?_smp_mflags} -C %{_target_platform}
173
174
175%install
176rm -rf $RPM_BUILD_ROOT
177
178make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
179
180# kdesu symlink
181ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
182
183# omit hicolor index.theme, use one from hicolor-icon-theme
184rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
185
186# remove country flags because some people/countries forbid some other
187# people/countries' flags :-(
188%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
189
190# install this service for KDE 3 applications too
191mkdir $RPM_BUILD_ROOT%{_datadir}/services
192ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
193      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
194
195# FIXME: -devel type files, omit for now
196rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
197
198# rpaths
199# use chrpath hammer for now, find better patching solutions later -- Rex
200chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
201chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
202
203%clean
204rm -rf $RPM_BUILD_ROOT
205
206%post
207touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
208touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
209
210%posttrans
211gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
212gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
213update-desktop-database -q &> /dev/null ||:
214update-mime-database %{_datadir}/mime &> /dev/null
215
216%postun
217if [ $1 -eq 0 ] ; then
218    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
219    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
220    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
221    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
222    update-desktop-database -q &> /dev/null ||:
223    update-mime-database %{_datadir}/mime &> /dev/null
224fi
225
226%post libs -p /sbin/ldconfig
227%postun libs -p /sbin/ldconfig
228
229
230%files
231%defattr(-,root,root,-)
232%{_sysconfdir}/dbus-1/system.d/*
233%{_sysconfdir}/xdg/menus/kde-information.menu
234%{_bindir}/*
235# omit ksvgtopng which kdelibs3 includes
236%{_datadir}/kde4/apps/*
237%exclude %{_datadir}/kde4/apps/cmake/
238%{_datadir}/config/*.knsrc
239%{_datadir}/config.kcfg/
240%{_datadir}/dbus-1/interfaces/*
241%{_datadir}/dbus-1/services/*
242%{_datadir}/dbus-1/system-services/*
243%{_datadir}/icons/default.kde4
244%{_datadir}/kde4/services/*
245%{_datadir}/kde4/servicetypes/*
246%{_datadir}/mime/packages/network.xml
247%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
248%{_datadir}/sounds/*
249%{_libdir}/kconf_update_bin/*
250%{_libdir}/libkdeinit4_*.so
251%{_libdir}/kde4/kcm_*.so
252%{_libdir}/kde4/kded_*.so
253%{_libdir}/kde4/platformimports/touch/org/kde/plasma/*
254%{_libexecdir}/kde4/drkonqi
255#{_libexecdir}/kde4/installdbgsymbols.sh
256%{_libexecdir}/kde4/kcmremotewidgetshelper
257%{_libexecdir}/kde4/kdeeject
258%{_libexecdir}/kde4/kdesu
259%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
260%{_libexecdir}/kde4/kdontchangethehostname
261%{_libexecdir}/kde4/khc_docbookdig.pl
262%{_libexecdir}/kde4/khc_htdig.pl
263%{_libexecdir}/kde4/khc_htsearch.pl
264%{_libexecdir}/kde4/khc_indexbuilder
265%{_libexecdir}/kde4/khc_mansearch.pl
266%{_libexecdir}/kde4/kioexec
267%{_libexecdir}/kde4/knetattach
268%{_mandir}/man1/*
269%{_mandir}/man8/*
270%{_datadir}/icons/hicolor/*/*/*
271%{_docdir}/HTML/en/*
272%{_datadir}/applications/kde4/Help.desktop
273%{_datadir}/applications/kde4/knetattach.desktop
274%{_datadir}/config/kshorturifilterrc
275%{_datadir}/desktop-directories/*.directory
276%{_datadir}/emoticons/kde4/
277%{_datadir}/locale/l10n/
278%{_datadir}/locale/currency/
279%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
280%{_datadir}/services/khelpcenter.desktop
281
282%files devel
283%defattr(-,root,root,-)
284%{_includedir}/*
285%{_datadir}/kde4/apps/cmake/modules/*.cmake
286
287%files libs
288%defattr(-,root,root,-)
289%{_libdir}/attica_kde.so
290%{_libdir}/libknotifyplugin.so
291%{_libdir}/libkwalletbackend.so.*
292%{_libdir}/libmolletnetwork.so.*
293%{_libdir}/kde4/*.so
294%{_libdir}/kde4/imports/
295# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
296%exclude %{_libdir}/kde4/kcm_*.so
297%exclude %{_libdir}/kde4/kded_*.so
298%{_libdir}/kde4/plugins/phonon_platform/
299
300%files flags
301%defattr(-,root,root,-)
302%{_datadir}/locale/l10n/*/flag.png
303
304
305%changelog
306* Tue May 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
307- new upstream release
308
309* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
310- new upstream release
311- add BuildRequires: gpgme-devel
312
313* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-2
314- rebuild with ilmbase-2.1.0 & OpenEXR-2.1.0
315
316* Sun Dec 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
317- new upstream release
318
319* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
320- new upstream release
321- remove Patch50 (kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch)
322
323* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
324- new upstream release
325
326* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
327- new upstream release
328- add patches from fedora
329  - Patch50 (kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch)
330  - Patch51 (kde-runtime-4.9.0-installdbgsymbols.patch)
331
332* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
333- new upstream release
334
335* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
336- new upstream release
337
338* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
339- new upstream release
340
341* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
342- rebuild with attica-0.4.1
343
344* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
345- new upstream release
346- remove Patch3 (kdebase-runtime-4.6.90-iconthemes-inherit.patch)
347- add BuildRequires: kactivities-devel, nupomuk-core-devel, qca2-devel
348
349* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-4
350- rebuild with exiv2-0.23
351
352* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-3
353- rebuild with exiv2-0.22
354
355* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-2
356- rebuilt without libqzeitgeist
357
358* Tue Dec 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
359- new upstream release
360
361* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
362- new upstream release
363
364* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
365- new upstream release
366- built with exiv2-0.21.1
367
368* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
369- new upstream release
370
371* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
372- rebuilt with libsmbclient-3.5.8
373
374* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
375- new upstream release
376
377* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
378- added BR: libXpm-devel
379
380* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
381- new upstream release
382- added devel subpackage
383
384* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
385- new upstream release
386- updated summary
387- dropt Patch100
388
389* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
390- new upstream release
391- added Patch100 from Fedora
392  - backport to fix the freeze of kded on first use of the network:/kio-slave
393
394* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
395- new upstream release
396- added Conflicts: kdebase3 at Vine Linux 5
397
398* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
399- new upstream release
400
401* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
402- rebuilt with exiv2-0.19
403
404* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
405- new upstream release
406
407* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
408- new upstream release
409
410* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
411- new upstream release
412- built with new toolchain
413
414* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
415- new upstream release
416
417* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
418- new upstream release
419
420* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
421- new upstream release
422- used %%cmake macro
423
424* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
425- Initial build for Vine Linux
426
427* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
428- respin
429
430* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
431- 4.3.0
432
433* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
434- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
435
436* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
437- 4.3rc3
438
439* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
440- respin (soprano-2.3.0)
441- License: LGPLv2+
442
443* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
444- 4.3rc2
445
446* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
447- drop unneeded BR: ImageMagick (#509241)
448
449* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
450- don't start nepomuk server unconditionally (#487322)
451
452* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
453- 4.3rc1
454
455* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
456- KDE-4.3 beta2 (4.2.90)
457
458* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
459- Drop old Fedora < 8 conditionals
460
461* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
462- file conflicts with kdepim
463
464* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
465- KDE 4.3 beta 1
466
467* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
468- fix persistent systray notifications (#485796)
469
470* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
471- -flags subpkg
472- koji/noarch hacks dropped
473
474* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
475- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
476
477* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
478- KDE 4.2.2
479
480* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
481- flags subpkg (not enabled)
482- optimize scriptlets
483
484* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
485- fix PulseAudio cmake detection
486
487* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
488- 4.2.1
489
490* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
491- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
492
493* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
494- #486059 -  missing dependency on htdig
495
496* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
497- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
498
499* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
500- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
501
502* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
503- own %%_kde4_datadir/locale/l10n/
504
505* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
506- respun tarball
507
508* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
509- Files not trashed to the correct location in Dolphin/Konqueror
510  (#481598, kdebug#178479)
511- omit --with-samba crud
512
513* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
514- 4.2.0
515- +BR: pulseaudio-libs-devel xine-lib-devel
516- -BR: giflib-devel pcre-devel
517
518* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
519- tarball respin
520- drop extraneous deps (that are in kdelibs)
521
522* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
523- 4.2rc1
524
525* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
526- include %%_bindir/kdesu symlink
527
528* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
529- 4.2beta2
530
531* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
532- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
533  and should be in a -devel package if it gets shipped)
534
535* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
536- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
537
538* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
539- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
540
541* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
542- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
543
544* Wed Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
545- 4.1.80
546- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
547- BR cmake >= 2.6.2
548- Use 'make install/fast'
549- Drop subpkg phonon-backend-xine and related file entries: this has to be
550  part of phonon now that it moved there
551- Drop xine-lib-devel BR
552- Add libkwalletbackend to files list
553- Drop _default_patch_fuzz 2
554
555* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
556- apply upstream patch to fix X crash when disabling compositing
557
558* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
559- 4.1.3
560
561* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
562- apply upstream patch, kioexec processes never terminate
563
564* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
565- fix broken audio-backend-jack.svgz
566
567* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
568- add missing icons
569
570* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
571- make VERBOSE=1
572- respin against new(er) kde-filesystem
573- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
574
575* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
576- 4.1.2
577
578* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
579- fix inherit issue in iconthemes, preview icons
580  do not show
581
582* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
583- fix #460710, knetattach is kio_remote's wizard program, don't show
584  it in the menu.
585
586* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
587- 4.1.1
588
589* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
590- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
591
592* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
593- crash fix when stopping a service that is not yet initialized
594
595* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
596- don't remove autostart directory on F8- (does not conflict, fixes build
597  failure due to nepomukserver.desktop listed in filelist but not found)
598
599* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
600- 4.1.0
601
602* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
603- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
604
605* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
606- 4.0.99
607
608* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
609- respin
610
611* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
612- -phonon-backend-xine: new subpkg
613
614* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
615- 4.0.98
616
617* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
618- 4.0.85
619
620* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
621- 4.0.84
622
623* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
624- 4.0.83 (beta2)
625
626* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
627- 4.0.82
628
629* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
630- add searchproviders-shortcuts for redhat bugzilla
631
632* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
633- 4.1 beta 1
634
635* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
636- BR new minimum version of soprano-devel
637
638* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
639- update to 4.0.72 (4.1 alpha 1)
640- drop upstreamed deinterlace-crash patch
641- drop khelpcenter patch (fixed upstream)
642- update Phonon PulseAudio patch
643- drop Fedora 7 support
644- update file list
645
646* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
647- omit conflicting icons (kde3_desktop=1 case)
648
649* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
650- oxygen-icon-theme: build noarch
651
652* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
653- %%post/%%postun: hicolor icon theme scriptlets
654
655* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
656- only omit hicolor index.theme (#439374)
657
658* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
659- fix khelpcenter, search plugins/settings in correct path (#443016)
660
661* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
662- respin (at f13's request)
663
664* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
665- pulseaudio patch (use as default, if available)
666
667* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
668- don't crash if we don't have deinterlacing support in xine-lib (#440299)
669
670* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
671- rebuild for the new %%{_kde4_buildtype}
672
673* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
674- update file list for _kde4_libexecdir
675
676* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
677- 4.0.3
678
679* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
680- don't own %%_kde4_docdir/HTML/en/
681
682* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
683- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
684- include noarch build hooks (not enabled)
685
686* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
687- BR libxcb-devel everywhere (including F7)
688
689* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
690- if building for a KDE 4 desktop, include the khelpcenter.desktop service
691  description for KDE 3 here so help works in KDE 3 apps
692
693* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
694- 4.0.2
695
696* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
697- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
698
699* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
700- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
701  (kio_smb itself is already GPLv2+)
702
703* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
704- 4.0.1
705
706* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
707- respun tarball
708
709* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
710- update to 4.0.0
711- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
712
713* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
714- kde-3.97.0
715
716* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
717- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
718
719* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
720- build without libxcb in F7 as we STILL don't have it (see #373361)
721
722* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
723- no longer set kde3_desktop on F9
724- update file list for !kde3_desktop (Sebastian Vahl)
725- don't ship country flags even for full version (as in kdebase 3)
726
727* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
728- kde-3.96.2
729
730* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
731- kde-3.96.1
732
733* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
734- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
735
736* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
737- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
738
739* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
740- kde-3.96.0
741
742* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
743- kdebase-runtime-3.95.2
744
745* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
746- kdebase-runtime-3.95.0
747
748* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
749- Provides: oxygen-icon-theme ...
750
751* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
752- patch dolphin.desktop to get Dolphin to start from the menu
753
754* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
755- update to 3.94.0
756
757* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
758- don't make this the default kdebase on F9 yet
759- drop ExcludeArch: ppc64 (#300601)
760
761* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
762- ExcludeArch: ppc64 (#300601)
763- update description
764
765* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
766- add missing BR alsa-lib-devel
767
768* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
769- remove files which conflict with KDE 3
770- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
771- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
772
773* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
774- update to 3.93.0
775- drop kde4home patch (no longer applied)
776- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
777- remove kdebase-kdm Obsoletes/Provides (for the same reason)
778- remove KDM (and KDM session) setup code (for the same reason)
779- remove rss-glx conflict (Plasma is now in kdebase-workspace)
780- remove redhat-startkde patch (startkde is now in kdebase-workspace)
781- remove kde4-opt.sh (all the code in it is commented out)
782- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
783- remove bogus BRs on automake and libtool
784- remove workspace-only BRs
785- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
786- remove workspace files and directories
787- handle icons (moved from kdelibs4)
788- add mkdir %%{buildroot} in %%install
789
790* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
791- use macros.kde4
792- License: GPLv2
793
794* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
795- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
796- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
797- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
798
799* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
800- consolekit_kdm patch (#228111, kde#147790)
801- update startkde patch
802
803* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
804- kde-3.92 (kde-4-beta1)
805
806* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
807- fix startkde
808- add env/shutdown directory
809
810* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
811- kde4.desktop: fix session Name
812
813* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
814- cleanup/fix kde4.desktop
815- kdepimlibs4->kdepimlibs
816
817* Fri Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
818- fix %%_sysconfdir for %%_prefix != /usr case.
819
820* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
821- updated kde4home.diff
822- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
823
824* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
825- kde-3.91.0
826- CMAKE_BUILD_TYPE=debug
827
828* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
829- specfile cleanup (%%prefix issues mostly)
830
831* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
832- update to 3.90.1
833- bump cmake BR to 2.4.5 as required upstream now
834- don't set execute bits by hand anymore, cmake has been fixed
835- use multilibs in /opt/kde4
836- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
837- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
838  in case we want to drop the Rs on these from kdelibs4-devel
839- consistently add all BRs as -devel Rs, not just almost all, until we can
840  figure out which, if any, are really needed
841- BR libsmbclient-devel instead of samba on F>=7, EL>=6
842
843* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
844- restore minimum version requirement for cmake
845- build against libxklavier on EL5
846- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
847
848* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
849- +eXecute perms for %%{_prefix}/lib/*
850
851* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
852- rebuild for patched FindKDE4Internal.cmake
853
854* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
855- update to 3.80.3
856- update and improve parallel-installability patch
857- drop obsolete joydevice.h patch
858- remove translations of "KDE" without the "4" from kde4.desktop
859- resync BR and -devel Requires
860- don't set LD_LIBRARY_PATH
861- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
862- fix missing underscore in _datadir
863- install kde4.desktop in install, not prep
864- fix invalid syntax in kde4.desktop
865
866* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
867- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
868- compiling with QA_RPATHS=0x0003; export QA_RPATHS
869
870* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
871- parallel build support
872- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
873- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
874- spec file cleanups and added clean up in %%install
875- fixed PATH for libkdecore.so.5; cannot open shared object file;
876- added Logitech mouse support
877- added dbus-devel, hal-devel and more as BR
878- fixed broken joydevice.h - Kevin Kofler
879- added file kde4.desktop
880
881* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
882- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
883- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.