source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 8252

Revision 8252, 28.6 KB checked in by Takemikaduchi, 10 years ago (diff)

KDE-4.12.2

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.12.2
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.xz
15
16# add shortcuts for search provider
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18
19# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
20Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
21
22# correct path for htsearch
23Patch7:        kdebase-runtime-4.5.3-htsearch.patch
24
25# Launch compiz via compiz-manager so we get window decorations and
26# other such decadent luxuries (AdamW 2011/01)
27Patch8:        kdebase-runtime-4.5.95-compiz.patch
28
29# add overrides in default manpath
30Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
31
32## upstreamable patches
33# make installdbgsymbols.sh use pkexec instead of su
34# increase some timeouts in an effort to see (some) errors before close
35Patch51: kde-runtime-4.9.0-installdbgsymbols.patch
36
37## upstream patches
38
39
40Provides:  kdebase4-runtime = %{version}-%{release}
41Provides:  kde-runtime = %{version}-%{release}
42Obsoletes: kdebase4-runtime < %{version}-%{release}
43
44Obsoletes: nepomukcontroller
45Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
46
47# knotify4 provides dbus service org.freedesktop.Notifications too
48Provides: desktop-notification-daemon
49
50BuildRoot:     %{_tmppath}/%{name}-%{version}-root
51BuildRequires: alsa-lib-devel
52BuildRequires: attica-devel >= 0.1.4
53BuildRequires: bzip2-devel
54BuildRequires: chrpath
55BuildRequires: clucene-core-devel
56BuildRequires: doxygen
57BuildRequires: exiv2-devel >= 0.12
58BuildRequires: glib2-devel
59BuildRequires: gpgme-devel
60BuildRequires: kdelibs-devel >= %{version}
61BuildRequires: kdepimlibs-devel >= %{version}
62BuildRequires: kactivities-devel >= %{version}
63BuildRequires: libcanberra-devel
64#BuildRequires: libqzeitgeist-devel
65BuildRequires: libsmbclient-devel
66BuildRequires: libssh-devel >= 0.4.2
67BuildRequires: libXpm-devel
68BuildRequires: libXScrnSaver-devel
69BuildRequires: NetworkManager-devel
70BuildRequires: nepomuk-core
71BuildRequires: nepomuk-core-devel
72BuildRequires: OpenEXR-devel
73BuildRequires: openslp-devel
74BuildRequires: openssl-devel
75BuildRequires: pkgconfig
76BuildRequires: polkit-qt-devel
77BuildRequires: pulseaudio-libs-devel
78BuildRequires: qca2-devel
79BuildRequires: qimageblitz-devel
80BuildRequires: shared-mime-info >= 0.40
81BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
82BuildRequires: soprano-devel >= 2.6.50
83BuildRequires: xine-lib-devel libxcb-devel
84BuildRequires: xorg-x11-font-utils
85BuildRequires: xorg-x11-proto-devel
86BuildRequires: xz-devel
87BuildRequires: zlib-devel
88
89Requires: eject
90Requires: %{name}-libs = %{version}-%{release}
91Requires: %{name}-flags = %{version}-%{release}
92# KHelpcenter requires htdig for building search indices
93Requires: htdig
94# ensure default/fallback icon theme present
95# beware of bootstrapping, there be dragons
96Requires: oxygen-icon-theme >= %{version}
97
98# some items moved -workspace -> -runtime
99Conflicts: kdebase-workspace < 4.5.80
100
101Vendor: Project Vine
102Distribution: Vine Linux
103
104%description
105Core runtime for KDE 4.
106
107%description -l ja
108KDE 4 の中心となるランタイム部分です.
109
110%package devel
111Summary:  Developer files for %{name}
112Summary(ja): %{name} の開発用ファイル
113Group:    Development/Libraries
114Requires: %{name}-libs = %{version}-%{release}
115
116%description devel
117%{summary}.
118
119%description -l ja devel
120%{name} の開発用ファイルです.
121
122%package libs
123Summary: Runtime libraries for %{name}
124Summary(ja): %{name} のランタイムライブラリ
125Group:   System Environment/Libraries
126Requires: kdelibs4 >= %{version}
127Requires: kdepimlibs >= %{version}
128# cagibi is runtime dep, a dbus service
129Requires: cagibi
130
131%description libs
132%{summary}.
133
134%description -l ja libs
135%{name} のランタイムライブラリです.
136
137%package flags
138Summary: Geopolitical flags
139Group: User Interface/Desktops
140Requires: %{name}-libs = %{version}-%{release}
141BuildArch: noarch
142
143%description flags
144%{summary}.
145
146
147%prep
148%setup -q -n kde-runtime-%{version}
149
150%patch1 -p1 -b .searchproviders-shortcuts
151%patch6 -p1 -b .home_onlyshowin_kde
152%patch7 -p1 -b .htsearch
153%patch8 -p1 -b .config
154%patch9 -p1 -b .man-overrides
155%patch51 -p1 -b .installdgbsymbols
156
157
158%build
159mkdir -p %{_target_platform}
160pushd %{_target_platform}
161%cmake \
162    -DCMAKE_BUILD_TYPE=release \
163    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
164    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
165    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
166    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
167    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
168    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
169    ..
170popd
171
172make %{?_smp_mflags} -C %{_target_platform}
173
174
175%install
176rm -rf $RPM_BUILD_ROOT
177
178make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
179
180# kdesu symlink
181ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
182
183# omit hicolor index.theme, use one from hicolor-icon-theme
184rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
185
186# remove country flags because some people/countries forbid some other
187# people/countries' flags :-(
188%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
189
190# install this service for KDE 3 applications too
191mkdir $RPM_BUILD_ROOT%{_datadir}/services
192ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
193      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
194
195# FIXME: -devel type files, omit for now
196rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
197
198# rpaths
199# use chrpath hammer for now, find better patching solutions later -- Rex
200chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
201chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
202
203%clean
204rm -rf $RPM_BUILD_ROOT
205
206%post
207touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
208touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
209
210%posttrans
211gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
212gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
213update-desktop-database -q &> /dev/null ||:
214update-mime-database %{_datadir}/mime &> /dev/null
215
216%postun
217if [ $1 -eq 0 ] ; then
218    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
219    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
220    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
221    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
222    update-desktop-database -q &> /dev/null ||:
223    update-mime-database %{_datadir}/mime &> /dev/null
224fi
225
226%post libs -p /sbin/ldconfig
227%postun libs -p /sbin/ldconfig
228
229
230%files
231%defattr(-,root,root,-)
232%{_sysconfdir}/dbus-1/system.d/*
233%{_sysconfdir}/xdg/menus/kde-information.menu
234%{_bindir}/*
235# omit ksvgtopng which kdelibs3 includes
236%{_datadir}/kde4/apps/*
237%exclude %{_datadir}/kde4/apps/cmake/
238%{_datadir}/config/*.knsrc
239%{_datadir}/config.kcfg/
240%{_datadir}/dbus-1/interfaces/*
241%{_datadir}/dbus-1/services/*
242%{_datadir}/dbus-1/system-services/*
243%{_datadir}/icons/default.kde4
244%{_datadir}/kde4/services/*
245%{_datadir}/kde4/servicetypes/*
246%{_datadir}/mime/packages/network.xml
247%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
248%{_datadir}/sounds/*
249%{_libdir}/kconf_update_bin/*
250%{_libdir}/libkdeinit4_*.so
251%{_libdir}/kde4/kcm_*.so
252%{_libdir}/kde4/kded_*.so
253%{_libdir}/kde4/platformimports/touch/org/kde/plasma/*
254%{_libexecdir}/kde4/drkonqi
255#{_libexecdir}/kde4/installdbgsymbols.sh
256%{_libexecdir}/kde4/kcmremotewidgetshelper
257%{_libexecdir}/kde4/kdeeject
258%{_libexecdir}/kde4/kdesu
259%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
260%{_libexecdir}/kde4/kdontchangethehostname
261%{_libexecdir}/kde4/khc_docbookdig.pl
262%{_libexecdir}/kde4/khc_htdig.pl
263%{_libexecdir}/kde4/khc_htsearch.pl
264%{_libexecdir}/kde4/khc_indexbuilder
265%{_libexecdir}/kde4/khc_mansearch.pl
266%{_libexecdir}/kde4/kioexec
267%{_libexecdir}/kde4/knetattach
268%{_mandir}/man1/*
269%{_mandir}/man8/*
270%{_datadir}/icons/hicolor/*/*/*
271%{_docdir}/HTML/en/*
272%{_datadir}/applications/kde4/Help.desktop
273%{_datadir}/applications/kde4/knetattach.desktop
274%{_datadir}/config/kshorturifilterrc
275%{_datadir}/desktop-directories/*.directory
276%{_datadir}/emoticons/kde4/
277%{_datadir}/locale/l10n/
278%{_datadir}/locale/currency/
279%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
280%{_datadir}/services/khelpcenter.desktop
281
282%files devel
283%defattr(-,root,root,-)
284%{_includedir}/*
285%{_datadir}/kde4/apps/cmake/modules/*.cmake
286
287%files libs
288%defattr(-,root,root,-)
289%{_libdir}/attica_kde.so
290%{_libdir}/libknotifyplugin.so
291%{_libdir}/libkwalletbackend.so.*
292%{_libdir}/libmolletnetwork.so.*
293%{_libdir}/kde4/*.so
294%{_libdir}/kde4/imports/
295# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
296%exclude %{_libdir}/kde4/kcm_*.so
297%exclude %{_libdir}/kde4/kded_*.so
298%{_libdir}/kde4/plugins/phonon_platform/
299
300%files flags
301%defattr(-,root,root,-)
302%{_datadir}/locale/l10n/*/flag.png
303
304
305%changelog
306* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
307- new upstream release
308- add BuildRequires: gpgme-devel
309
310* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-2
311- rebuild with ilmbase-2.1.0 & OpenEXR-2.1.0
312
313* Sun Dec 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
314- new upstream release
315
316* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
317- new upstream release
318- remove Patch50 (kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch)
319
320* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
321- new upstream release
322
323* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
324- new upstream release
325- add patches from fedora
326  - Patch50 (kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch)
327  - Patch51 (kde-runtime-4.9.0-installdbgsymbols.patch)
328
329* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
330- new upstream release
331
332* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
333- new upstream release
334
335* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
336- new upstream release
337
338* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
339- rebuild with attica-0.4.1
340
341* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
342- new upstream release
343- remove Patch3 (kdebase-runtime-4.6.90-iconthemes-inherit.patch)
344- add BuildRequires: kactivities-devel, nupomuk-core-devel, qca2-devel
345
346* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-4
347- rebuild with exiv2-0.23
348
349* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-3
350- rebuild with exiv2-0.22
351
352* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-2
353- rebuilt without libqzeitgeist
354
355* Tue Dec 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
356- new upstream release
357
358* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
359- new upstream release
360
361* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
362- new upstream release
363- built with exiv2-0.21.1
364
365* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
366- new upstream release
367
368* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
369- rebuilt with libsmbclient-3.5.8
370
371* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
372- new upstream release
373
374* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
375- added BR: libXpm-devel
376
377* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
378- new upstream release
379- added devel subpackage
380
381* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
382- new upstream release
383- updated summary
384- dropt Patch100
385
386* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
387- new upstream release
388- added Patch100 from Fedora
389  - backport to fix the freeze of kded on first use of the network:/kio-slave
390
391* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
392- new upstream release
393- added Conflicts: kdebase3 at Vine Linux 5
394
395* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
396- new upstream release
397
398* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
399- rebuilt with exiv2-0.19
400
401* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
402- new upstream release
403
404* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
405- new upstream release
406
407* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
408- new upstream release
409- built with new toolchain
410
411* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
412- new upstream release
413
414* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
415- new upstream release
416
417* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
418- new upstream release
419- used %%cmake macro
420
421* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
422- Initial build for Vine Linux
423
424* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
425- respin
426
427* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
428- 4.3.0
429
430* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
431- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
432
433* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
434- 4.3rc3
435
436* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
437- respin (soprano-2.3.0)
438- License: LGPLv2+
439
440* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
441- 4.3rc2
442
443* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
444- drop unneeded BR: ImageMagick (#509241)
445
446* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
447- don't start nepomuk server unconditionally (#487322)
448
449* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
450- 4.3rc1
451
452* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
453- KDE-4.3 beta2 (4.2.90)
454
455* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
456- Drop old Fedora < 8 conditionals
457
458* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
459- file conflicts with kdepim
460
461* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
462- KDE 4.3 beta 1
463
464* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
465- fix persistent systray notifications (#485796)
466
467* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
468- -flags subpkg
469- koji/noarch hacks dropped
470
471* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
472- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
473
474* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
475- KDE 4.2.2
476
477* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
478- flags subpkg (not enabled)
479- optimize scriptlets
480
481* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
482- fix PulseAudio cmake detection
483
484* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
485- 4.2.1
486
487* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
488- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
489
490* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
491- #486059 -  missing dependency on htdig
492
493* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
494- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
495
496* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
497- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
498
499* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
500- own %%_kde4_datadir/locale/l10n/
501
502* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
503- respun tarball
504
505* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
506- Files not trashed to the correct location in Dolphin/Konqueror
507  (#481598, kdebug#178479)
508- omit --with-samba crud
509
510* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
511- 4.2.0
512- +BR: pulseaudio-libs-devel xine-lib-devel
513- -BR: giflib-devel pcre-devel
514
515* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
516- tarball respin
517- drop extraneous deps (that are in kdelibs)
518
519* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
520- 4.2rc1
521
522* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
523- include %%_bindir/kdesu symlink
524
525* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
526- 4.2beta2
527
528* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
529- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
530  and should be in a -devel package if it gets shipped)
531
532* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
533- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
534
535* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
536- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
537
538* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
539- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
540
541* Wed Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
542- 4.1.80
543- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
544- BR cmake >= 2.6.2
545- Use 'make install/fast'
546- Drop subpkg phonon-backend-xine and related file entries: this has to be
547  part of phonon now that it moved there
548- Drop xine-lib-devel BR
549- Add libkwalletbackend to files list
550- Drop _default_patch_fuzz 2
551
552* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
553- apply upstream patch to fix X crash when disabling compositing
554
555* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
556- 4.1.3
557
558* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
559- apply upstream patch, kioexec processes never terminate
560
561* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
562- fix broken audio-backend-jack.svgz
563
564* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
565- add missing icons
566
567* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
568- make VERBOSE=1
569- respin against new(er) kde-filesystem
570- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
571
572* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
573- 4.1.2
574
575* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
576- fix inherit issue in iconthemes, preview icons
577  do not show
578
579* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
580- fix #460710, knetattach is kio_remote's wizard program, don't show
581  it in the menu.
582
583* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
584- 4.1.1
585
586* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
587- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
588
589* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
590- crash fix when stopping a service that is not yet initialized
591
592* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
593- don't remove autostart directory on F8- (does not conflict, fixes build
594  failure due to nepomukserver.desktop listed in filelist but not found)
595
596* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
597- 4.1.0
598
599* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
600- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
601
602* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
603- 4.0.99
604
605* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
606- respin
607
608* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
609- -phonon-backend-xine: new subpkg
610
611* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
612- 4.0.98
613
614* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
615- 4.0.85
616
617* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
618- 4.0.84
619
620* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
621- 4.0.83 (beta2)
622
623* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
624- 4.0.82
625
626* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
627- add searchproviders-shortcuts for redhat bugzilla
628
629* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
630- 4.1 beta 1
631
632* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
633- BR new minimum version of soprano-devel
634
635* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
636- update to 4.0.72 (4.1 alpha 1)
637- drop upstreamed deinterlace-crash patch
638- drop khelpcenter patch (fixed upstream)
639- update Phonon PulseAudio patch
640- drop Fedora 7 support
641- update file list
642
643* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
644- omit conflicting icons (kde3_desktop=1 case)
645
646* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
647- oxygen-icon-theme: build noarch
648
649* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
650- %%post/%%postun: hicolor icon theme scriptlets
651
652* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
653- only omit hicolor index.theme (#439374)
654
655* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
656- fix khelpcenter, search plugins/settings in correct path (#443016)
657
658* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
659- respin (at f13's request)
660
661* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
662- pulseaudio patch (use as default, if available)
663
664* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
665- don't crash if we don't have deinterlacing support in xine-lib (#440299)
666
667* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
668- rebuild for the new %%{_kde4_buildtype}
669
670* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
671- update file list for _kde4_libexecdir
672
673* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
674- 4.0.3
675
676* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
677- don't own %%_kde4_docdir/HTML/en/
678
679* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
680- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
681- include noarch build hooks (not enabled)
682
683* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
684- BR libxcb-devel everywhere (including F7)
685
686* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
687- if building for a KDE 4 desktop, include the khelpcenter.desktop service
688  description for KDE 3 here so help works in KDE 3 apps
689
690* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
691- 4.0.2
692
693* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
694- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
695
696* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
697- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
698  (kio_smb itself is already GPLv2+)
699
700* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
701- 4.0.1
702
703* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
704- respun tarball
705
706* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
707- update to 4.0.0
708- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
709
710* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
711- kde-3.97.0
712
713* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
714- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
715
716* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
717- build without libxcb in F7 as we STILL don't have it (see #373361)
718
719* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
720- no longer set kde3_desktop on F9
721- update file list for !kde3_desktop (Sebastian Vahl)
722- don't ship country flags even for full version (as in kdebase 3)
723
724* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
725- kde-3.96.2
726
727* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
728- kde-3.96.1
729
730* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
731- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
732
733* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
734- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
735
736* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
737- kde-3.96.0
738
739* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
740- kdebase-runtime-3.95.2
741
742* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
743- kdebase-runtime-3.95.0
744
745* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
746- Provides: oxygen-icon-theme ...
747
748* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
749- patch dolphin.desktop to get Dolphin to start from the menu
750
751* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
752- update to 3.94.0
753
754* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
755- don't make this the default kdebase on F9 yet
756- drop ExcludeArch: ppc64 (#300601)
757
758* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
759- ExcludeArch: ppc64 (#300601)
760- update description
761
762* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
763- add missing BR alsa-lib-devel
764
765* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
766- remove files which conflict with KDE 3
767- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
768- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
769
770* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
771- update to 3.93.0
772- drop kde4home patch (no longer applied)
773- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
774- remove kdebase-kdm Obsoletes/Provides (for the same reason)
775- remove KDM (and KDM session) setup code (for the same reason)
776- remove rss-glx conflict (Plasma is now in kdebase-workspace)
777- remove redhat-startkde patch (startkde is now in kdebase-workspace)
778- remove kde4-opt.sh (all the code in it is commented out)
779- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
780- remove bogus BRs on automake and libtool
781- remove workspace-only BRs
782- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
783- remove workspace files and directories
784- handle icons (moved from kdelibs4)
785- add mkdir %%{buildroot} in %%install
786
787* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
788- use macros.kde4
789- License: GPLv2
790
791* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
792- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
793- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
794- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
795
796* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
797- consolekit_kdm patch (#228111, kde#147790)
798- update startkde patch
799
800* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
801- kde-3.92 (kde-4-beta1)
802
803* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
804- fix startkde
805- add env/shutdown directory
806
807* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
808- kde4.desktop: fix session Name
809
810* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
811- cleanup/fix kde4.desktop
812- kdepimlibs4->kdepimlibs
813
814* Fri Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
815- fix %%_sysconfdir for %%_prefix != /usr case.
816
817* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
818- updated kde4home.diff
819- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
820
821* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
822- kde-3.91.0
823- CMAKE_BUILD_TYPE=debug
824
825* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
826- specfile cleanup (%%prefix issues mostly)
827
828* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
829- update to 3.90.1
830- bump cmake BR to 2.4.5 as required upstream now
831- don't set execute bits by hand anymore, cmake has been fixed
832- use multilibs in /opt/kde4
833- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
834- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
835  in case we want to drop the Rs on these from kdelibs4-devel
836- consistently add all BRs as -devel Rs, not just almost all, until we can
837  figure out which, if any, are really needed
838- BR libsmbclient-devel instead of samba on F>=7, EL>=6
839
840* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
841- restore minimum version requirement for cmake
842- build against libxklavier on EL5
843- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
844
845* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
846- +eXecute perms for %%{_prefix}/lib/*
847
848* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
849- rebuild for patched FindKDE4Internal.cmake
850
851* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
852- update to 3.80.3
853- update and improve parallel-installability patch
854- drop obsolete joydevice.h patch
855- remove translations of "KDE" without the "4" from kde4.desktop
856- resync BR and -devel Requires
857- don't set LD_LIBRARY_PATH
858- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
859- fix missing underscore in _datadir
860- install kde4.desktop in install, not prep
861- fix invalid syntax in kde4.desktop
862
863* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
864- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
865- compiling with QA_RPATHS=0x0003; export QA_RPATHS
866
867* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
868- parallel build support
869- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
870- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
871- spec file cleanups and added clean up in %%install
872- fixed PATH for libkdecore.so.5; cannot open shared object file;
873- added Logitech mouse support
874- added dbus-devel, hal-devel and more as BR
875- fixed broken joydevice.h - Kevin Kofler
876- added file kde4.desktop
877
878* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
879- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
880- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.