source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 8084

Revision 8084, 28.5 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.11.4
7Release:       2%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.xz
15
16# add shortcuts for search provider
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18
19# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
20Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
21
22# correct path for htsearch
23Patch7:        kdebase-runtime-4.5.3-htsearch.patch
24
25# Launch compiz via compiz-manager so we get window decorations and
26# other such decadent luxuries (AdamW 2011/01)
27Patch8:        kdebase-runtime-4.5.95-compiz.patch
28
29# add overrides in default manpath
30Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
31
32## upstreamable patches
33# make installdbgsymbols.sh use pkexec instead of su
34# increase some timeouts in an effort to see (some) errors before close
35Patch51: kde-runtime-4.9.0-installdbgsymbols.patch
36
37## upstream patches
38
39
40Provides:  kdebase4-runtime = %{version}-%{release}
41Provides:  kde-runtime = %{version}-%{release}
42Obsoletes: kdebase4-runtime < %{version}-%{release}
43
44Obsoletes: nepomukcontroller
45Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
46
47# knotify4 provides dbus service org.freedesktop.Notifications too
48Provides: desktop-notification-daemon
49
50BuildRoot:     %{_tmppath}/%{name}-%{version}-root
51BuildRequires: alsa-lib-devel
52BuildRequires: attica-devel >= 0.1.4
53BuildRequires: bzip2-devel
54BuildRequires: chrpath
55BuildRequires: clucene-core-devel
56BuildRequires: doxygen
57BuildRequires: exiv2-devel >= 0.12
58BuildRequires: glib2-devel
59BuildRequires: kdelibs4-devel >= %{version}
60BuildRequires: kdepimlibs-devel >= %{version}
61BuildRequires: kactivities-devel >= %{version}
62BuildRequires: libcanberra-devel
63#BuildRequires: libqzeitgeist-devel
64BuildRequires: libsmbclient-devel
65BuildRequires: libssh-devel >= 0.4.2
66BuildRequires: libXpm-devel
67BuildRequires: libXScrnSaver-devel
68BuildRequires: NetworkManager-devel
69BuildRequires: nepomuk-core
70BuildRequires: nepomuk-core-devel
71BuildRequires: OpenEXR-devel
72BuildRequires: openslp-devel
73BuildRequires: openssl-devel
74BuildRequires: pkgconfig
75BuildRequires: polkit-qt-devel
76BuildRequires: pulseaudio-libs-devel
77BuildRequires: qca2-devel
78BuildRequires: qimageblitz-devel
79BuildRequires: shared-mime-info >= 0.40
80BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
81BuildRequires: soprano-devel >= 2.6.50
82BuildRequires: xine-lib-devel libxcb-devel
83BuildRequires: xorg-x11-font-utils
84BuildRequires: xorg-x11-proto-devel
85BuildRequires: xz-devel
86BuildRequires: zlib-devel
87
88Requires: eject
89Requires: %{name}-libs = %{version}-%{release}
90Requires: %{name}-flags = %{version}-%{release}
91# KHelpcenter requires htdig for building search indices
92Requires: htdig
93# ensure default/fallback icon theme present
94# beware of bootstrapping, there be dragons
95Requires: oxygen-icon-theme >= %{version}
96
97# some items moved -workspace -> -runtime
98Conflicts: kdebase-workspace < 4.5.80
99
100%description
101Core runtime for KDE 4.
102
103%description -l ja
104KDE 4 の中心となるランタイム部分です.
105
106%package devel
107Summary:  Developer files for %{name}
108Summary(ja): %{name} の開発用ファイル
109Group:    Development/Libraries
110Requires: %{name}-libs = %{version}-%{release}
111
112%description devel
113%{summary}.
114
115%description -l ja devel
116%{name} の開発用ファイルです.
117
118%package libs
119Summary: Runtime libraries for %{name}
120Summary(ja): %{name} のランタイムライブラリ
121Group:   System Environment/Libraries
122Requires: kdelibs4 >= %{version}
123Requires: kdepimlibs >= %{version}
124# cagibi is runtime dep, a dbus service
125Requires: cagibi
126
127%description libs
128%{summary}.
129
130%description -l ja libs
131%{name} のランタイムライブラリです.
132
133%package flags
134Summary: Geopolitical flags
135Group: User Interface/Desktops
136Requires: %{name}-libs = %{version}-%{release}
137BuildArch: noarch
138
139%description flags
140%{summary}.
141
142
143%prep
144%setup -q -n kde-runtime-%{version}
145
146%patch1 -p1 -b .searchproviders-shortcuts
147%patch6 -p1 -b .home_onlyshowin_kde
148%patch7 -p1 -b .htsearch
149%patch8 -p1 -b .config
150%patch9 -p1 -b .man-overrides
151%patch51 -p1 -b .installdgbsymbols
152
153
154%build
155mkdir -p %{_target_platform}
156pushd %{_target_platform}
157%cmake \
158    -DCMAKE_BUILD_TYPE=release \
159    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
160    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
161    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
162    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
163    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
164    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
165    ..
166popd
167
168make %{?_smp_mflags} -C %{_target_platform}
169
170
171%install
172rm -rf $RPM_BUILD_ROOT
173
174make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
175
176# kdesu symlink
177ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
178
179# omit hicolor index.theme, use one from hicolor-icon-theme
180rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
181
182# remove country flags because some people/countries forbid some other
183# people/countries' flags :-(
184%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
185
186# install this service for KDE 3 applications too
187mkdir $RPM_BUILD_ROOT%{_datadir}/services
188ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
189      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
190
191# FIXME: -devel type files, omit for now
192rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
193
194# rpaths
195# use chrpath hammer for now, find better patching solutions later -- Rex
196chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
197chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
198
199%clean
200rm -rf $RPM_BUILD_ROOT
201
202%post
203touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
204touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
205
206%posttrans
207gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
208gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
209update-desktop-database -q &> /dev/null ||:
210update-mime-database %{_datadir}/mime &> /dev/null
211
212%postun
213if [ $1 -eq 0 ] ; then
214    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
215    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
216    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
217    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
218    update-desktop-database -q &> /dev/null ||:
219    update-mime-database %{_datadir}/mime &> /dev/null
220fi
221
222%post libs -p /sbin/ldconfig
223%postun libs -p /sbin/ldconfig
224
225
226%files
227%defattr(-,root,root,-)
228%{_sysconfdir}/dbus-1/system.d/*
229%{_sysconfdir}/xdg/menus/kde-information.menu
230%{_bindir}/*
231# omit ksvgtopng which kdelibs3 includes
232%{_datadir}/kde4/apps/*
233%exclude %{_datadir}/kde4/apps/cmake/
234%{_datadir}/config/*.knsrc
235%{_datadir}/config.kcfg/
236%{_datadir}/dbus-1/interfaces/*
237%{_datadir}/dbus-1/services/*
238%{_datadir}/dbus-1/system-services/*
239%{_datadir}/icons/default.kde4
240%{_datadir}/kde4/services/*
241%{_datadir}/kde4/servicetypes/*
242%{_datadir}/mime/packages/network.xml
243%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
244%{_datadir}/sounds/*
245%{_libdir}/kconf_update_bin/*
246%{_libdir}/libkdeinit4_*.so
247%{_libdir}/kde4/kcm_*.so
248%{_libdir}/kde4/kded_*.so
249%{_libdir}/kde4/platformimports/touch/org/kde/plasma/*
250%{_libexecdir}/kde4/drkonqi
251#{_libexecdir}/kde4/installdbgsymbols.sh
252%{_libexecdir}/kde4/kcmremotewidgetshelper
253%{_libexecdir}/kde4/kdeeject
254%{_libexecdir}/kde4/kdesu
255%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
256%{_libexecdir}/kde4/kdontchangethehostname
257%{_libexecdir}/kde4/khc_docbookdig.pl
258%{_libexecdir}/kde4/khc_htdig.pl
259%{_libexecdir}/kde4/khc_htsearch.pl
260%{_libexecdir}/kde4/khc_indexbuilder
261%{_libexecdir}/kde4/khc_mansearch.pl
262%{_libexecdir}/kde4/kioexec
263%{_libexecdir}/kde4/knetattach
264%{_mandir}/man1/*
265%{_mandir}/man8/*
266%{_datadir}/icons/hicolor/*/*/*
267%{_docdir}/HTML/en/*
268%{_datadir}/applications/kde4/Help.desktop
269%{_datadir}/applications/kde4/knetattach.desktop
270%{_datadir}/config/kshorturifilterrc
271%{_datadir}/desktop-directories/*.directory
272%{_datadir}/emoticons/kde4/
273%{_datadir}/locale/l10n/
274%{_datadir}/locale/currency/
275%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
276%{_datadir}/services/khelpcenter.desktop
277
278%files devel
279%defattr(-,root,root,-)
280%{_includedir}/*
281%{_datadir}/kde4/apps/cmake/modules/*.cmake
282
283%files libs
284%defattr(-,root,root,-)
285%{_libdir}/attica_kde.so
286%{_libdir}/libknotifyplugin.so
287%{_libdir}/libkwalletbackend.so.*
288%{_libdir}/libmolletnetwork.so.*
289%{_libdir}/kde4/*.so
290%{_libdir}/kde4/imports/
291# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
292%exclude %{_libdir}/kde4/kcm_*.so
293%exclude %{_libdir}/kde4/kded_*.so
294%{_libdir}/kde4/plugins/phonon_platform/
295
296%files flags
297%defattr(-,root,root,-)
298%{_datadir}/locale/l10n/*/flag.png
299
300
301%changelog
302* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-2
303- rebuild with ilmbase-2.1.0 & OpenEXR-2.1.0
304
305* Sun Dec 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
306- new upstream release
307
308* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
309- new upstream release
310- remove Patch50 (kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch)
311
312* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
313- new upstream release
314
315* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
316- new upstream release
317- add patches from fedora
318  - Patch50 (kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch)
319  - Patch51 (kde-runtime-4.9.0-installdbgsymbols.patch)
320
321* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
322- new upstream release
323
324* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
325- new upstream release
326
327* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
328- new upstream release
329
330* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
331- rebuild with attica-0.4.1
332
333* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
334- new upstream release
335- remove Patch3 (kdebase-runtime-4.6.90-iconthemes-inherit.patch)
336- add BuildRequires: kactivities-devel, nupomuk-core-devel, qca2-devel
337
338* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-4
339- rebuild with exiv2-0.23
340
341* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-3
342- rebuild with exiv2-0.22
343
344* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-2
345- rebuilt without libqzeitgeist
346
347* Tue Dec 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
348- new upstream release
349
350* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
351- new upstream release
352
353* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
354- new upstream release
355- built with exiv2-0.21.1
356
357* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
358- new upstream release
359
360* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
361- rebuilt with libsmbclient-3.5.8
362
363* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
364- new upstream release
365
366* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
367- added BR: libXpm-devel
368
369* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
370- new upstream release
371- added devel subpackage
372
373* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
374- new upstream release
375- updated summary
376- dropt Patch100
377
378* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
379- new upstream release
380- added Patch100 from Fedora
381  - backport to fix the freeze of kded on first use of the network:/kio-slave
382
383* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
384- new upstream release
385- added Conflicts: kdebase3 at Vine Linux 5
386
387* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
388- new upstream release
389
390* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
391- rebuilt with exiv2-0.19
392
393* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
394- new upstream release
395
396* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
397- new upstream release
398
399* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
400- new upstream release
401- built with new toolchain
402
403* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
404- new upstream release
405
406* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
407- new upstream release
408
409* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
410- new upstream release
411- used %%cmake macro
412
413* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
414- Initial build for Vine Linux
415
416* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
417- respin
418
419* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
420- 4.3.0
421
422* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
423- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
424
425* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
426- 4.3rc3
427
428* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
429- respin (soprano-2.3.0)
430- License: LGPLv2+
431
432* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
433- 4.3rc2
434
435* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
436- drop unneeded BR: ImageMagick (#509241)
437
438* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
439- don't start nepomuk server unconditionally (#487322)
440
441* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
442- 4.3rc1
443
444* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
445- KDE-4.3 beta2 (4.2.90)
446
447* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
448- Drop old Fedora < 8 conditionals
449
450* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
451- file conflicts with kdepim
452
453* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
454- KDE 4.3 beta 1
455
456* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
457- fix persistent systray notifications (#485796)
458
459* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
460- -flags subpkg
461- koji/noarch hacks dropped
462
463* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
464- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
465
466* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
467- KDE 4.2.2
468
469* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
470- flags subpkg (not enabled)
471- optimize scriptlets
472
473* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
474- fix PulseAudio cmake detection
475
476* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
477- 4.2.1
478
479* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
480- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
481
482* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
483- #486059 -  missing dependency on htdig
484
485* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
486- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
487
488* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
489- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
490
491* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
492- own %%_kde4_datadir/locale/l10n/
493
494* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
495- respun tarball
496
497* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
498- Files not trashed to the correct location in Dolphin/Konqueror
499  (#481598, kdebug#178479)
500- omit --with-samba crud
501
502* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
503- 4.2.0
504- +BR: pulseaudio-libs-devel xine-lib-devel
505- -BR: giflib-devel pcre-devel
506
507* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
508- tarball respin
509- drop extraneous deps (that are in kdelibs)
510
511* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
512- 4.2rc1
513
514* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
515- include %%_bindir/kdesu symlink
516
517* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
518- 4.2beta2
519
520* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
521- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
522  and should be in a -devel package if it gets shipped)
523
524* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
525- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
526
527* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
528- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
529
530* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
531- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
532
533* Wed Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
534- 4.1.80
535- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
536- BR cmake >= 2.6.2
537- Use 'make install/fast'
538- Drop subpkg phonon-backend-xine and related file entries: this has to be
539  part of phonon now that it moved there
540- Drop xine-lib-devel BR
541- Add libkwalletbackend to files list
542- Drop _default_patch_fuzz 2
543
544* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
545- apply upstream patch to fix X crash when disabling compositing
546
547* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
548- 4.1.3
549
550* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
551- apply upstream patch, kioexec processes never terminate
552
553* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
554- fix broken audio-backend-jack.svgz
555
556* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
557- add missing icons
558
559* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
560- make VERBOSE=1
561- respin against new(er) kde-filesystem
562- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
563
564* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
565- 4.1.2
566
567* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
568- fix inherit issue in iconthemes, preview icons
569  do not show
570
571* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
572- fix #460710, knetattach is kio_remote's wizard program, don't show
573  it in the menu.
574
575* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
576- 4.1.1
577
578* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
579- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
580
581* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
582- crash fix when stopping a service that is not yet initialized
583
584* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
585- don't remove autostart directory on F8- (does not conflict, fixes build
586  failure due to nepomukserver.desktop listed in filelist but not found)
587
588* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
589- 4.1.0
590
591* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
592- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
593
594* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
595- 4.0.99
596
597* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
598- respin
599
600* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
601- -phonon-backend-xine: new subpkg
602
603* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
604- 4.0.98
605
606* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
607- 4.0.85
608
609* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
610- 4.0.84
611
612* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
613- 4.0.83 (beta2)
614
615* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
616- 4.0.82
617
618* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
619- add searchproviders-shortcuts for redhat bugzilla
620
621* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
622- 4.1 beta 1
623
624* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
625- BR new minimum version of soprano-devel
626
627* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
628- update to 4.0.72 (4.1 alpha 1)
629- drop upstreamed deinterlace-crash patch
630- drop khelpcenter patch (fixed upstream)
631- update Phonon PulseAudio patch
632- drop Fedora 7 support
633- update file list
634
635* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
636- omit conflicting icons (kde3_desktop=1 case)
637
638* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
639- oxygen-icon-theme: build noarch
640
641* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
642- %%post/%%postun: hicolor icon theme scriptlets
643
644* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
645- only omit hicolor index.theme (#439374)
646
647* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
648- fix khelpcenter, search plugins/settings in correct path (#443016)
649
650* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
651- respin (at f13's request)
652
653* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
654- pulseaudio patch (use as default, if available)
655
656* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
657- don't crash if we don't have deinterlacing support in xine-lib (#440299)
658
659* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
660- rebuild for the new %%{_kde4_buildtype}
661
662* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
663- update file list for _kde4_libexecdir
664
665* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
666- 4.0.3
667
668* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
669- don't own %%_kde4_docdir/HTML/en/
670
671* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
672- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
673- include noarch build hooks (not enabled)
674
675* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
676- BR libxcb-devel everywhere (including F7)
677
678* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
679- if building for a KDE 4 desktop, include the khelpcenter.desktop service
680  description for KDE 3 here so help works in KDE 3 apps
681
682* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
683- 4.0.2
684
685* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
686- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
687
688* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
689- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
690  (kio_smb itself is already GPLv2+)
691
692* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
693- 4.0.1
694
695* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
696- respun tarball
697
698* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
699- update to 4.0.0
700- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
701
702* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
703- kde-3.97.0
704
705* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
706- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
707
708* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
709- build without libxcb in F7 as we STILL don't have it (see #373361)
710
711* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
712- no longer set kde3_desktop on F9
713- update file list for !kde3_desktop (Sebastian Vahl)
714- don't ship country flags even for full version (as in kdebase 3)
715
716* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
717- kde-3.96.2
718
719* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
720- kde-3.96.1
721
722* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
723- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
724
725* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
726- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
727
728* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
729- kde-3.96.0
730
731* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
732- kdebase-runtime-3.95.2
733
734* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
735- kdebase-runtime-3.95.0
736
737* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
738- Provides: oxygen-icon-theme ...
739
740* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
741- patch dolphin.desktop to get Dolphin to start from the menu
742
743* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
744- update to 3.94.0
745
746* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
747- don't make this the default kdebase on F9 yet
748- drop ExcludeArch: ppc64 (#300601)
749
750* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
751- ExcludeArch: ppc64 (#300601)
752- update description
753
754* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
755- add missing BR alsa-lib-devel
756
757* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
758- remove files which conflict with KDE 3
759- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
760- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
761
762* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
763- update to 3.93.0
764- drop kde4home patch (no longer applied)
765- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
766- remove kdebase-kdm Obsoletes/Provides (for the same reason)
767- remove KDM (and KDM session) setup code (for the same reason)
768- remove rss-glx conflict (Plasma is now in kdebase-workspace)
769- remove redhat-startkde patch (startkde is now in kdebase-workspace)
770- remove kde4-opt.sh (all the code in it is commented out)
771- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
772- remove bogus BRs on automake and libtool
773- remove workspace-only BRs
774- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
775- remove workspace files and directories
776- handle icons (moved from kdelibs4)
777- add mkdir %%{buildroot} in %%install
778
779* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
780- use macros.kde4
781- License: GPLv2
782
783* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
784- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
785- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
786- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
787
788* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
789- consolekit_kdm patch (#228111, kde#147790)
790- update startkde patch
791
792* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
793- kde-3.92 (kde-4-beta1)
794
795* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
796- fix startkde
797- add env/shutdown directory
798
799* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
800- kde4.desktop: fix session Name
801
802* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
803- cleanup/fix kde4.desktop
804- kdepimlibs4->kdepimlibs
805
806* Fri Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
807- fix %%_sysconfdir for %%_prefix != /usr case.
808
809* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
810- updated kde4home.diff
811- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
812
813* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
814- kde-3.91.0
815- CMAKE_BUILD_TYPE=debug
816
817* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
818- specfile cleanup (%%prefix issues mostly)
819
820* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
821- update to 3.90.1
822- bump cmake BR to 2.4.5 as required upstream now
823- don't set execute bits by hand anymore, cmake has been fixed
824- use multilibs in /opt/kde4
825- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
826- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
827  in case we want to drop the Rs on these from kdelibs4-devel
828- consistently add all BRs as -devel Rs, not just almost all, until we can
829  figure out which, if any, are really needed
830- BR libsmbclient-devel instead of samba on F>=7, EL>=6
831
832* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
833- restore minimum version requirement for cmake
834- build against libxklavier on EL5
835- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
836
837* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
838- +eXecute perms for %%{_prefix}/lib/*
839
840* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
841- rebuild for patched FindKDE4Internal.cmake
842
843* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
844- update to 3.80.3
845- update and improve parallel-installability patch
846- drop obsolete joydevice.h patch
847- remove translations of "KDE" without the "4" from kde4.desktop
848- resync BR and -devel Requires
849- don't set LD_LIBRARY_PATH
850- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
851- fix missing underscore in _datadir
852- install kde4.desktop in install, not prep
853- fix invalid syntax in kde4.desktop
854
855* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
856- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
857- compiling with QA_RPATHS=0x0003; export QA_RPATHS
858
859* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
860- parallel build support
861- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
862- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
863- spec file cleanups and added clean up in %%install
864- fixed PATH for libkdecore.so.5; cannot open shared object file;
865- added Logitech mouse support
866- added dbus-devel, hal-devel and more as BR
867- fixed broken joydevice.h - Kevin Kofler
868- added file kde4.desktop
869
870* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
871- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
872- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.