source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 5293

Revision 5293, 27.1 KB checked in by inagaki, 13 years ago (diff)

update: kdebase-runtime, kdelibs

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.7.4
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.bz2
15
16# add shortcuts for search provider
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18
19# make icontheme inherit working, https://bugs.kde.org/59901
20Patch3:        kdebase-runtime-4.6.90-iconthemes-inherit.patch
21
22# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
23Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
24
25# correct path for htsearch
26Patch7:        kdebase-runtime-4.5.3-htsearch.patch
27
28# Launch compiz via compiz-manager so we get window decorations and
29# other such decadent luxuries (AdamW 2011/01)
30Patch8:        kdebase-runtime-4.5.95-compiz.patch
31
32# add overrides in default manpath
33Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
34
35## upstream patches
36
37Provides:  kdebase4-runtime = %{version}-%{release}
38Provides:  kde-runtime = %{version}-%{release}
39Obsoletes: kdebase4-runtime < %{version}-%{release}
40
41Obsoletes: nepomukcontroller
42Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
43
44# knotify4 provides dbus service org.freedesktop.Notifications too
45Provides: desktop-notification-daemon
46
47BuildRoot:     %{_tmppath}/%{name}-%{version}-root
48BuildRequires: alsa-lib-devel
49BuildRequires: attica-devel >= 0.1.4
50BuildRequires: bzip2-devel
51BuildRequires: chrpath
52BuildRequires: clucene-core-devel
53BuildRequires: doxygen
54BuildRequires: exiv2-devel >= 0.12
55BuildRequires: glib2-devel
56BuildRequires: kdelibs4-devel >= %{version}
57BuildRequires: kdepimlibs-devel >= %{version}
58BuildRequires: libcanberra-devel
59BuildRequires: libqzeitgeist-devel
60BuildRequires: libsmbclient-devel
61BuildRequires: libssh-devel >= 0.4.2
62BuildRequires: libXpm-devel
63BuildRequires: libXScrnSaver-devel
64BuildRequires: NetworkManager-devel
65BuildRequires: OpenEXR-devel
66BuildRequires: openslp-devel
67BuildRequires: openssl-devel
68BuildRequires: pkgconfig
69BuildRequires: polkit-qt-devel
70BuildRequires: pulseaudio-libs-devel
71BuildRequires: qimageblitz-devel
72BuildRequires: shared-mime-info >= 0.40
73BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
74BuildRequires: soprano-devel >= 2.6.50
75BuildRequires: xine-lib-devel libxcb-devel
76BuildRequires: xorg-x11-font-utils
77BuildRequires: xorg-x11-proto-devel
78BuildRequires: xz-devel
79BuildRequires: zlib-devel
80
81Requires: eject
82Requires: %{name}-libs = %{version}-%{release}
83Requires: %{name}-flags = %{version}-%{release}
84# KHelpcenter requires htdig for building search indices
85Requires: htdig
86# ensure default/fallback icon theme present
87# beware of bootstrapping, there be dragons
88Requires: oxygen-icon-theme >= %{version}
89
90# some items moved -workspace -> -runtime
91Conflicts: kdebase-workspace < 4.5.80
92
93%description
94Core runtime for KDE 4.
95
96%description -l ja
97KDE 4 の中心となるランタイム部分です.
98
99%package devel
100Summary:  Developer files for %{name}
101Summary(ja): %{name} の開発用ファイル
102Group:    Development/Libraries
103Requires: %{name}-libs = %{version}-%{release}
104
105%description devel
106%{summary}.
107
108%description -l ja devel
109%{name} の開発用ファイルです.
110
111%package libs
112Summary: Runtime libraries for %{name}
113Summary(ja): %{name} のランタイムライブラリ
114Group:   System Environment/Libraries
115Requires: kdelibs4 >= %{version}
116Requires: kdepimlibs >= %{version}
117# cagibi is runtime dep, a dbus service
118Requires: cagibi
119
120%description libs
121%{summary}.
122
123%description -l ja libs
124%{name} のランタイムライブラリです.
125
126%package flags
127Summary: Geopolitical flags
128Group: User Interface/Desktops
129Requires: %{name}-libs = %{version}-%{release}
130BuildArch: noarch
131
132%description flags
133%{summary}.
134
135
136%prep
137%setup -q -n kde-runtime-%{version}
138
139%patch1 -p1 -b .searchproviders-shortcuts
140%patch3 -p1 -b .iconthemes-inherit
141%patch6 -p1 -b .home_onlyshowin_kde
142%patch7 -p1 -b .htsearch
143%patch8 -p1 -b .config
144%patch9 -p1 -b .man-overrides
145
146%build
147mkdir -p %{_target_platform}
148pushd %{_target_platform}
149unset QTDIR || : ; . /etc/profile.d/qt4.sh
150%cmake \
151    -DCMAKE_BUILD_TYPE=release \
152    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
153    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
154    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
155    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
156    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
157    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
158    ..
159popd
160
161make %{?_smp_mflags} -C %{_target_platform}
162
163
164%install
165rm -rf $RPM_BUILD_ROOT
166
167make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
168
169# kdesu symlink
170ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
171
172# omit hicolor index.theme, use one from hicolor-icon-theme
173rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
174
175# remove country flags because some people/countries forbid some other
176# people/countries' flags :-(
177%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
178
179# install this service for KDE 3 applications too
180mkdir $RPM_BUILD_ROOT%{_datadir}/services
181ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
182      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
183
184# FIXME: -devel type files, omit for now
185rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
186
187# rpaths
188# use chrpath hammer for now, find better patching solutions later -- Rex
189chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
190chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
191
192%clean
193rm -rf $RPM_BUILD_ROOT
194
195%post
196touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
197touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
198
199%posttrans
200gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
201gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
202update-desktop-database -q &> /dev/null ||:
203update-mime-database %{_datadir}/mime &> /dev/null
204
205%postun
206if [ $1 -eq 0 ] ; then
207    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
208    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
209    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
210    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
211    update-desktop-database -q &> /dev/null ||:
212    update-mime-database %{_datadir}/mime &> /dev/null
213fi
214
215%post libs -p /sbin/ldconfig
216%postun libs -p /sbin/ldconfig
217
218
219%files
220%defattr(-,root,root,-)
221%{_sysconfdir}/dbus-1/system.d/*
222%{_sysconfdir}/xdg/menus/kde-information.menu
223%{_bindir}/*
224# omit ksvgtopng which kdelibs3 includes
225%if %{?_dist_release} == "vl5"
226%exclude %{_bindir}/ksvgtopng
227%endif
228%{_datadir}/kde4/apps/*
229%exclude %{_datadir}/kde4/apps/cmake/
230%{_datadir}/config/*.knsrc
231%{_datadir}/autostart/nepomukcontroller.desktop
232%{_datadir}/autostart/nepomukserver.desktop
233%{_datadir}/config.kcfg/
234%{_datadir}/dbus-1/interfaces/*
235%{_datadir}/dbus-1/services/*
236%{_datadir}/dbus-1/system-services/*
237%{_datadir}/icons/default.kde4
238%{_datadir}/kde4/services/*
239%{_datadir}/kde4/servicetypes/*
240%{_datadir}/mime/packages/network.xml
241%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
242%{_datadir}/sounds/*
243%{_libdir}/kconf_update_bin/*
244%{_libdir}/libkdeinit4_*.so
245%{_libdir}/kde4/kcm_*.so
246%{_libdir}/kde4/kded_*.so
247%{_libexecdir}/kde4/drkonqi
248#{_libexecdir}/kde4/installdbgsymbols.sh
249%{_libexecdir}/kde4/kcmremotewidgetshelper
250%{_libexecdir}/kde4/kdeeject
251%{_libexecdir}/kde4/kdesu
252%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
253%{_libexecdir}/kde4/kdontchangethehostname
254%{_libexecdir}/kde4/khc_docbookdig.pl
255%{_libexecdir}/kde4/khc_htdig.pl
256%{_libexecdir}/kde4/khc_htsearch.pl
257%{_libexecdir}/kde4/khc_indexbuilder
258%{_libexecdir}/kde4/khc_mansearch.pl
259%{_libexecdir}/kde4/kioexec
260%{_libexecdir}/kde4/knetattach
261%{_mandir}/man1/*
262%{_mandir}/man8/*
263%{_datadir}/icons/hicolor/*/*/*
264%{_docdir}/HTML/en/*
265%{_datadir}/applications/kde4/Help.desktop
266%{_datadir}/applications/kde4/knetattach.desktop
267%{_datadir}/applications/kde4/nepomukbackup.desktop
268%{_datadir}/applications/kde4/nepomukcontroller.desktop
269%{_datadir}/config/kshorturifilterrc
270%{_datadir}/desktop-directories/*.directory
271%{_datadir}/emoticons/kde4/
272%{_datadir}/locale/l10n/
273%{_datadir}/locale/currency/
274%{_datadir}/ontology/kde/
275%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
276%{_datadir}/services/khelpcenter.desktop
277
278%files devel
279%defattr(-,root,root,-)
280%{_includedir}/*
281%{_libdir}/libnepomuksync.so
282%{_datadir}/kde4/apps/cmake/modules/*.cmake
283
284%files libs
285%defattr(-,root,root,-)
286%{_libdir}/attica_kde.so
287%{_libdir}/libknotifyplugin.so
288%{_libdir}/libkwalletbackend.so.*
289%{_libdir}/libmolletnetwork.so.*
290%{_libdir}/libnepomukcommon.so
291%{_libdir}/libnepomukdatamanagement.so
292%{_libdir}/libnepomuksync.so.*
293%{_libdir}/kde4/*.so
294%{_libdir}/kde4/imports/
295# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
296%exclude %{_libdir}/kde4/kcm_*.so
297%exclude %{_libdir}/kde4/kded_*.so
298%{_libdir}/kde4/plugins/phonon_platform/
299
300%files flags
301%defattr(-,root,root,-)
302%{_datadir}/locale/l10n/*/flag.png
303
304
305%changelog
306* Tue Dec 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
307- new upstream release
308
309* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
310- new upstream release
311
312* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
313- new upstream release
314- built with exiv2-0.21.1
315
316* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
317- new upstream release
318
319* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
320- rebuilt with libsmbclient-3.5.8
321
322* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
323- new upstream release
324
325* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
326- added BR: libXpm-devel
327
328* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
329- new upstream release
330- added devel subpackage
331
332* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
333- new upstream release
334- updated summary
335- dropt Patch100
336
337* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
338- new upstream release
339- added Patch100 from Fedora
340  - backport to fix the freeze of kded on first use of the network:/kio-slave
341
342* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
343- new upstream release
344- added Conflicts: kdebase3 at Vine Linux 5
345
346* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
347- new upstream release
348
349* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
350- rebuilt with exiv2-0.19
351
352* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
353- new upstream release
354
355* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
356- new upstream release
357
358* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
359- new upstream release
360- built with new toolchain
361
362* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
363- new upstream release
364
365* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
366- new upstream release
367
368* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
369- new upstream release
370- used %%cmake macro
371
372* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
373- Initial build for Vine Linux
374
375* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
376- respin
377
378* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
379- 4.3.0
380
381* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
382- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
383
384* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
385- 4.3rc3
386
387* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
388- respin (soprano-2.3.0)
389- License: LGPLv2+
390
391* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
392- 4.3rc2
393
394* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
395- drop unneeded BR: ImageMagick (#509241)
396
397* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
398- don't start nepomuk server unconditionally (#487322)
399
400* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
401- 4.3rc1
402
403* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
404- KDE-4.3 beta2 (4.2.90)
405
406* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
407- Drop old Fedora < 8 conditionals
408
409* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
410- file conflicts with kdepim
411
412* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
413- KDE 4.3 beta 1
414
415* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
416- fix persistent systray notifications (#485796)
417
418* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
419- -flags subpkg
420- koji/noarch hacks dropped
421
422* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
423- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
424
425* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
426- KDE 4.2.2
427
428* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
429- flags subpkg (not enabled)
430- optimize scriptlets
431
432* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
433- fix PulseAudio cmake detection
434
435* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
436- 4.2.1
437
438* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
439- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
440
441* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
442- #486059 -  missing dependency on htdig
443
444* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
445- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
446
447* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
448- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
449
450* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
451- own %%_kde4_datadir/locale/l10n/
452
453* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
454- respun tarball
455
456* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
457- Files not trashed to the correct location in Dolphin/Konqueror
458  (#481598, kdebug#178479)
459- omit --with-samba crud
460
461* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
462- 4.2.0
463- +BR: pulseaudio-libs-devel xine-lib-devel
464- -BR: giflib-devel pcre-devel
465
466* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
467- tarball respin
468- drop extraneous deps (that are in kdelibs)
469
470* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
471- 4.2rc1
472
473* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
474- include %%_bindir/kdesu symlink
475
476* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
477- 4.2beta2
478
479* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
480- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
481  and should be in a -devel package if it gets shipped)
482
483* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
484- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
485
486* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
487- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
488
489* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
490- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
491
492* Fri Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
493- 4.1.80
494- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
495- BR cmake >= 2.6.2
496- Use 'make install/fast'
497- Drop subpkg phonon-backend-xine and related file entries: this has to be
498  part of phonon now that it moved there
499- Drop xine-lib-devel BR
500- Add libkwalletbackend to files list
501- Drop _default_patch_fuzz 2
502
503* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
504- apply upstream patch to fix X crash when disabling compositing
505
506* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
507- 4.1.3
508
509* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
510- apply upstream patch, kioexec processes never terminate
511
512* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
513- fix broken audio-backend-jack.svgz
514
515* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
516- add missing icons
517
518* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
519- make VERBOSE=1
520- respin against new(er) kde-filesystem
521- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
522
523* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
524- 4.1.2
525
526* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
527- fix inherit issue in iconthemes, preview icons
528  do not show
529
530* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
531- fix #460710, knetattach is kio_remote's wizard program, don't show
532  it in the menu.
533
534* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
535- 4.1.1
536
537* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
538- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
539
540* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
541- crash fix when stopping a service that is not yet initialized
542
543* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
544- don't remove autostart directory on F8- (does not conflict, fixes build
545  failure due to nepomukserver.desktop listed in filelist but not found)
546
547* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
548- 4.1.0
549
550* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
551- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
552
553* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
554- 4.0.99
555
556* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
557- respin
558
559* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
560- -phonon-backend-xine: new subpkg
561
562* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
563- 4.0.98
564
565* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
566- 4.0.85
567
568* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
569- 4.0.84
570
571* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
572- 4.0.83 (beta2)
573
574* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
575- 4.0.82
576
577* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
578- add searchproviders-shortcuts for redhat bugzilla
579
580* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
581- 4.1 beta 1
582
583* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
584- BR new minimum version of soprano-devel
585
586* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
587- update to 4.0.72 (4.1 alpha 1)
588- drop upstreamed deinterlace-crash patch
589- drop khelpcenter patch (fixed upstream)
590- update Phonon PulseAudio patch
591- drop Fedora 7 support
592- update file list
593
594* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
595- omit conflicting icons (kde3_desktop=1 case)
596
597* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
598- oxygen-icon-theme: build noarch
599
600* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
601- %%post/%%postun: hicolor icon theme scriptlets
602
603* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
604- only omit hicolor index.theme (#439374)
605
606* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
607- fix khelpcenter, search plugins/settings in correct path (#443016)
608
609* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
610- respin (at f13's request)
611
612* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
613- pulseaudio patch (use as default, if available)
614
615* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
616- don't crash if we don't have deinterlacing support in xine-lib (#440299)
617
618* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
619- rebuild for the new %%{_kde4_buildtype}
620
621* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
622- update file list for _kde4_libexecdir
623
624* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
625- 4.0.3
626
627* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
628- don't own %%_kde4_docdir/HTML/en/
629
630* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
631- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
632- include noarch build hooks (not enabled)
633
634* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
635- BR libxcb-devel everywhere (including F7)
636
637* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
638- if building for a KDE 4 desktop, include the khelpcenter.desktop service
639  description for KDE 3 here so help works in KDE 3 apps
640
641* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
642- 4.0.2
643
644* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
645- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
646
647* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
648- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
649  (kio_smb itself is already GPLv2+)
650
651* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
652- 4.0.1
653
654* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
655- respun tarball
656
657* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
658- update to 4.0.0
659- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
660
661* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
662- kde-3.97.0
663
664* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
665- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
666
667* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
668- build without libxcb in F7 as we STILL don't have it (see #373361)
669
670* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
671- no longer set kde3_desktop on F9
672- update file list for !kde3_desktop (Sebastian Vahl)
673- don't ship country flags even for full version (as in kdebase 3)
674
675* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
676- kde-3.96.2
677
678* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
679- kde-3.96.1
680
681* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
682- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
683
684* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
685- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
686
687* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
688- kde-3.96.0
689
690* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
691- kdebase-runtime-3.95.2
692
693* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
694- kdebase-runtime-3.95.0
695
696* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
697- Provides: oxygen-icon-theme ...
698
699* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
700- patch dolphin.desktop to get Dolphin to start from the menu
701
702* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
703- update to 3.94.0
704
705* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
706- don't make this the default kdebase on F9 yet
707- drop ExcludeArch: ppc64 (#300601)
708
709* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
710- ExcludeArch: ppc64 (#300601)
711- update description
712
713* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
714- add missing BR alsa-lib-devel
715
716* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
717- remove files which conflict with KDE 3
718- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
719- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
720
721* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
722- update to 3.93.0
723- drop kde4home patch (no longer applied)
724- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
725- remove kdebase-kdm Obsoletes/Provides (for the same reason)
726- remove KDM (and KDM session) setup code (for the same reason)
727- remove rss-glx conflict (Plasma is now in kdebase-workspace)
728- remove redhat-startkde patch (startkde is now in kdebase-workspace)
729- remove kde4-opt.sh (all the code in it is commented out)
730- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
731- remove bogus BRs on automake and libtool
732- remove workspace-only BRs
733- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
734- remove workspace files and directories
735- handle icons (moved from kdelibs4)
736- add mkdir %%{buildroot} in %%install
737
738* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
739- use macros.kde4
740- License: GPLv2
741
742* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
743- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
744- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
745- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
746
747* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
748- consolekit_kdm patch (#228111, kde#147790)
749- update startkde patch
750
751* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
752- kde-3.92 (kde-4-beta1)
753
754* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
755- fix startkde
756- add env/shutdown directory
757
758* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
759- kde4.desktop: fix session Name
760
761* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
762- cleanup/fix kde4.desktop
763- kdepimlibs4->kdepimlibs
764
765* Thu Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
766- fix %%_sysconfdir for %%_prefix != /usr case.
767
768* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
769- updated kde4home.diff
770- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
771
772* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
773- kde-3.91.0
774- CMAKE_BUILD_TYPE=debug
775
776* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
777- specfile cleanup (%%prefix issues mostly)
778
779* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
780- update to 3.90.1
781- bump cmake BR to 2.4.5 as required upstream now
782- don't set execute bits by hand anymore, cmake has been fixed
783- use multilibs in /opt/kde4
784- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
785- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
786  in case we want to drop the Rs on these from kdelibs4-devel
787- consistently add all BRs as -devel Rs, not just almost all, until we can
788  figure out which, if any, are really needed
789- BR libsmbclient-devel instead of samba on F>=7, EL>=6
790
791* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
792- restore minimum version requirement for cmake
793- build against libxklavier on EL5
794- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
795
796* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
797- +eXecute perms for %%{_prefix}/lib/*
798
799* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
800- rebuild for patched FindKDE4Internal.cmake
801
802* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
803- update to 3.80.3
804- update and improve parallel-installability patch
805- drop obsolete joydevice.h patch
806- remove translations of "KDE" without the "4" from kde4.desktop
807- resync BR and -devel Requires
808- don't set LD_LIBRARY_PATH
809- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
810- fix missing underscore in _datadir
811- install kde4.desktop in install, not prep
812- fix invalid syntax in kde4.desktop
813
814* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
815- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
816- compiling with QA_RPATHS=0x0003; export QA_RPATHS
817
818* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
819- parallel build support
820- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
821- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
822- spec file cleanups and added clean up in %%install
823- fixed PATH for libkdecore.so.5; cannot open shared object file;
824- added Logitech mouse support
825- added dbus-devel, hal-devel and more as BR
826- fixed broken joydevice.h - Kevin Kofler
827- added file kde4.desktop
828
829* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
830- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
831- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.