source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 5040

Revision 5040, 27.1 KB checked in by inagaki, 13 years ago (diff)

update: kdelibs, kdebase-runtime

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.7.2
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.bz2
15
16# add shortcuts for search provider
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18
19# make icontheme inherit working, https://bugs.kde.org/59901
20Patch3:        kdebase-runtime-4.6.90-iconthemes-inherit.patch
21
22# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
23Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
24
25# correct path for htsearch
26Patch7:        kdebase-runtime-4.5.3-htsearch.patch
27
28# Launch compiz via compiz-manager so we get window decorations and
29# other such decadent luxuries (AdamW 2011/01)
30Patch8:        kdebase-runtime-4.5.95-compiz.patch
31
32# add overrides in default manpath
33Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
34
35## upstream patches
36
37Provides:  kdebase4-runtime = %{version}-%{release}
38Provides:  kde-runtime = %{version}-%{release}
39Obsoletes: kdebase4-runtime < %{version}-%{release}
40
41Obsoletes: nepomukcontroller
42Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
43
44# knotify4 provides dbus service org.freedesktop.Notifications too
45Provides: desktop-notification-daemon
46
47BuildRoot:     %{_tmppath}/%{name}-%{version}-root
48BuildRequires: alsa-lib-devel
49BuildRequires: attica-devel >= 0.1.4
50BuildRequires: bzip2-devel
51BuildRequires: chrpath
52BuildRequires: clucene-core-devel
53BuildRequires: doxygen
54BuildRequires: exiv2-devel >= 0.12
55BuildRequires: glib2-devel
56BuildRequires: kdelibs4-devel >= %{version}
57BuildRequires: kdepimlibs-devel >= %{version}
58BuildRequires: libcanberra-devel
59BuildRequires: libqzeitgeist-devel
60BuildRequires: libsmbclient-devel
61BuildRequires: libssh-devel >= 0.4.2
62BuildRequires: libXpm-devel
63BuildRequires: libXScrnSaver-devel
64BuildRequires: NetworkManager-devel
65BuildRequires: OpenEXR-devel
66BuildRequires: openslp-devel
67BuildRequires: openssl-devel
68BuildRequires: pkgconfig
69BuildRequires: polkit-qt-devel
70BuildRequires: pulseaudio-libs-devel
71BuildRequires: qimageblitz-devel
72BuildRequires: shared-mime-info >= 0.40
73BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
74BuildRequires: soprano-devel >= 2.6.50
75BuildRequires: xine-lib-devel libxcb-devel
76BuildRequires: xorg-x11-font-utils
77BuildRequires: xorg-x11-proto-devel
78BuildRequires: xz-devel
79BuildRequires: zlib-devel
80
81Requires: eject
82Requires: %{name}-libs = %{version}-%{release}
83Requires: %{name}-flags = %{version}-%{release}
84# KHelpcenter requires htdig for building search indices
85Requires: htdig
86# ensure default/fallback icon theme present
87# beware of bootstrapping, there be dragons
88Requires: oxygen-icon-theme >= %{version}
89
90# some items moved -workspace -> -runtime
91Conflicts: kdebase-workspace < 4.5.80
92
93%description
94Core runtime for KDE 4.
95
96%description -l ja
97KDE 4 の中心となるランタイム部分です.
98
99%package devel
100Summary:  Developer files for %{name}
101Summary(ja): %{name} の開発用ファイル
102Group:    Development/Libraries
103Requires: %{name}-libs = %{version}-%{release}
104
105%description devel
106%{summary}.
107
108%description -l ja devel
109%{name} の開発用ファイルです.
110
111%package libs
112Summary: Runtime libraries for %{name}
113Summary(ja): %{name} のランタイムライブラリ
114Group:   System Environment/Libraries
115Requires: kdelibs4 >= %{version}
116Requires: kdepimlibs >= %{version}
117# cagibi is runtime dep, a dbus service
118Requires: cagibi
119
120%description libs
121%{summary}.
122
123%description -l ja libs
124%{name} のランタイムライブラリです.
125
126%package flags
127Summary: Geopolitical flags
128Group: User Interface/Desktops
129Requires: %{name}-libs = %{version}-%{release}
130BuildArch: noarch
131
132%description flags
133%{summary}.
134
135
136%prep
137%setup -q -n kde-runtime-%{version}
138
139%patch1 -p1 -b .searchproviders-shortcuts
140%patch3 -p1 -b .iconthemes-inherit
141%patch6 -p1 -b .home_onlyshowin_kde
142%patch7 -p1 -b .htsearch
143%patch8 -p1 -b .config
144%patch9 -p1 -b .man-overrides
145
146%build
147mkdir -p %{_target_platform}
148pushd %{_target_platform}
149unset QTDIR || : ; . /etc/profile.d/qt4.sh
150%cmake \
151    -DCMAKE_BUILD_TYPE=release \
152    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
153    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
154    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
155    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
156    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
157    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
158    ..
159popd
160
161make %{?_smp_mflags} -C %{_target_platform}
162
163
164%install
165rm -rf $RPM_BUILD_ROOT
166
167make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
168
169# kdesu symlink
170ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
171
172# omit hicolor index.theme, use one from hicolor-icon-theme
173rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
174
175# remove country flags because some people/countries forbid some other
176# people/countries' flags :-(
177%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
178
179# install this service for KDE 3 applications too
180mkdir $RPM_BUILD_ROOT%{_datadir}/services
181ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
182      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
183
184# FIXME: -devel type files, omit for now
185rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
186
187# rpaths
188# use chrpath hammer for now, find better patching solutions later -- Rex
189chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
190chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
191
192%clean
193rm -rf $RPM_BUILD_ROOT
194
195%post
196touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
197touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
198
199%posttrans
200gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
201gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
202update-desktop-database -q &> /dev/null ||:
203update-mime-database %{_datadir}/mime &> /dev/null
204
205%postun
206if [ $1 -eq 0 ] ; then
207    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
208    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
209    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
210    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
211    update-desktop-database -q &> /dev/null ||:
212    update-mime-database %{_datadir}/mime &> /dev/null
213fi
214
215%post libs -p /sbin/ldconfig
216%postun libs -p /sbin/ldconfig
217
218
219%files
220%defattr(-,root,root,-)
221%{_sysconfdir}/dbus-1/system.d/*
222%{_sysconfdir}/xdg/menus/kde-information.menu
223%{_bindir}/*
224# omit ksvgtopng which kdelibs3 includes
225%if %{?_dist_release} == "vl5"
226%exclude %{_bindir}/ksvgtopng
227%endif
228%{_datadir}/kde4/apps/*
229%exclude %{_datadir}/kde4/apps/cmake/
230%{_datadir}/config/*.knsrc
231%{_datadir}/autostart/nepomukcontroller.desktop
232%{_datadir}/autostart/nepomukserver.desktop
233%{_datadir}/config.kcfg/
234%{_datadir}/dbus-1/interfaces/*
235%{_datadir}/dbus-1/services/*
236%{_datadir}/dbus-1/system-services/*
237%{_datadir}/icons/default.kde4
238%{_datadir}/kde4/services/*
239%{_datadir}/kde4/servicetypes/*
240%{_datadir}/mime/packages/network.xml
241%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
242%{_datadir}/sounds/*
243%{_libdir}/kconf_update_bin/*
244%{_libdir}/libkdeinit4_*.so
245%{_libdir}/kde4/kcm_*.so
246%{_libdir}/kde4/kded_*.so
247%{_libexecdir}/kde4/drkonqi
248#{_libexecdir}/kde4/installdbgsymbols.sh
249%{_libexecdir}/kde4/kcmremotewidgetshelper
250%{_libexecdir}/kde4/kdeeject
251%{_libexecdir}/kde4/kdesu
252%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
253%{_libexecdir}/kde4/kdontchangethehostname
254%{_libexecdir}/kde4/khc_docbookdig.pl
255%{_libexecdir}/kde4/khc_htdig.pl
256%{_libexecdir}/kde4/khc_htsearch.pl
257%{_libexecdir}/kde4/khc_indexbuilder
258%{_libexecdir}/kde4/khc_mansearch.pl
259%{_libexecdir}/kde4/kioexec
260%{_libexecdir}/kde4/knetattach
261%{_mandir}/man1/*
262%{_mandir}/man8/*
263%{_datadir}/icons/hicolor/*/*/*
264%{_docdir}/HTML/en/*
265%{_datadir}/applications/kde4/Help.desktop
266%{_datadir}/applications/kde4/knetattach.desktop
267%{_datadir}/applications/kde4/nepomukbackup.desktop
268%{_datadir}/applications/kde4/nepomukcontroller.desktop
269%{_datadir}/config/kshorturifilterrc
270%{_datadir}/desktop-directories/*.directory
271%{_datadir}/emoticons/kde4/
272%{_datadir}/locale/l10n/
273%{_datadir}/locale/currency/
274%{_datadir}/ontology/kde/
275%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
276%{_datadir}/services/khelpcenter.desktop
277
278%files devel
279%defattr(-,root,root,-)
280%{_includedir}/*
281%{_libdir}/libnepomuksync.so
282%{_datadir}/kde4/apps/cmake/modules/*.cmake
283
284%files libs
285%defattr(-,root,root,-)
286%{_libdir}/attica_kde.so
287%{_libdir}/libknotifyplugin.so
288%{_libdir}/libkwalletbackend.so.*
289%{_libdir}/libmolletnetwork.so.*
290%{_libdir}/libnepomukcommon.so
291%{_libdir}/libnepomukdatamanagement.so
292%{_libdir}/libnepomuksync.so.*
293%{_libdir}/kde4/*.so
294%{_libdir}/kde4/imports/
295# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
296%exclude %{_libdir}/kde4/kcm_*.so
297%exclude %{_libdir}/kde4/kded_*.so
298%{_libdir}/kde4/plugins/phonon_platform/
299
300%files flags
301%defattr(-,root,root,-)
302%{_datadir}/locale/l10n/*/flag.png
303
304
305%changelog
306* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
307- new upstream release
308
309* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
310- new upstream release
311- built with exiv2-0.21.1
312
313* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
314- new upstream release
315
316* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
317- rebuilt with libsmbclient-3.5.8
318
319* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
320- new upstream release
321
322* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
323- added BR: libXpm-devel
324
325* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
326- new upstream release
327- added devel subpackage
328
329* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
330- new upstream release
331- updated summary
332- dropt Patch100
333
334* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
335- new upstream release
336- added Patch100 from Fedora
337  - backport to fix the freeze of kded on first use of the network:/kio-slave
338
339* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
340- new upstream release
341- added Conflicts: kdebase3 at Vine Linux 5
342
343* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
344- new upstream release
345
346* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
347- rebuilt with exiv2-0.19
348
349* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
350- new upstream release
351
352* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
353- new upstream release
354
355* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
356- new upstream release
357- built with new toolchain
358
359* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
360- new upstream release
361
362* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
363- new upstream release
364
365* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
366- new upstream release
367- used %%cmake macro
368
369* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
370- Initial build for Vine Linux
371
372* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
373- respin
374
375* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
376- 4.3.0
377
378* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
379- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
380
381* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
382- 4.3rc3
383
384* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
385- respin (soprano-2.3.0)
386- License: LGPLv2+
387
388* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
389- 4.3rc2
390
391* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
392- drop unneeded BR: ImageMagick (#509241)
393
394* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
395- don't start nepomuk server unconditionally (#487322)
396
397* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
398- 4.3rc1
399
400* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
401- KDE-4.3 beta2 (4.2.90)
402
403* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
404- Drop old Fedora < 8 conditionals
405
406* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
407- file conflicts with kdepim
408
409* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
410- KDE 4.3 beta 1
411
412* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
413- fix persistent systray notifications (#485796)
414
415* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
416- -flags subpkg
417- koji/noarch hacks dropped
418
419* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
420- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
421
422* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
423- KDE 4.2.2
424
425* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
426- flags subpkg (not enabled)
427- optimize scriptlets
428
429* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
430- fix PulseAudio cmake detection
431
432* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
433- 4.2.1
434
435* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
436- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
437
438* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
439- #486059 -  missing dependency on htdig
440
441* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
442- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
443
444* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
445- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
446
447* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
448- own %%_kde4_datadir/locale/l10n/
449
450* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
451- respun tarball
452
453* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
454- Files not trashed to the correct location in Dolphin/Konqueror
455  (#481598, kdebug#178479)
456- omit --with-samba crud
457
458* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
459- 4.2.0
460- +BR: pulseaudio-libs-devel xine-lib-devel
461- -BR: giflib-devel pcre-devel
462
463* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
464- tarball respin
465- drop extraneous deps (that are in kdelibs)
466
467* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
468- 4.2rc1
469
470* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
471- include %%_bindir/kdesu symlink
472
473* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
474- 4.2beta2
475
476* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
477- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
478  and should be in a -devel package if it gets shipped)
479
480* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
481- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
482
483* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
484- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
485
486* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
487- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
488
489* Fri Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
490- 4.1.80
491- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
492- BR cmake >= 2.6.2
493- Use 'make install/fast'
494- Drop subpkg phonon-backend-xine and related file entries: this has to be
495  part of phonon now that it moved there
496- Drop xine-lib-devel BR
497- Add libkwalletbackend to files list
498- Drop _default_patch_fuzz 2
499
500* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
501- apply upstream patch to fix X crash when disabling compositing
502
503* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
504- 4.1.3
505
506* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
507- apply upstream patch, kioexec processes never terminate
508
509* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
510- fix broken audio-backend-jack.svgz
511
512* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
513- add missing icons
514
515* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
516- make VERBOSE=1
517- respin against new(er) kde-filesystem
518- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
519
520* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
521- 4.1.2
522
523* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
524- fix inherit issue in iconthemes, preview icons
525  do not show
526
527* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
528- fix #460710, knetattach is kio_remote's wizard program, don't show
529  it in the menu.
530
531* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
532- 4.1.1
533
534* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
535- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
536
537* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
538- crash fix when stopping a service that is not yet initialized
539
540* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
541- don't remove autostart directory on F8- (does not conflict, fixes build
542  failure due to nepomukserver.desktop listed in filelist but not found)
543
544* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
545- 4.1.0
546
547* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
548- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
549
550* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
551- 4.0.99
552
553* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
554- respin
555
556* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
557- -phonon-backend-xine: new subpkg
558
559* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
560- 4.0.98
561
562* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
563- 4.0.85
564
565* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
566- 4.0.84
567
568* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
569- 4.0.83 (beta2)
570
571* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
572- 4.0.82
573
574* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
575- add searchproviders-shortcuts for redhat bugzilla
576
577* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
578- 4.1 beta 1
579
580* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
581- BR new minimum version of soprano-devel
582
583* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
584- update to 4.0.72 (4.1 alpha 1)
585- drop upstreamed deinterlace-crash patch
586- drop khelpcenter patch (fixed upstream)
587- update Phonon PulseAudio patch
588- drop Fedora 7 support
589- update file list
590
591* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
592- omit conflicting icons (kde3_desktop=1 case)
593
594* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
595- oxygen-icon-theme: build noarch
596
597* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
598- %%post/%%postun: hicolor icon theme scriptlets
599
600* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
601- only omit hicolor index.theme (#439374)
602
603* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
604- fix khelpcenter, search plugins/settings in correct path (#443016)
605
606* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
607- respin (at f13's request)
608
609* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
610- pulseaudio patch (use as default, if available)
611
612* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
613- don't crash if we don't have deinterlacing support in xine-lib (#440299)
614
615* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
616- rebuild for the new %%{_kde4_buildtype}
617
618* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
619- update file list for _kde4_libexecdir
620
621* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
622- 4.0.3
623
624* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
625- don't own %%_kde4_docdir/HTML/en/
626
627* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
628- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
629- include noarch build hooks (not enabled)
630
631* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
632- BR libxcb-devel everywhere (including F7)
633
634* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
635- if building for a KDE 4 desktop, include the khelpcenter.desktop service
636  description for KDE 3 here so help works in KDE 3 apps
637
638* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
639- 4.0.2
640
641* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
642- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
643
644* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
645- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
646  (kio_smb itself is already GPLv2+)
647
648* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
649- 4.0.1
650
651* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
652- respun tarball
653
654* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
655- update to 4.0.0
656- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
657
658* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
659- kde-3.97.0
660
661* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
662- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
663
664* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
665- build without libxcb in F7 as we STILL don't have it (see #373361)
666
667* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
668- no longer set kde3_desktop on F9
669- update file list for !kde3_desktop (Sebastian Vahl)
670- don't ship country flags even for full version (as in kdebase 3)
671
672* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
673- kde-3.96.2
674
675* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
676- kde-3.96.1
677
678* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
679- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
680
681* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
682- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
683
684* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
685- kde-3.96.0
686
687* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
688- kdebase-runtime-3.95.2
689
690* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
691- kdebase-runtime-3.95.0
692
693* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
694- Provides: oxygen-icon-theme ...
695
696* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
697- patch dolphin.desktop to get Dolphin to start from the menu
698
699* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
700- update to 3.94.0
701
702* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
703- don't make this the default kdebase on F9 yet
704- drop ExcludeArch: ppc64 (#300601)
705
706* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
707- ExcludeArch: ppc64 (#300601)
708- update description
709
710* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
711- add missing BR alsa-lib-devel
712
713* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
714- remove files which conflict with KDE 3
715- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
716- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
717
718* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
719- update to 3.93.0
720- drop kde4home patch (no longer applied)
721- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
722- remove kdebase-kdm Obsoletes/Provides (for the same reason)
723- remove KDM (and KDM session) setup code (for the same reason)
724- remove rss-glx conflict (Plasma is now in kdebase-workspace)
725- remove redhat-startkde patch (startkde is now in kdebase-workspace)
726- remove kde4-opt.sh (all the code in it is commented out)
727- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
728- remove bogus BRs on automake and libtool
729- remove workspace-only BRs
730- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
731- remove workspace files and directories
732- handle icons (moved from kdelibs4)
733- add mkdir %%{buildroot} in %%install
734
735* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
736- use macros.kde4
737- License: GPLv2
738
739* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
740- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
741- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
742- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
743
744* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
745- consolekit_kdm patch (#228111, kde#147790)
746- update startkde patch
747
748* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
749- kde-3.92 (kde-4-beta1)
750
751* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
752- fix startkde
753- add env/shutdown directory
754
755* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
756- kde4.desktop: fix session Name
757
758* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
759- cleanup/fix kde4.desktop
760- kdepimlibs4->kdepimlibs
761
762* Thu Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
763- fix %%_sysconfdir for %%_prefix != /usr case.
764
765* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
766- updated kde4home.diff
767- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
768
769* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
770- kde-3.91.0
771- CMAKE_BUILD_TYPE=debug
772
773* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
774- specfile cleanup (%%prefix issues mostly)
775
776* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
777- update to 3.90.1
778- bump cmake BR to 2.4.5 as required upstream now
779- don't set execute bits by hand anymore, cmake has been fixed
780- use multilibs in /opt/kde4
781- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
782- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
783  in case we want to drop the Rs on these from kdelibs4-devel
784- consistently add all BRs as -devel Rs, not just almost all, until we can
785  figure out which, if any, are really needed
786- BR libsmbclient-devel instead of samba on F>=7, EL>=6
787
788* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
789- restore minimum version requirement for cmake
790- build against libxklavier on EL5
791- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
792
793* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
794- +eXecute perms for %%{_prefix}/lib/*
795
796* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
797- rebuild for patched FindKDE4Internal.cmake
798
799* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
800- update to 3.80.3
801- update and improve parallel-installability patch
802- drop obsolete joydevice.h patch
803- remove translations of "KDE" without the "4" from kde4.desktop
804- resync BR and -devel Requires
805- don't set LD_LIBRARY_PATH
806- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
807- fix missing underscore in _datadir
808- install kde4.desktop in install, not prep
809- fix invalid syntax in kde4.desktop
810
811* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
812- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
813- compiling with QA_RPATHS=0x0003; export QA_RPATHS
814
815* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
816- parallel build support
817- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
818- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
819- spec file cleanups and added clean up in %%install
820- fixed PATH for libkdecore.so.5; cannot open shared object file;
821- added Logitech mouse support
822- added dbus-devel, hal-devel and more as BR
823- fixed broken joydevice.h - Kevin Kofler
824- added file kde4.desktop
825
826* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
827- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
828- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.