source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 1773

Revision 1773, 25.0 KB checked in by inagaki, 14 years ago (diff)

update: kdebase-runtime, kdebase-workspace, kdepimlibs, oxygen-icon-theme

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.5.1
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdebase-runtime-%{version}.tar.bz2
15Source1:       khelpcenter.desktop
16
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18Patch2:        kdebase-runtime-4.2.85-knetattach.patch
19Patch3:        kdebase-runtime-4.1.1-iconthemes-inherit.patch
20Patch5:        kdebase-runtime-4.3.1-manpath.patch
21# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
22Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
23
24## 4.5 Upstream patches
25# backport of 1160390, fixed: start call to cagibi only in next event loop, could be started
26# in on-demand load by a d-bus call ourself, so d-bus connection has a mutex locked already
27Patch100: kdebase-runtime-4.5.0-kioslave.patch
28Patch101: kdebase-runtime-4.4.0-virtuosoconverter.patch
29
30
31# when kdesu was removed, this is/should-be only temporary
32Provides:  kdebase4-runtime = %{version}-%{release}
33Obsoletes: kdebase4-runtime < %{version}-%{release}
34
35# knotify4 provides dbus service org.freedesktop.Notifications too
36Provides: desktop-notification-daemon
37
38Requires: kdepimlibs >= %{version}
39Requires: eject
40Requires: %{name}-libs = %{version}-%{release}
41# KHelpcenter requires htdig for building search indices
42Requires: htdig
43
44# ensure default/fallback icon theme present
45# beware of bootstrapping, there be dragons
46Requires: oxygen-icon-theme >= %{version}
47
48BuildRoot:     %{_tmppath}/%{name}-%{version}-root
49BuildRequires: alsa-lib-devel
50BuildRequires: attica-devel
51BuildRequires: bzip2-devel
52BuildRequires: clucene-core-devel
53BuildRequires: exiv2-devel
54BuildRequires: hal-devel
55BuildRequires: kdelibs4-devel >= %{version}
56BuildRequires: kdepimlibs-devel >= %{version}
57BuildRequires: libsmbclient-devel
58BuildRequires: libXScrnSaver-devel
59BuildRequires: OpenEXR-devel
60BuildRequires: openslp-devel
61BuildRequires: openssl-devel
62BuildRequires: pkgconfig
63BuildRequires: polkit-qt-devel
64BuildRequires: pulseaudio-libs-devel
65BuildRequires: qimageblitz-devel
66BuildRequires: shared-desktop-ontologies-devel
67BuildRequires: soprano-devel >= 2.3.0
68BuildRequires: xine-lib-devel libxcb-devel
69BuildRequires: xorg-x11-font-utils
70BuildRequires: xorg-x11-proto-devel
71%if %{?_dist_release} != "vl4" && %{?_dist_release} != "vl5"
72BuildRequires: libssh-devel >= 0.4.2
73BuildRequires: xz-devel
74%endif
75BuildRequires: zlib-devel
76
77%if %{?_dist_release} == "vl4" || %{?_dist_release} == "vl5"
78Conflicts: kdebase3
79%endif
80
81%description
82Core runtime for KDE 4.
83
84%description -l ja
85KDE 4 の中心を構成するランタイム部分です.
86
87%package libs
88Summary: Runtime libraries for %{name}
89Summary(ja): %{name} のランタイムライブラリ
90Group:   System Environment/Libraries
91Requires: kdelibs4 >= %{version}
92Requires: kdepimlibs >= %{version}
93#Requires: %{name} = %{version}-%{release}
94# cagibi is runtime dep, a dbus service
95Requires: cagibi
96
97%description libs
98%{summary}.
99
100
101%package flags
102Summary: Geopolitical flags
103Group: User Interface/Desktops
104Requires: %{name} = %{version}-%{release}
105
106%description flags
107%{summary}.
108
109
110%prep
111%setup -q -n kdebase-runtime-%{version}
112
113%patch1 -p1 -b .searchproviders-shortcuts
114%patch2 -p1 -b .knetattach
115%patch3 -p1 -b .iconthemes-inherit
116#patch5 -p1 -b .manpath
117%patch6 -p1 -b .home_onlyshowin_kde
118
119#patch100 -p1 -b .kioslave
120%patch101 -p1 -b .virtuosoconverter
121
122%build
123mkdir -p %{_target_platform}
124pushd %{_target_platform}
125unset QTDIR || : ; . /etc/profile.d/qt4.sh
126%cmake \
127    -DCMAKE_BUILD_TYPE=release \
128    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
129    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
130    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
131    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
132    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
133    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
134    ..
135popd
136
137make %{?_smp_mflags} -C %{_target_platform}
138
139
140%install
141rm -rf $RPM_BUILD_ROOT
142
143make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
144
145# kdesu symlink
146ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
147
148# omit hicolor index.theme, use one from hicolor-icon-theme
149rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
150
151# remove country flags because some people/countries forbid some other
152# people/countries' flags :-(
153%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
154
155# install this service for KDE 3 applications
156# NOTE: This is not a standard .desktop file, but an "almost standard" one
157#       installed into a KDE-3-specific directory, as usual for KDE 3 services,
158#       so we can't use desktop-file-install for it.
159install -p -D %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
160
161# FIXME: -devel type files, omit for now
162rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
163
164%clean
165rm -rf $RPM_BUILD_ROOT
166
167%post
168touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
169touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
170
171%posttrans
172gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
173gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
174update-desktop-database -q &> /dev/null ||:
175update-mime-database %{_datadir}/mime &> /dev/null
176
177%postun
178if [ $1 -eq 0 ] ; then
179    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
180    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
181    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
182    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
183    update-desktop-database -q &> /dev/null ||:
184    update-mime-database %{_datadir}/mime &> /dev/null
185fi
186
187%post libs -p /sbin/ldconfig
188%postun libs -p /sbin/ldconfig
189
190
191%files
192%defattr(-,root,root,-)
193%{_sysconfdir}/dbus-1/system.d/*
194%{_sysconfdir}/xdg/menus/kde-information.menu
195%{_bindir}/*
196# omit ksvgtopng which kdelibs3 includes
197%if %{?_dist_release} == "vl4" || %{?_dist_release} == "vl5"
198%exclude %{_bindir}/ksvgtopng
199%endif
200# FIXME(?), currently contains cmake/modules -- Rex
201%{_datadir}/kde4/apps/*
202%{_datadir}/config/*.knsrc
203%{_datadir}/autostart/nepomukserver.desktop
204%{_datadir}/config.kcfg/
205%{_datadir}/dbus-1/interfaces/*
206%{_datadir}/dbus-1/services/*
207%{_datadir}/dbus-1/system-services/*
208%{_datadir}/icons/default.kde4
209%{_datadir}/kde4/services/*
210%{_datadir}/kde4/servicetypes/*
211%{_datadir}/mime/packages/network.xml
212%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
213%{_datadir}/sounds/*
214%{_libdir}/kconf_update_bin/*
215%{_libdir}/libkdeinit4_*.so
216%{_libdir}/kde4/kcm_*.so
217%{_libdir}/kde4/kded_*.so
218%{_libexecdir}/kde4/*
219%{_libdir}/strigi/*
220%{_mandir}/man1/*
221%{_mandir}/man8/*
222%{_datadir}/icons/hicolor/*/*/*
223%{_docdir}/HTML/en/*
224%{_datadir}/applications/kde4/Help.desktop
225%{_datadir}/applications/kde4/knetattach.desktop
226%{_datadir}/config/kshorturifilterrc
227%{_datadir}/desktop-directories/*.directory
228%{_datadir}/emoticons/kde4/
229%{_datadir}/locale/en_US/entry.desktop
230%{_datadir}/locale/l10n/
231%{_datadir}/locale/currency/
232%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
233%{_datadir}/services/khelpcenter.desktop
234
235%files libs
236%defattr(-,root,root,-)
237%{_libdir}/attica_kde.so
238%{_libdir}/libkwalletbackend.so.*
239%{_libdir}/libmolletnetwork.so.*
240%{_libdir}/kde4/*.so
241# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
242%exclude %{_libdir}/kde4/kcm_*.so
243%exclude %{_libdir}/kde4/kded_*.so
244%{_libdir}/kde4/plugins/phonon_platform/
245#{_libdir}/kde4/plugins/styles/
246
247%if 0%{?flags}
248%files flags
249%defattr(-,root,root,-)
250%{_datadir}/locale/l10n/*/flag.png
251%endif
252
253
254%changelog
255* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
256- new upstream release
257- updated summary
258- dropt Patch100
259
260* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
261- new upstream release
262- added Patch100 from Fedora
263  - backport to fix the freeze of kded on first use of the network:/kio-slave
264
265* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
266- new upstream release
267- added Conflicts: kdebase3 at Vine Linux 5
268
269* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
270- new upstream release
271
272* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
273- rebuilt with exiv2-0.19
274
275* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
276- new upstream release
277
278* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
279- new upstream release
280
281* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
282- new upstream release
283- built with new toolchain
284
285* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
286- new upstream release
287
288* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
289- new upstream release
290
291* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
292- new upstream release
293- used %%cmake macro
294
295* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
296- Initial build for Vine Linux
297
298* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
299- respin
300
301* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
302- 4.3.0
303
304* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
305- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
306
307* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
308- 4.3rc3
309
310* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
311- respin (soprano-2.3.0)
312- License: LGPLv2+
313
314* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
315- 4.3rc2
316
317* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
318- drop unneeded BR: ImageMagick (#509241)
319
320* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
321- don't start nepomuk server unconditionally (#487322)
322
323* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
324- 4.3rc1
325
326* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
327- KDE-4.3 beta2 (4.2.90)
328
329* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
330- Drop old Fedora < 8 conditionals
331
332* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
333- file conflicts with kdepim
334
335* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
336- KDE 4.3 beta 1
337
338* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
339- fix persistent systray notifications (#485796)
340
341* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
342- -flags subpkg
343- koji/noarch hacks dropped
344
345* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
346- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
347
348* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
349- KDE 4.2.2
350
351* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
352- flags subpkg (not enabled)
353- optimize scriptlets
354
355* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
356- fix PulseAudio cmake detection
357
358* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
359- 4.2.1
360
361* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
362- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
363
364* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
365- #486059 -  missing dependency on htdig
366
367* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
368- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
369
370* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
371- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
372
373* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
374- own %%_kde4_datadir/locale/l10n/
375
376* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
377- respun tarball
378
379* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
380- Files not trashed to the correct location in Dolphin/Konqueror
381  (#481598, kdebug#178479)
382- omit --with-samba crud
383
384* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
385- 4.2.0
386- +BR: pulseaudio-libs-devel xine-lib-devel
387- -BR: giflib-devel pcre-devel
388
389* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
390- tarball respin
391- drop extraneous deps (that are in kdelibs)
392
393* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
394- 4.2rc1
395
396* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
397- include %%_bindir/kdesu symlink
398
399* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
400- 4.2beta2
401
402* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
403- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
404  and should be in a -devel package if it gets shipped)
405
406* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
407- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
408
409* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
410- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
411
412* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
413- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
414
415* Fri Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
416- 4.1.80
417- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
418- BR cmake >= 2.6.2
419- Use 'make install/fast'
420- Drop subpkg phonon-backend-xine and related file entries: this has to be
421  part of phonon now that it moved there
422- Drop xine-lib-devel BR
423- Add libkwalletbackend to files list
424- Drop _default_patch_fuzz 2
425
426* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
427- apply upstream patch to fix X crash when disabling compositing
428
429* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
430- 4.1.3
431
432* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
433- apply upstream patch, kioexec processes never terminate
434
435* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
436- fix broken audio-backend-jack.svgz
437
438* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
439- add missing icons
440
441* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
442- make VERBOSE=1
443- respin against new(er) kde-filesystem
444- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
445
446* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
447- 4.1.2
448
449* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
450- fix inherit issue in iconthemes, preview icons
451  do not show
452
453* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
454- fix #460710, knetattach is kio_remote's wizard program, don't show
455  it in the menu.
456
457* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
458- 4.1.1
459
460* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
461- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
462
463* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
464- crash fix when stopping a service that is not yet initialized
465
466* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
467- don't remove autostart directory on F8- (does not conflict, fixes build
468  failure due to nepomukserver.desktop listed in filelist but not found)
469
470* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
471- 4.1.0
472
473* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
474- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
475
476* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
477- 4.0.99
478
479* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
480- respin
481
482* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
483- -phonon-backend-xine: new subpkg
484
485* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
486- 4.0.98
487
488* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
489- 4.0.85
490
491* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
492- 4.0.84
493
494* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
495- 4.0.83 (beta2)
496
497* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
498- 4.0.82
499
500* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
501- add searchproviders-shortcuts for redhat bugzilla
502
503* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
504- 4.1 beta 1
505
506* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
507- BR new minimum version of soprano-devel
508
509* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
510- update to 4.0.72 (4.1 alpha 1)
511- drop upstreamed deinterlace-crash patch
512- drop khelpcenter patch (fixed upstream)
513- update Phonon PulseAudio patch
514- drop Fedora 7 support
515- update file list
516
517* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
518- omit conflicting icons (kde3_desktop=1 case)
519
520* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
521- oxygen-icon-theme: build noarch
522
523* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
524- %%post/%%postun: hicolor icon theme scriptlets
525
526* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
527- only omit hicolor index.theme (#439374)
528
529* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
530- fix khelpcenter, search plugins/settings in correct path (#443016)
531
532* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
533- respin (at f13's request)
534
535* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
536- pulseaudio patch (use as default, if available)
537
538* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
539- don't crash if we don't have deinterlacing support in xine-lib (#440299)
540
541* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
542- rebuild for the new %%{_kde4_buildtype}
543
544* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
545- update file list for _kde4_libexecdir
546
547* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
548- 4.0.3
549
550* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
551- don't own %%_kde4_docdir/HTML/en/
552
553* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
554- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
555- include noarch build hooks (not enabled)
556
557* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
558- BR libxcb-devel everywhere (including F7)
559
560* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
561- if building for a KDE 4 desktop, include the khelpcenter.desktop service
562  description for KDE 3 here so help works in KDE 3 apps
563
564* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
565- 4.0.2
566
567* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
568- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
569
570* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
571- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
572  (kio_smb itself is already GPLv2+)
573
574* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
575- 4.0.1
576
577* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
578- respun tarball
579
580* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
581- update to 4.0.0
582- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
583
584* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
585- kde-3.97.0
586
587* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
588- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
589
590* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
591- build without libxcb in F7 as we STILL don't have it (see #373361)
592
593* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
594- no longer set kde3_desktop on F9
595- update file list for !kde3_desktop (Sebastian Vahl)
596- don't ship country flags even for full version (as in kdebase 3)
597
598* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
599- kde-3.96.2
600
601* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
602- kde-3.96.1
603
604* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
605- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
606
607* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
608- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
609
610* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
611- kde-3.96.0
612
613* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
614- kdebase-runtime-3.95.2
615
616* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
617- kdebase-runtime-3.95.0
618
619* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
620- Provides: oxygen-icon-theme ...
621
622* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
623- patch dolphin.desktop to get Dolphin to start from the menu
624
625* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
626- update to 3.94.0
627
628* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
629- don't make this the default kdebase on F9 yet
630- drop ExcludeArch: ppc64 (#300601)
631
632* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
633- ExcludeArch: ppc64 (#300601)
634- update description
635
636* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
637- add missing BR alsa-lib-devel
638
639* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
640- remove files which conflict with KDE 3
641- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
642- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
643
644* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
645- update to 3.93.0
646- drop kde4home patch (no longer applied)
647- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
648- remove kdebase-kdm Obsoletes/Provides (for the same reason)
649- remove KDM (and KDM session) setup code (for the same reason)
650- remove rss-glx conflict (Plasma is now in kdebase-workspace)
651- remove redhat-startkde patch (startkde is now in kdebase-workspace)
652- remove kde4-opt.sh (all the code in it is commented out)
653- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
654- remove bogus BRs on automake and libtool
655- remove workspace-only BRs
656- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
657- remove workspace files and directories
658- handle icons (moved from kdelibs4)
659- add mkdir %%{buildroot} in %%install
660
661* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
662- use macros.kde4
663- License: GPLv2
664
665* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
666- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
667- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
668- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
669
670* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
671- consolekit_kdm patch (#228111, kde#147790)
672- update startkde patch
673
674* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
675- kde-3.92 (kde-4-beta1)
676
677* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
678- fix startkde
679- add env/shutdown directory
680
681* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
682- kde4.desktop: fix session Name
683
684* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
685- cleanup/fix kde4.desktop
686- kdepimlibs4->kdepimlibs
687
688* Thu Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
689- fix %%_sysconfdir for %%_prefix != /usr case.
690
691* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
692- updated kde4home.diff
693- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
694
695* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
696- kde-3.91.0
697- CMAKE_BUILD_TYPE=debug
698
699* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
700- specfile cleanup (%%prefix issues mostly)
701
702* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
703- update to 3.90.1
704- bump cmake BR to 2.4.5 as required upstream now
705- don't set execute bits by hand anymore, cmake has been fixed
706- use multilibs in /opt/kde4
707- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
708- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
709  in case we want to drop the Rs on these from kdelibs4-devel
710- consistently add all BRs as -devel Rs, not just almost all, until we can
711  figure out which, if any, are really needed
712- BR libsmbclient-devel instead of samba on F>=7, EL>=6
713
714* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
715- restore minimum version requirement for cmake
716- build against libxklavier on EL5
717- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
718
719* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
720- +eXecute perms for %%{_prefix}/lib/*
721
722* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
723- rebuild for patched FindKDE4Internal.cmake
724
725* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
726- update to 3.80.3
727- update and improve parallel-installability patch
728- drop obsolete joydevice.h patch
729- remove translations of "KDE" without the "4" from kde4.desktop
730- resync BR and -devel Requires
731- don't set LD_LIBRARY_PATH
732- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
733- fix missing underscore in _datadir
734- install kde4.desktop in install, not prep
735- fix invalid syntax in kde4.desktop
736
737* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
738- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
739- compiling with QA_RPATHS=0x0003; export QA_RPATHS
740
741* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
742- parallel build support
743- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
744- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
745- spec file cleanups and added clean up in %%install
746- fixed PATH for libkdecore.so.5; cannot open shared object file;
747- added Logitech mouse support
748- added dbus-devel, hal-devel and more as BR
749- fixed broken joydevice.h - Kevin Kofler
750- added file kde4.desktop
751
752* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
753- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
754- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.